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Introduction to CDM Administration Guide
The CDM Administration Guide describes how to perform administrative tasks in CDM.

CDM is a unified financial governance solution that focuses on improving financial processes and
controls, particularly in the final stages before disclosure. It helps the finance department improve the
timeliness and quality of financial management processes and reporting. CDM also facilitates audits,
extends enterprise resource planning (ERP) transactional controls, and improves financial risk
management.

Audience
The CDM Administration Guide is intended for individuals working in the Office of Finance, who need to
create, manage, and administer financial reports and workflows that are created with CDM. In addition
to administrators, users who have been granted various permissions can perform the administrative
tasks in this guide. To use this guide, you should have experience in developing financial reports for
regulatory submission.
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Overview of CDM
CDM is a corporate reporting solution that combines numeric data with other presentation elements.
Text and graphics can be used to supplement data in a report.

Many organizations manually produce their external financial reporting documents, for example, 10K,
10Q, and Board Books. With CDM, statutory financial reports are dynamically generated from a central
database to produce highly formatted reports complete with appropriate commentary and
supplementary notes.

CDM provides a collaborative environment that incorporates workflow and audit trails to ensure a high
degree of data accuracy and to provide better internal controls for corporate governance.

Functionality of CDM
The CDM interface is used to produce and output financial reports.

CDM contains the following functionality and capabilities:

l Performance
The document rendering mechanism is fast because rendered output is put into a cache that then
is shared by all users working on the same part of the report.

l Collaboration
Users can check out multiple report objects simultaneously.

l Workflow
Users can easily see the status of each part of a financial document and determine which parts
are overdue and who is responsible. Workflow includes automatic email notification to quickly
contact the persons responsible for items that are overdue.

l Internal Control
CDM provides a comprehensive set of internal controls to ensure that the proper steps are
followed in the creation, submission, and approval of each document.

l Audit Trail
Users can easily compare any two versions of the document to see what was changed, who
changed it, and when it was changed. Audit trails are divided into the following sections:
o Login Audit - Records every authentication request to the CDM database via the web

service.
o Report Properties - Records any changes that have occurred in a report.
o Report Object Properties - Records any changes that have occurred in an object.

l Data Sourcing
This feature provides an easy-to-use method to pull data from various data sources including the
leading ERP systems, the leading consolidation systems, relational databases, OLAP
databases, and Microsoft™ Excel.

l Ease of Use
If users already know how to use Microsoft Excel, Microsoft Word, and Microsoft PowerPoint,
using CDM is intuitive and easy. It provides a user interface that leverages all the calculation
abilities of Excel, the formatting capabilities of Word, and the presentation abilities of PowerPoint.
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l Data Collection for Operational Data
CDM provides functionality so that the user can write back to Cognos® TM1® for data collection.
External financial documents often include data that might not exist in your ERP or consolidation
system.

l User Security
CDM provides controlled access to sensitive information and helps to maintain privacy.

l Business Rules and Validation
In some organizations, data might come from various sources. CDM business rules ensure that
summary data in one area of the document always ties to detailed data that exists elsewhere in
the document.

l PowerPoint Integration
Users can create PowerPoint objects to output presentations using existing data in the report.

l Report and Object Level Commentary
Gives users insight on the creation process for reports and report objects.

l Dashboards
Users can present financial information in the form of charts, graphs, and grids by creating
widgets in the dashboard.

l Integration with IBM® and IBM Cognos® Products

l Ability to support Single Sign-On

Typical Report Examples
You can use CDM to create various financial reports for internal or external publication for any
organization.

Corporate and regulatory reports often contain repetitive sections that are time-consuming to reproduce
and manage with consistency. CDM enables such reports to be used as templates, which can simplify
and accelerate the process of submitting reports.

Statutory Reporting
In many countries or regions, federal securities laws require publicly traded companies to disclose
information on an ongoing basis. You can use CDM to prepare statutory reports.

US Regulatory Reporting: 10-K, 10-Q, and 20-F
Regulatory bodies such as the Securities and Exchange Commission (SEC) require businesses to
submit annual reports on Form 10-K, and quarterly reports on Form 10-Q for specified events.
Businesses must comply with various other disclosure requirements. Foreign issuers must use Form
20-F to meet disclosure requirements.

The annual report on Form 10-K provides a comprehensive overview of the company's business and
financial condition and includes audited financial statements. The annual report on Form 10-K is distinct
from the annual report to shareholders.
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Form 10-Q includes unaudited financial statements and provides a continuing view of the company's
financial position during the year. The report must be filed for each of the first three quarters of the
company's fiscal year.

Form 20-F is a comprehensive core disclosure document that foreign private issuers must file annually
with the SEC to register securities when they are offered in the US.

Exhibits specifically refer to attachments that the SEC officially defines in its rules and regulations. The
SEC might require one or more exhibits to be included with a 10-K or 10-Q filing.

Canadian Regulatory Reporting: Annual Reports and MD&A
In Canada, public and privately owned corporations are required to produce annual reports and to
disclose important events that affect the business in Management Discussion and Analysis (MD&A)
reports. You can also use CDM for various other required reports.

UK Regulatory Reporting: Annual Reports and Form 363
The EU Transparency Directive is designed to bring all European stock exchanges up to the same level,
with a uniform set of rules for Listing and Disclosure that apply across the European Union. There are
more stringent requirements for interim and annual reports.

In the UK, the Companies House and Financial Services Authority (FSA) requires businesses to submit
various reports and forms on a timely basis. For example, the Companies House requires an Annual
Return (Form 363) to update company contact information, including contact information for corporate
executives, and to provide a statement of principal business activities.

Corporate and Industry Reporting
You can use CDM to create standard corporate reports, such as quarterly and annual reports. You can
also create industry-specific reports, such as airline industry reports.

Quarterly Reports, Annual Reports, and Board Books
In general, corporations in different countries and regions are required to produce quarterly and annual
reports, displaying financial results for the period. CDM enables consistent report formatting and
presentation of data.

You can also use CDM to create and manage content related to board meeting agenda packets, known
as board books.

Airline Industry: Form 41
The Form 41 provides valuable information for those who need to analyze and understand the US
airline industry and its member carriers. Form 41 reports on carrier costs, operations, profit and loss
statements, and balance sheets.

Internal Reporting
You can also use CDM to create reports used for internal control. You can also maintain existing
customized reports.

Any report that was built in Microsoft™ Excel, Microsoft Word, or any presentation built in Microsoft
PowerPoint can be created and maintained in CDM. Additional functionality, such as Workflow and
Audit Trail, can then be applied.
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Basic Concepts
Before you begin to use CDM, you should understand some basic concepts.

Important: Using CDM requires a working knowledge of Microsoft™ Excel, Microsoft Word,
and Microsoft PowerPoint. The advanced functionality for Microsoft products is beyond the
scope of this guide. However, some topics are included for your convenience. For more
information, see the Microsoft documentation.

Report Overview
In CDM, the administrator creates reports and assigns users the ability to work on various parts of the
report. Users can access data, adjust, or calculate data values, and present data with formatting, text,
and images.

User Object Summary Tab
When you open a new or existing report in CDM, you first view it in the User Object Summary tab, which
displays information about the report as it is completed. The work area of the User Object Summary tab
lists the report objects for which you have workflow permission to view or edit. You can review report
objects that you have checked out or that other users have checked out. You can also view report
objects checked out by other users for which you have workflow permission. Double-click a report object
in the report tree to open that report object.

You can view the following information in the columns of the User Object Summary tab area for reports,
and sort the columns in ascending or descending order by clicking the column header.

l Name
The user-specified name of each report object in the report.

l Document Type
The purpose of a Word object. For example, if the Word object contains page setup content, the
document type is PageSetup.

l Printable
The print setting for the report object. A check mark indicates that the object is printable. An x
indicates that the object is not printable. Only the documents and objects marked as Printable will
be included in the final generated report.

l Report Object Due Date
The date when the report object must be complete, as set by the administrator.

l Workflow Status
The current workflow state for the report object. The state can be updated at any time by an
administrator or by a valid user in the workflow approval process.

l Workflow Due Date
The deadline for completing the workflow process for the report object, as assigned by the
administrator. A deadline is displayed only if the administrator set a deadline within the workflow
process for that report object.
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l Checkout Status
The checkout state for the report object. An object is checked in or checked out (locked) by the
current user or another user. A message appears on your screen, identifying the person who
checked out the report object.

The following commands are available in the ribbon for the User Object Summary tab:

Name Description

Refresh Used to refresh the information in the User Object Summary tab.

Preview
Used to open a Word or PowerPoint report object selected in the work area as checked
in and displaying any variables as resolved (that is, how hey will appear in a generated
report). This cannot be used for Excel report objects.

Edit

Used to open and edit a report object selected in the work area. Word or PowerPoint
report objects are opened as checked out and any variables are displayed as
unresolved (that is, they are not shown as they will appear in a generated report). Excel
report objects are opened as checked out and any variables are displayed as resolved
(that is, how they will appear in a generated report).

Open
Used to open the report object selected in the work area as checked in and any
variables displayed as unresolved (that is, they are not shown as they will appear in a
generated report).

Printable
Used to toggle between printable and non-printable for the report object selected in the
work area.

Export List
Used to output the information in the User Object Summary tab to an Excel
spreadsheet.

Workflow Used to view and modify the workflow for the report object selected in the work area.

Open a Report
To edit the content of a report, you must sign in to CDM, and then open the report.

You can use several methods to open a report:

l Click File > Open > Reports, and double-click the report that you want to open. After the report is
open, the User Object Summary tab displays. You can optionally export the content into a CSV
file by right-clicking in the work area and clicking Export as .csv.

l If you opened the report previously, and you want to open it again, click File > Recent, and then
double-click the report that you want to open.

l On the quick access toolbar, click the Open icon, and then double-click the report that you want
to open.

l If you receive an email indicating that the report object is ready for review, you can click the report
object name to open the report object directly.

Copy a Report as a URL
To copy a report as a URL, select the report name in the report tree, and then right-click and select
Copy as a Link. This action allows you to send the location of the report as a URL. When a user clicks
the URL, the report opens directly in CDM if the user has the appropriate View Report permission.
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Lock a Report
If a report in CDM is nearing its deadline for filing, you can lock the report. Locking a report prevents any
updates to variables, data queries, and reference objects when new information becomes available in
the source. This is useful when the report does not require a refresh for new information, for example, if
the user is nearing quarter close when data needs to be finalized.

Users granted the Manage Report Workflow permission can perform this task.

To lock a report:

1. Open the report that you want to work with.

2. Select the report.

3. Click Home > Lock Report or Report Object.

4. The report is locked as indicated by the Lock icon in the report tree and the Lock Report or
Report Object command on the Home tab remains highlighted.

5. To unlock the report, click Home > Lock Report or Report Object. The command is no longer
highlighted and the report is unlocked.

Report Object Overview
A report object defines the type of content that is in a report. Report objects represent most of the
content of your report in CDM.

There are five types of report objects in CDM: Excel, Word, PowerPoint, Web Page, and PDF. If you are
the administrator, you can add report objects to any report.

Overview of Excel Objects
Excel objects are primarily used to work with data values in CDM.

When an Excel object is added to a report, the Excel object has no data. You can reference and display
data from the database or an external source in the Excel object. You can also add text or data
manually.

When the data is in the Excel object, it can be referenced by other Excel formulas. You can reference a
large data set and display only some of the values. You can also import external Excel files directly into
Excel objects for reference and storage.

Overview of Word Objects
Word objects are primarily used to present textual information in a report in CDM.

When a newWord object is added to a report, the Word object contains no text. CDM can leverage
existing reports by importing them directly into the Word object for use in the report. You can add text,
images, graphs, or data to enhance the report. Every time you save a Word object, the data is saved in
the CDM database.

You can view an audit trail for the report object information and content in the database and you can
compare different versions.
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Overview of PowerPoint Objects
In CDM, PowerPoint objects are primarily used for visual presentations in a report.

When a new PowerPoint object is added to a report, the object contains no text. CDM can take
advantage of existing PowerPoint documents by importing them directly into the PowerPoint object for
use in the report. You can add charts, display ranges, or image ranges containing data or graphics to
enhance the PowerPoint object. Every time you save a PowerPoint object, the data is saved in the CDM
database.

You can view an audit trail for the report object information and content in the database and you can
compare different versions of the PowerPoint object.

Note: If you work in Microsoft™ Office 2007, you can work with only one instance of a
PowerPoint object at a time. When you view audit trails for PowerPoint objects, the audit trail
content does not load because of this limitation. You will receive a message in which you can
save the logs separately. If you work in a later version of Microsoft Office, this restriction does
not apply.

Overview of Web Page Objects
You can use Web Page objects to display web pages in a report in CDM for reference.

Web Page objects can be included in the report for reference while you are working on the report, but
they are not generated upon output.

Note: Because Web Page objects are not included in the generated report, Web Page objects
cannot be included in the Table of Contents.

Overview of PDF Objects
You can use PDF objects to attach documents in Portable Document Format (PDF) to a report in CDM
for reference.

PDF objects can be included in the report for reference while you are working on the report, but they are
not generated upon output.

Note: Because PDF objects are not included in the generated report, PDF objects cannot be
included in the Table of Contents.

Object Ribbon
The object ribbon in CDM contains icons that provide functionality specific to the report object in CDM.

When you work in an Excel, Word, or PowerPoint object in CDM, you can use the same interface that
you use in Microsoft™. The interface contains generic Microsoft commands that you can use to create,
control, edit, delete, and format information in the object. When you open a PDF object in CDM, the
object has the same functionality as found in Adobe™ Reader or Adobe Acrobat.

You can view the object ribbon inside your object by clicking the Section View Mode icon in the status
bar. To switch back to the main ribbon, click the Default View Mode icon.
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Workflow and Auditing Overview
A workflow is a process that is used to track the progress of a report and its report objects toward
completion. The workflow defines what needs to be done at each point in the approval process. You
have permission to view and work with report objects that are associated with your assigned workflow
state.

You can also advance or reject a report object through all the statuses configured for that report object
or section. A user can only advance the current status to the next status in the approval chain, or reject
and revert a report object to its previous status.

Audit Trail
CDM has an Audit Trail feature that records every submission to the database, along with the user
name and date of submission. It can be used to view all status changes to report objects in the report.

Data Source Overview
A data source is the physical connection to a data repository such as a relational database, an OLAP
cube, or a Microsoft Excel file.

A data source connection specifies the parameters needed to connect to the data source, such as the
location of the database. It can also include credential information and other details specific to the data
source.

In CDM, the administrator can add data source connections to these types of databases:

l OLAP

l Relational

l Microsoft™ Excel

l Hyperion Financial Management (HFM)

The administrator must create a data source connection before users can create queries. After the
administrator adds a data source, users should be informed that the data source is available for them to
perform queries and run reports.

Query Overview
A query is a request for information from a database that is based on specific conditions. You can use a
query to create custom data queries on data from the data sources available to CDM and retrieve the
results into a report. The query can then be inserted into an Excel object.

When querying relational data sources, you retrieve data through SELECT statements. However, you
can also use other query commands against the database, as permitted by the data source provider.

Important: The advanced functionality for Microsoft™ products is beyond the scope of this
guide. However, some topics are included for your convenience. For more information, see
Microsoft documentation or Microsoft online help.
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Checklist Overview
In CDM, a checklist is primarily used to provide task-oriented information and reference within a report.
You can create customized checklists as a means of process control, compliance, and verification.

You can add or delete checklists at any time when you are building a new report or when you are
working with an existing report. You can leverage your existing checklists and procedures, or you can
configure CDM to provide standard checklist types to use with your reports.

Users can add or delete checklists in a report and also append files to a checklist for reference and
support in the reporting process.

These default checklists are available:

l Task
Represents a task that the user needs to complete.

l Information
Represents informational content.

l Reference
Includes a reference to a file attached to the checklist.

l Misc.
Represents a checklist of any other type.

Task and Task List Overview
In CDM, administrators can define tasks in an hierarchical or task list that users are required to
complete.

Task lists can coordinate a long process such as steps required to configure CDM for a 10K/Q report or
as simple as a list of set up tasks. Task lists can be either ordered, or unordered. You can also assign
different icons to different tasks.

Dashboard Overview
A dashboard is an interface that integrates data from a variety of sources and provides a unified display
of relevant and in-context information. Fixed dashboards are available in CDM to view the progress of a
report by graphical means. The administrator also has the ability to create custom dashboards and
make them available to the user.

The function of the dashboard differs, depending on whether your role in CDM is as an administrator or
a user.

l The administrator can add, edit, and configure the dashboard by opening the Administration tab
in the Navigation Pane.

l The user can view a dashboard by opening the Dashboard tab in the Navigation Pane. The
Dashboard tab contains a list of dashboards that are configured for the user.

When a dashboard is configured, you can open and view the dashboard types.
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Custom Dashboards
A custom dashboard is a dashboard that is created by the user from widgets and various data sources
to meet specific requirements. It is not supplied with the application. A custom dashboard is configured
by a user who has administrative rights.

You can use these widgets in a custom dashboard:

l Chart
Shows the progress as an area, bar, line or pie chart. Both 2D and 3D charts are available.

l Grid
Shows textual information in a grid format. You can optionally export the contents of the grid into
a CSV file by right-clicking in the grid widget and clicking Export as .csv.

l Gauge
Shows one value from a column of values.

l Image
Allows the user to add an image to the dashboard.

l Web browser
Allows the user to enter a link to a web page in the dashboard.

Fixed Dashboards
A fixed dashboard is a dashboard that is supplied with the application to provide report and data source
information in a graphical format. CDM includes these fixed dashboards: Report Summary Dashboard
and Excel Analysis Dashboard.

You cannot edit or delete a fixed dashboard, even if you are an administrator.

Bidirectional Language Overview
If you use CDM in Arabic or Hebrew, the direction of most content appears on your screen from right to
left automatically, as you would expect. Arabic or Hebrew are considered bidirectional languages
because some content should appear in the opposite direction from the basic text.

The default text direction of a language does not allow the proper display of Arabic or Hebrew text in an
English user interface, and Latin-based text in an Arabic or Hebrew user interface. Also, numbers and
some other special types of content should normally appear from left to right, regardless of the language
of the surrounding text. CDM uses a concept called base text direction to apply your preference for the
direction in which certain types of bidirectional items appear in the user interface.

In addition, if you use CDM in Arabic, you can choose to view digits in the manner normally seen in
English and many other languages, or in the digit shaping common in Arabic. CDM uses a concept
called digit shaping to apply your preference for the appearance of digits in the user interface.

Base Text Direction for Arabic or Hebrew
If you use CDM in Arabic or Hebrew, you can ensure that special types of content appear in the correct
direction in your user interface. To do this, you must specify your preference for base text direction.
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CDM uses a concept called base text direction to apply your preference for the direction in which certain
types of bidirectional items appear.

l For left-to-right sentences in English and other Latin-based languages, the proper base text
direction is left-to-right, even if the sentence includes Arabic or Hebrew words.

l For right-to-left sentences in Arabic or Hebrew, the proper base text direction is right-toleft, even
if the sentence includes English words or numbers.

This list displays some of the types of content that should appear left-to-right even if the main content is
right-to-left:

l Text in English or another left-to-right language

l Numbers

l URLs

l Email addresses

l File paths

l Trademark symbols

Important: Your selection for base text direction is not applied in password fields, and just the
content of the field is mirrored according to the selected language (locale).

To select the base text direction for Arabic or Hebrew:

1. Click File > Options.

2. In the Options window, select your preferred language in the Language field.

3. Click the Base text direction field, and select one of these options:

l Default - To inherit the default natural direction of the language that is used in the user
interface. If you want to use the default behavior of the language in your user interface, this
is your best choice.

l Left-to-right - To properly display text in left-to-right languages such as English and French.
If you are sure that your content contains text from English or any Latin-based language
only, this is your best choice.

l Right-to-left - To properly display text in right-to-left languages such as Arabic and Hebrew.
If you are sure that your content contains text from Arabic or Hebrew only, this is your best
choice.

l Contextual - To properly display text whose direction is not known in advance. CDM
selects the direction based on the context of the most recent strongly directional character.
If your content might contain both Latinbased text and also Arabic or Hebrew text or any
special content elements, this is your best choice. For example, in a right-to-left context, a
trademark sign is considered to be right-to-left, and it would be displayed in an incorrect
order if the brand name is in English or a Latin-based language. In an Arabic or Hebrew

https://insightsoftware.com/


14

report, to correctly display a trademark sign for an English name brand (left-to-right), you
must select Contextual.

4. Click OK.

5. To ensure that all your selections are applied to your user interface, exit from CDM and log in
again.

Special content appears in your user interface in the order that you specified. If you want, you can apply
similar preferences to your Excel, Word, and PowerPoint objects. For more information, see Microsoft™
documentation or Microsoft™ online help.

Digit Shaping for Arabic
If you use CDM in Arabic, you can specify whether you want to view digits in Arabic style in your user
interface. To do this, you must specify your preference for digit shaping.

In Arabic, digits often have an appearance that is different from the appearance of digits that are used in
other languages. If you do not specify your preference, CDM applies digit shaping in your user interface
based on your selection in the Digit Shaping field in the General tab of the Options window.

Note:
l In your database, all numbers are stored in Latin-based format, even if you choose to
display them in Arabic style.

l CDM does not support numeric shaping when you generate Word reports from Excel
objects.

To select digit shaping for Arabic:

1. Click File > Options.

2. In the Options window, select Arabic in the Language field.

3. Click the Digit Shaping field, and select one of these options:

l National - To specify digit shaping based on the language that you are using when you
work in CDM.

l Contextual - To specify digit shaping based on adjoining characters in the value. Latin-
based digits follow Latin scripts, and Arabic digits follow Arabic text. When there is no
preceding text, the value in the Base text direction field determines digit shaping.

l None - To display the digits in their Latin-based form and shape. The digit shape appears in
CDM as it appears in your regional settings form if you specify None in the Digit Shaping
field.

4. Click OK.

5. To ensure that all your selections are applied to your user interface, exit from CDM and log in
again.
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Digit shaping appears in your user interface as you specified. If you want, you can apply similar
preferences to your Excel, Word, and PowerPoint objects. For more information, see Microsoft™
documentation or Microsoft™ online help.

Note: If you use CDM in Arabic, and if you select Contextual for Digit Shaping in the Options
window, some dates in report properties might appear with Latin-based number shaping. The
dates that appear with Latin-based number shaping are those that are selected through a
calendar field in CDM.

EDGAR HTML Overview
You can use the HTML tools for Electronic Data Gathering, Analysis, and Retrieval (EDGAR) in CDM to
preview your HTML file for the SEC.

You can use CDM to generate valid EDGAR content for the SEC in this way:

l You can generate HTML output. You can find information on this method in this documentation.

l You can generate output that conforms with SEC EDGAR Filer Manual rules. The EDGAR Filer
Manual validates that the taxonomy and instance document comply with the rules. You can find
information on this method in the CDM XBRL User Guide.

l You can generate high definition HTML output. You can find information on this method in this
documentation.

Desktop Publishing Overview
You can adapt the output from CDM for use in a desktop publishing application such as Adobe™
InDesign.

For Excel objects, you must tag specific content for your desktop publishing application. For Word
objects, you have the option of tagging specific content or enabling the desktop publishing utility to allow
you to generate content to desktop publishing automatically without the use of tags.

The tags that you create in CDM will be stored in the form of XML when the report is generated. The
generated XML file can then be imported in the specified application.

To set up desktop publishing styles in CDM, the administrator must set up styles and apply permissions
to the appropriate users and user groups. Then, the users can apply those styles to content in Excel and
Word objects.

Important: The functionality for desktop publishing products such as Adobe InDesign is
beyond the scope of this guide. For more information, see the appropriate documentation or
online help.

Automatic Generation Without the Use of Tags
To generate content to desktop publishing automatically without the use of tags you must first modify
the server-specific CDM.config file (default path is C:\inetpub\wwwroot\CertentCDM-
Server\Config) by adding the <EnableDesktopPublishingAutomaticWordGeneration
value="true" /> key. This enables the desktop publishing utility.
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Also, to prevent styles from being duplicated during report generation, you must ensure the
reduceStyles value is set to true in the <ReportGeneration imageDpi="200"
reduceStyles="true" /> key. After modifying the CDM.config file, you must then perform an IIS
reset of the server machine and then open the client.

To generate content to desktop publishing, the paragraphs and table styles being used in the Word
objects must exist in the Administration desktop publishing styles. Contact your administrator to ensure
the styles are present. The style names there must be identical to the ones in the Word objects (the
names are case sensitive) you want to generate.

If a paragraph in a Word object contains a character style that does not exist in the Administration
desktop publishing styles, but the paragraph style is present, then the paragraph's entire content is
generated under the same XML node (in effect, tag). If a paragraph contains a character style that exists
in the Administration desktop publishing styles, but the paragraph style doesn't exist, then the
paragraph's content is not generated in the XML file.

To generate Word tables, the paragraph and character styles that exist in a table's cell must also exist in
the Administration desktop publishing styles as well. If not, the generated table is empty. The Table
Style must also exist or the table will not generate.

Range variables (##D for named ranges) are generated with the Table Normal table style and Normal
paragraph styles in cells. These styles must exist in the Administration desktop publishing styles to
generate the range variables to desktop publishing.

Objects other than charts and images are not generated (for example, text boxes, shapes, and so on).
Paragraph styles on which charts and images rely must exist in the Administration desktop publishing
styles to generate the chart or image. Charts and images that are not inline with text are not generated.

If you have a style that can be applied both to paragraphs and characters and it is used on characters,
its name suffixed by a space and the Char text must exist in the Administration desktop publishing
styles to generate that nested tag. For example, you have defined a style named My Style that can be
used both for paragraphs and characters. To generate this style for characters, you need to have the My
Style Char style added in the Administration desktop publishing styles.

All XML nodes for charts and images are generated with the name found in Alt Text Description for
Word objects and actual chart or image names for Excel objects.

It is not recommended to use Word tables for automatic word generation to desktop publishing as there
are limitations with resolving merged cells. It is recommended that you create the tables in an Excel
object and tag them there.

The < and > characters are not escaped. If needed, a placeholder can be used instead that can be
replaced with the appropriate content in the generated XML (in effect &lt; for < and &gt; for >).

When generating content to desktop publishing, the style names might be modified to comply with the
XML naming rules. For example, for the Word style 1_My Style to be generated, the same style name,
that is 1_My Style, must exist in the Administration desktop publishing styles and the XML node will
have the name _MyStyle.
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Getting Started
To get started in CDM, you need to know how to log in. You also need to know your role because your
role determines the tasks that you can perform.

Roles
CDM provides a collaborative environment for users to contribute to the report, based on the role of the
user. Your contributions depend on whether your role is administrator or user.

Administrator Role
The administrator in CDM creates the initial structure of a report and provides security access to the
report. The administrator assigns parts of the report to users, along with a deadline for submission.

The administrator can edit any part of the report, maintain the overall structure of the report, manage the
project deadlines, configure user access levels, configure dashboards, and monitor work status and
submissions.

The administrator can also publish the report for the users. The administrator can choose to delegate
some administrative tasks to non-administrative users.

User Role
Users can contribute content to various parts of a report in CDM, and multiple users can work on
different aspects of the same report.

Users can view details, but they can update the report only within the documents that were assigned to
them. By default, tasks such as changing deadlines for submission or changing global settings for all
reports are normally performed only by the administrator. Users with the correct permissions can view
the dashboards that are created for them. The administrator can choose to delegate some
administrative tasks to non-administrative users.

Sign In to Certent CDM
The administrator provides you with your login credentials for CDM.

1. Select your server and click OK. At any time you can click Switch Server to enter a specific
server address.

2. In the Sign in prompt, enter your user name and click Next.

3. In the Enter password prompt, enter your password and click Sign in.

Note: Depending on security set by the administrator, if you enter an incorrect name or
password, you might have to wait for a period before you can attempt another log in. It
is also possible that your account is locked immediately. If this occurs, contact the
administrator to unlock it.

4. If you have any objects that are checked out from a previous session, you are prompted to load
the report that the objects are in. Select the report and click OK. Optionally, expand the hierarchy
of the report and select the object that was checked out in a previous session. The report and
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objects open in the same session as when you last logged out. Or, click Cancel to start CDM
without opening the report with objects that were checked out.

CDM opens, with the Open tab in view or a report with checked out objects in view. Depending on your
role, you can now select a report or dashboard, or you do other tasks.

Important: For security reasons, sign out when you finish working with CDM.

If you want to change your password, use one of these methods:

l In the status bar, click your user name. In the User Profile window, enter your old password and
new password. Confirm the new password and click OK.

l If you have sufficient permission, click Administration, and then under Security, double-click
Users. Right-click your name and click Change Password. Enter and confirm a new password,
and then click OK.
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Report Creation and Design
In CDM, data is stored in tables in the CDM database. You can use CDM to access data, to adjust or
calculate data values in the report, and to present data with formatting, text, and images.

Report Building Process
You can use CDM to design your reports and to add content.

The report building process consists of the following tasks:

1. The administrator constructs a new report.

2. The administrator organizes the report by adding sections and report objects to the report.

3. Users add text and numeric data to the report objects, and can collaborate on content and further
customize information displayed in the report.

4. A report can be produced in various formats.

Add a Report
You can create a financial report for internal or external publication. CDM can simplify and accelerate
the process of submitting reports.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Reports. The Reports tab opens in the work area.

3. In the report list, right-click the report group and select Add Report. A new row representing the
new report opens in the table.

4. Type a name for the report, and press Enter.

5. If a workflow template in Administration > Workflow > Workflow Templates has been
designated as the default workflow template, it is assigned to the new report.

Reuse Existing Reports with the Rollforward and
Cascade Features
You can reduce the amount of time required to create a new report by reusing an existing report or
report object.

You can use the Rollforward or Cascade feature to copy existing reports or report objects to new
reports.

l The Rollforward feature creates a complete copy of a report or report object in the destination
report. All report features, including the report structure, security settings, shared objects, data,
and XBRL projects along with their associated facts are duplicated in the destination report.

l The Cascade feature converts shared objects to reference objects in the destination report.

The checkout and lock status of reports or report objects does not affect the ability to perform a
rollforward or cascade operation. If a report object is checked out, the most recent version from the
database is used.
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For both features, the association between the source report and the destination report is recorded in
the CDM database. The association record can include the path between more than two reports. For
example, if you cascade Master 1 to Report 1, and then cascade Report 1 to Report 2, the association
record would include the path between three reports. The report path appears in the Object Explorer
status bar. The association records for reports support the Change Reference and Push Down features.

These records are also created for reference objects, which support the Break Reference feature and
allows you to change which source object they reference in the rollforward or cascade wizard.

The following example describes the processing of report objects with Rollforward and Cascade
features.

Report 1, the source report, contains Obj1 (a shared report object), Obj2 (a reference object to Obj1),
and Obj3 (a non-shared report object). Obj1, Obj2, and Obj3 are associated with a defined query,
Query1. Query1 depends on the query variable QueryVar1. QueryVar1 is defined at the report level
(Report 1,QueryVar1) and for each report object (Obj1,QueryVar1, Obj2,QueryVar1, Obj3,QueryVar1).

The following diagram shows the results of rollforward and cascade actions. Report 4 and Report 5
show the results of subsequent rollforward and cascade actions.

Rollforward and cascade operations do not duplicate queries. Queries are not linked to a specific report.
The associations between report objects and queries are copied to the destination report. The report-
level and object-level query variables are copied to the destination report. In the rollforward or cascade
wizard, you can modify the query variables. You can modify the value for object-level and data query-
level variables.

If the report is associated with an XBRL project, when you roll forward a report, you can create a new
XBRL project and can edit the time periods in the report. Any XBRL tags in the source report remain in
the destination report. You must have application permissions to manage projects in order to do this.

To reuse an existing report using the Rollforward or Cascade feature:

1. In the Reports tab in the work area, right-click the source report and select Rollforward or
Cascade.

2. Complete the steps in the wizard that opens.

3. The new report appears in the destination report groups.
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Edit the Properties of a Report
You can edit the properties of a report. Properties are elements such as the name and owner.

1. In the Reports tab in the work area, select the report that you want to edit.

2. Right-click the report and select Properties.

3. In the Properties tab of the Properties and Comments window, edit the properties as you want.
You can change any property that is not gray.

4. Click OK.

You can view or edit the following information:

Property Description

Name The user-specified name of the report.

Report Owner
Shows the initial creator of the report. This name can be changed in
the Properties and Comments window.

Description Displays the report description

Period Start Date Displays the starting period date of the report.

Period End Date Displays the ending period date of the report.

Report Due Date Displays the configured due date for the report.

Current State Due Date Displays the due date for the current state in the report.

Submission Date Displays the submission date for the report.

Zero Amount Shown As
Specifies a character to represent the zeros in the report when the
report is generated.

Current Workflow State Displays the current workflow state for the report.

Template Workflow Assigned Displays the workflow template assigned to the report.

PowerPoint Print Options
Allows you to specify the orientation of slides in PowerPoint objects.
The default choice is Landscape.

Language and Region Options
Allows you to set the preferred language and region that will be used
to generate Excel print areas and variables to Microsoft Word,
Microsoft PowerPoint, Adobe PDF and Edgar HTML.

Generate charts as images

Allows you to generate charts as images. If selected, this option will
be set as an active default for the report. Users, however, can clear it
when working with reports or when generating a report. If you
generate charts as images, you can view the information in your
generated report, but you cannot change it afterward. If this option is
not selected, charts are generated as Microsoft™ Office chart
objects. It is recommended that charts be generated as Microsoft
Office chart objects.

Replace Embedded Fonts in HD
Allows you to replace embedded fonts in the report as base64 in HD
generation.

Report Row Height (At least)

When enabled, if the content in an Excel cell is word-wrapped and is
not completely displayed because the height of the corresponding
row is specified to a smaller value, CDM will apply the least row
height that can accommodate the whole content in Word generation
to make the entire content visible.
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Property Description

Use Advanced Refresh

This option must be enabled in the CDM.config file to appear in the
report properties. When enabled, queries are updated immediately
after the data source expires according to its expiration settings.
Also, Excel report objects are updated immediately after a data
query or a destination variable is enabled.

CDM performs the Advanced Refresh operations using the Refresh
Service Account. In CDM, refreshing data is an audited process, so
CDM needs to have an identity for background tasks. CDM hence
creates the Refresh Service Account by default and applies it to start
background data refresh processes automatically. As stated in its
name, the Refresh Service Account is a service account in the
database (in the IsService column of the core.User table) and
therefore cannot be used for logging in to CDM.

Note:
l It is not possible to change the name of the Refresh
Service Account in the database; otherwise, CDM
won't recognize it anymore.

l The Refresh Service Account is not visible when
administering CDM native users.

Use cell value for report and
workflow validation

Allows you to switch between cell display value and cell actual value
when evaluating either a report validation rule (##R) or a workflow
validation rule (##WF).

Specify Report and Section Due Dates
A due date is applied to a report or a section to indicate a deadline for when work should be completed.

How Due Dates Are Used
Users granted the Modify Report Properties permission can assign a due date to a report. Users
granted the Manage Report Object Properties permission can assign a due date to a section or to a
report object.

The due dates are used to indicate the date on which all work should be completed. If the due date is
equal to the current date or has passed, Current State Due Date in the Properties and Comments
window is highlighted.

Manage Due Dates and Due Date Inheritance
Due dates can be managed at any level of a report (report, section, or report object).

l Create and apply report-level due dates to all sections and report
o To set or change a due date for a CDM report, in the Report tab in the Navigation Pane,

right-click the report and select Properties > Manage All Report Properties, then enter a
date in the Report Due Date field.
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o To apply the due date to all sections and report objects in a report, right-click the report and
select Properties > Apply Report Due Date. The descendant report objects and sections
will now inherit the due date from the report due date setting.

ll Create and apply section-level due dates to all descendants within a section
You can set an explicit due date for a section by clearing the Inherit Due Date checkbox in the
Properties and Comments window (right-click the section and select Properties > Manage All
Section Properties) and setting a new due date. When set, the due date is inherited by any new
objects or sections that are added as descendants to the section. At any time, you can apply the
section due date to all sections and report objects within the section by right-clicking on the
section and selecting Properties > Apply Section Due Date. Due dates for the descendant
sections and report objects are discarded and they inherit the section due date.

l Create and apply report object-level due dates to an individual report object
You can set an explicit due date for a report object by clearing the Inherit Due Date checkbox in
the Properties and Comments window (right-click the report object and select Properties >
Manage All Object Properties). You then enter a new due date for the report object in the Report
Object Due Date field.

Workflow State Due Dates
Due dates can also be applied to workflow states to enforce when certain stages in the workflow must
be completed.

When the due date for a workflow state has passed the workflow due date of the report object, the
section or report will be highlighted in the Properties.

The workflow state due date for a report object, section, or report is calculated relative to its due date.

To learn more about how to set workflow state due dates and how they are calculated, see Workflow
State.

Refresh a Report
When you generate a report, CDM reloads data from the application cache. You can choose to
manually refresh the report to make sure that the data is up to date.

1. Open the report that you want to work with.

2. Click Home > Refresh Report > Quick Refresh Report or Full Refresh Report. Quick Refresh
Report reloads data from the local cache while Full Refresh Report fetches data from external
data sources.

Data and any modified settings are updated throughout the report. If the parts of the report are
delegated to other users, the changes appear when the other user logs in to CDM or refreshes the
report.

Delete a Report
If you no longer need a report , you can delete it. You can delete a report only if no report objects are
checked out, and if the report does not contain shared objects that are referenced in another report.

Important: If you delete a report, you cannot undo your action. Proceed with caution. You
should create the necessary database backup for future reference.
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To delete a report:

1. In the Reports tab in the work area, select the report that you want to delete.

2. Right-click the report and select Delete.

3. In the confirmation window, click Yes.

Report Management
When you have Reports under Administration opened, you can centrally manage all report and report
groups, as well as the report workflows in the application by performing the following tasks:

l Refresh
Refreshes the Reports tab to update the latest information.

l Save
Saves changes to the report.

l Add
Creates a new report group in the application as a container for other reports. If a report group is
selected, you can add a new report to the report group. You can add a report group as a sibling or
child of another report group.

l Edit
Opens the Properties and Comments window for the currently selected report.

l Delete
Deletes the currently selected report.

l Import
Imports source data from outside of the CDM database.

l Export
Exports content from Excel objects, Word objects, PowerPoint objects, and PDF objects from
CDM into external files.

l View By
Used when you manage application or report permissions, and when you associate users with
groups.

l Rollforward
Starts the Rollforward wizard.

l Cascade
Starts the Cascade wizard.

l Change References
Starts the Change Reference operation for the selected report.

l Manage Workflow
Opens the Manage Workflow window where you can configure your report workflow. You can
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apply report workflow to one or more reports. If you select a report group and apply a report
workflow, the workflow is applied to all of the child reports of this group.

l Workflow Template
Associates a workflow template with the selected reports. If you select a report group and
associate it with a workflow template, then all of the child reports of the selected group have this
workflow template associated with them.

Report Groups
You can use a report group to organize types of reports in CDM. For example, you might create
separate report groups for different corporate entities such as companies, divisions, or cost centers.

After you create your report groups, you can create multiple reports for each report group.

Add a Report Group
You can add a report group to organize your reports. You can add a report group as a sibling or a child
of another report group.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Reports. The Reports tab opens in the work area.

3. In the report list, right-click a report group and click Add Report Group > As Child/As Sibling.

4. Type a name for the report group and press Enter.

Rename a Report Group
You can change the name of a report group.

1. In the Reports tab in the work area, right-click the report group you want to rename and click
Rename.

2. Type a new name and press Enter.

Delete a Report Group
If you no longer need a report group, you can delete it. You cannot delete the report group if any of the
reports in the group contains report objects that are checked out.

Important: If you delete a report group, you cannot undo your action. Proceed with caution.

To delete a report group:

1. In the Reports tab in the work area. right-click the report group you want to delete and click
Delete.

2. In the confirmation window, click Yes.
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Report Objects
A report object is a type of content in a report in CDM. You can add as many report objects as necessary
to a report.

As the administrator, you can add or delete report objects at any time when you are building a new
report, or when you are working with an existing report. Users can edit existing report objects, but they
cannot add report objects to, or delete report objects from, a report.

CDM includes these report object types:

l Excel objects

l Word objects

l PowerPoint objects

l PDF objects

l Web Page objects

Add a Report Object to a Report
You can add a report object to a report.

When a report is opened by filtering one or more custom groups, report objects that are added are
automatically assigned to the custom group or groups.

To add a report object to a report:

1. Open the report that you want to work with.

2. In the report tree on the left, right-click the name of the report, click Add Child, and then the
report object type. You can select one of the five report object types: Excel Object, Word Object,
PowerPoint Object, PDF Object, and Web Object. You can also select Shared Report Object
or Section.

3. The report object appears in the User Object Summary tab in the work area.

Change the Order of Report Objects in a Report
You can change the order of report objects in a report. Report objects can appear in any logical order in
a report.

1. Open the report that you want to work with.

2. The report objects display in the report tree in the order that they will appear in the report when it
is generated.

3. To change the order that a report object appears in the report, drag and drop it to a different
location in the report tree. When you drag the report object, you can see icons that indicate
locations that are, or are not, appropriate new locations. You can also see the following
messages to help you place the report object where you want it: Drop Before, Drop After, and
Drop In.

4. Click Refresh.
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Edit the Properties of a Report Object
1. Open the report that you want to work with.

2. In the report tree, right-click the report object and click Properties > Manage All Object
Properties.

3. In the Properties tab of the Properties and Comments window, edit the properties as you want.
You can change any property that is not gray.

4. Click OK.

You can view or edit the following information:

Property Report Object Type Description

Name All
User specified name for the report object.
Each report object or section must have a
unique name.

Report Object Due Date All The due date of the report object.

Inherit Due Date All

If selected, the report object inherits the due
date from its parent section due date or the
report due date, depending on its position in
the report hierarchy.

Workflow Due Date All The due date of the current workflow.

Inherit Workflow All

If selected, the report object inherits the
workflow due date from its parent section
workflow due date or the report workflow due
date, depending on its position in the report
hierarchy.

Document Type Word

The document type for the current Word
object.

l Page Setup - Defines the Word object
as a page setup object that can
enforce certain styles and formatting
throughout the entire report.

l Normal - Defines the Word object as a
normal page.

l Header - Defines the Word object as a
header.

Note: When you generate a
section of a report, the
header from a previous
section is sometimes
generated even if the header
is not associated with the
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Property Report Object Type Description

generated section.

l Footer - Defines the Word object as a
footer.

l Header Footer Placement - Enabled
when you select header or footer. You
can display the header or footer on
odd or even pages.

l Footer Reset Style - Enabled when
you select Footer. This setting defines
the style used for page numbers.

l Page Reset Number - Enabled when
you select Footer. This setting controls
how many pages are reset when you
define the page number. For example,
you browse to the Word object and by
using the context menu, you click
Properties. You can define the
number of pages that you need to
reset the overall page number by using
this option. This is useful when you
require the page numbers to reset to
Page 1 after you create a specific
number of report objects.

Print Options
Excel, Word, and
PowerPoint

The print options for the current report object.

l Printable - When the report is
generated, the report object is printed.

l Not Printable - When the report is
generated, the report object is not
printed. An icon in the report tree
beside the report object name
indicates that the report object is not
printable. Web Page and PDF objects
are automatically not printable.

l Exhibit - This is a read-only checkbox.
It is shown as selected if the report
object is grouped with other exhibit
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Property Report Object Type Description

report objects under an Exhibit section.
When the report is generated, the
report object is combined with the
other exhibit documents in the Exhibit
section into one document seperate
from the report. An exhibit is a
mandatory document that is required
by the regulatory body, along with the
report itself.

l Supporting Document - If selected,
when the report is generated, the
report object is printed as a separate
document. Optionally, a supporting
document can be included as part of
the report content at generation. A
supporting document is an additional
optional document that a company
chooses to submit along with the
mandatory content.

Break Type
Excel, Word, and
PowerPoint

When you specify a break type, you can
specify the number of pages, rows, or slides
to use for spacing.

You cannot assign break types to Web Page
and PDF objects because these report
objects are not included in the generated
report.

Continue with Next Word

Specifies a string of text that is displayed on
the second and later pages of a report if the
current report object that contains a note
variable heading exceeds one page.

ToC Variable
Excel, Word, and
PowerPoint

Defines a table of contents variable for the
report object.

You cannot assign ToC variables to Web
Page and PDF objects because these report
objects are not included in the generated
report.

Note Type Excel and Word

Specifies the note types that the report uses.

l Automatic - Enables the Note Variable
field.

l Manual - Enables the Note Number
and Note Variable fields.
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Property Report Object Type Description

o You can use the Note Number
field to enter the value of the note
number required.

o You can use the Note Variable
field to specify the name of the
variable that is associated with
this note.

You cannot assign note variables to Web
Page and PDF objects because these report
objects are not included in the generated
report.

Active User All
Displays the user who checked out the
current report object.

Current Workflow State All
Shows the current workflow state of the
report object.

Share Report Object All

Marks the current report object as shared and
makes the report object visible in the window
that opens when you add reference objects.
When a report object is set as shared, an icon
in the report tree beside the report object
name indicates that the report object is a
shared object.

Include in XBRL Inline
Generation

PDF

Specifies whether to include the PDF content
in XBRL inline generation. This feature is only
available for ESMA jurisdiction. It allows you
to add supplementary documents to an
annual filing to meet a jurisdictional
compliance requirement.

l Do not include - Specifies not to
include the PDF.

l Include before - Specifies to stitch the
PDF content at the beginning of the
generated document.

l Include after - Specifies to stitch the
PDF content at the end of the
generated document.

When multiple PDF objects are included
before/after the generated document, they
will be stitched at the beginning/end of the
document, in the same order they are found
in the report tree. The PDF content will
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Property Report Object Type Description

always start on a new page.

Note:
l You can modify properties for a report object only if you have checked it out and have
permission to modify report object properties. You cannot modify report object
properties if the report object is checked out by another user. Also, if a report object is
checked out and the session state is invalid, for example as a result of a crash, you
cannot modify report object properties, until the object is forcefully checked back in.

l If you use CDM in Arabic and you select Contextual for Digit Shaping in the Options
window, some dates in report properties might appear with European number shaping.
The dates that might appear with European number shaping are those that are selected
through a calendar field in CDM.

Associate a Report Object with a Custom Group
You can associate a report object with a custom group. However, before doing this, you must define the
custom groups that you need. For each Excel, Word, or PowerPoint object, you can select one or more
groups.

When a report is generated using a custom group, CDM filters out and excludes any report objects that
are not part of the selected group.

When a report is opened by filtering one or more custom groups, report objects that are added to the
report are automatically assigned to the custom group or groups.

To associate a report object with custom groups:

1. Open the report that you want to work with.

2. In the report tree, right-click the report object that you want to associate with a custom group and
select Properties > Custom Groups.

3. Select the custom group that you want to associate with the report object and click the single
arrow to move it to the appropriate pane. To associate all custom groups with the report object,
click the double arrow to move them to the appropriate pane.

4. Click OK.

Include or Exclude Report Objects in a Generated
Report
Print options can be used to control print and print-type properties for report objects and sections.

Printable Property
You include or exclude report objects from a generated report by using the Printable property.

You can set the Printable property for an individual report object to include or exclude it from a
generated report. You can also set the Printable property for a section to include or exclude all its report
objects and subsections from the generation.
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When a section is set to Not Printable, the descendant report objects and sections appear as Not
Printable. The section descendants' Printable property is grayed out and you cannot change their
Printable property.

The explicit Printable property of report objects and sections is maintained in CDM, therefore, you can
change the Printable property of a parent section without modifying the Not Printable property of a
report object that is not to be printed.

Variables defined in Microsoft Excel objects that are Not Printable are still resolved when referenced in
other CDM report objects.

Print Type Property
You can use the Print Type property to determine if Microsoft Word, PowerPoint, and Excel objects or
sections are to be generated in the main report, in an exhibit, or are supporting documents.

When adding or importing a child report object or section to an exhibit section, the Print Type property is
automatically set to Exhibit. The report object or section is included in the generation of the exhibit
section. This property can not be changed. Such report objects can be additionally marked as Exhibit
Supporting Document using the report object properties.

In all other scenarios, the default Print Type for newly created or imported report objects and sections is
to be included in the main report. Such report objects can be additionally marked as Supporting
Document using the report object properties. You can then use the Include Supporting Documents
and Include supporting documents in the main report generation options to control how supporting
documents are generated and accessed.

Set the Printable Property for a Report Object or Section
1. Open the report that you want to work with.

2. To exclude a single report object from generation, right-click it and select Properties > Printable
> Not Printable.

3. To exclude all of descendant report objects in a section, right-click the section and select
Properties > Printable > Not Printable.

4. To make a report object or section eligible for generation again, right-click and select Properties
> Printable > Printable.

Tip: When sections or report objects in a report are set as Not Printable, their names in the
report tree become lighter and more transparent. You can also set a report object or section as
Not Printable in their Properties and Comments window (right-click and select Properties >
Manage All Object Properties and clear the Printable checkbox).

Push Report Objects Down to Cascaded Reports
You can push down one or more report objects from a master report to cascaded reports.

l In the destination report, you need permission to view the report and to add report objects.

l In the source report, you need permission to push down report object updates and to create
report objects.
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As you add new report objects to a master report, you can add copies of these report objects to any
cascaded reports by pushing the report objects down.

In a cascaded report, pushed-down report objects appear in the report tree under the Pushed Down
Objects heading. Report objects under this heading are not included when you generate the report. If
you want to include any pushed-down report objects in a generated report, drag the report objects to a
different part of the hierarchy.

To push report objects down to cascaded reports:

1. Open the report that you want to work with.

2. In the report tree, right-click the report object that you want to push down to the cascaded reports
and select Pushdown.

Tip: If you want to push down more than one report object at once, press CTRL and
select multiple report objects. Then right-click in the report tree and select Pushdown.

3. Select the checkboxes for the cascaded reports that you want to push the report object down to,
and click OK.

4. A copy of the report object is pushed down to the cascaded reports. If you push down a report
object that already exists in the cascaded report, a number is added to the name of the report
object.

Note: By default, pushed-down report objects are not printable.

Delete a Report Object from a Report
If you no longer need a report object, you can delete it.

Important: If you delete a report object, you cannot undo your action. Proceed with caution.

To delete a report object from a report:

1. Open the report that you want to work with.

2. In the report tree, right-click the report object that you want to delete and select Delete.

3. In the confirmation window, click Yes.

Report Object Templates
You can use report object templates to define, manage, and enforce templates used in CDM.

Report object templates enforce style management, layout, and page settings for a project. Report
object templates automatically enforce the settings for newly created objects in the report. Bidirectional
users have the option to set sheet or paragraph direction for all objects.

You can export a predefined template to be edited in Microsoft™ Office and imported back into CDM.
These predefined report object templates are available:
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l Excel 2007 and later

l Word 2007 and later

l PowerPoint 2007 and later

The templates cannot be created or deleted. You can export a predefined template to be edited in
Microsoft Office and imported back into CDM and you can reset the template back to the default
template.

Note: The report object template applies styles and layout to new report objects. If you make
changes to a template, the formats of existing report objects are not changed.

Export a Report Object Template
You can export a report object template and make it available on your system, either for use on another
system or to edit in Microsoft™ Office.

These steps illustrate the workflow for editing a template:

1. Export the template to your system from CDM.

2. Edit the template in Microsoft Office.

3. Update the template in CDM.

To export a report object template:

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Resources, double-click Report Object Templates. The Report Object Templates tab
opens in the work area.

3. Select the template that you want to export for editing.

4. Click Home > Export, and save the template on your system. The template is now available for
you on your system.

Update a Report Object Template in CDM
A report object template on your system can be used to set the default style for new objects created in
CDM.

Make sure that you have the correct template on your system. This template will overwrite the current
template in CDM.

To update a report object template in CDM:

1. In the Report Object Templates tab in the work area, select the template that you want to update.

2. Click Home > Edit.

3. Select Use custom template, browse to where you have saved the edited template, and click
Open.

4. Click OK to save the template for use in CDM.
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Apply the Default Setting to a Report Object Template
If you are not happy with the changes that you have made to a report object template in CDM, you can
revert to the default report object template.

1. In the Report Object Templates tab in the work area, select the template that you want to revert to
the default setting.

2. Click Home > Edit.

3. Select Use default template and click OK. The selected template is reverted to the default
settings.

Shared Objects and Reference Objects
You can select an existing report object in CDM and make it as a shared object.

A shared object is a report object that is made available for its content to be referenced within the same
report or across reports. Any report object in CDM can be shared within the same report or any other
report.

A shared object can be added as a copy of the shared object or as a reference object that is updated
with the shared object. A reference object does not contain its own content.

If necessary, a shared object can be unshared, which prevents the report object from being referenced
in other locations or reports.

Shared Objects
Any report object can be shared within the same report or any other report.

Before you can share a report object, you first configure that report object as a shared object. You can
then add that report object to a different location in the same report or in another report.

Share a Report Object
1. Open the report that you want to work with.

2. Right-click the report object that you want to share, then click Properties > Shared > Share.

3. The report object is now configured as a shared object and can be added to the current report or
another report as a copy object or reference object.

Add a Shared Object to a Report
You can add a shared object from one report to other reports.

1. Open the report that you want to work with.

2. In the report tree on the left, right-click the report that you want to add a shared object to, and
click Add Child > Shared Report Object.

3. Select the shared object that you want, and click either Copy or Reference. You can select a
report object only if it is configured as a shared object.

4. The shared object is added as the last report object in the report, either as a copy object or a
reference object.
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Reference Objects and Copy Objects
When a report object is configured as a shared object, that shared object can be inserted as a reference
object or copied as a new report object within the same report or in a different report.

What Are Reference Objects and Copy Objects
A report object that is added to a report as a copy of a shared object is called a copy object. A copy
object is not associated with the original source object. A copy object is a copy of the information in the
source object when the copy object is added. If the source object is modified, the information in the copy
object is not updated. However, users can modify the copy object. The information in the source object
is not modified if the copy object is modified. A copy object can be used as a template in other reports.
For example, an administrator can create a format in an Excel object and share that format with other
reports by adding a copy of that Excel object.

A report object that is added as a reference to a shared object is called a reference object. The shared
object to which the reference object is linked is called a source object. A reference object does not
contain its own content. It remains associated with the original shared object (the source object). When
a report with a reference object is refreshed, the information in the reference object is updated from the
source object. If the information in the reference object needs to be updated, it must be done at the
source. A reference object is read-only and cannot be modified directly. The administrator can use a
reference object to share a report object with different users and set different workflow privileges.

You can remove the reference to the shared object (breaking the reference) if needed. You can also
change the source object a referenced object currently references by selecting a different source object.
To change the source object of a reference object, you need to have at least a roll forward of the report
that contains the original shared object, in effect, the same base shared object but in a different report.

To determine whether a report object is a shared object or a reference object, you can use any of these
indicators:

l Shared and reference objects display a small indicator with the report object name in the report
tree.

l A tool tip indicates whether a report object is a shared object or a reference object.

l Any report object that references another report object displays a message in the information bar.

Add a Shared Object as a Copy
If a report object is configured as a shared object, you can create a copy of that shared object within the
same report or in a different report. A copy object can be modified, but any modifications in the original
source object are not applied to the copy object.

To add a shared object as a copy object to a report:

1. Open the report that you want to work with.

2. In the report tree on the left, right-click the report object where you want to insert a shared report
object as a copy, and click Add Sibling > Shared Report Object.

3. From the list, select the shared object that you want to copy and click Copy.

4. Apply a workflow to the copy object. The workflow for a copy object can be different from the
source object.
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Add a Shared Object as a Reference
If a report object is configured as a shared object, you can add it as a reference object within the same
report or in a different report. When a report is refreshed, the information in a reference object is
updated from the source.

To add a shared object as a reference object to a report:

1. Open the report that you want to work with.

2. In the report tree, right-click the report object where you want to insert a shared report object as a
reference, and click Add Sibling > Shared Report Object.

3. From the list, select the shared object that you want to link to and click Reference.

Tip: When you hover your mouse over a reference object, you can see the names of its
source report and source report object. To open the reference object, right-click it and
click References > Open.

4. Apply a workflow to the reference object. You can change the workflow of a reference object. A
reference object can have a workflow that is different from the workflow of the source object.

The information bar for the reference object contains the following message in the work area for the
report object:

This object is referencing another object.

Change the Source Report Associated with a Reference
Object
After you roll forward or cascade a report, you can change the source report that is associated with any
reference object in the resulting rollforward or cascaded report.

You can change the source for a reference object, but only if the source is contained in a report that is
part of a rollforward chain. You can also change the source report associated with a reference object
when performing a rollforward or cascade operation on a report.

To change the source report associated with a reference object:

1. Open the report that you want to work with.

2. In the report tree, right-click one or more selected reference objects and click References >
Change. The Change References for Selected Report Objects window opens.

3. Use the drop-down menu for each selected reference object to choose the source report you
want it associated with. Only source reports for which you have the appropriate permissions are
made available for selection.

4. Click OK. The selected reference objects are now associated with the source report you
specified.

Break a Reference
You can break the reference between a reference object and the source object. The reference object
becomes a non-reference object.
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1. Open the report that you want to work with.

2. In the report tree, right-click the reference object and click References > Break.

The report object no longer references the original source object and can be modified. Modifications in
the original source object are not applied to the report object.

Reference Objects in Cascaded Reports
When you cascade an existing report, any reference objects in the cascaded report reference the
shared objects in the original report.

You can use cascaded reports for single sourcing. Cascaded reports contain all the report objects in the
original source report. When you modify a shared object in the original report, the changes are
automatically copied to the associated reference object in cascaded reports.

If needed, you can update the source object for all reference objects to a new source. For example, if
you cascade a report for use in a different year, the reference objects remain associated with the
original report and the original data. You can change the references from the original source report to
any other report, as needed.

When you create a cascaded report based on another cascaded report, reference objects in
subsequent cascaded report also reference shared objects in the original report.

Note: All referenced objects in copied reports are read-only.

Unshared Objects
If a report object was configured as a shared object, an administrator can change that shared object to
unshared if needed. Users cannot copy or reference an unshared object.

To convert a shared object to unshared:

1. Open the report that you want to work with.

2. In the report tree on the left, select the shared report object.

3. Click Show Properties.

4. In the Properties pane, clear the Share Report Object checkbox.

5. Click OK. The report object is no longer shared and users cannot select the report object in the
Add shared object window.

When you change a shared object to an unshared object, you must consider whether the shared object
is referenced by other report objects. In general, you can convert the reference objects associated with
that shared object to non-referenced (normal) report objects or delete the referenced objects. You can
also change the source object a referenced object currently references by selecting a different source
object. To change the source object of a reference object, you need to have at least a roll forward of the
report that contains the original shared object, in effect, the same base shared object but in a different
report.

Note the following special situations:

l If the reference object contains child objects, the child objects remain unchanged or deleted.
However, if the child object is checked out in the current report or another report, the reference
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object and its child object are not deleted.

l If the reference object contains a child object that is shared and referenced by other objects, the
following conditions apply:
o You can choose to convert the reference object to a non-reference object. The child objects

do not change.
o You cannot delete the reference object.

You might need to refresh or reload the report to see the changes.

Note: You cannot add children to report objects in CDM v10.2.6 Refresh Pack 1 or later.
Instead, you must create a section. However, reports that were created before upgrading to
CDM v10.2.6 Refresh Pack 1, or if they are imported from another version, will still function as
they did previously.

Exhibits and Supporting Documents
You can append additional documents called exhibits and supporting documents to your reports in
CDM. Exhibits and supporting documents add important information to the financial reports that you
create.

An exhibit is a mandatory document that is required by the regulatory body, along with the report itself.
An exhibit is usually a Word object, and it can also be an Excel object. Exhibit objects are grouped into
sections that are designated as Exhibit sections. When you generate a report, all exhibit objects
grouped under an exhibit section are combined into one document that accompanies the report.

A supporting document is an additional optional document that a company chooses to submit along with
the mandatory content. A supporting document can be an Excel, Word, or PowerPoint object. When you
generate a report, supporting documents are generated separately by default. If you prefer, you can
combine all supporting documents in the main report. Supporting document objects can also be
grouped under an exhibit section but thereby become an exhibit document object and are added to the
exhibit document that is generated for that exhibit section.

Add and Generate an Exhibit
You can designate a report object as an exhibit object by grouping it under an exhibit section. When the
report is generated, all exhibit objects (including exhibit objects grouped in descendant exhibit sections)
are combined into one document.

For example, you have a report that is organized like this:

REPORT
----Report Object 1

----Report Object 2

----Exhibit Section 1

--------Exhibit Object 1

--------Exhibit Object 2

------------Exhibit Section 2
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----------------Exhibit object 3

When the report is generated, Exhibit Objects 1, 2, and 3 are combined into a single document.

Exhibits are included in report snapshots.

To add an exhibit in a report:

1. Open the report that you want to work with.

2. Determine the location in the report hierarchy where you want to add a section that will be the
exhibit section under which you want to group your exhibits.

3. Right-click and select Add Child or Add Sibling and then Section.

4. Enter a name for the section.

5. Right-click the section and select Properties > Manage All Object Properties and then select
the Exhibit checkbox.

6. Enter an exhibit type, description, and file name in the respective Exhibit Type, Exhibit
Description, and Exhibit File Name fields. The information you enter will be displayed in the
manifest that is created upon report generation. Exhibit File Name will also be used as the file
name for the exhibit document created upon report generation.

7. Click OK.

8. Add or import Word or Excel report objects under the exhibit section. They automatically become
designated as exhibit documents.

9. You can also click and drag any Word or Excel report object in the report and place them under
the exhibit section. They automatically become designated as exhibit documents.

Note: When you designate a section as an exhibit section, any descendant report objects or
sections currently grouped under that section automatically become exhibit objects. You can
only change their exhibit object designation by clicking and dragging them out from under the
exhibit section to another location in the report hierarchy.

Add and Generate a Supporting Document
Supporting documents are included in report snapshots.

To add and generate supporting documents in a report:

1. Open the report that you want to work with.

2. Determine the location where you want to insert a supporting document, and create the Excel,
Word, or PowerPoint object.

3. Right-click the report object and select Properties > Manage All Object Properties. The
Properties and Comments window is displayed.

4. In the Report Object Configuration > Print Options section, select the Supporting Document
checkbox.

5. Insert the appropriate content for the supporting document.
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6. When you are ready to output the report, select Include Supporting Documents. If you want to
combine all supporting documents in the main report, also click Include supporting documents
in the main report.

Hyperlink to Exhibits
Managing hyperlinks to content being authored can be a hassle. CDMmanages the hyperlink to exhibit
files being created regardless of the generation format: Microsoft Word, Microsoft Excel, Microsoft
PowerPoint, Edgar HTML, Adobe PDF, or inline XBRL.

Insert a Hyperlink to an Exhibit Section
In a report, you can have one or more sections containing multiple report objects defined as Exhibit
sections. You can place a hyperlink to an exhibit section in a report object.

1. Open the report that you want to work with.

2. Open and check out the report object in which you want to place a hyperlink to an exhibit section.

3. In the Report Object tab on the ribbon, click Insert Variable > Exhibit. The Reference Variables
pane is displayed, listing all exhibit variables in the report.

4. In the report object, click on where you want to insert the hyperlink.

5. In the Reference Variables pane, select an exhibit section variable and click Insert (or double-
click the exhibit section variable). The hyperlink is inserted.

6. Save and check in the report object.

If the exhibit file name property is set, the exhibit links the report main document to it.

If the exhibit file name property is not set, the exhibit links the report main document to the name of the
exhibit section. The exhibit is generated with the file name set to the name of the exhibit section.

Insert a Hyperlink to a Web Object (External URL)
In a report, you can define Web objects as exhibits. You can then place a hyperlink to a Web object
exhibit in a report object.

You can define a Web object as an exhibit by right-clicking on it and selecting Properties > Manage All
Object Properties, and then selecting the Is Exhibit checkbox and clicking OK.

To insert a hyperlink to a Web object:

1. Open the report that you want to work with.

2. Open and check out the report object in which you want to place a hyperlink to a Web object
exhibit.

3. In the Report Object tab on the ribbon, click Insert Variable > Exhibit. The Reference Variables
pane is displayed, listing all exhibit variables in the report.

4. In the report object, click on where you want to insert the hyperlink.

5. In the Reference Variables pane, select a Web object exhibit variable and click Insert (or double-
click the Web object exhibit variable). The hyperlink is inserted.

6. Save and check in the report object.
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If you generate the report to EDGAR HTML and open the HTML, hyperlinks point to the selected section
exhibits file when you click the links. Or if you generate in Word and save the generated Word
document, the hyperlinks point to the correct linked files or URL for the Web object.

Sections
You can add sections in any report in CDM to group and organize report objects in the report.

Full reports can contain many report objects. Administrators can add sections periodically throughout
the report and organize the report objects in the sections. The sections make it easier for users to
navigate the report hierarchy.

You can apply a workflow to a section and have all new or existing descendant report objects and
sections below it in the report hierarchy inherit that workflow, eliminating having to individually create
workflows for each of the report objects.

You can also designate top-level sections as exhibit sections. All descendant report objects in an exhibit
section become exhibit documents and are combined into one exhibit document that is included with the
report when using Word generation.

Add a Section to a Report
You can add sections to provide spacing and grouping of report objects.

After adding a section, you can click and drag it to reposition it anywhere in the report hierarchy. When
you add a section, the template workflow assigned to the report is automatically applied to the section
workflow and any report objects and sections below it in the report hierarchy that have Inherit Workflow
enabled.

To add a section to a report:

1. Open the report that you want to work with.

2. Determine the location where you want the section.

3. Do any of the following:

l If adding a section to the report, right-click and select Add Child > Section. The section is
placed immediately below the report in the report tree structure.

l If adding a section to another section, right-click the section and select Add Sibling >
Section. The new section is placed on the same level in the report tree structure as the
section you selected. Or right-click the section and select Add Child > Section. The new
section is placed one level below in the report tree structure as the section you selected.

l If adding a section between report objects, right-click the report object that immediately
precedes that location and select Add Sibling > Section. The section is placed below but
on the same level as the report object you selected.

Edit the Properties of a Section
You can view and modify the properties of a section to tailor the section in a specific way.

1. Open the report that you want to work with.

2. In the report tree, right-click the section and select Properties > Manage All Section Properties.
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3. In the Properties tab of the Properties and Comments window, edit the properties as you want.
You can change any property that is not gray.

4. Click OK.

You can view or edit the following information:

Property Description

Name
User specified name for the section. Each section in a report must have
a unique name.

Section Due Date The due date of the section.

Inherit Due Date
If selected, the section inherits the due date from its parent section due
date or the report due date, depending on its position in the report
hierarchy.

Workflow Due Date The due date of the section's workflow.

Inherit Workflow
If selected, the section inherits the workflow due date from its parent
section workflow due date or the report workflow due date, depending
on its position in the report hierarchy.

Print Options

The print options for the section.

l Printable - When selected and the report or section is
generated, descendant report objects whose properties have
Printable selected are included in the output. When not selected,
all descendant report objects are excluded in generation output
and their names in the report outline become lighter and more
transparent.

l Exhibit - When selected, designates the section as an Exhibit
Section. If selected, report objects grouped together in the
section are combined into one document separate from the
report. Enter values for these fields:

o Exhibit Type - The type of exhibit that is being included with
the report.

o Exhibit Description - Used to enter a description about the
exhibit document.

o Exhibit File Name - Designates the file name for the exhibit
document created at generation. If this field is left blank,
then the name given to the section is used.

Check In and Check Out Report Objects in a Section
You can check in or check out multiple report objects that are in a section in one action.

1. With the report open, right-click on the section in the report tree.

2. Select Check In (if you want to ensure in all report objects in the section have a checked-in
status) or Check Out (if you want to check out all the report objects in the section for editing).

3. The Checkout Status for the report objects is updated in the User Object Summary tab.

https://insightsoftware.com/


44

Delete a Section from a Report
If you no longer need a section in a report, you can delete it.

When deleting a section in a report, any report objects or sections that are descendants (children) of
that section will also be deleted.

To delete a section in a report:

1. Open the report that you want to work with.

2. In the report tree, right-click the section that you want to delete and select Delete.

3. In the confirmation window, click Yes.

Report Format and Print Settings
You can apply common formatting such as fonts, margins, and columns across all report objects in a
report in CDM.

How Does It Work
The Page Setup Word object must have the Page Setup property. When you generate the report output,
CDM applies the settings.

CDM compiles the entire report in descending order. The location of the Page Setup Word object
among the other report objects determines where you want to start to apply the print settings. The
settings are applied only to the report objects that appear after the Page Setup Word object containing
the setting information. For example, if you insert the Page Setup Word object containing the setting
information after the third report object in the report, CDM applies the settings to all subsequent report
objects, but not to the first three report objects.

It is possible to have more than one Word object containing print settings. For example, if you want to
apply different formatting after the ninth report object, insert a new Page Setup Word object after the
ninth report object. CDM applies the new settings to all subsequent report objects.

The first Page Setup Word object that contains font settings is used to apply a common font style and
size across the entire report. If a subsequent Page Setup Word object contains different font styles or
sizes, all subsequent report objects after the second Page Setup Word object inherit the font size and
type from the Page Setup Word object. The first Page Setup Word object continues to apply the
formatting to all report objects until the second Page Setup Word object is found.

Important: Word objects in CDM have the same functionality as Microsoft™ Word. The
advanced functionality for Microsoft products is beyond the scope of this guide. However,
some topics are included for your convenience. For more information, see Microsoft
documentation or Microsoft online help.

Apply Page Setup Formatting in a Report
You can specify your settings in a special Word object called a Page Setup Word object to apply
common formatting such as fonts, margins, and columns across all report objects in a report.

The first step in formatting your report is creating a Page Setup Word object, and then placing it in the
report tree. When you generate your report, all report objects that follow the Page Setup Word object
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will have the formatting in the Page Setup Word object. If you need different formatting in one or more
report objects, you can change settings in those report objects.

To create a Page Setup Word object for applying page setup formatting in a report:

1. Open the report that you want to work with.

2. To insert a Word object that will contain your common formatting information, complete these
steps:
a. Determine the location where you want common formatting to start.

b. Right-click the report object that immediately precedes that location, and click Add Sibling >
Word Object.

Tip: If you insert the Word object in the wrong location, you can drag and drop it in
the correct location.

3. Click Show Properties.

4. Select these property settings:

l Name - Specify the name as Page Setup.

l Document type - Set the property to Page Setup.

5. Click the Section View Mode icon in the status bar.

6. To indent the table that will contain the content in Word objects, insert a table in the Page Setup
Word object, select the table, and click Indent from Left. You can use this option to indent tables
from the left margin by a certain measurement.

Note: This property is available only for tables in Word objects that are indented from
the left margin. If the table is centered or indented from the right using table
enforcement settings, then the measurement in the Indent from Left area is ignored.

7. In the Page Setup Word object, specify other formatting in the same way that you would set up
any Microsoft™ Word file. You can insert text into the Page Setup Word object. Insert dummy text
and format it as required. For example, to identify your formatting choices, you can type Font -
Times Roman 10 point. The text that you type in the Page Setup Word object does not appear in
the generated report.
a. Specify font type and size, and text alignment in the Home tab.

b. Specify margins, orientation, and columns in the Page Layout tab.

c. To specify how paragraphs should flow in your report, select a paragraph in the Page Setup
Word object, right-click, click Paragraph, and select Keep lines together.

d. To prevent a long table from splitting into the next page, the Keep with Next option must be
enabled in paragraph settings, where the dummy text is inserted. At that point, the long
table will be pushed to the next page, keeping the table together. If this option is disabled,
then the table will break into the following page.

8. Click the Default View Mode icon in the status bar.
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When the report is generated, all report objects following this Page Setup Word object contain the
formatting that you specified in the Page Setup Word object.

Exclude a Report Object from the Common Format in a
Report
You can add a Page Setup Word object to specify page setup formatting such as fonts, orientation, and
margins for a report. By default, your page setup formatting applies to all report objects that follow it in
the report, but you can specify that a single report object or a range of report objects should not have the
same settings, meaning, you can exclude some report objects from common formatting.

To exclude a report object from the common format in a report:

1. Open the report that you want to work with.

2. In the report tree on the left, select the report object for which you want to specify different
formatting, and check it out. When the report is generated, the report object that you select will be
formatted according to the settings that you change in the Enforcement settings area of the
selected report object. For any settings that you do not change, the report object will be formatted
according to the settings in the Page Setup Word object that precedes it in the report.

3. Click Show Properties.

4. In the report object that you just opened, change the settings in the Enforcement settings area
as required (do not select these options in the Page Setup Word object itself). Some settings are
applicable to certain types of report objects only.

Setting Report Object Type Description

Margins Excel, Word
To specify different margins for this report object
when the report is generated, clear this setting
and specify different margins.

Columns Excel, Word

To specify different column settings for this report
object when the report is generated, clear this
setting and specify different column settings. This
is useful for pages with two or three columns.

Page Orientation Excel, Word
To specify different orientation for this report
object when the report is generated, clear this
setting and specify different orientation.

Text Alignment Excel, Word
To specify different alignment for text in this
report object when the report is generated, clear
this setting and specify a different alignment.

Font Size Excel, Word, PowerPoint
To specify different font size for this report object
when the report is generated, clear this setting
and specify a different font size.

Font Type Excel, Word, PowerPoint
To specify different font type for this report object
when the report is generated, clear this setting
and specify a different font type.

Paragraph: Keep
with Next

Word

Sometimes paragraphs start on one page and
then continue on the next page when the report is
generated. You can specify whether paragraphs
should start on the original page and then split
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Setting Report Object Type Description

where necessary, or if they should move to the
next page so that the entire paragraph can
appear together. To move paragraphs to the next
page if they might be split, select this setting.

Table Alignment Excel, Word
To specify different alignment for tables in this
report object when the report is generated, clear
this setting and specify a different alignment.

Table Indent from
Left

Word

To force all tables in a Word object to be indented
from the left side for this report object when the
report is generated, select this setting and
specify the indentation.

Keep with Next
Paragraph/Table

Excel, Word

Sometimes tables start on one page and then
continue on the next page when the report is
generated. You can specify whether tables
should start on the original page and then split
where necessary, or if they should move to the
next page so that the entire table can appear
together. To move tables to the next page if they
might be split, select this setting.

When the report is generated, the report object is formatted according to the settings that you changed
in the Enforcement settings area of the selected report object. If you do not use the enforcement
settings from the Page Setup Word object, the settings from the report object are used.

Note:
l If no Page Setup Word object exists, no common formatting is applied even if
enforcement settings are selected.

l You can apply enforcement settings to all Word objects except the Page Setup Word
object itself. You cannot apply enforcement settings to PDF objects and Web Page
objects.

Start and Reset Page Numbering in a Report
You can start page numbering at the beginning of a report, and you can reset the numbering to restart in
other locations if necessary.

1. Open the report that you want to work with.

2. To insert a Word object that will contain your page numbering information, complete these steps:
a. Determine the location where you want page numbering to start.

b. Right-click the report object that immediately precedes that location, and click Add Sibling >
Word Object.

Tip: If you insert the Word object in the wrong location, you can drag and drop it in
the correct location.
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3. Select the newWord object in the report tree, and check it out.

4. Click Show Properties.

5. Select these property settings:

l Name - Specify a name such as Page Numbering.

l Document type - Set the property to Footer.

l Header Footer Placement - You can select Standard, Odd, or Even. Typically, select
Standard.

l Footer Reset Style - Use this field if the report contains a previous numbering scheme, and
you want to change the numbering style later in the report. For example, you might want to
change the numbering from roman numerals in an introductory section of the report to
regular numbers in the main section of the report. Select a numbering style that is different
from the original numbering style.

l Page Reset Number - Use this field if the report contains a previous numbering scheme,
and you want to reset the numbering to page 1 later in the report. You can define the
number of pages that you need to reset the overall page number. This is useful if you need
the page numbers to reset after creating a certain number of report objects. For example, if
you have a five-page report, and you specify 3 in this field, when the report is generated,
the first page number would be 2.

6. Click OK twice.

7. Click the Section View Mode icon in the status bar.

8. In the Word object, click Insert > Page Number > Current Position. Then select a page number
style.

9. Select the page number and apply the formatting that you want to use:

l Set justification for the page number, for example, left, right, or center.

l Apply other styles as required, for example, bold, underline, or italics.

10. Click the Default View Mode icon in the status bar.

11. Save your changes to the report, and check in the Word object if you want.

When you generate the report, page numbering starts at the specified location in the report.

Start and Reset Headers and Footers in a Report
Headers and footers appear in the upper or lower areas of a page, and they can contain content across
multiple pages in a report. You can use Word objects to insert and reset headers and footers in a report.

https://insightsoftware.com/


49

1. Open the report that you want to work with.

2. To insert a Word object that will contain your header or footer information, complete these steps:
a. Determine the location where you want the headers or footers to start.

b. Right-click the report object that immediately precedes that location, and click Add Sibling >
Word Object.

Tip: If you insert the Word object in the wrong location, you can drag and drop it in
the correct location.

3. Select the newWord object in the report tree, and check it out.

4. Click Show Properties.

5. Specify a name such as Header.

6. If you want to insert a header, select these property settings:

l Document type - Set the property to Header.

l Header Footer Placement - You can select Standard, Odd, or Even. Typically, select
Standard.

7. If you want to insert a footer, select these property settings:

l Document type - Set the property to Footer.

l Header Footer Placement - You can select Standard, Odd, or Even. Typically, select
Standard.

8. Click OK twice.

9. Click the Section View Mode icon in the status bar.

10. In the body of the Word object, add the content and formatting for the header or footer.

11. Click the Default View Mode icon in the status bar.

12. Save your changes to the report, and check in the Word object if you want.

When you generate the report, the header or footer starts at the specified location in the report.

Insert Row and Page Breaks Between Report Objects
in a Report
When you generate a report, all report objects are compiled together to create one report. You can
control the transition between report objects by inserting blank pages or blank rows between report
objects in a report.
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1. Open the report that you want to work with.

2. To insert a Word object that will contain your page break information, complete these steps:
a. Determine the location where you want a page break to occur.

b. Right-click the report object that immediately precedes that location, and click Add Sibling >
Word Object.

Tip: If you insert the Word object in the wrong location, you can drag and drop it in
the correct location.

3. Select the newWord object in the report tree, and check it out.

4. Click Show Properties.

5. Specify a name such as Page Breaks.

6. Set the property to Normal.

7. For Break Type, select one of these options:

l Blank Row - The break type has the same font type, font size, and paragraph settings as
the Normal style of the report object. For Excel objects, the break type has the same format
as the first Word object's Normal style (except for the font type which is always Times New
Roman). If no other Word objects exist before the Excel object, the break type has 12 point
Times New Roman font with 0 spacing before and after, and single line spacing as
paragraph properties. In the next field, specify the number of blank rows you want to add
between report objects.

l New Page - If you set the number of the New Page break to 0, the next report object is
pushed to the next page, instead of appearing on the same page as the previous report
object. If you set the number to 1 or more, CDM inserts one or more blank pages before the
next report object.

l Blank Row with Page Setup Properties

o Font Size and Font Type are copied from the Page Setup dummy paragraph.

o Spacing Before, Spacing After, and Line Spacing are copied from the Page Setup
dummy paragraph.

o For Paragraph Pagination, all options will be set to false except Widow/Orphan
control. If the number of breaks is higher than 1, then the lines will be included in the
same paragraph instead of adding separate paragraphs. If there is no Page Setup
object, Paragraph Pagination will default to Blank Row functionality.

8. Click OK twice.

9. Save your changes to the report, and check in the Word object if you want.

When you generate the report, the new blank rows or blank pages are inserted between report objects.
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Report Snapshots
A snapshot is the content of a report or report object captured at a specific moment in time.

You can use a snapshot to determine the changes made to a report or a report object over time. If the
snapshot output option is selected when a report is generated, CDM saves a snapshot of the report.

PDF and Web objects are not included in a report snapshot and cannot be generated as report object
snapshots.

When you generate a filing report, CDM automatically generates a snapshot at the same time. The
snapshot contains the XBRL file and an Excel document with the validation result as a separate
worksheet.

Add a Snapshot
You can use a snapshot to represent the content of a report, report objects grouped in a section, or
report object captured at a specific moment in time.

Important: When you generate a filing report, CDM generates the snapshot automatically, and
you do not need to perform the following procedure.

To add a snapshot in a report:

1. Open the report that you want to work with.

2. In the report tree on the left, select the report, a section containing report objects, or one or more
report objects.

3. Right-click the selection and select Generate Selection.

4. In the generation window, select a format, for example Microsoft Word.

5. Under Additional Preferences, select the Save as Snapshot option and enter a description.

6. Select other options as required.

7. Click OK.

Add a Snapshot from the Section Tab
1. Open the report that you want to work with.

2. In the report tree, double-click the report or a section containing report objects. The report or
section opens in the work area and the Section Tools area containing the Section tab displays
on the ribbon.

3. In the Section tab, click Save as Snapshot.

4. In the Save as Snapshot Description dialog, enter a description for the snapshot you are saving.

5. Click OK. The snapshot is saved.
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View a Snapshot
You can view a snapshot of a report, a single report object, or multiple report objects, if the Save as
Snapshot option was selected when a report was generated.

Ensure that the report contains the snapshot that you want to view. The report or report objects must be
generated with the Save as Snapshot option.

To view a snapshot of a report:

1. Open the report that you want to work with.

2. Click Home > View Snapshots.

3. Select a snapshot, and then click View. The snapshot opens in a specific viewer based on the
format that was selected for the snapshot when it was generated. For example, if you selected
Microsoft Word as the format, the snapshot will open in Microsoft Word for viewing. The View
Snapshots window contains the following information about each snapshot:

l Report Name - The name of the report used to generate the snapshot.

l Generation Type - The format of the snapshot.

l Description - Any text entered in the Description field when the snapshot was generated.

l Date Created - The date that the snapshot was created.

l User - The user who created the snapshot.

4. You can sort any column in the View Snapshots window by clicking a column header. Or, for any
column, click the column filter icons to edit your view of the table.

5. When you are finished with the View Snapshots window, click Close.

Use Snapshots to Compare Versions of a Report or
Report Object
You can use snapshots to compare two versions of a report or report object. When you compare
snapshots, you can see any changes made over time. For example, you can see what was deleted from
an earlier version or what was added to a later version.

To compare versions of a report or report object using snapshots:

1. Ensure that the report contains the snapshots that you want to view. The report or report object
must be generated with the Save as Snapshot option.

2. Open the report that you want to work with.

3. Click Home > View Snapshots.

4. Select any two snapshots by pressing CTRL and clicking each snapshot. You can sort any
column in the View Snapshots window by clicking a column header. Or, for any column, click the
column filter icons to edit your view of the table.

5. Click Compare.
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6. The snapshots open in Microsoft™ Word or your PDF viewer, based on the format of the
snapshot when generated.

l If you compare two Microsoft Word snapshots, the first selected snapshot is compared to
the second selected snapshot. The second selected snapshot displays with any differences
identified.

l If you compare two PDF snapshots, each snapshot displays in the PDF viewer. You can
visually inspect the two snapshots for differences.

l If you compare a Microsoft Word snapshot and a PDF snapshot, the snapshots open in
Microsoft Word or your PDF viewer. You can visually inspect the snapshots for differences.

Delete a Snapshot
If you do not need a snapshot of a report or report object, you can delete the snapshot.

Important: If you delete a snapshot, you cannot undo your action. The deleted snapshot is no
longer present in the View Snapshots window, and it is removed from CDM. Proceed with
caution.

To delete a snapshot:

1. Ensure that the report contains the snapshot that you want to view.

2. Open the report that you want to work with.

3. Click Home > View Snapshots.

4. Select the snapshot you want to delete, and click Delete.

5. In the confirmation message, click Yes.

Report Output
You can generate your report in CDM in several formats such as Excel, Word, PDF, and HTML. Before
you generate output from an Excel object, you can also preview the output to ensure all content is
correct.

Report Output Formats
You can generate your report in the following formats:

l Microsoft Excel
You can generate the report as a Microsoft™ Excel document.

l Microsoft Word
Microsoft Word is the default output format. When you generate the report as a Microsoft Word
document, all report presentation details are applied. PowerPoint objects, Web Page objects,
and PDF objects are not included in Microsoft Word output.

l Microsoft PowerPoint
Unlike Microsoft Word or PDF output, when you select Microsoft PowerPoint as the output
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format, only PowerPoint objects are included in the output. This behavior applies to both the
Generate Entire Report and Generate Selected Objects options. Word objects and Excel objects
are not included in the Microsoft PowerPoint output. If a PowerPoint object includes references to
external data, such as a graph in an Excel object, the referenced object is included in the
Microsoft PowerPoint output.

l Adobe PDF
Like output to a Microsoft Word document, output to a PDF document includes all report
presentation details. The PDF format provides a high-resolution output for printing. PowerPoint
objects, Web Page objects, and PDF objects are not included in PDF output.

l Email with PDF Attached
You can generate a PDF document and send it to one or more recipients. The PDF document is
the same as a document created by using the Adobe PDF output option.

l High Definition HTML
You can generate a high definition .htm version of your Word reports.

l EDGAR HTML
If you use the EDGAR feature in CDM, you can generate a document in HTML format suitable for
use with the EDGAR feature.

l Desktop Publishing
If you use the desktop publishing feature in CDM, you can generate a document in XML format
suitable for use with a desktop publishing application such as Adobe™ InDesign.

Preview an Excel Object
Before you generate output from an Excel object, you can preview the output. You might find this useful
to ensure that all content appears correctly, especially if the Excel object contains ## variables.

To preview an Excel object:

1. Open the report that you want to work with.

2. Open the Excel object.

3. In the Report Object tab on the ribbon, click Generate & Preview > Preview.

4. In the Preview window, confirm that the content appears correctly.

5. If necessary, check out the Excel object and make changes.

6. When the content appears correctly in the preview, you can generate the Excel object.

Specify Regional Settings for Report Output
Users granted the Modify Report permission can set the preferred Language and Region Options in
the report properties that will be used to generate Excel print areas and variables to Microsoft Word,
Microsoft PowerPoint, Adobe PDF and Edgar HTML.

When generate a report, users are still able to select a different language and region option than the
preferred option.
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When no Language and Region Options is set in the report properties, or selected on generation, the
default language and region that is set on the CDM application server is used, making the default
behavior identical with the one from previous versions.

Validate Report Output
As you are working with a report in CDM, you can validate the report periodically to find errors that can
cause report generation to fail.

While you are compiling the report, a full validation can cost time and is rarely needed. Therefore two
types of validation are available: Quick Report Validation and Full Report Validation. The quick
validation is made against the cache without doing a cache refresh. The latest changes in the report are
validated. A full validation refreshes the cache before validation. In either case, before generation of a
report, the report is automatically validated.

To validate a report:

1. Open the report that you want to work with.

2. Click the parent report and click Home > Validate and select one of the following actions: Quick
Report Validation and Full Report Validation.

3. Click OK to start the validation.

Tip: You can view the progress in the All processes completed window in the status
bar. While processes are running, the title bar shows the number of running processes.
When the processes are finished, the title is All processes completed.

4. To open the validation file, open the All processes completed window in the status bar, and click
the Open icon. A check mark indicates that a process generated properly. An exclamation point
indicates an error that stopped the process.
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Generate Report Output
You can generate output from CDM to test the report building progress or to create a document for
internal or external reporting. You can also generate output containing macros and for the EDGAR
feature or desktop publishing applications such as Adobe™ InDesign, if you use those features.

Note: When you generate an inline document or submission package, you can choose to save
temporary files on the server (associated to the long running process). These files are saved
in a Support Files folder (the XPS file will not be included). To do this, enable Include Certent
Support files during generation in the Options window (to access the Options window, click
Options on the File tab).

Before you generate report output, you should verify that the print setting is correct for Word, Excel, and
PowerPoint objects. Only report objects that are set to Printable are included in the report output. As
additions to the main report, you can generate separate documents for report objects that are set to
Supporting Document or Exhibit. The administrator must configure and enable email notifications to
support the Email with PDF Attached report output option.

When you generate a report, all report presentation details are applied, such as page setup properties,
note variables, and table of contents settings. You can customize report generation to provide the
following results:

l Generate the report by selecting one or more custom groups.

l Include supporting documents and exhibits. Supporting documents can be generated as
separate documents or included in the main report. Exhibits are grouped in an Exhibit section
and are combined into a single document at generation. You cannot include supporting
documents and exhibits with Microsoft™ PowerPoint output.

l Create a report snapshot. Report snapshots are useful for tracking changes to reports.

l Refresh data to include the most recent information from data sources, variables, and reference
report objects in the generated report. The use of cached data is useful to reduce generation time
because the server does not have to contact data sources and update all their values.

l Generate the report for all Excel objects or selected Excel objects.

If you select all Excel objects, you generate all content from the printable range (##RS-##RE) in
all Excel objects in the report to an external Excel file at the highest version of the Microsoft Office
version available in the report. If you make a selection of Excel objects, you generate the
selected content from the printable range in the Excel objects in the report to an external Excel
file at the highest version of the Microsoft Office version available in the report.

You can also specify to have multiple workbooks for the output. If you select Use Separate
Workbooks, then you must specify the number of worksheets in each book. For example, if you
make a selection of 100 printable ranges and 25 worksheets per workbook, you generate four
workbooks, each with 25 worksheets. The naming convention of each worksheet for the
workbook follows the convention objectName_rangeNumber and is limited to 31 characters.

l If you generate a report or report object in Microsoft Word or PowerPoint format in Microsoft
Office Version 2007 or later, and if you choose Microsoft Word or PowerPoint as your output
format, you can choose to generate charts as either images or objects.
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l You can specify the culture to be considered for date formats, number formats, and currency
formats. The culture is in the form of language and regional settings that are applied to Excel
report objects in the generated report. The setting is available for the report output types:
Microsoft Word, Microsoft PowerPoint, Adobe PDF, and EDGAR HTML.

l When you generate a section of a report, the header from a previous section is sometimes
generated even if the header is not associated with the generated section.

l The list of macros that can be selected for a particular generation are filtered based on the
macros' target (Excel or PowerPoint) when the macro was created. The generated report
contains the selected macros in separate modules for each macro. The modules have the
macros' names from CDM. When generating a report, the all processes window differentiates a
macro generation from a regular generation. If at generation time, an empty macro (in effect, the
user added a name and target and optionally a description but no VBA code) is selected for
insertion, a warning is displayed when opening the generation in CDM.

To generate report output:

1. Open the report that you want to work with.

2. Click the Home tab, then in the Navigation Pane, click Administration.

3. Double-click Reports. The Reports tab opens in the work area.

4. To generate the entire report, complete one of the following actions:

l Right-click the report name and click Report Generation > Entire Report.

l Click Home > Generate > Generate Entire Report.

5. To generate one or more Word objects or PowerPoint objects without generating the entire
report, complete one of the following actions:

l Right-click the Word or PowerPoint object or objects and click Report Generation >
Selected Report Objects.

l Open the Word or PowerPoint object. Then, in the Report Object tab on ribbon, click
Generate.

6. To generate one or more Excel objects without generating the entire report, complete one of the
following actions:

l Right-click the Excel object or objects and click Report Generation > Selected Report
Objects.

l Open the Excel object. Then, in the Report Object tab on ribbon, click Generate & Preview
> Generate.

Tip: If you use this method, you can choose to preview the Excel object first, to
see if it appears correctly before you generate. To do so, click Generate &
Preview > Preview.
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7. Select the format, custom group, additional preferences, and macros that are to be included.
Alternatively, you can double-click a format icon to generate the report in the selected format with
the current options.

Tip: The generation of a report always starts with a validation. You can check Perform
Full Refresh to refresh the cache before validation.

8. Specify how you want to generate charts:

l If you generate charts as images, you can view the information in your generated report, but
you cannot change it afterward. This option might result in better rendering of advanced
chart types such as 3D charts and rounded edges. To generate charts as images, make
sure that the Generate charts as images checkbox is selected. This is the default selection
for Microsoft Office version 2007 or later.

l If you generate charts as objects, the appearance of the chart is clearer, and you can click
the content afterwards and edit it, if necessary. However, it might take longer to process
your report if you generate charts as objects. To generate charts as objects, make sure that
the Generate charts as images checkbox is cleared.

Tip: In Windows™ Server 2003, generated charts appear wider than the original ones. If
you use Windows Server 2003, you might prefer to generate charts as images.

9. To save a snapshot of the report, select Save as Snapshot.

10. Use the Select Language and Region Option drop-down list to select the culture option for your
generated report.

11. If you want to see the appearance of variables before you proceed, click Preview.

Note: No matter which versions of Office are used in your system, when you preview a
report or report object by clicking the Preview button, you can see charts only as
images. However, when you actually generate the report or report object, if you use
Office 2007 or later, you can generate charts as either images or objects.

12. Click OK.

Excel objects in the report might contain more than one data worksheet. (The first data worksheet is
originally named Sheet1, but it might have been renamed.) If there are multiple ##RS and ##RE range
variables applied in the same worksheet, or across different worksheets, the content is read from left to
right and then top to bottom when it is generated in the final document. At that point, all the printable
ranges inside the Excel object are separated by one blank row.

Note: A ##RS-##RE range cannot overlap with other ##RS-##RE directives when you are
defining a worksheet with multiple ranges.

CDM creates the output file on your computer. For example, on Microsoft Windows 7, the report is
added to the C:\Users\username\AppData\Local\Temp directory. The output file is not added to
the CDM database.
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If you selected macros to be included in the generated report, the resulting workbook or presentation is
macro-enabled (for example, XLSM, PPTM) and contains those macros.

When you open a report, you can choose to save it. If you do so, and then you open it again, the report
opens from the location that you specified; otherwise, it opens from a temporary location.

Report Export and Import
You can use CDM to export a report that has already been created and tagged against a taxonomy. The
exported report can then be imported into a different location.

Data Included in Report Export and Import
When you export or import a report, the following types of data can be included from a single report:

l Report structure (hierarchy of report objects, object content, and object properties)

l Shared status of each report object (shared or not shared)

l Report properties

l Reference variables

l Hyperion Financial Management (HFM) formulas

l Data sources, data queries, and query variables used in the report

l Query variable overrides

l Associations between report objects and data queries

l Associations between report objects and data sources, include HFM data source associations

l Associations between reports and data queries

l XBRL projects associated with the reports, project aspects such as title, units, time periods, entity
schemes and identifiers, and XBRL variables and their values

l Entry point URIs of taxonomies that are associated with the projects in the report

Data Excluded in Report Export and Import
The following types of data are not included in an exported or imported report:

l Reference objects that reference a report object outside the report

l Comments

l Checklists

l Workflow

l Snapshots
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l Users, user groups, and permissions

l Audit history (when you import an exported report, the auditable entities such as reports and
report objects will receive an audit entry on behalf of the user at the target site)

l Checked-out state (when you import an exported report, all report objects will be checked in)

l Locked state for reports and report objects (when you import an exported report, the reports and
report objects will not be locked, regardless of the locked state of the source report or report
objects)

l Expiration policies of data sources

Export a Report Created and Tagged Against a
Taxonomy
A taxonomy is a description of a multidimensional data store expressed in XML. You can use CDM to
export a report that was created and tagged against a taxonomy.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Reports. The Reports tab opens in the work area.

3. From the report list, select the report and click Home > Export.

4. Complete the steps in the Export Reports wizard.

When the export process is complete, a summary provides the following information:

l Number of report objects exported

l Number of queries exported

l Number of projects exported

l Number of taxonomies exported

l Name of any reference objects that were skipped

l Name of data sources

l Name of data queries exported

Import an Exported Report
You can use CDM to import a report that was previously exported.

Before You Begin
Before you import an exported report or set of reports, prepare the following information:

l You must know the master encryption password.

l You must know which report group will contain the imported report.
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l You might need to specify how to associate user taxonomies with projects.
o If there is one user taxonomy with the required entry point URI, the import process

automatically associates the taxonomy with the appropriate project.
o If there is more than one user taxonomy with the required entry point URI, you must specify

which project to use.
o If there is no user taxonomy with the required entry point URI, you must manually import the

taxonomy first. For more information, see the topics on adding taxonomies in the CDM
XBRL Administration Guide.

l You must be prepared to resolve conflicts with XBRL aspects. Some aspects might have names
that conflict with existing aspects. For each conflicting aspect name, you must select one of the
following options:
o Replace the aspect being imported with the existing aspect. Any items that reference the

aspect that is being imported will now reference the existing aspect.
o Rename the aspect that you are importing.

l Ensure that the appropriate data source runtime prerequisites are installed on the destination
application server. For example, if you are importing Oracle Essbase queries, make sure that you
have Essbase runtime installed on the destination application server.

Procedure
1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Reports. The Reports tab opens in the work area.

3. From the report list, select where to import the report, then click Home > Import.

4. Complete the steps in the Import Reports wizard.

5. After the import is complete, make sure that your data connection details, such as server names
and credentials, are updated. If your paths are incorrect, your data will not refresh.

When the import process is complete, a summary provides the following information:

l Number of reports imported

l Number of report objects imported

l Number of queries imported

l Number of projects imported

l Number of taxonomies imported

l A list of the imported data sources that you might need to fix later

l Name of data sources

l Name of data queries imported
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Workflow and Auditing
A workflow is a process that is used to track the progress of a report object towards completion. For
users to track work with a report, section, or report object, a workflow must be associated with each. A
report, section, or report object can be advanced through all the workflow states configured for it. With
assigned permissions, you can advance the current state to the next state in the approval chain, or
reject and revert a report object to its previous state.

Workflows
Workflows are used by:

1. A user with administration permissions creating workflow states and transitions. The workflow
states define what needs to be done at each point in the approval process (for example, review or
approve). The workflow transitions define the flow from state to state. With assigned
permissions, you can design a workflow process that uses any number of states and transitions
in the approval process and for many users.

2. Creating a workflow template that can be automatically assigned to new reports, sections, or
report objects so you can save time by not having to add several states to a blank workflow.
Workflow templates are created at the application level and are available to all reports, report
sections, and report objects. You can use a template to quickly create reports, ready for use.
There is no need to manually create workflow states each time you create a new report object or
section. The workflow template can be also used as a starting point to create a customized
workflow for a report object or section. A report itself can use only one template but you can
change which template is used. You can use a workflow template and then customize the
template for specific report objects or sections as required. You can lock or edit the report object
or section, assign users and user groups to the report object or section, change the default status
of the report object or section, and set the due date.

3. Assigning the workflow template to the report or manually assign the workflow states to each
report object or section.

4. Assigning users and user groups to the template or to the report objects or sections. The users
and user groups must be defined first.

No Workflow Application Default
You can specify that no workflow template be used for new reports in CDM. If you have the Manage
Workflow Template permission, go to Administration > Workflow and double-click Workflow
Templates. In the Workflow Templates tab, the default workflow template is highlighted by a check
mark. Select the default workflow template and click Home > Default Template. There is now no
assigned default template for new reports.

Auditing
An audit trail is a detailed analysis of all changes that are made to reports or report objects. The audit
trail feature records every submission to the CDM database, along with the user name and the date of
submission. You can log in, view, and recover the audit trail.
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Workflow State
In CDM, you can design workflow states that can be used in a workflow to define what needs to be done
at each point in the approval process.

Add a Workflow State
Some workflow states are provided in CDM. If the workflow state that you need does not exist, you can
add it.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Workflow, double-click Workflow States. The Workflow States tab opens in the work
area.

3. Click Home > Add > Workflow State. The Add Workflow State Template window is displayed.

4. Enter a name for the workflow state.

5. You can specify a description for the workflow state. The description can contain a maximum of
50 characters.

6. Select an image for the state. If you need an image that does not appear in the State Image area,
click Add Another Image > Browse, and browse for an image on your computer. You can save
the image you uploaded to the image gallery.

Note: Ideally, the size of the image should be 42 x 42 pixels. If the image that you select
is larger than 42 x 42 pixels, the size is reduced automatically when it appears in a
workflow process.

7. In the Report Summary Options area, select the color for text and background.

8. Click OK.

Edit a Workflow State
You can change the details of a workflow state.

1. In the Workflow States tab in the work area, right-click the workflow state you want to edit and
select Edit.

2. Change the name, description, and image for the workflow state.

3. Change the color for text and background.

4. Click OK.

Delete a Workflow State
If you no longer need a workflow state, you can delete it. You cannot delete a workflow state if it is
currently in use.

Important: If you delete a workflow state, you cannot undo your action. Proceed with caution.
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To delete a workflow state:

1. In the Workflow States tab in the work area, right-click the workflow state you want to delete and
select Delete.

2. In the confirmation window, click Yes.

Workflow State Transitions
In CDM, you can create one or more transitions for each workflow state. A transition moves the current
workflow state to the next state in the workflow process.

For each workflow state in the workflow process, you can link multiple transitions to any number of other
states. You then have the option to move the current state to any number of different states based on
which transition you choose. You can assign one transition as a default to automatically move the
current state to the next or you can choose which transition to use from the many you have created.

Add a Workflow State Transition
You can add a workflow state transition in CDM. A workflow state transition is used to move the current
state to the next state in the workflow process.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Workflow, double-click Workflow Templates. The Workflow Templates tab opens in the
work area.

3. Select the workflow template to which you want to add a transition and click Edit.

4. For any workflow state, draw a line from the gray Out pipe to the white In pipe of the workflow
state that you want as the next step in the workflow process. A transition line appears between
the two states.

5. You can create many transitions from one state to several others and designate one transition as
the default (to set a transition as the default, right-click it and select Default). The default
represents the most likely transition to be used automatically when the state moves to another
state. However, a user can choose the other transitions not designated as the default as an
option when the state is moved.

6. Click OK.

Set Attributes for a Workflow State Transition
Workflow state transition attributes determine what actions take place when a current state is moved to
the next state in a workflow. You can set different attributes for a workflow state transition in a workflow
template.

For each workflow state transition, you can set the following attributes:

l Email Body
Used to enter a message if a pre-configured email message does not exist for the workflow state.
See Email Notification for Workflow Processes.
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l Default
Determines that the transition is to be used when moving a current state to the next state using
the Move to Next State > Automatic option.

l Transition Rules
Used to define workflow rules to control the workflow process based on user-defined conditions.
Rules apply to either referenced or copied object-level workflows.

To set attributes for a workflow state transition in a workflow template:

1. In the Workflow Templates tab in the work area, select the workflow template and click Edit.

2. To enter a message if a pre-configured email message does not exist for the workflow state,
right-click a transition and select Email Body. Enter the text of the message to be sent and click
OK.

3. To set a transition as the default transition, right-click it and select Default.

4. To apply transition rules, right-click a transition and select Transition Rules and apply the
condition.

5. Click OK.

Edit a Workflow State Transition
You can change the details of a workflow state transition in a workflow template.

1. In the Workflow Templates tab in the work area, select the workflow template and click Edit.

2. To enter a message if a preconfigured email message does not exist for the workflow state, right-
click a transition and select Email Body. Enter the text of the message to be sent and click OK.

3. To reposition a transition, click and hold the transition at either the gray Out pipe or white In pipe
of the workflow state and drag it to the corresponding pipe on another transition. The transition
line is repositioned.

4. To edit the message that is to be sent by email when the workflow state is moved, right-click the
transition and select Email Body. Edit the text of the message and click OK.

5. To edit a transition as the default when the workflow state is moved, right-click the transition and
select or clear Default.

6. To edit transition rules, right-click a transition and select Transition Rules and apply or remove a
condition.

7. Click OK.

Delete a Workflow State Transition
If you no longer need a workflow state transition in a workflow template, you can delete it.

1. In the Workflow Templates tab in the work area, select the workflow template and click Edit.

2. Click a transition to select it and click Delete.

3. Click OK

https://insightsoftware.com/


66

Workflow Templates
Workflow templates are created at the application level in CDM and are available to be applied to all
reports, sections, and report objects as a copy or as a reference.

A workflow template can be used as a starting point to create a customized workflow for a report, a
section, or a report object.

After opening workflow templates, the name and description of each template is loaded. You can
optionally export the contents into a CSV file by right-clicking in the work area and clicking Export as
.csv.

Add a Workflow Template
If the workflow template that you need does not exist, you can add one.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Workflow, double-click Workflow Templates. The Workflow Templates tab opens in the
work area.

3. Click Home > Add > Workflow Template. The Add Workflow Process window is displayed.

4. Specify a name for the workflow process.

5. You can specify a description for the workflow template.

6. To change your view of the workflow process, click Zoom In, Zoom Out, or Zoom to Fit.

7. Edit the workflow process:
a. From the Toolbox box, select icons that represent workflow states you want in this workflow

process and drag them to the Workflow box. Arrange the icons in the appropriate order for
your workflow process.

b. Assign users or groups that can use each workflow state.

c. Set the attributes for each workflow state.

d. Create transitions for each workflow state.

8. When you are finished, click OK.

9. If there are multiple templates, specify which template is the default template by selecting the
template and clicking Default.

Assign Users or User Groups to a Workflow Template
When you design a workflow process, you must assign users or user groups to each workflow state. If a
user is not assigned to a workflow state, they cannot work with or make changes to the report, section,
or report object using that workflow. Users are restricted to advancing the workflow state only for
reports, sections, or report objects that they are assigned to.

To assign users or user groups to a workflow state in a workflow template:

1. In the Workflow Templates tab in the work area, right-click the workflow template and select Edit.

2. Select a workflow state in the diagram.

3. Click Assign Users/Groups.

https://insightsoftware.com/


67

4. Select a user or user group and click Add.

5. Click OK twice.

Set Attributes for a Workflow State in a Workflow
Template
Workflow state attributes determine how users work within a workflow. You can set different attributes
for a workflow state in a workflow template.

For each workflow state, you can set the following attributes:

l Set Due Date
Determines when the workflow state is due. The due date is set in relation to the due date of the
assigned report object.

For example, the current date is June 1; the report object's due date is June 30. You have three
states in a workflow that will be completed simultaneously. You need 5 days to complete the
tasks in the first state, 10 days for the second state, and 15 days for the third state. To complete
all workflow states by June 30, the first state is due June 25 (June 30 minus the offset of 5 days),
the second state is due June 20 (June 30 minus the offset of 10 days), and the third state is due
June 15 (June 30 minus the offset of 15 days).

l Default
Determines the default state for report objects. The first state added to the diagram is
automatically the default state. You can specify a different state as the default.

l Editable
Determines whether users can edit the report, section, or report object when it is in this workflow
state. When report objects are in a workflow state that is not editable, the content in the report
objects cannot be changed and the report objects cannot be checked out. Report objects can still
be moved through the different workflow states that are editable.

l Locked
Determines whether the report, section, or report object can be refreshed when in this state.

To set attributes for a workflow state in a workflow template:

1. In the Workflow Templates tab in the work area, right-click the workflow template and select Edit.

2. To change the due date of a state, select the state and click Set Due Date. Select an appropriate
due date offset and click OK.

3. To change the default state, select the new state and click Default.

4. To allow users to edit the report, section, or report object in a state, select the state and click
Editable.

5. To lock a report, section, or report object in a state, select the state and click Locked.

6. To show or hide the legend, click Show Legend.

7. Click OK.
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Delete a Workflow Template
If you no longer need a workflow template, you can delete the template. You cannot delete a workflow
template if the template is referenced by any report object.

Important: If you delete a workflow template, you cannot undo your action. Proceed with
caution.

To delete a workflow template:

1. In the Workflow Templates tab in the work area, right-click the workflow template you want to
delete and select Delete.

2. In the confirmation window, click Yes.

Email Notification for Workflow Processes
You can use email notification in CDM to inform the next users in a workflow that the workflow state has
changed. The email can automatically include required information and a user can customize the
default content of the email message before it is sent.

Configure the Email Notification Template for a
Workflow
If you want users to send an email notification when they move a section or report object to the next step
in the approval process in CDM, you can create an email template to include a default message and
update the notifications configuration file.

The configuration file is Notifications.config. You can configure the location of the template files for
each notification event in the notifications section of the configuration file.

Important: Make sure that the recipient of the email registers the CDM protocol in the Options
window, as described in the CDM User Guide. Also, if the recipient of the email uses web mail,
links might not appear or function correctly.

Use the following example to configure the email notification configuration file:

<Notifications>
<MessageTemplates>
<MessageTemplate event="ReportObjectWorkflowStateChanged" format="Html"
filePath="EmailTemplates\ChangeReportObjectWorkflowState.html" />
<MessageTemplate event="ReportGenerated" format="Html"
filePath="EmailTemplates\ReportGenerated.html" />
</MessageTemplates>
</Notifications>

The following list provides the detail for this configuration:

l The notifications system can be enabled or disabled using the Notifications enabled
attribute.
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l Set the format for the event to either Plaintext or Html.

l The file path to the template is relative to the application path.

Create an email template file that includes an email subject line, body, and tags.

Email Template Parameters
If you want users to send an email notification when they move a section or report object to the next step
in the approval process in CDM, you can complete the email template with parameters for two types of
email events. The custom format allowed depends on the type of event.

Create an email template file that includes an email subject line, body, and tags. The first line of the
template file contains the template for the subject line of the notification and the rest of the file contains
the template for the body of the notification. Include tags that are dynamically replaced with values when
the notification is sent. The format of a tag is $(TagName[:customFormat]), where TagName is the
name of the value which you want to place at the tag location and customFormat is a custom string
formatting parameter. If a tag is null, then an empty string is used in the notification.

The ReportObjectWorkflowStateChanged Event
For the ReportObjectWorkflowStateChanged event, use the following supported tags:

l ReportName
The tag format is "string". The name of the report that contains the section or report object with
the workflow state changes.

l ReportObjectName
The tag format is "string". The name of the section or report object with the workflow state
changes.

l SenderFirstName
The tag format is "string". The first name of the user who changed the workflow state.

l SenderLastName
The tag format is "string". The last name of the user who changed the workflow state.

l SenderEmail
The tag format is "string". The email address of the user who changed the workflow state.

l InitialStateName
The tag format is "string". The name of the initial workflow state.

l FinalStateName
The tag format is "string". The name of the final workflow state.

l ReportObjectLink
The tag format is "string". The link from CDM to the section or report object.

l ReportObjectDueDate
The tag format is "datetime". The due date and time (UTC) of the section or report object.

l WorkflowStateDueDate
The tag format is "datetime". The due date and time (UTC) of the final workflow state.
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Tip: If you are not located in the UTC time zone, conversion is required to determine the due
date and time as it corresponds to your time zone.

l ToRecipients
The tag format is "string". The list of recipients associated with the final workflow state. These are
the users in the To field of the notification.

l CcRecipients
The tag format is "string". The list of recipients associated with the initial workflow state. These
are the users in the Cc field of the notification.

l NotificationMessage
This is the custom notification message. If the user does not supply a custom message, the
message from the transition is used. If the workflow state transition email body field is empty, an
empty string is used.

The ReportGenerated Event
For the ReportGenerated event, use the following supported tags:

l ReportName
The tag format is "string". The name of the generated report.

l ReportLink
The tag format is "string". The link to the report that was generated.

l NotificationMessage
The tag format is "string". The custom notification message.

Enable and Configure Email Notification for a Workflow
You can set up the email notification feature to send an automated email to the assigned user of a
workflow process.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Notifications, double-click Email Settings. The Email Settings tab opens in the work area.

3. Select the Enable Email Notifications checkbox.

4. In the SMTP Server Settings area, complete these settings:

l A valid sender email address.

l A valid mail server name.

l A valid port number for the mail server.

5. In the Security and Authentication area, you can perform one of these steps to set the user
credentials:

l Select the Use Default Credentials checkbox to use the default credentials. This will use
the credentials on the application server to authenticate to the SMTP server. The
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credentials on the application server are defined in the Credentials.config file, under
EmailNotifications.

l Clear the Use Default Credentials checkbox to override the default credentials. Type a
user name and password.

6. To enable Secure Sockets Layer (SSL), select the Enable SSL checkbox.

7. Click Save.

Enable Custom Email Messages in a Workflow
You can enable and disable the feature that allows users to add custom messages to email notifications
in the workflow.

1. Click File > Options.

2. In the Options window, select the Allow custom email notification message checkbox.

3. Click OK.

Progress Reports, Audit Trails, and Workflow
Assignment Reports
You can monitor information about a report in CDM with progress reports, audit trails, and workflow
assignment reports.

A progress report provides a detailed view of the status of sections and report objects. The audit trail
provides detailed analysis of all changes that are made to reports, sections, or report objects. The
workflow assignment report provides a detailed view of the workflow for each report. For example, you
can see the due date for each workflow state.

These reports can be run at any time by the administrator or by any user who has administrative access
to the feature.

Create a Progress Report
You can create a progress report for a report that provides a detailed view of the status of sections and
report objects.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Reports. The Reports tab opens in the work area.

3. From the report list, select the report and click Home > Progress Report.

4. In the progress report, perform one or more tasks:

l To copy the data into Microsoft™ Excel for further analysis, click Export to Excel.
Alternatively, right-click the report, and click Export To Excel.

l To change the appearance of the report, right-click any column header, and click one of the
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available options. For example, you can sort, group, and filter.

l To refresh the data in the report, click Refresh, or right-click the report and click Refresh.

5. Click Close.

View an Audit Trail
You can view an audit trail for a report, all the sections or report objects in the report, or login activity.

1. Open the report that you want to work with.

2. Click Home > Report Audit Trail. The Report Audit window opens.

3. Select the type of audit report:

l Click on Report to view an audit trail for a report. You can view information such as the
report name, description, date, and operation type, for a list of the versions of the report.

l Click on Report Object to view a detailed audit trail of all the sections (group objects) and
report objects in the report. To view a section or report object version in the application that
it was created in, select a version of the section or report object from the audit trail list, and
click View. You can also click View to view section or report object content from previous
versions.

l Click on Login to view an audit trail of all login activity for all users that have logged into
CDM.

4. The audit trail is presented as a grid. You can sort and group some of the columns. To group the
table by a column, drag and drop the column into the Drag a column header here to group by
that column area above the column header.

5. You can also click the following buttons to perform additional tasks:

l Refresh - To refresh the audit trail.

l Export to Microsoft Excel - To export the list of audit records to a Microsoft Excel file. You
can also filter the number of audited records based on date.

6. Click Close to close the Report Audit window.

Restore Version from Audit for Word, Excel, and
PowerPoint Objects
You can restore an earlier version of a Word, Excel, or PowerPoint report object in CDM. When you
restore an earlier version it becomes your working copy. All versions still exist in the CDM database and
can also be restored as required.

To use an audit trail to restore an earlier version of all changes for a report object in a report:

1. Open the report that you want to work with.

2. Open the Excel, Word, or PowerPoint object of which you want to restore an earlier version.
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3. In the Report Object tab on the ribbon, click Object Audit Trail. The Report Object Audit
window opens.

4. Select an audit version and click View to identify it as the version you want to restore.

5. With the identified audit version selected, click Restore.

6. A prompt is displayed to confirm the restore is completed.

7. Click OK to close the prompt.

8. The Report Object Audit window displays the restored version with an updated time stamp and
Restore Object from Audit displayed in the Operation Type column.

9. Close the Report Object Audit window. The report object displays content from the version you
restored.

Note: Desktop publishing and XBRL tags that have been created on the report object after the
creation date of the restored audit entry are orphaned and need to be recreated.

Create a Workflow Assignment Report
The workflow assignment report provides a detailed view of your assigned areas of the workflow. For
example, you can see the due date for your assignments.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Reports. The Reports tab opens in the work area.

3. From the report list, select the report and click Home > User Workflow Assignment.

4. In the progress report, perform one or more tasks:

l To change the appearance of the report, right-click any column header, and select one of
the available options. For example, you can sort, group, and filter.

l To refresh the data in the report, click Refresh, or right-click the report and click Refresh.

5. Click Close.
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Data Sources
A data source defines the physical connection to a data repository such as a relational database, an
OLAP cube, or a Microsoft Excel file.

A data source connection specifies the parameters needed to connect to the database, such as the
location of the database and the timeout duration. A data source connection can include credential
information and sign-on. You can also add new connections to a data source and modify or delete
existing connections.

You must create a data source connection before users can create queries. After you add a data
source, an icon with the name of the data source appears in the Data Source Connectivity work area.
You should then inform users that the data source is available for them to perform queries and run
reports. You can optionally export the list of data sources into a CSV file by right-clicking in the work
area and clicking Export as .csv.

In CDM, you can add data source connections to the following data types:

l OLAP

l Relational

l Microsoft Excel

l Hyperion Financial Management (HFM)

l Business Intelligence

Configure the Whitelist Element for Data Sources
You must configure the whitelist element in the CDM.config file so that CDM can connect successfully to
data sources. Each new data source must be whitelisted.

1. Open CDM.config on the computer where the CDM server has been installed. The default
location is C:\inetpub\wwwroot\CertentCDM-Server\Config.

2. Locate the add key inside the DataSources\Whiteliste element:

<add name ="Any data source" serverName="*" />

3. Modify the key by making these changes:

l Enter a unique value for the name parameter.

l Enter the name or the IP address of the database server as a value for the serverName
parameter.

Tip: You can use these wildcards: * which represents any sequence of zero or more
characters, and ? which represents any single character.

4. For each data source you want to connect to, add a new add key, and specify new values for the
name and serverName parameters.

5. Save the changes to the CDM.config file.
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You can now use CDM to add a data source and then connect successfully to the database server.

Configure Windows Authentication for Data
Sources
If you plan to use Windows™ authentication to connect to your data source, you must enable a data
sources account by editing the Credentials.config file.

1. Open Credentials.config on the computer where the CDM server has been installed. The default
location is C:\inetpub\wwwroot\CertentCDM-Server\Config.

2. Locate the DataSourcesCredentials key element:

<DataSourcesCredentials enabled="true" userName="" password="" />

3. Modify the key by making these changes:

l Ensure that the name parameter is set to true.

l Set the value of the userName parameter to the name of a Windows account that has
access to the database server.

l Set the value of the password parameter to the password of the Windows account.

4. Save the changes to the Credentials.config file.

You can now use CDM to connect to a data source using Windows authentication.

Add an OLAP Data Source
You must add an external OLAP data source so that CDM users can query OLAP data.

1. Install the 64-bit version of the client runtime on the CDM application server, as necessary for the
type of database that you plan to use.

l For an Oracle Essbase data source, follow these steps:

l Download and install Essbase Client install from the Oracle website.

l Edit the PATH Environment Variable to include the bin folder of Essbase Client. For
example, the Oracle home path on a 64-bit computer is C:\Oracle\Middleware.
Therefore, the Essbase Client bin path is
C:\Oracle\Middleware\EPMSystem11R1\common\EssbaseRTC-
64\11.1.2.0\bin.

l For an IBM® Cognos® TM1® data source, download and install the IBM Cognos TM1
client, version 9.5 or later. To connect to TM1 10.1 data, you must install the same version
of TM1 client library on the CDM application server.

2. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.
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l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

3. Click Home > Add > OLAP Data Source, or right-click any existing data source in the work area
and click Add > OLAP Data Source.

4. Specify the connection parameters for the desired type of data source.

l Oracle Essbase

l Microsoft Analysis Services

l IBM Cognos TM1

Tip: You can connect to IBM Cognos Controller data by first publishing the data to
a TM1 cube and then using CDM to connect to the TM1 data source.

l IBM Cognos TM1 Using NATed IP

5. Click Test Connection.

l
If the connection succeeds, the Connection successful icon is displayed.

l
If the connection fails, the Connection test failed icon is displayed. Check with the
database administrator to ensure that the database server is running and that you have the
correct parameters.

6. Click OK.

Users can now create and edit queries based on the newly defined OLAP data source. They can also
associate queries with reports, allowing query results to be used by the reports.

Important: You must ensure that each new data source is added to the whitelist element so
that the CDM application server can authenticate the data source.

Connection Parameters for Oracle Essbase
To connect to Oracle Essbase as an OLAP data source in CDM, use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Provider Select Oracle Essbase.

Server Enter the name of the Essbase server, for example, essbaseserver.
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Parameter Description

Authentication Type

Select Basic Authentication to authenticate against the server account.
Select Active Directory SSO to authenticate using an existing Active
Directory user account.

The credentials will be passed to the Essbase server and only data that
the Active Directory user is authorized to view will be returned. Using this
option, you no longer need to create additional accounts to use Essbase
data sourcing.

Note: If you define queries with Essbase SSO, these are run
against Essbase SSO with your credentials as the current user
of CDM. Your credentials need to be imported into CDM from an
Active Directory source. The same Active Directory needs to be
defined at the Oracle Essbase Server level under Shared
Services.

User ID
Enter the user name of the Essbase server account if you are using basic
authentication. Enter the user name of the account that has access to the
Essbase data source if you are using Windows™ authentication.

Password Enter the password of the account that you are using for authentication.

Login Attribute

When using Essbase Single Sign-On authentication Active Directory
SSO, use the default value sAMAccountName.

Note: This is the attribute in the Lightweight Directory Access
Protocol (LDAP) to identify users in Active Directory. You
should use this default value.

Locking User
When using Essbase Single Sign-On authentication Active Directory
SSO, enter the user name of the user to use when refreshing report
contents after locking the report.

Locking Password
When using Essbase Single Sign-On authentication Active Directory
SSO, enter the password of the user to use when refreshing report
contents after locking the report.

Application
Enter the name of the application on the server that is hosting the
Essbase cube.

Cube Enter the name of the cube that is defined in Oracle Essbase.

Connection Parameters for Microsoft Analysis
Services
To connect to Microsoft™ Analysis Services (MSAS) as an OLAP data source in CDM, use the following
parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy Select the expiration policy. Expiration policies determine when the
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Parameter Description

cached data must be refreshed from the underlying external data
sources.

Provider Select Microsoft Analysis Services.

Server Enter the name of the MSAS server, for example, msasserver.

Authentication Type

Select Windows Authentication to authenticate against a data sources
Microsoft Windows™ account that users create on their computers.

Users must assign rights for the data sources account to access the data
sources. A separate data sources account gives you more flexibility when
you are assigning access rights on external data.

Important: The Credentials.config file needs to be updated for
the DataSourcesCredentials configuration settings.

Application
Enter the name of the application on the server that is hosting the MSAS
cube or in-memory tabular model.

Cube Enter the name of the cube or tabular model that is defined in MSAS.

Connection Parameters for IBM Cognos TM1
To connect to IBM® Cognos® TM1® as an OLAP data source in CDM, use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Provider Select TM1.

Connection Type
Choose depending on how your TM1 server is deployed: TM1 on Prem
or TM1 on Cloud.

Admin Host Enter the TM1 Admin host.

Server IP Populated automatically based on the Server Name selected.

Authentication Type

Select Basic Authentication to authenticate against the server account
using standard Cognos® TM1 credentials. Select CAM authentication to
authenticate using an existing CAM user account.

The credentials will be passed to Cognos TM1 and only data that the user
is authorized to view will be returned. Using this option, you no longer
need to create additional accounts to use Cognos TM1 data sourcing.

User ID
Enter the username of the TM1 server account if you are using basic
authentication.

Password
Enter the password of the account that you are using for basic
authentication.

Locking User
When using CAM authentication, specify the username of the user to use
when refreshing report contents after locking the report.
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Parameter Description

Locking Password
When using CAM authentication, specify the password of the user to use
when refreshing report contents after locking the report.

Namespace ID
When using CAM authentication, specify the namespace ID of the user to
use when refreshing report contents after locking the report.

Server Name
Select the name of the TM1 Server on the server that is hosting the TM1
cube.

Cube Select the name of the cube that is defined in TM1.

Connection Parameters for IBM Cognos TM1 Using
NATed IP
To connect to IBM® Cognos® TM1® using NATed IP as an OLAP data source in CDM, use the
following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Provider Select TM1.

Connection Type
Choose depending on how your TM1 server is deployed: TM1 on Prem
or TM1 on Cloud.

Using NATed VPN Select if using a NATed IP.

Admin Host Enter the TM1host REST URL.

NATed Server IP Enter the NATed IP of the TM1 server.

Authentication Type

Select Basic Authentication to authenticate against the server account
using standard Cognos® TM1 credentials. Select CAM authentication to
authenticate using an existing CAM user account.

The credentials will be passed to Cognos TM1 and only data that the user
is authorized to view will be returned. Using this option, you no longer
need to create additional accounts to use Cognos TM1 data sourcing.

User ID
Enter the username of the TM1 server account if you are using basic
authentication.

Password
Enter the password of the account that you are using for basic
authentication.

Locking User
When using CAM authentication, specify the username of the user to use
when refreshing report contents after locking the report.

Locking Password
When using CAM authentication, specify the password of the user to use
when refreshing report contents after locking the report.

Namespace ID
When using CAM authentication, specify the namespace ID of the user to
use when refreshing report contents after locking the report.

Server Name
Select the name of the TM1 Server on the server that is hosting the TM1
cube.
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Parameter Description

Cube Select the name of the cube that is defined in TM1.

Add a Relational Data Source
You must add an external relational data source so that CDM users can query relational data.

1. Install the 64-bit version of the client runtime on the CDM application server, as necessary for the
type of database that you plan to use.

l For a Microsoft™ SQL Server data source, no further installation is required. The client
runtime is included in the .NET Framework.

l For an Oracle data source, download and install the Oracle Instant Client and the Oracle
Data Provider for .NET from the Oracle website.

l For an IBM® DB2® data source, download and install the IBM Data Server Driver Package.
This package contains the IBM DB2 ADO.NET provider and the client runtime.

2. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

3. Click Home > Add > Relational Data Source, or right-click any existing data source in the work
area and click Add > Relational Data Source.

4. Specify the connection parameters for the desired type of data source.

l Microsoft SQL Server

l Oracle

l IBM DB2 for Linux, UNIX, and Windows

l IBM DB2 for i

l ODBC

Note: CDM does not support DSN ODBC data sources.

l OLE DB
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5. Click Test Connection.

l
If the connection succeeds, the Connection successful icon is displayed.

l
If the connection fails, the Connection test failed icon is displayed. Check with the
database administrator to ensure that the database server is running and that you have the
correct parameters.

6. Click OK.

Users can now create and edit queries based on the newly defined relational data source. They can
also associate queries with reports, allowing query results to be used by the reports.

Important: You must ensure that each new data source is added to the whitelist element, so
that the CDM application server can authenticate the data source.

Connection Parameters for Microsoft SQL Server
To connect to Microsoft™ SQL Server as a relational data source in CDM, use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Connection Type Select Microsoft SQL Server.

Server Name Enter the name of the SQL server that holds the database.

Authentication

Select SQL Server Authentication to authenticate against the
server account. Select Windows Authentication to authenticate
against a data sources Microsoft Windows™ account that users
create on their computers.

Users must assign rights for the data sources account to access the
data sources. A separate data sources account gives you more
flexibility when you are assigning access rights on external data.

User Name

Enter the username of the SQL server account if you are using SQL
server authentication. Enter the username of the account that has
access to the SQL data source if you are using Windows
authentication.

Password
Enter the password of the account that you are using for
authentication.

Database Select the database name from the drop-down menu.

Connection Parameters for Oracle
To connect to Oracle as a relational data source in CDM, use the following parameters:
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Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Connection Type Select Oracle.

Server Name Enter the name of the Oracle server that holds the database.

Port
Enter the port number that is used by the server to establish the
connection to the service.

Service Name Enter the name of the service or database that hosts the information.

User Name Enter the username of the account with access to the service.

Password Enter the password of the account.

Connection Parameters for IBM DB2
To connect to IBM® DB2® for Linux™, UNIX™ and Windows™ as a relational data source in CDM, use
the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Connection Type Select IBM DB2 for Linux, UNIX, and Windows.

Server Name
Enter the name of the server that holds the DB2 database. The
format should be ADDRESS:PORT. The default port number is 446.

Database Enter the name of the database.

User Name Enter the user name of the account with access to the database.

Password Enter the password of the account.

Connection Parameters for IBM DB2 for i
To connect to IBM® DB2® for i as a relational data source in CDM, use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Connection Type Select IBM DB2 for i.

Server Name
Enter the name of the server that holds the DB2 database. The
format should be ADDRESS:PORT. The default port number is 446.
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Parameter Description

User Name Enter the user name of the account with access to the database.

Password Enter the password of the account.

Database Enter the name of the database.

Connection Parameters for ODBC
To connect to Open Database Connectivity (ODBC) as a relational data source in CDM, use the
following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Connection Type Select ODBC.

Connection String Enter the name of the connection string.

Connection Parameters for OLE DB
To connect to Object Linking and Embedding Database (OLE DB) as a relational data source in CDM,
use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the
cached data must be refreshed from the underlying external data
sources.

Connection Type Select OLE DB.

Connection String Enter the name of the connection string.

Add a Microsoft Excel Data Source
You can add a Microsoft™ Excel data source so that CDM users can query data in an external Microsoft
Excel spreadsheet.

1. Verify that the Excel spreadsheet is on a network that is accessible by the CDM server. The
server cannot link to a file that is on your local computer.

2. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.
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l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

3. Click Home > Add > External Microsoft Excel File Data Source, or right-click any existing data
source in the work area and click Add > External Microsoft Excel File Data Source.

4. Specify the connection parameters.

5. Click Test Connection.

l
If the connection succeeds, the Connection successful icon is displayed.

l
If the connection fails, the Connection test failed icon is displayed. Check with the
database administrator to ensure that the database server is running and that you have the
correct parameters.

6. Click OK.

Users can now create and edit queries to the newly created Microsoft Excel data source. They can also
associate queries with reports, allowing query results to be used by the reports.

Note: You must ensure that each new data source is added to the whitelist element so that the
application server can authenticate the data source.

Connection Parameters for Excel Data Source
To connect to Excel as one of your data sources in CDM, use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when
the cached data must be refreshed from the underlying external
data sources.

File Path

Click Select File, browse to the location of the Excel file, and
double-click the file name. The file location must be accessible
by the application server.

Note: You cannot edit the file path manually. To
change the path, click Select File again and browse to
a new location.

Allow Query Variables in File Path

Select this checkbox to enable a user to use query variables in
the file path of the Excel data source. This option is useful if a
user wants to centrally manage a data source location and
update it whenever the source location of the Excel file
changes.

https://insightsoftware.com/
datasc_exprpolicy.htm


85

Add an HFM Data Source
You must add a Hyperion Financial Management (HFM) data source so that CDM users can use to
create and refresh HFM formulas at the report object level.

Users do not create queries using an HFM data source. After an HFM server is defined, users can
create and refresh HFM formulas. These formulas are resolved when a report is generated.

Supported HFM Formulas
These HFM formulas are supported:

l HsGetValue
Retrieves data from a data source for the dimension members that you specify.

l HsGetText
Retrieves the cell's text description from a data source for the dimension members that you
specify.

l HsLabel
Displays the default member label for a specified dimension member.

l HsCurrency
Retrieves the currency value of the specified dimension member.

l HsDescription
Displays the description of the specified dimension member.

Setup
A batch file (provided at CDM installation) on the HFM server must be run to allow CDM Data Source
Connector (DSC) web applications to connect to it. If adding an HFM data source fails, check that this
batch file has been run.

To connect to HFM 11.1.2.4 from CDM requires deploying the CDM Data Source Connector 3.0 on the
HFM Server machine (not the foundation server). The DSC files are provided by Certent Support upon
request.

Prerequisites

l JDK 8 or higher, deployed on the HFM server

l Java certificate converter (recommended: openSSL)

Unsecured Connection Configuration
CDM Server Side
No configuration is required.
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HFM Server Side
1. Run the config.bat file from CDM Data Source Connector 3.0 and enter this required data:

l javaw.exe location (default location for JDK8: C:\Program Files\Java\jdk1.8.0_
191\jre\bin\javaw.exe).

l EPM Home directory (default: C:\Oracle\Middleware\EPMSystem11R1).

l EPM Instance directory (default: C:\Oracle\Middleware\user_
projects\epmsystem1).

l Port the connector should listen on (default: 7911).

l Type false when prompted for a secure connection.

2. After the configuration process is completed, run the start.bat file to start the Connector.

Secured Connection Configuration
CDM Server Side

1. Import the certificate you want to use for the connection in IIS in the Server Certificates area.
Alternately, the certificate can be created in IIS directly using the IIS manager and exported to
file.

2. In the CDM.config file from the connector web application (default location:
C:\inetpub\wwwroot\CognosDM-Server\Connector\Config), modify the
DataSourceConnector key as follows:

<DataSourceConnector useSecureConnection="true"
serverCertificateName="%certificateNamefromIIS%"/>

3. Call an IISReset.

HFM Server Side
The certificate file obtained from the CDM server-side configuration must be converted to a keystore file
with a .jks extension. This can be done with any utility that supports the conversion. Certent
recommends the openSSL freeware that has been used during internal testing.

To convert the certificate using Certent recommended method:

1. Copy the certificate from the CDM server to the HFM server.

2. Run the certconvert.bat file from the CDM Data Source Connector 3.0 and enter the required
data:

l Certificate file path (for example: C:\Certificate.pfx).

l Certificate password (the one it was exported with).

l Path to the openSSL executable (default: C:\OpenSSL-Win64\bin\openssl.exe).
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l Path to the keytool executable from the deployed jre7 (default: C:\Program
Files\Java\jdk1.8.0_191\jre\bin\keytool.exe).

l Password for the resulting keystore.

After this operation is completed, an hfmconnect.jks keystore file is created in the CDM Data Source
Connector 3.0 directory which is used to configure the Connector.

To configure and start up the connector:

1. Run the config.bat from the CDM Data Source Connector 3.0 directory and enter the required
data:

l Input javaw.exe location (default location for JDK 8: C:\Program
Files\Java\jdk1.8.0_191\jre\bin\javaw.exe).

l Input the EPM Home directory (default: C:\Oracle\Middleware\EPMSystem11R1).

l Input the EPM Instance directory (default: C:\Oracle\Middleware\user_
projects\epmsystem1).

l Input the port the connector should listen on (default: 7911).

l Type true when prompted for a secure connection.

l Path to the jks keystore (default: <HFMConnectorPath>\hfmconnect.jks).

l Password for the keystore.

2. After the configuration process is completed, run the start.bat file to start the Connector.

Add a HFM Data Source
1. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

2. Click Home > Add > HFM Data Source, or right-click any existing data source in the work area
and click Add > HFM Data Source.

3. Specify the connection parameters.
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4. Click Test Connection.

l
If the connection succeeds, the Connection successful icon is displayed.

l
If the connection fails, the Connection test failed icon is displayed. Check with the
database administrator to ensure that the database server is running and that you have the
correct parameters. You can also expand the error message to see further details to help
you troubleshoot the connection.

5. Click OK.

Users can now refresh HFM formulas that use the data source. These formulas are resolved when a
report is generated.

Connection Parameters for HFM Data Source
To connect to HFM as one of your data sources in CDM, use the following parameters:

Parameter Description

Name
Enter the name of the data source connection. This will have to
be referenced in all HFM formulas.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when
the cached data must be refreshed from the underlying
external data sources.

HFM Connection Type

Select which HFM version to connect to:

l For HFM 11.1.2.3 and earlier, select Autodetect HFM
version.

l For HFM 11.1.2.4 and later, select Use Data Source
Connector.

EPM Server name
Enter the name of the machine where HFM is installed, without
the domain.

HFM Connection Port
Enter the port that was defined during HFM Connector
configuration (default: 7911) .

Server Name (see EPM)
Enter the server name that was defined in EPM, without the
domain.

Cluster Name
Enter the cluster name that has been defined in EPM (visible in
the EPM System Configurator), without the domain.

Use current Active Directory user
Select this option if you want to use the user that is logged into
the CDM client for data retrieval.

Domain Enter the domain where the user is located.

Username Enter the username of a user that has access to the HFM DB.

Password Enter the password for the user.

URL Optional: SmartView URL.
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Parameter Description

Application Select the name of the application where the data is located.

Add a Business Intelligence Data Source
You can define an IBM® Cognos® Business Intelligence as one of your data source, allowing you to
refresh IBM Cognos for Microsoft™ Office data, such as cross-tabs, charts, lists, and images, in your
Excel report objects.

You must have a valid URL that connects to the Cognos Business Intelligence server where your
Cognos® for Microsoft Office data is stored.

The Cognos for Microsoft Office add-in is used for placing Cognos Business Intelligence data into Excel
report objects. Excel report objects can be created in CDM, or they can be Excel files that already have
Cognos Business Intelligence data in them and are imported into CDM.

Global Refresh of Data from Cognos for Microsoft
Office
A global refresh of all Cognos for Microsoft Office data in your Excel report objects occurs when:

l The expiration policy you choose for the data source has expired.

l You perform a global refresh of the data at any time using Full Refresh Report (not Quick
Refresh Report) when working with a report.

l You lock or unlock a report object.

l You generate a report, if the Perform Full Refresh option is selected.

When a global refresh occurs, the Cognos Business Intelligence data is refreshed similar to when you
use the Cognos for Microsoft Office Refresh Data and Format option. Floating Cognos Business
Intelligence content (for example, images such as charts displayed as images) is refreshed similar to
the Cognos for Microsoft Office Refresh Data option.

Note: If one Excel report object has data from two different Cognos Business Intelligence
servers and one of the expiration policies triggers a refresh, the data from the second server
(where the expiration policy is yet to expire) is also refreshed.

Use Business Intelligence Without Using Excel Add-in
An extra option, IBM Cognos Business Intelligence, is available when adding a BI data source and does
not require the use of an Excel add-in. This option supports regular CAM authentication only. When
creating a BI data source with a specific target (IBM Cognos Business Intelligence or IBM Cognos for
Go! Office), the target cannot be modified when editing the data source later. Data queries, containing
unformatted (raw) data, are created to pull BI content, after which they are inserted into Excel objects. BI
reports are supported only (no workspace). When creating a BI data query, you can use query variables
in the report path. This allows for pulling different data using the same query. When pulling chart
reports, only the data is brought into CDM.
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Users can refresh the Cognos for Microsoft Office content in their Excel report objects or, if the IBM
Cognos Business Intelligence option is used, create Business Intelligence data queries to insert and
refresh BI data in Excel report objects.

Add a BI Data Source
1. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

2. Click Home > Add > Business Intelligence Data Source, or right-click any existing data source
in the work area and click Add > Business Intelligence Data Source.

3. Specify the connection parameters.

4. Click Test Connection.

l
If the connection succeeds, the Connection successful icon is displayed.

l
If the connection fails, the Connection test failed icon is displayed. Check with the
Cognos Business Intelligence server administrator to ensure that the server is running and
that you have the correct parameters. You can also expand the error message to see
further details to help you troubleshoot the connection.

5. Click OK.

Connection Parameters for BI Data Source
To connect to BI as one of your data sources in CDM, use the following parameters:

Parameter Description

Name Enter a unique name for the data source.

Description Specify a description for the data source. This is optional.

Expiration Policy
Select the expiration policy. Expiration policies determine when the cached
data must be refreshed from the underlying external data sources.

Target

Select IBM Cognos Business Intelligence or accept the default for the URL
method.

Note: This target cannot be changed by editing the data source
after it is created

Authentication Type
Applicable only when IBM Cognos Business Intelligence is selected. Only
CAM authentication is available.

URL
Enter the URL that connects to the server where the Cognos Business
Intelligence data is stored.
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Parameter Description

Namespace ID
Enter the ID of the namespace defined on the CAM server that has been
configured for the Cognos Business Intelligence server you need to access.

Username Enter the username for the Namespace ID you have entered.

Password Enter the password for the Username you are using.

Edit a Data Source Connection
You can edit an existing data source connection in CDM to change its connection parameters, file path,
or expiration policy. For example, if a database is moved to a different server, and you still want to
access the same data, you must update the data source connection with the name or IP address of the
new server.

To edit a data source connection:

1. Verify that no reports will be adversely affected if you edit the data source connection.

2. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

3. Right-click the data source connection you want to edit and click Edit, or double-click the data
source connection.

4. Edit the connection parameters. If a password is used as part of a connection string parameter, it
is masked and cannot be viewed. For more information, see the Connection Parameters section
for the database type that you are editing.

Note: You can modify only the connection information. To change to a different
database type, you must create a new data source and specify the new database type.

5. Click Test Connection.

l
If the connection succeeds, the Connection successful icon is displayed.

l
If the connection fails, the Connection test failed icon is displayed. Check with the
database administrator to ensure that the database server is running and that you have the
correct parameters.

6. Click OK.

Delete a Data Source Connection
If you no longer need a data source connection for CDM, you can delete it.
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Important: If you delete a data source, you cannot undo your action. Proceed with caution.

To permanently delete a data source connection, take these steps:

1. Verify that no reports will be adversely affected if you delete the data source connection. You
cannot delete a data source if any queries are set up to use it.

2. In CDM, do either of the following to open the Data Source Connectivity tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Source
Connectivity.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Source Connectivity under External Data.

3. Right-click on the data source connection you want to delete and select Delete.

4. In the confirmation window, click Yes.

Expiration Policies for Data Sources
CDM uses a data cache to manage the data from data sources and expiration policies to determine
when the cached data is obsolete.

When you performs an action on a report, such as opening a report object or generating the entire
report, CDM refreshes the external data and updates the data cache. Any future refresh operations will
access the data cache, without retrieving data from external data sources. If you require the latest data
and not the cached data, you can run a Full Refresh on a report or report object, or generate a report
with Perform full refresh enabled.

However, frequent manual refreshes of the data source can negatively impact performance. As an
alternative, you can define when the cached data is considered obsolete by using expiration policies.
Expiration policies determine when the cached data must be refreshed from the underlying external
data sources.

Note: You must have the Manage Expiration Policies permission to add, edit, or delete expiration
policies.

Expiration Policy Types
CDM supports the following types of expiration policies:

l Absolute Time sets a policy that is based on a fixed date and time, which must be in the future.
The data associated with this policy is obsolete in the data cache when the configured date and
time are reached. The specified time is based on Universal Time (Coordinated Universal Time)
on the CDM server. When users access expiration policies from the CDM client, the displayed
time is relative to the user's local time zone and format instead.

l Sliding Time sets a policy based on an interval of time. Data that is associated with this policy is
obsolete in the data cache after a specified time interval, calculated from the moment when the
data was cached.
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l Extended Format Time sets a fully customizable policy. You can define the minute, hour, day,
month and frequency of the expiration. Data associated with this policy is obsolete in the data
cache when all the defined conditions are met.

l File Dependency sets a policy that expires when the specified file is modified. Data that is
associated to this policy is obsolete in the data cache when the configured file has been modified,
calculated from the moment when the data was cached.

l Never Expires sets a policy that never expires.

Predefined Expiration Policies
CDM includes several predefined expiration policies, such as daily at certain times. The Whenever the
external Microsoft Excel file is modified expiration policy applies to External Microsoft Excel File data
sources. This policy cannot be edited or deleted. Data that is associated to this policy is obsolete in the
data cache when the external data source has been modified, calculated from the moment when the
data was cached.

Add an Expiration Policy
1. In CDM, do either of the following to open the Expiration Policies tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Expiration Policies.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Expiration Policies under External Data.

2. Click Home > Add > Expiration Policy.

3. Enter a name and description for the policy.

4. Select the appropriate policy type from the drop-down list.

l When you select Absolute Time, you must specify a future date and time.

l When you select Sliding Time, you can modify the interval by selecting the number of days,
hours, or minutes and then clicking the up or down arrows to adjust the value.

l When you select Extended Format Time, you can define the minute, hour, day, month, and
frequency of the expiration.

l When you select File Dependency, enter the file path information or click Browse to select
a file to specify the data source. You can optionally click Test Connection to test your data
source connection.

5. Click OK.

Edit an Expiration Policy
1. In the Expiration Policies tab in the work area, right-click on an expiration policy and click Edit.

2. Update the policy information.
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3. Click OK.

Delete an Expiration Policy

Important: If you delete an expiration policy, you cannot undo your action. Proceed with
caution.

1. In the Expiration Policies tab in the work area, right-click on an expiration policy and click Delete.

2. In the confirmation window that opens, click Yes.

3. The policy is deleted if the policy is not associated to an external data source. If the expiration
policy is used, an error message is displayed instead.
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Data Queries
A query is a request for information from a database that is based on specific conditions. You can use a
data query to create custom data queries on data from the data sources available in CDM and retrieve
the results into a report. The query can then be inserted into an Excel object.

Users can copy a report-level query variable to the object-level variables table and apply properties to it.
For more information, see the CDM User Guide.

OLAP Queries
You can add an OLAP data query in CDM against an Oracle Essbase, IBM® Cognos® TM1®, or
Microsoft™ Analysis Services data sources.

You can use the Add OLAP Data Query wizard to add data queries using predefined
dimension/member view, by selecting specific dimensions and members, or by using a
multidimensional expression script. If you manually select dimensions and members, you can specify
which dimensions represent the columns and rows of the data query.

You must have already created a data source that points to the OLAP database and specifies the
database type. See Add an OLAP Data Source.

Add an OLAP Data Query Using Custom Data
You can add an OLAP data query that contains selected dimensions and members.

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. Click Home > Add > OLAP Query, or right-click any existing query in the query list and click Add
> OLAP Query. The Add OLAP Data Query wizard displays.

3. Enter a query name in the Name field.

4. Select an OLAP data source from the OLAP Data Source drop-down list.

5. For a TM1® OLAP database, select None in the View drop-down list. The dimensions available
display in the Page Options box. Dimensions with an associated member display in the
<dimension>.<member> format. Dimensions that do not have an associated member are
highlighted.

6. You can add or modify a member for a dimension before adding that dimension as a column or
row. You can add only one member using this method.
a. Double-click a dimension in the Page Options box.

b. In the Select a Dimension Member window, expand the member hierarchy to locate the
appropriate member. Select Show Aliases to display the alias names of the dimensions
instead of the actual names.
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c. To search for a member, type the word to search in the Type and wait to search field.

The search text can be:

l Oracle Essbase - member name or the MEMBER_ALIAS property.

l Cognos® TM1 - member name, or the MEMBER_CAPTION or MEMBER_ALIAS
property.

l Microsoft™ Analysis Service - member name or the MEMBER_CAPTION property.

A list of members containing the search text opens. The search results are ordered
hierarchically, as are found in the dimension tree. You are able to select a member node
from the list. If selecting row or column members and you want to include children, you can
right-click the node and choose the appropriate option: Children, IChildren, Descendants,
IDescendants, and Bottom Level Descendants.

d. Select a member and click OK.

7. In the Page Options box of the Add OLAP Data Query wizard, use the arrow keys or drag
dimensions to assign rows and columns in the query. You must select a default member in the
Page Options box. Ensure that a leaf-level member is selected if the query is write-back enabled.
A leaf-level member is a member of a hierarchy that has no children.

8. If needed, add or modify the members that are associated with a dimension you selected for the
query.
a. Double-click a dimension in the Columns or Rows box.

b. In the Edit Dimension Specifications window, expand the member hierarchy to locate the
appropriate members. You can also search for a member using the method described
earlier.

c. Click Add MDX Script to add a multidimensional expression (MDX) script to the query, as
needed.

d. Use the tools in the Current member specifications box:

l Change the dimension/member relationship to child or descendant by clicking
Change Relationship.

l Change the order of the members with the Move Up and Move Down controls.

Important: In CDM, the default parent-child order returned is parents before their
children. In Financial Statement Reporting (FSR), the parent-child order returned
is children before their parents. If you migrate your data from Financial Statement
Reporting (FSR), version 6.6.1 to CDM, a special flag is set to retain the same
order result as Financial Statement Reporting. If you would like to edit your query
to change the order after migration, delete and replace the query and then relink
your formulas.

e. Specify the following dimension options:

l Show Aliases - Display the alias names of the dimensions instead of the actual
names. For IBM® Cognos® TM1 queries, this option might not update the user
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interface to display the alternative alias.

l Join Asymmetrically With Next Dimension - Specify whether to group the results that
are based on the parent members.

f. Click OK to return to the Add OLAP Data Query wizard.

9. In the Additional Properties section, specify the query properties.
a. In the Description field, enter an optional description for the OLAP data query.

b. To allow a user to edit the data in the query and write the data back to the OLAP cube,
select Write-Back Enabled.

Note: To write data back to an OLAP data source, all dimension members in the
data query must be leaf-level members. A leaf-level member is a member of a
hierarchy that has no children.

c. To specify how missing or zero values are displayed, select Display Missing Data As, then
type the string or value to indicate how you want to display zero or missing data, for
example, Zero, Nil, and 0.

Important: If you select Display Missing Data As, you cannot write back to the
OLAP database. The Display Missing Data As option is mutually exclusive with
the Write-Back Enabled option.

d. To suppress rows containing only null values, select Suppress Rows With Null Values.

e. To suppress rows containing only 0 (zero) values, select Suppress Rows With Zero
Values.

f. To display row headers in the results table of an OLAP query, select Display Dimension
Row Headers. The headers enable you use a pivot table in an Excel worksheet to analyze
data that is inserted into the object. You do not have to do a manual update if the query
result changes.

10. Click Next to preview the OLAP query results.

11. Click Next to associate reports with this query. You can select Make This Query Global to make
the query available to all reports.

12. Click Finish.

Add an OLAP Data Query Using Predefined Views
You can add an OLAP data query with predefined views in CDM against an IBM® Cognos® TM1® data
source. The specific database views must have already been created in a third-party tool, such as IBM
Cognos® TM1 Architect.

1. With the Data Queries tab open in the work area in CDM, click Home > Add > OLAP Query, or
right-click any existing query in the query list and click Add > OLAP Query.

2. In the Add OLAP Data Query wizard, enter a query name in the Name field.

3. Select an OLAP data source from the OLAP Data Source drop-down list.
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4. Select a predefined view from the View drop-down list. The data query will filter based on the
Cognos TM1 view. If the view is modified outside on the Cognos TM1 cube level, the data query
in CDM will be updated appropriately.

5. In the Additional Properties section, specify properties of the query. You can select Show
Attribute if you want to display dimension members according to the value the member has in the
attribute instead of the member name.

6. Click Next to preview the OLAP query results.

7. Click Next to associate reports with this query. You can select Make This Query Global to make
the query available to all reports.

8. Click Finish.

Add an OLAP Data Query Using Multidimensional
Expression Scripts
You can add an OLAP data query by using an multidimensional expression (MDX) script in CDM.

1. With the Data Queries tab open in the work area in CDM, click Home > Add > OLAP Query, or
right-click any existing query in the query list and click Add > OLAP Query.

2. In the Add OLAP Data Query wizard, enter a query name in the Name field.

3. Select an OLAP data source from the OLAP Data Source drop-down list.

4. Select Use Script.

5. Add a multidimensional expression (MDX) script to the query. You can use query variables in the
script by typing them using the appropriate syntax.

For example, {CurYear} can be created to represent the year of the reporting period. Data from
this query applies a filter based on the year to ensure that data is updated based on different
periods of the reporting cycle.

You can use only Select type scripts, for example:

Select {[Time].[Quarter 1]} on Rows,
{[Year].[Planning Years]} on Columns from [ABCDemo]
where ([Scenario].[Actual], [All Products].[No Product], [Accounts].
[Balance Sheet], [Office Products Inc].[No Company] )

Dimension member selection can be done on rows and columns. Dimension member selections
after the where keyword are the page options.

6. In the Additional Properties section, specify properties of the query. You can select Show
Attribute if you want to display dimension members according to the value the member has in the
attribute instead of the member name.

7. Click Next to preview the OLAP query results.

8. Click Next to associate reports with this query. You can select Make This Query Global to make
the query available to all reports.

9. Click Finish.
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Relational Queries
After you have set up the relational data sources, you can add queries to the data.

Add a Relational Data Query
To add a new relational data query, you must have already created a data source that points to the
relational database and specifies the database type.

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. Click Home > Add > Relational Query, or right-click any existing query in the query list and click
Add > Relational Query. The Add Relational Query Wizard displays.

3. Enter a query name in the Query Name field.

4. Select a relational data source from the Connection Name drop-down list.

5. Optionally, specify a description for the query.

6. Click Next.

7. Select the checkboxes in front of the reports that you want to associate with this query or select
Make This Query Global to make the query available to all reports.

8. Click Finish. The Query Builder displays for you to build the SQl query for retrieving data from the
specified relational data source.

Build a Relational Data Query
CDM provides a database querying module that is integrated with Active Query Builder to cope with
SQL query building.

When you query relational data sources in CDM, you must retrieve data through SELECT statements. If
you use SQL statements other than SELECT, such as UPDATE or DELETE, they are reported as
errors.

See SQL Queries for information such as the SQL keywords and operators you can use in CDM.

To build a relation data query:

1. In the Data Queries tab in the work area, double-click a relational database query in the query
list.

2. The Query Builder gives you a choice of methods for creating SQL queries. You can type SQL
commands directly in the SQL Query with Variables pane of the window, or you can drag tables
into the Main pane and create queries using a graphical interface. The following steps show how
to use the graphical interface.

3. Drag a table from the pane on the right that displays database tables into the Main pane and
select columns from the table. The column is displayed in the Expression drop-down list.
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4. Specify the query parameters to customize the query:

l Aggregate - Select an aggregate from the drop-down list.

l Alias- Type an alias if needed.

l Sort Type - Select a sort type from the drop-down list.

l Sort Order - Select a sort order from the drop-down list.

l Grouping - Select which items to group.

l Criteria - Select criteria that the query must meet.

5. Use the following commands on the ribbon of the Query Builder tab to work with the query:

l Refresh Metadata- Refreshes the current query metadata.

l Insert Query Variable - Adds a variable to the query.

l Validate - Validates the query syntax.

l Run - Executes the query.

l Stop - Stops query execution.

l Show Structure - Toggles the Query Structure pane.

For detailed instructions about how to build SQL query using the Query Builder, refer to the Active
Query Builder User's Guide.

SQL Queries
Structured Query Language (SQL) is a standard language for accessing and manipulating databases.
You use SQL when you work with relational queries in CDM.

You can use SQL statements to perform the following types of database-related tasks:

l Execute queries against the database

l Retrieve data from the database

SQL statements have a specific syntax and require certain information, which can be difficult to
understand. When you select what you want to include in a SQL statement in CDM, you can ensure that
your statement is structured correctly.

Important: The advanced functionality for Microsoft™ products is beyond the scope of this
guide. However, some topics are included for your convenience. For more information, see
Microsoft documentation or Microsoft online help.
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Keywords, Clauses, and Statements
You can use SQL statements in relational queries in CDM to perform most of the activities that you need
to perform in a database.

When you query relational data sources in CDM, you must retrieve data through SELECT statements. If
you use SQL statements other than SELECT, such as UPDATE or DELETE, they are reported as errors.
Use of a semicolon is not supported.

Note: SQL itself is not case-sensitive. Names can be case-sensitive, and they can contain
spaces and other delimiters if they are surrounded by double quotation marks.

The following statement shows the structure of a basic SQL statement:

SELECT VendorName FROM Table_Vendor

Keyword Description

SELECT

The SELECT clause is mandatory, and specifies a list of columns to be
retrieved. The result is stored in a result table, called the result set.

SELECT column_names

Tip: The asterisk (*) is a quick way of selecting all columns in a
table. For example:

SELECT * FROM table_name

FROM

The FROM clause is mandatory and always follows the SELECT clause, and
lists the tables to be accessed by the query.

SELECT column_names
FROM table_name

WHERE

Optional. When used, the WHERE clause always follows the FROM clause.
WHERE filters rows in the tables specified in the FROM clause. If the WHERE
clause is not included, all rows are used.

SELECT column_names
FROM table_name
WHERE conditional_expression

Comparison Operators
The WHERE clause can use comparison operators as part of the expression in a relational query in CDM.
The result of a WHERE expression is always evaluated to true, false, or unknown.

Operator Description

= Equal to

> Greater than

< Less than

>= Greater than or equal to
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Operator Description

<= Less than or equal to

<> Not equal to

Logical Operators
The WHERE clause in a SQL statement can use logical operators as part of an expression in a relational
query in CDM. Like comparison operators, logical operators evaluate to true, false, or unknown.

Logical Operator Description

AND

This operator combines two logical conditions. AND requires that each must
be met for the record to be included in the result set. When you use the AND
and OR operators together, AND has a greater precedence than OR.

SELECT columns
FROM tables
WHERE column1 = value1 AND column2 = value2

In this case, column1must equal value1 and column2must equal value2,
or no record is returned in the result set.

OR

This operator combines two logical conditions. OR requires that any of the
conditions must be met for the record to be included in the result set. When
you use the AND and OR operators together in an expression, OR has a
lesser precedence than AND.

SELECT columns
FROM tables
WHERE column1 = value1 OR column2 = value2

In this case, either column1 or column2must equal the stated value, or no
record is returned in the result set.

NOT

This operator inverts the result of a comparison expression or a logical
expression. To be able to return a record in the result set, NOT requires that
none of the conditions are met.

SELECT columns
FROM tables
WHERE NOT column1 = value1

In this case, column1 cannot equal value1, or no record is returned in the
result set.

Joins and Unions
You can use a SQL statement to create joins and unions between tables in a relational query in CDM.

Query Type Description

JOIN

You can use a join statement to combine rows from multiple tables. An inner
join is the most common, and returns all rows from multiple tables where the
join condition is met. An outer join is used to include rows that exist in one
table (but not the other). A left outer join preserves rows from the table
specified before the join statement. A right outer join preserves rows from the
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Query Type Description

table specified after the join statement. For example, an inner join might look
like this:

SELECT * FROM tableA
JOIN tableB on column_nameA = column_nameB

UNION

You can use a union statement to combine the result sets of two or more
SELECT queries. By default, it removes duplicate rows between the various
SELECT statements. Using the ALL qualifier forces duplicate rows to persist in
the query result. For example, a union of 2 tables with duplicate rows
preserved might look like this:

SELECT column_nameA
FROM tableA
UNION ALL
SELECT column_nameB
FROM tableB

Excel Queries
After you have added Microsoft Excel data sources in CDM, you can query data from the Excel
spreadsheets.

To add a query to an existing external Microsoft Excel data source:

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. Click Home > Add > External Microsoft Excel File Query, or right-click any existing query in the
query list and click Add > External Microsoft Excel File Query. The Add External Excel File
Data Query Wizard displays.

3. Enter a query name in the Name field.

4. Select an Excel data source from the External Microsoft Excel Data Source drop-down list.

5. Select a sheet from the Default Worksheet drop-down list. If your worksheet contains a query
variable, select Allow query variables in worksheet name. A list of named ranges in the sheet is
displayed.

6. Double-click one or more range names, or type a range in the The ranges to be copied field.

7. Specify a description for the query in the Description field if you want.

8. Click Next.

9. Select the checkboxes in front of the reports that you want to associate with this query or select
Make This Query Global to make the query available to all reports.

10. Click Finish.
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Business Intelligence Queries
After you have set up a Business Intelligence data source in CDM, you can add BI queries.

To add a Business Intelligence query:

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. Click Home > Add > Business Intelligence data query, or right-click any existing query in the
query list and click Add > Business Intelligence data query. The Add Business Intelligence
data query wizard displays.

3. Enter a query name in the Name field.

4. Specify a description for the query in the Description field if you want.

5. Select a Business Intelligence data source from the Business Intelligence Data Source drop-
down list.

6. Click Browse and select a Business Intelligence report or report view from the Report drop-down
list. This BI report or report view is located on the Business Intelligence server and contains the
queries you want to use to bring BI data in to CDM.

7. To have the BI data query point to different reports or report views on the BI server, you can
select Allow query variables in report location. The selected report field becomes editable,
allowing you to enter the query variable names to use.

8. Click Next. If the selected BI report contains parameters, they are detected and displayed.
Different types of parameters are displayed differently. For example, simple parameters do not
have a drop-down menu from which you can select values for that parameter, but instead display
the type of the parameter in a tool tip when you hover your mouse over it. Parameters that allow
multiple values have checkboxes, whereas parameters that can have a single value are
displayed with a radio button in their respective drop-down menus. The Business Intelligence
simple parameters MultiLine, Range, Calendar Type, and MultiSelect are not supported. Query
variables are not supported for parameters.

9. You can optionally enter a query variable into any of the field in the BI Query Parameters
section. This only applies for queries that are string, number, or date (simple queries) and not for
trees or lists. Also, for simple queries, a default value, applied in Business Intelligence, is shown.
If no default value exists, the field is blank.

10. Click Next. A preview of the Business Intelligence data query results taken from the BI report you
selected is displayed. If you selected Allow query variables in report location, the location of the
report with the query variables resolved is shown.

11. Click Next.

12. Select the checkboxes in front of the reports that you want to associate with this query or select
Make This Query Global to make the query available to all reports.

13. Click Finish.
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You can use the BI queries you have created to insert data into CDM report objects. Refer to the CDM
User Guide for instructions.

Create a Data Query Based on an Existing One
You can create a new query based on an existing query for all types of data sources in CDM. You must
already have a data query that points to a relational database and specifies the database type.

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. In the data query list, right-click the query you want to use and click Copy into New.

3. Edit the query name, server type, connection, or comments as required.

l An OLAP data query and an external Microsoft™ Excel data query can both be edited in the
query wizard.

l A relational database query can be edited in the Query Builder window.

4. Ensure the correct reports are associated with the data query

5. Click Finish.

Edit a Data Query
You can change the details of a query.

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. In the data query list, right-click the query you want to edit and click Edit, or double-click the
query row.

3. In the query wizard, change the query name, server type, or properties, as required.

4. Click Finish.

Delete a Data Query
If you no longer need a query, you can delete it.

Important: If you delete a query, you cannot undo your action. Proceed with caution.

https://insightsoftware.com/


106

1. In CDM, do either of the following to open the Data Queries tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Data Queries.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Data Queries under External Data.

2. In the data query list, right-click the query that you want to delete and click Delete.

3. In the confirmation window, click Yes.

Associate Data Queries with Reports
You can associate a data query with a report in CDM. When you associate data queries with reports, the
queried data can be used by the specified reports.

To associate data queries with a report:

1. In CDM, do either of the following to open the Associate Queries with Reports tab in the work
area:

l Click the File tab, then navigate to Administration > External Data > Associate Queries
with Reports.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Associate Queries with Reports under External Data.

2. In the Reports pane, navigate the report hierarchy and select a report. You can use the search
field to find a report.

3. In the Associated Queries pane, use the checkboxes to select the queries you want to associate
with the report.

4. Repeat the preceding two steps to associate queries with other reports.

5. Click Home > Save to save your association.

In addition to the preceding procedure, you can also associate a query with reports when you add or edit
the query.

Query Variables
You can use a query variable in CDM to maintain unique internal references for each report.

Add a Query Variable
If you need a query variable that does not currently exist in CDM, you can create one.

1. In CDM, do either of the following to open the Query Variables tab in the work area:

l Click the File tab, then navigate to Administration > External Data > Query Variables.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Query Variables under External Data.
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2. Click Home > Add > Query Variable. The Add Query Variable window displays.

3. Specify a name and value for the query variable.

4. You can add a comment to provide information about the purpose and use of the query variable.

5. If you want to allow a user to override the value that you specified, select Allows Override.

6. Click OK.

Edit a Query Variable
You can change details of a query variable.

1. From the query variable list in the work area, right-click the variable you want to edit and select
Edit, or double-click the query variable row.

2. You can change the value and comment for the query variable.

3. To change the override setting, select or clear Allows Override.

4. Click OK.

Delete a Query Variable
If you no longer need a query variable, you can delete it.

You cannot delete a query variable if it is currently used by a data query or data source or if it is
overridden.

Important: If you delete a query variable, you cannot undo your action. Proceed with caution.

To delete a query variable:

1. From the query variable list in the work area, select the variable you want to delete and click
Delete.

2. In the confirmation window, click Yes.
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Checklists
In CDM, a checklist is primarily used to provide task-oriented information and reference within a report.
You can create customized checklists as a means of process control, compliance, and verification.

You can add or delete checklists at any time when you are building a new report, or when you are
working with an existing report. You can leverage your existing checklists and procedures, or you can
configure CDM to provide standard checklist types to use with your reports.

You can add or delete checklists in a report, and you can also append files to a checklist for reference
and support in the reporting process. After your checklists are loaded, you can optionally export the data
into a CSV file by right-clicking in the working space and clicking Export as .csv.

Add a Checklist
You can create a checklist in CDM and associate the checklist with a report. You can add a checklist as
a sibling or a child of another checklist.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Resources,, double-click Checklists. The Checklists tab opens in the work area.

3. Click Home > Add > Checklist as Child/ Checklist as Sibling.

4. Type a name for the checklist.

5. Select a checklist type. There are several types of default checklists.

l Task - Represents a task that the user needs to complete.

l Checklist - Includes a reference to a file attached to the checklist.

l Information - Represents informational content.

l Misc. - Represents a checklist of any other type.

6. If you select the Checklist type, click Browse to attach a file to the checklist.

7. Specify a description for the checklist if you want

8. Click Next.

9. Select the reports that use this checklist, and click Finish.

Edit a Checklist
You can edit the contents of a checklist.

1. In the Checklists tab in the work area, select the checklist that you want to edit.

2. Click Home > Edit. An editing window opens.
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3. Change the name of the checklist.

Tip: You can also change the name of the checklist by right-clicking it in the checklist
table and then selecting Rename.

4. Change the checklist type or edit the checklist description, if necessary.

5. Click Next.

6. To change the reports that will use this checklist, select or clear the checkboxes for each
available report.

7. When you are finished, click Finish.

Delete a Checklist
If you no longer need a checklist, you can delete it.

Before you can delete a checklist, you must detach it from any report objects to which it is attached. For
information about detaching checklists from report objects, see the CDM User Guide.

Important: If you delete a checklist, you cannot undo your action. Proceed with caution.

To delete a checklist:

1. In the Checklists tab in the work area, select the checklist that you want to delete

2. Click Home > Delete.

3. In the confirmation window, click Yes.
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Tasks and Task Lists
In CDM, administrators define tasks in hierarchical lists that users are required to complete.

Tasks are added to task lists in a hierarchical structure. A task list can be ordered or unordered.
Ordered task lists contain tasks which must be completed in the same order as they appear in the task
hierarchy. Unordered task lists contain tasks which can be completed in any order.

Task lists and tasks can be edited and deleted at any time. Tasks can be promoted or demoted to a
different place in the task list hierarchy.

Administrators assign permissions to users so they can view task lists and tasks and mark them as
complete.

Create a Task List
You can create a task list to which one or more tasks can be added.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Tasks. The Tasks tab opens in the work area.

3. Click Home > Add > Task List. The New Task List tab is displayed.

4. Click Add.

5. Enter a name for the task list in the Name field.

6. In the Description field, enter details that describe the task list if you want.

7. Select an icon that you want to represent the task list. You can choose from a set of default icons
or you can add your own icons to the icon palette to choose from if required.

8. You can select the Tasks must be completed in this order checkbox to designate the list as an
ordered task list. Tasks and subtasks in the list must then be completed according to the order of
the hierarchy in which they are displayed.

9. Click Home > Save to save the task list. You can now add tasks to the task list.

Add a Task to a Task List
Task lists are built in a hierarchical structure consisting of tasks which can include subtasks. You can
add one or more tasks to a task list.

1. In the Tasks tab in the work area, double-click the task list to which you want to add a task. The
task list is displayed in a new tab in the work area.

2. Click Add. The New Task window opens.

3. Enter a name for the task in the Name field.

4. In the Description field, enter details that describe the task if you want.

5. Select an icon that you want to represent the task list. You can choose from a set of default icons
or you can add your own icons to the icon palette to choose from if required.

6. Click Add link to link the task to a report object.
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7. Click OK.

8. Click Home > Save to save the task list.

Edit a Task List
1. In the Tasks tab in the work area, double-click the task list you want to edit. The task list is

displayed in a new tab in the work area.

2. You can perform one or more of these actions:

l Change the task list's name and description.

l Change the icon that is used to represent the task list.

l Change the task order.

l Designate the task list as ordered or unordered.

3. Click Home > Save to save the task list.

Change the Task Order in a Task List
You can change the position of one or more tasks as they are displayed in a task list's hierarchy.

When you move a task, its hierarchy level remains the same. For example, when you move a third-level
task up or down in the task list, you are only changing its position among the order of all third-level tasks.
To change a task's hierarchy level (for example, from third-level to secondlevel), you must promote or
demote the task.

To change the task order in a task list:

1. In the Tasks tab in the work area, double-click a task list. The task list is displayed in a new tab in
the work area.

2. You can perform one or more of these actions:

l Select a task and click Move Up or Move Down to move the task up or down respectively in
its hierarchy level in the task list.

l Select a task and click Promote or Demote to change its hierarchy level position higher or
lower respectively in the task list.

3. Click Home > Save to save the task list.

Edit a Task
You can edit the details of a task. Incomplete and completed tasks can be edited at any time.

1. In the Tasks tab in the work area, double-click a task list. The task list is displayed in a new tab in
the work area.

2. Select the task you want to edit and click Edit.
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3. In the Edit window, you can perform one or more of the following actions:

l Change the task name or description.

l Change the icon that is used to represent the task.

l Change the report object linked with the task.

4. Click OK.

5. Click Home > Save to save the task list.

Link Tasks to Report Objects
The user can select a report object to be associated with a task. After creating the link, the user can
easily navigate and open the report object from the task.

Important: Ensure that you link to report objects based on your permissions. Links do not
enforce User Filter or View Report permissions, therefore you can see the full list of report
objects when you are creating a link. If you create a link to a report object that you do not have
permissions for, you will receive an error message when you try to open the link.

1. In the Tasks tab in the work area, double-click a task list. The task list is displayed in a new tab in
the work area.

2. Select the task that you want to associate with a report object and click Edit.

3. In the Edit window, click Add link.

4. In the Link Task window, select the report from the list and click Next.

5. Select the report object you want to link with the task.

6. Click Finish.

7. Click OK.

8. Click Home > Save to save the task list.

Add an Icon to the Icon Palette for Tasks and
Task Lists
You can add your own icon to the default icons in the icon palette for tasks and task lists.

An icon is selected and assigned to a task list or task to differentiate it from other task lists or tasks. You
can add your own icon to the default icons that are available for selection. Icons that you add must be 32
pixels by 32 pixels in size.

1. In the Tasks tab in the work area, double-click a task list to open it, or open a task in the task list.

2. Click Add Another Image and then Browse.

3. In the Select State Image window, navigate to the icon that you want to add, select it, and click
Open.
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4. To change your selection, click Browse to select another image.

5. Click Save Image to Gallery.

Delete a Task
You can delete a task at any time, whether it has been marked complete or has not been completed.

1. In the Tasks tab in the work area, double-click a task list. The task list is displayed in a new tab in
the work area.

2. Select the task that you want to delete and click Delete.

3. In the confirmation message, click OK.

4. Click Home > Save to save the task list.

Delete a Task List
1. In the Tasks tab in the work area, select the task list you want to delete.

2. Right-click the task list and select Delete.

3. In the confirmation message, click OK.
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Dashboards
A dashboard is an interface that integrates data from a variety of sources and provides a unified display
of relevant and in-context information.

Users can view a dashboard to understand different types of data. Dashboards can also be used to
query any relational database that contains useful information for the user. For example, if there is an
Essbase relational source that contains financial/fiscal year end data, that can be queried and a
dashboard can be created to use this information. It is not specific to the CDM database.

Widgets can be used to query the underlying information within a report to understand the status and to
view the use of variables within a report object.

The tasks that you can perform with dashboards and widgets depend on your role in CDM. A person
with administrative rights can create and manage dashboards. Users can view the dashboard to monitor
progress of the report.

Find a Dashboard
If your report contains many dashboards, you can easily search for the dashboard that you need.

All dashboards in the report that you are viewing are listed in the Dashboards pane. To find a particular
dashboard, you can scroll down the list and then click the dashboard that you want to work with.
However, if your report contains many dashboards, you might prefer to use the search functionality in
CDM.

To search for a dashboard:

1. Click the Home tab, then in the Navigation Pane, click Dashboards.

2. Click the Search icon in the Dashboards pane header.

3. In the search field, type the full name or part of the name of the dashboard that you want to find.
You cannot type special characters in the search field. A search result list of all matching
dashboards opens under the field.

4. To focus on the appropriate dashboard in the Dashboards pane, click the name in the search
result list. The selected dashboard in the Dashboards pane is highlighted.
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Fixed Dashboards
A fixed dashboard is a dashboard that is supplied with the application to provide report and data source
information in a graphical format. A fixed dashboards is provided automatically with CDM.

CDM comes with these fixed dashboards: Report Summary Dashboard and Excel Analysis Dashboard.

You cannot edit or delete a fixed dashboard, even if you are an administrator.

Report Summary Dashboard
The Report Summary dashboard in CDM is a fixed dashboard that displays generic report information. It
contains the Document Summary, Object Status, and Object Summary widgets.

Document Summary Widget
The Document Summary widget is a grid widget that displays the following information on a report.

l Report Name
The name of the report selected from the dropdown menu.

l Report Group
If the report belongs to a group, the name of the report group.

l Report Owner
The name of the user who is owner of the report.

l Period End Date
The end date of the reporting period.

l Report Due Date
The date that the report is due for completion to meet the submission date.

l Submission Date
The date that the report is due for completion to meet the submission date.

l Number of Working Days Before Submission Due Date
The number of working days before the report is due for completion to meet the submission date.

Object Status Widget
The Object Status widget is a pie chart widget that displays the workflow status of the report. The pie
chart provides the user with workflow information that indicates the completion status and the percent
breakdown of the current workflow state for each section or report object.

Object Summary Widget
The Object Summary widget is a grid widget that displays information related to the completion of each
section and report object in the report. You can optionally export the contents of the grid into a CSV file
by right-clicking in the grid widget and clicking Export as .csv.

l Name
The title of each section or report object in the report.
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l Report Object Due Date
The deadline for completing the workflow process for a section or report object. A deadline is
displayed only if one was set within the workflow process for that section or report object.

l Workflow Status
The progress of the section or report object (for example, work in progress, under review,
approved, and so on).

l Workflow Due Date
The deadline for completing the workflow process for a section or report object. A deadline is
displayed only if one was set within the workflow process for that section or report object.

l Active User
The current workflow user.

l Printable
A check mark indicates that the section or report object is printable. Otherwise, it contains an x.

l Locked
A check mark indicates that the section or report object is locked. Otherwise, it is empty.

l Shared
A check mark indicates that the section or report object is shared. Otherwise, it is empty.

l Reference
A check mark indicates that the section or report object is a reference. Otherwise, it is empty.

Excel Analysis Dashboard
The Excel Analysis dashboard in CDM is a fixed dashboard that displays the analysis of Excel objects
within a report in terms of data sources. It contains the Document Summary, Data Source Retrievals,
Object Status, and Object Summary widgets.

Document Summary Widget
The Document Summary widget is a grid widget that displays the following information of a report.

l Report Name
The name of the report selected from the dropdown menu.

l Report Owner
The name of the user who is owner of the report.

l Report Due Date
The date the report is due for completion to meet submission date.

l Current Workflow State
The current state of the report.

Data Source Retrievals Widget
The Data Source Retrievals widget is a gauge widget that shows the total number of data source
retrievals for all report objects within a report. For example, if there are five report objects in a report and
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Obj1 has five Data source retrievals and Obj2 has three data source retrievals, the gauge pin points to
8.

Object Status Widget
The Object Status widget is a pie chart widget that displays the workflow status of the report. The pie
chart provides the user with workflow information that indicates the completion status and the percent
breakdown of the current workflow state for each report object.

Object Summary Widget
The Object Summary widget is a grid widget that displays information related to the completion of each
Excel object in the report. You can optionally export the contents of the grid into a CSV file by right-
clicking in the grid widget and clicking Export as .csv.

l Name
The title of each report object in the report.

l Workflow Status
The progress of the report object (for example, work in progress, under review, approved, and so
on.

l Checkout Status
The checkout status of the report object: Checked In, Checked Out.

l Active User
The current workflow user.

l Printable
A check mark indicates that the report object is printable. Otherwise, it contains an x.

l Shared
A check mark indicates that the report object is shared. Otherwise, it is empty.

l Reference
A check mark indicates that the report object is a reference. Otherwise, it is empty.

l Data Query Name
The name of the data query associated with the report.

l Data Query Type
The type of query, OLAP, Relational query, or External Excel File Query.

Custom Dashboards
A custom dashboard is a dashboard that is created by the user from widgets and various data sources
to meet specific requirements. It is not supplied with the application. You can create custom dashboards
to help users view data that is not provided in a fixed dashboard.

You can create and edit a custom dashboard to meet the specific needs of users by editing the
properties of the widgets in the dashboard. You can use the following widgets in a custom dashboard:
Chart, Grid, Gauge, Image, and Web browser.
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Add a Custom Dashboard
If the two standard dashboards that come with CDM do not meet your needs, you can create a custom
dashboard.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Dashboards. The Dashboards tab opens in the work area.

3. Click Home > Add > Dashboard.

4. Specify a name for the dashboard.

5. Specify a description for the dashboard if you want.

6. Click OK to confirm.

7. The dashboard opens in a new tab in the work area and the Dashboard Manager tab displays on
the ribbon. You can now add widgets to the dashboard.

Configure a Variable for a Custom Dashboard
When you create a custom dashboard, you can configure dashboard variables to specify the data that
you want to display.

A query variable is a variable that is used to filter data source queries. A query variable can be used to
define columns that change based on the query result. If a variable has multiple values associated with
it, the query can return more results.

To configure a variable for a custom dashboard:

1. In the Dashboards tab in the work area, select the dashboard that you want to configure and click
Home > Edit, or double-click the row of the dashboard.

2. You can edit the name and description of the dashboard in the Dashboard Manager tab on the
ribbon.

3. Click Configure Variables in the Dashboard Manager tab. The Override Query Variables
window is displayed.

4. In the Application Query Variables table, select the name of the query and click the arrow to add
it to the Dashboard Query Variables list.

5. In the Display Name field of the Override window, type a display name for the variable.

6. To add a new value, click Add in the Values box, type the value and press Enter.

7. In the Comment field, you can add a comment.

8. Click OK.

9. Click OK to confirm.

Delete a Custom Dashboard
If you no longer need a custom dashboard, you can delete it. You can delete a custom dashboard, but
not a fixed dashboard.
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Important: If you delete a custom dashboard, you cannot undo your action. Proceed with
caution. No confirmation window opens before the dashboard is deleted.

To delete a custom dashboard:

1. In the Dashboards tab in the work area, select the dashboard that you want to delete.

2. Click Home > Delete.

3. In the confirmation window, click Yes.
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Widgets
A custom dashboard is a dashboard that is created by the user from widgets and various data sources
to meet specific requirements. It is not supplied with the application. Widgets help users in CDM to
understand your report content and status in an easier way.

Each widget has a title. The user can edit the properties of widgets based on the type of widget
selected.

These widgets are available: Chart, Gauge, Grid, Image, and Web Browser.

You can view widgets in both fixed dashboards and custom dashboards, but you can add widgets only
to custom dashboards.

Important: After editing a dashboard, if you do not save the dashboard, the changes you make
will be lost when you close the dashboard. An asterisk in the dashboard tag indicates that the
dashboard needs to be saved.

Add Widgets to a Custom Dashboard
You can add widgets to a custom dashboard and change the details of a dashboard.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Double-click Dashboards. The Dashboards tab opens in the work area.

3. Select the dashboard that you want to add widgets to and click Home > Edit. The dashboard is
displayed in a new tab in the work area and the Dashboard Manager tab displays on the ribbon.

4. In the Dashboard Manager tab, click the widget you need.

5. Click Home > Save.

You can format and configure the widget for data.

Format the Header and Borders of a Widget
After you add a widget to a custom dashboard, you can format the appearance of the widget. All widgets
have the same formatting controls.

You can change the following formats for each widget header:

l Title
The title of the widget.

l Height
The head height.

l Line Height
The offset from the vertical alignment of the text in the header.

l Font type, size, weight, and color
The details of the font in the header.
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l Background Color
The color of the background of the header.

l Horizontal alignment
Left, center, right, and stretch.

l Vertical alignment
Top, center, bottom, and stretch.

You can change the following border and background settings for each widget:

l Height
The total height of the widget.

l Width
The total width of the widget.

l Top
The vertical position of the widget in the dashboard.

l Left
The horizontal position of the widget in the dashboard.

l Widget background
The color of the background of the widget.

l Border Style
The color, line thickness, and corner radius of the widget.

l Margin
The width of margin in the order left, top, right, bottom.

To format the header and borders of a widget:

1. In the Dashboards tab in the work area, open a custom dashboard.

2. Select the widget you want to format. The Widget Tools area displays on the ribbon.

3. Click the Format tab in the Widget Tools area. You can now format the widget header, and the
widget border properties.

4. After you have made all the changes, click Home > Save.

Display Data in a Grid Widget
You can add a grid widget to a custom dashboard. A grid widget shows textual information in a grid
format.

To display data in a grid widget, you must create a query for a relational data source. The columns
defined in the widget must be mapped to the query result. For example, if the query result contains
headers as shown in the following table, the headers in the widget must be the same as in the original
query.

Table 1: Example Query Result for a Grid Widget
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ObjectName ObjectType WorkflowState

Default Page Setup Word Work in progress

Front Cover Page PDF Review

Shareholder Page Setup Word Review

Item 9A Control and Procedures PDF Work in progress

Header PowerPoint Submit

To display data in the grid widget:

1. Click the grid widget that you created in a dashboard.

2. Select the data for the grid widget.
a. Click the Grid tab in the Widget Tools area on the ribbon.

b. Click Select Data.

c. From the Query drop-down list, select the query.

d. Click OK.

3. Define the columns for the grid widget.
a. Click the Grid tab in the Widget Tools area on the ribbon.

b. Click Manage Columns.

c. In the Manage Grid Columns window, click Add.

d. In the Header Text field, type the name to be displayed as the column header.

e. In the Data Field field, type the name of the first column from the query result. In the
example, this is ObjectName.

f. Repeat these steps for each column in the grid.

g. Click OK.

4. Click Home > Save.

Display Data in a Chart Widget
You can add a chart widget to a custom dashboard. A chart widget compares numerical values between
reports that contain similar series of data.

To display a chart series, you must create a query for a relational data source. The query must have two
values, the value for the X axis, and the value for the Y axis. The value for the Y axis must be a decimal
value. The query result must contain columns that can be mapped for each series to be displayed. For
example, if the query result contains data as shown in the following table, the column names in the
query result must be used when defining the X data fields and Y data fields.

Table 2: Example Query Result for a Chart Widget

WorkflowState Report1ObjectsNo Report2ObjectsNo

Start 80 55

Pending Review 40 26

Complete 30 47
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To display data in the chart widget:

1. Click the chart widget that you created in a dashboard.

2. Select the data for the chart widget.
a. Click the Chart tab in the Widget Tools area on the ribbon.

b. Click Select Data.

c. From the Query drop-down list, select the query.

d. Click OK.

3. Define the first data series.
a. Click the Chart tab in the Widget Tools area on the ribbon.

b. Click Manage Series.

c. In the Manage Series window, click Add.

d. In the Name field, type the name for the first series, for example 10 K.

e. In the X Data Field field, type the name of the first column from the query result. In the
example, this is WorkflowState.

f. In the Y Data Field field, type the name of the second column from the query result. In the
example, this is Report1ObjectsNo.

g. Click OK.

4. Define the second data series.
a. Click the Chart tab in the Widget Tools area on the ribbon.

b. Click Manage Series.

c. In the Manage Series window, click Add.

d. In the Name field, type the name for the second series, for example 10 K.

e. In the X Data Field field, type the name of the first column from the query result. In the
example, this is WorkflowState.

f. In the Y Data Field field, type the name of the second column from the query result. In the
example, this is Report2ObjectsNo.

g. Click OK.

5. Define the orientation and position of the legend.
a. Click the Chart tab in the Widget Tools area on the ribbon.

b. In the Legend section of the Chart tab, you can set the orientation, horizontal position, and
vertical position of the legend.

6. Define the X and Y axes.
a. Click the Chart tab in the Widget Tools area on the ribbon.

b. In the X Axis and Y Axis sections of the Chart tab, type the name of the X axis and Y axis.

c. If you want to temporarily remove the name for an axis, clear Show for that axis.

d. To reverse the order for an axis, click Reverse for that axis.

e. To stagger the values for an axis in two lines, click Staggered for that axis.
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f. To set a maximum or minimum value for the Y axis, select the appropriate checkbox in the Y
Axis section, and set a value.

7. Click Home > Save.

Important: If you do not save the dashboard, the changes you make to the widget will be lost
when you close the dashboard. An asterisk in the dashboard tag indicates that the dashboard
needs to be saved.

Display Data in a Gauge Widget
You can add a gauge widget to a custom dashboard. A gauge widget shows one numerical value in a
gauge format, and it can have either a linear or a dial format.

To display data in a gauge widget, you must create a query for a relational data source. The gauge
widget displays one decimal value from the query result. Therefore, only the first row of a column is
displayed. The query result must contain the column that can be mapped for the value to be displayed.

Table 3: Example Query Result for a Gauge Widget

ReportName ExcelReportObjects WordReportObjects PDFReportObjects

10 Q 67 65 77

10 K 55 83 55

To display data in the gauge widget:

1. Click the gauge widget that you created in a dashboard.

2. Select the data for the grid widget.
a. Click the Gauge tab in the Widget Tools area on the ribbon.

b. Click Select Data.

c. From the Query drop-down list, select the query.

d. Click OK.

3. Define the data column.
a. Click the Gauge tab in the Widget Tools area on the ribbon.

b. In the Data Field field, type the name of the column from the query result that contains the
value to be displayed, for example ExcelReportObjects.

4. Click Home > Save.

Display a Graphic in an Image Widget
You can add an image widget to a custom dashboard. A graphic can be linked to an image widget.

1. Click the image widget that you created in a dashboard.

2. Click the Image tab in the Widget Tools area on the ribbon, then click Select Data.

3. Browse to where the image is located, and click Open.

4. Click Home > Save.
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Display a Website in a Widget
You can add a web browser to a custom dashboard. A web browser is included in the widget tools
where you can connect to a particular website or use a web browser.

1. Click the web browser widget that you created in a dashboard.

2. Click the Web Browser tab in the Widget Tools area on the ribbon, then type or paste the web
address in the Web Address field.

3. Click Home > Save.
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Desktop Publishing
If you use desktop publishing applications such as Adobe™ InDesign to add special formatting to your
reports, you can use CDM to identify the content that you want to format in a certain way in the output for
your desktop publishing application.

Important: The functionality for desktop publishing applications such as Adobe™ InDesign is
beyond the scope of this guide. For more information, see the appropriate documentation or
online help.

Overview
You can adapt the output from Certent CDM for use in a desktop publishing application such as Adobe™
InDesign.

For Excel objects, you must tag specific content for your desktop publishing application. For Word
objects, automatic Word generation can be used. You can go to Administration > Resources >
Desktop Publishing Styles to import styles from desktop publishing applications such as Adobe
InDesign or manually create new styles. This is applicable for all styles: paragraph, character, list, table,
and so on.

You must have the Manage Desktop Publishing Styles permission to create or import desktop
publishing styles in CDM.

Report content can be generated so that it can be used in desktop publishing tools. The content is
encapsulated in XML tags that are named according to the content style. The generated XML file can
then be imported into a desktop publishing application and the styles can be automatically mapped
using their names.
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Word Content for Desktop Publishing
Microsoft Word report object content is generated automatically to desktop publishing XML and requires
no tagging.

Styles
Content that uses Word styles that are present in the CDM Desktop Publishing Styles list
(Administration > Resources > Desktop Publishing Styles) are automatically generated (in effect, tags
are not necessary). Contact your administrator to ensure the styles are present. The style names there
must be identical to those in the Word objects you want to generate (the names are case sensitive).

For example, consider this Word object:

Only the content with Word styles that are matching the names from the Desktop Publishing Styles list
are generated:

Thus Algerian and Bahnschrift styled content is generated in the output, while the third sentence, using
a style called Text Not Required, is excluded.
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Output Word Styles
Word content is enclosed in the appropriate style paragraph so as to be easily mapped in your desktop
publishing application. Here is the sample generated content from the example in the preceding Styles
section:

As previously explained, Line 3 does not appear as it uses a style not included in the Desktop
Publishing Styles list, and the BahnschriftChar tag shown on line 4 is enclosing the content where the
Word character style was applied in an Algerian styled paragraph.

Included or Discarded Content
When CDM report content is not intended to be published and its formatted with a style that is used on
other parts of the report that must be published, this approach is recommended: You must create two
styles using the same font, character size, and so on, with different names. One of these styles is to be
added to the Desktop Publishing Styles list and is then applied to content that is to be included in the
desktop publishing output. The second style is applied to content that is to be excluded from the output,
and this style is not to be added to the Desktop Publishing Styles list.

Specific Styling Scenarios
l If a character style is applied to part of a paragraph in a Word object, and this style does not exist
in the Desktop Publishing Styles list, but the paragraph style is present, then the paragraph's
entire content is generated under the same XML node (in effect, tag).

l If a paragraph contains a character style that exists in the Desktop Publishing Styles list, but the
paragraph style doesn't exist, then the paragraph's content is not generated in the XML file.

l To generate Word tables, the paragraph and character styles that exist in a table's cells must also
exist in the Desktop Publishing Styles list. If they do not, the generated table is empty. The table
style must also exist, or the table will not generate.

l Print areas and print area subranges are generated with the Table Normal table style and
Normal paragraph styles in cells. These styles must exist in the Desktop Publishing Styles list to
generate the range variables to desktop publishing.

l Objects other than charts and images are not generated (for example, text boxes, shapes, and so
on). To generate charts and images, the style of the paragraph they are anchored to must exist in

https://insightsoftware.com/


129

the Desktop Publishing Styles list. Charts and images that are not inline with text are not
generated.

l If you use a linked style in Word, that is, one that may be applied to both paragraphs and
characters and it is used on characters, it must be added to the Desktop Publishing Styles list
twice. The second entry should be its name suffixed by a space and the word "Char", and this
style name must exist in the Desktop Publishing Styles list to generate that nested tag. For
example, you have defined a style named "My Style" that can be used both for paragraphs and
characters. To generate this style for characters, you need to have a "My Style Char" style added
in the Desktop Publishing Styles list.

l When generating content to desktop publishing, the style names might be modified to comply
with the XML naming rules. For example, for the Word style "1_My Style" to be generated, the
same style name, that is "1_My Style", must exist in the Desktop Publishing Styles list and the
XML node will have the name "_MyStyle".

l Charts and images - all XML nodes for charts and images are generated with the name found in
the Alt Text description for Word objects and the tag name for Excel objects.

l Special characters - the < and > characters are not escaped. If needed, a placeholder can be
used instead that can be replaced with the appropriate content in the generated XML (in effect,
&lt; for < and &gt; for >).

Pictures
Pictures are automatically generated if they are inline to a paragraph with a style that has a name
matching a style in the Desktop Publishing Styles list.
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Excel Content for Desktop Publishing
Add a Desktop Publishing Tag to an Excel Object
In CDM, you can add tags to specific content in an Excel object for desktop publishing applications such
as Adobe™ InDesign.

When you tag an Excel object, you can use styles that were created in CDM or styles that were imported
into CDM from InDesign. To do so:

1. Open the report that you want to work with.

2. Check out the Excel object where you want to add a desktop publishing tag.
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3. Select the content that you want to apply a tag to. You can select one cell or multiple contiguous
cells, and you can also tag pictures, graphs, and ranges. You cannot mix different kinds of
content in a single tag or tag content that was already tagged.

4. Click Add Tag > New Tag in the Report Object tab on the ribbon. In the window that opens, a
name is automatically assigned to the tag that you are creating and the next consecutive number
after the previously created tag is used. If you prefer, you can change the name. Select a style
from the list. The list includes styles that were created in CDM and styles that were imported into
this report from an InDesign import file.

5. Click OK.

6. Click Save.

7. Check in the Excel object.

8. If a message indicates that some items from the Tag Explorer might be out of date, click Refresh
Now.

The order of tags in the XML file that you will eventually generate will be the same as the order of the
objects within the report. The order of tags in a report object are based on their placement in the report
object.

Use of Styles in an Excel Table
Tagging a full table in Excel, instead of individual cells and using proper Excel cell styles, gives the
desired result faster and tag maintenance is kept to a minimum. When tagging an Excel range you must
assign a name to the tag being created and choose a style from the list defined in the Desktop
Publishing Styles list (Administration > Resources > Desktop Publishing Styles). The cell tags
automatically use the Excel cell style name.

Consider this sample Excel table (note that the name of the style is placed in the cell as content). When
the range below is tagged, a tag name of "TableTagCreatedManually" and the "Normal" is assigned:

The generated desktop publishing content is:
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/

Note that the cell style is used as the name of the tag for each cell.

Report Generation for Desktop Publishing
You can generate a report or report object for desktop publishing in CDM. The resulting XML file can be
used in your desktop publishing application, such as Adobe™ InDesign.

1. Open the report that you want to work with.

2. Complete one of the following actions:

l To generate the entire report, select the report and click Home > Generate > Generate
Entire Report.

l To generate a selection of objects or a single report object , select the report objects and
click Home > Generate > Generate Selection.

3. In the window that opens, select Desktop Publishing in the Select Format section.

4. Optionally, to save a snapshot of the report or report object at the moment of generation, select
Save as Snapshot.

5. Select Automatic Word Generation.

6. Click OK to start the generation.

Tip: You can view the progress in the All processes completed window in the status
bar. While processes are running, the title bar shows the number of running processes.
When the processes are finished, the title is All processes completed. A check mark
indicates that a process generated properly. An exclamation point indicates an error
that stopped the process.

7. If the generation is not successful, an error message opens. Double-click the message to view
the Tag Explorer and the particular tag that has problems.
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8. If the generation is successful, the output contains the XML file. To save the generated XML file,
click the Save icon in the All processes completed window, select a location for the file, and
click Save. The generated XML file can now be imported into your desktop publishing
application.

Report Structure
When generating a report or report selection to desktop publishing, the report structure is reflected in
the output XML document for easy tagging in the desktop publishing application.

This report:

is generated as:

Desktop Publishing Styles
If you use desktop publishing applications such as Adobe™ InDesign to add special formatting to your
reports, you need desktop publishing styles in CDM to represent that formatting. You can create styles
in CDM, or you can import styles from your desktop publishing application.

You can work with desktop publishing styles if you have the Manage Desktop Publishing Styles
permission.

Grant Permissions for Desktop Publishing Styles
You can adapt the formatting of the content in your reports in CDM for use in a desktop publishing
application such as Adobe™ InDesign. Before users can work with desktop publishing styles, the
administrator must apply permissions to the appropriate reports, users, and user groups.
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1. Click the Home tab, then in the Navigation Pane, click Administration.

2. To specify permissions for a particular user or user group to work with desktop publishing styles,
complete the following steps. You must assign this permission only once per user or user group.
a. Under Security, double-click Application Permissions.

b. Select the user or user group.

c. In the work area, expand View.

d. Select the Allow checkbox next to Manage Desktop Publishing Styles.

3. To specify permissions for a particular user or user group to work with desktop publishing tags,
complete the following steps. You must assign this permission for each report.
a. Under Security, double-click Report Permissions.

b. Select the report or report group.

c. Select the user or user group.

d. In the work area, expand View.

e. Select the Allow checkbox next to Manage Desktop Publishing Tags.

4. Click Save.

Import Desktop Publishing Styles
If your InDesign application already contains many styles, importing styles is a more efficient approach
than creating new styles individually.

Export the styles from InDesign and save the XML file in a location that is accessible at the appropriate
file path. The file must follow XML format, and it must have an .xml extension. You can obtain this file in
InDesign by exporting the document in an .idml file format. You can then extract this archive to find the
style file named mapping.xml.

To import desktop publishing styles in CDM:

1. Do either of the following to open the Desktop Publishing Styles tab in the work area:

l Click the File tab, then navigate to Administration > Resources > Desktop Publishing
Styles.

l Click the Home tab, then in the Navigation Pane, click Administration and double-click
Desktop Publishing Styles under Resources.

2. Click Home > Import.

3. In the window that opens, click Browse, select the exported file, and click Open. The styles that
are available in the XML file are listed in the import window.

4. Select the styles that you want to import, or click All to select all styles in the list.

5. Click OK. The desktop publishing styles that you imported appear in the style table in the work
area, with a check mark in the Imported column. If a style with the same name exists in the
application, an error message opens. Styles from Microsoft™ Office are also added automatically
when a tag is created in a Word object.
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Add a Desktop Publishing Style
If you do not want to import styles from InDesign, or if you need one or more additional styles, you can
use CDM to create them.

1. In the Desktop Publishing Styles tab in the work area, click Home > Add > Desktop Publishing
Style.

2. Type a name for the desktop publishing style. The name must be unique, and blank spaces at the
beginning or end of the name are not allowed.

3. You can specify a description for the desktop publishing style. Blank spaces at the beginning or
end of the description are not allowed.

4. Click OK. The desktop publishing style that you created appears in the style table in the work
area.

Edit a Desktop Publishing Style
To edit the name or description of a desktop publishing style:

1. In the Desktop Publishing Styles tab in the work area, double-click the style that you want to edit.

2. Change the name or description of the desktop publishing style. The name must be unique, and
blank spaces at the beginning or end of the name or description are not allowed.

3. Click OK.

Delete a Desktop Publishing Style
If necessary, you can delete a desktop publishing style in CDM that was originally created for use in a
desktop publishing application such as Adobe™ InDesign. A style cannot be deleted if it is used in a tag.

Important: If you delete a desktop publishing style, you cannot undo your action. Proceed with
caution.

To delete a style:

1. In the Desktop Publishing Styles tab in the work area, select the style that you want to delete.

2. Click Home > Delete.

3. In the confirmation message that opens, click Yes.

Desktop Publishing Tags
After you create or import your desktop publishing styles, you can use them in CDM to add tags to
specific content in Excel objects for desktop publishing applications such as Adobe™ InDesign. In the
Excel objects, you can create and edit tags, or references to your tags.

View and Navigate Desktop Publishing Tags
To view desktop publishing tags in the Excel object and move from tag to tag:
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1. Open the report that you want to work with.

2. To view the list of tags that are available, open an object and click Show Tags in the Report
Object tab on the ribbon. The Tag Explorer opens, containing a list of all desktop publishing
tags, along with information on the content that is referenced by each tag.

l To view all tags in the selected report object, click Show all tags in > Selected report
object.

l To view all tags in the entire report, click Show all tags in > Report.

3. To view tags that exist in an Excel object, open the object and check it out, then click Highlight
Tags.

4. To move from one existing tag to another in an Excel object, check out the object, and then click
Go to Next Tag or Go to Previous Tag.

Edit a Desktop Publishing Tag
You can change the name of a tag and the desktop publishing style that is associated with the tag.

1. Open the report that you want to work with.

2. To view a list of tags that are available, click Report Object > Show Tags on the ribbon.

3. In the Tag Explorer, click the tag that you want to work with and click Edit.

4. In the window that opens, you can change the name of the tag. The new name must be unique,
and blank spaces at the beginning or end of the name are not allowed.

5. You can also change the desktop publishing style that is applied to this tag. Select the style from
the list or type the name of the style until it appears in the list.

6. Click OK. The desktop publishing tag appears in the Tag Explorer with the changes that you
made.

Edit a Reference to a Desktop Publishing Tag
To edit the reference of a tag and select different content:

1. Open the report that you want to work with.

2. Check out the Excel object where you want to edit a reference to a desktop publishing tag.

3. To view a list of tags that are available, click Report Object > Show Tags on the ribbon.

4. In the Tag Explorer, click the tag that you want to work with, and expand its hierarchy.

Tip: To access commands for expanding or collapsing a hierarchy, right-click any tag.

5. Ensure that the report object is the active document on your screen. To find the appropriate
report object, right-click the referenced content and click Navigate to Report Object.

6. In the report object, select the new content. You cannot select content that is already tagged.
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7. In the expanded hierarchy, click the referenced content that you want to replace with the newly
selected content and click Edit.

8. In the window that opens, compare the content in the Preview of Current Content section with
the content in the Preview of Selected Content section. If you are satisfied with the replacement,
click OK.

9. Check in the report object.

10. If a message indicates that some items from the Tag Explorer might be out of date, click Refresh
Now. The desktop publishing tag appears in the Tag Explorer with the changes that you made.

Delete a Reference to a Desktop Publishing Tag
If necessary, you can delete the reference to a desktop publishing tag in CDM that was originally added
to a report for use in a desktop publishing application such as Adobe™ InDesign.

In particular, you should delete orphan tags. Orphan tags are desktop publishing tags that exist in the
database but were deleted from the associated report object. An orphan tag is sometimes created when
the content is deleted before the tag is removed. When you create a tag and then check in a report
object without saving, the next time the report object is checked out, the reference from that tag is no
longer available.

If a tag contains an orphan reference, you can see a check mark in the Is Orphan column of the Tag
Explorer. If one tag contains both orphan reference content and valid reference content, you can see an
exclamation mark in the Is Orphan column of the Tag Explorer.

If a tag contains only one item of referenced content and you delete the referenced content, you
automatically delete the tag also.

Important: If you delete the reference to a desktop publishing tag, you cannot undo your
action. Proceed with caution.

To delete the reference to the tag:

1. Open the report that you want to work with.

2. Check out the Excel object where you want to delete a reference to a desktop publishing tag.

3. To view a list of tags that are available, click Report Object > Show Tags on the ribbon.

4. In the Tag Explorer, click the tag that contains the reference that you want to delete, and expand
its hierarchy.

Tip: To access commands for expanding or collapsing a hierarchy, right-click any tag.

5. Ensure that the report object is the active document on your screen. To find the appropriate
report object, right-click the referenced content and click Navigate to Report Object.

6. In the expanded hierarchy, click the referenced content, and click Delete.

7. Click OK.
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Macros
You can configure CDM to generate output to Excel or PowerPoint that contains macros.

Users with appropriate permissions must first create the macros in Administration by defining a name, a
description, a target (Excel or PowerPoint and the content). When generating a report to Excel or
Powerpoint, a user with appropriate permissions is able to select a number of macros that will be
inserted in the final output. The list of macros that can be selected for a particular generation is filtered
based on the macros target. The selection is similar to choosing Custom Groups. The generated report
contains the selected macros in separate modules for each macro. The modules have the macros
names from CDM. When generating a report, the all processes window differentiates a macro
generation from a regular generation. If, at generation time, an empty macro is selected for insertion, a
warning prompt is displayed when opening the generation from CDM (similar to refresh errors).

You can work with macros if you have the Manage Macros permission.

Add a Macro
To add a macro that can be included with generated Excel or PowerPoint output, take the following
steps:

1. In CDM, navigate to File > Administration > Resources > Macros. The Macros tab opens in the
work area.

2. Click Home > Add > Add Macro.

3. Enter a name for the macro. The name must be unique and limited to 31 characters. It must begin
with a letter and, except for underscores, contain no other non-alphanumerical characters.

4. Select if the target for the macro is Excel or PowerPoint output.

5. Specify a description for the macro if you want. A maximum of 256 characters is allowed.

6. Click OK.

7. Enter the macro content.

8. Click Save. The macro is added to the Macros table in the work area.

Edit a Macro
If necessary, you can edit the name or description of a macro for use in generating a report containing
macros.

1. From the macro list in the work area, select the macro you want to edit.

2. Click Home > Edit.

3. Make your changes to the macro, then click Save.

Delete a Macro
1. From the macro list in the work area, select the macro you want to delete.

2. Click Home > Delete.
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3. In the confirmation message that opens, click Yes. This permanently deletes the macro and
removes it from list.
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Security Administration
As an administrator, you define users, user groups, custom groups, and their permissions in CDM.

By default, only the administrator can perform many of the tasks in CDM. However, if you want some
users or user groups to be able to perform certain tasks, you can grant permissions to those users or
user groups.

Users and User Groups
As the administrator, it is your responsibility to ensure that all qualified users have the correct access to
CDM.

A user group is a group consisting of one or more defined individual users, identified by a single group
name. Users in a user group in CDM perform similar functions, have a similar status in an organization,
or require the same permissions.

Examples of user groups are Reviewers, Auditors, and Approvers. When you grant permissions to a
user group, the users within the group inherit these permissions. You can then override the group
permissions for an individual user. If required, you can later edit all properties of the user group.
Permissions assigned to an individual user override any permissions assigned to the user through the
groups that the user is assigned to.

After you open the list of qualified users or user groups, you can optionally export the data into a CSV
file by right-clicking in the working space and clicking Export as .csv.

Note: By default, only the administrator can manage user group permissions. However, the
administrator can grant permission to a user or user group to perform this task.

Add Users
You can add users to CDM. You can then associate the users with user groups and grant permissions to
them.

Users cannot be deleted because their actions are tracked in CDM, and deletion might adversely impact
audit trails.

To add a user:

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Users. The Users tab opens in the work area.

3. Click Home > Add > User.

4. Specify the following credentials and details about the user.

l User Name - The name used to log in to CDM. User Name appears as Login ID in the
Users tab and the Groups tab. You cannot change the user name later.

l Given name - The given name of the user.

l Surname - The surname of the user.
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l Display Name - A name that is simpler and easier to remember than the user name.

l Email Address - The company email address of the user. This address is used when an
email notification is generated.

l Password and Password Confirmation - Specify and then confirm the password for the
user.

l Active - If you want the new user to be active immediately, select this checkbox.

5. Click OK.

You can now grant permissions to the user. If the user is part of a user group, set the common
permissions for the group and then override the permissions for individual users as required.

Note: By default, only the Display Name is displayed as relevant user information throughout
CDM. However, you can configure CDM to also display either the User Name or the Source
from which the user name was imported if the user was imported, or both.

Add User Groups
You can add user groups to organize categories of users in CDM. When you grant or deny permissions
to a user group, the users within the group inherit these permissions. You can then override the group
permissions for an individual user. If required, you can later edit the properties of the user group.

User groups cannot be deleted because their actions are tracked in CDM, and deletion might adversely
impact audit trails.

To add a user group:

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Groups. The Groups tab opens in the work area.

3. Click Home > Add > Group.

4. Specify a name for the user group. The name must be unique.

5. Specify a display name for the user group. The display name is one that is simpler and easier to
remember than the actual name.

6. Select the Active checkbox if you want users in this user group to be able to work in CDM
immediately.

7. You can specify a description for the user group. The description can contain a maximum of 50
characters.

8. Click OK.

Import Users and User Groups from Microsoft Active
Directory
You can import users and user groups from Microsoft™ Active Directory into CDM.
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1. Click the Home tab, then in the Navigation Pane, click Administration.

2. To define the source type, complete the following steps:
a. Under Security, double-click Import Source.

b. Click Home > Add > Import Source.

c. Specify a name for your import source.

d. From the Provider Type drop-down list, select Microsoft Active Directory.

e. Specify the internal gateway URL and the external gateway URL.

f. You can specify a description for the source type.

g. Click OK.

3. To import a user, complete the following steps:
a. Under Security, double-click Users.

b. Click Home > Import.

c. Select the import source that you defined.

d. Enter your user name and password, or click Use Server's User.

e. Click Test Connection.

l If the connection succeeds, the Microsoft Active Directory interface opens.

l If the connection fails, an error message is displayed. Check with the database
administrator to ensure that the database server is running and that you have the
correct parameters.

f. In Microsoft Active Directory, select a user that you want to import. When you return to
CDM, you can see the imported user in the Administration > Users tab.

4. To import a user group, complete the following steps:
a. To select a user group, under Security, double-click Groups.

b. Click Home > Import.

c. Select the import source that you defined.

d. Enter your user name and password, or click Use Server's User.

e. Click Test Connection.

l If the connection succeeds, the Microsoft Active Directory interface opens.

l If the connection fails, an error message is displayed. Check with the database
administrator to ensure that the database server is running and that you have the
correct parameters.

f. In Microsoft Active Directory, select a user group that you want to import. When you return
to CDM, you can see the imported user group in the Administration > Groups tab.

5. After you import a user or user group, you can set up the users to be automatically added to the
Users or Groups tab. Double-click the imported user or user group and click OK.
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6. The Auto-Register property is disabled after the import is performed. You can enable it by editing
the imported group. To auto-register the members of the group, select Auto-Register. If you do
not select Auto-Register, you must manually select the users that are in these groups and click
Import and then associate the imported users with the imported groups.

The Source column in the Users or Groups tab in the work area identifies the source for the imported
users or user groups.

You can associate the imported users with user groups, grant permissions, and assign to workflows.

Convert a Classic CDM User to a IdP User
You can convert a classic CDM user to a IdP user.

This task can be performed if:

l A modern IdP is defined.

l The user is of type AD/LDAP or native.

To convert a classic CDM user to a IdP user:

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Users.

3. In the user list in the work area, right-click a user and select Set Source.

4. The account must be updated.

l ExternalID must be set to null.

l ImportSource must be set to the ID of the existing Identity Provider.

l IsAutoImported must be set to true.

5. A prompt is displayed. Click OK.

Associate Users with a User Group
After you add users and user groups to CDM, you associate users with a user group. Users inherit the
permissions set for the group, but you can override the group permissions for an individual user.

To associate users with a user group:

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Associate Users With Groups.

3. In the Users pane on the top, select a user that you want to add to one or more user groups.

4. In the User Groups pane on the bottom, select the Assign checkbox for the user groups that you
want the user to belong to. If you want the user to belong to all user groups, select the Assign All
checkbox.

5. Associate another user with one or more user groups.

6. Click Home > Save.
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Temporarily Remove a User's Access
You can temporarily revoke access to CDM for users at any time. For example, you might want to do so
if the user is on an extended leave from the company but plans to return. You cannot delete a user
permanently because the actions of users and user groups are tracked in CDM, and deletion might
adversely impact audit trails.

To temporarily remove a user's access:

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Users.

3. In the user list in the work area, double-click the user whose access you want to remove
temporarily.

4. Clear the Active checkbox.

5. Click OK.

Configure User Display
You can configure the CDM.config file to set what user information is to be displayed in CDM. By
default, only the Display Name is displayed as relevant user information throughout CDM. However, you
can configure CDM to also display either the User Name that was entered when the user was added or
the Source from which the user name was imported if the user was imported, or both.

1. Open the CDM.config file on the computer where the CDM server is installed. The default
location is C:\inetpub\wwwroot\CertentCDM-Server\Config.

2. Locate the UserDisplayFormat key:

<UserDisplayFormat name="DisplayName" />.

3. Modify the key by making these changes:

l Add a UserName parameter to the key.

l Add an ImportSourceName parameter to the key.

<UserDisplayFormat name="DisplayName/UserName/ImportSourceName" />

Note: If no parameters exist in the UserDisplayFormat key, DisplayName is used
as the default.

Custom Groups
A custom group is a group that is used to organize report objects in a report according to their purpose
or content. All other report objects are filtered out if they are not assigned to the custom group. As the
administrator, you create the custom groups. You can also associate report objects with custom groups,
or grant permission to users and user groups to do this.

After a report is created, users can associate certain report objects with a custom group to filter their
view of the report. For example, a full 10K report can contain report objects that are required in Q1, Q2,
and Q3 reports. Users can use custom groups created for each quarter to load and generate only those
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report objects that are associated with each group. Also, when a report is opened by filtering one or
more custom groups, report objects that are added or imported are automatically assigned to the
custom group or groups.

Add a Custom Group
You can create custom groups in CDM to allow users to load and generate reports that contain only the
report objects associated with each group.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Resources, double-click Custom Groups. The Custom Groups tab opens in the work
area.

3. Click Home > Add > Custom Group.

4. Specify a name for the custom group.

5. Specify a description for the custom group if you want. The description can contain a maximum of
50 characters.

6. When you have multiple items, use the Sort Order column to determine the sort order. Specify a
number to represent the order of this item in relation to others.

7. Click OK.

Edit a Custom Group
1. In the Custom Groups tab in the work area, double-click the custom group that you want to edit

2. Change the name and description, if necessary. The description can contain a maximum of 50
characters.

3. When you have multiple items, use the Sort Order column to determine the position of each
custom group in the Custom Groups tab. Specify a number to represent the order of this item in
relation to others.

4. Click OK.

Delete a Custom Group
If you no longer need a custom group, you can delete it. You cannot delete a custom group if it has
report objects associated with it.

Important: If you delete a custom group, you cannot undo your action. Proceed with caution.

To delete a custom group:

1. In the Custom Groups tab in the work area, select the custom group that you want to delete

2. Click Home > Delete.

3. In the confirmation window, click Yes.
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Permissions
Permissions are set at application level or report level or both in CDM. Application permissions
determine what you can and cannot do when managing the application as a whole. Report permissions
determine what you can and cannot do with specified reports.

Initially, users and user groups do not have any permissions set. They must be explicitly granted. When
you grant application permissions and report permissions to a user group, the users inherit the group
permissions. You can then override the group permissions for an individual user.

By default, only the administrator can set permissions. However, if you want some users or user groups
to be able to perform certain tasks, you can grant permissions to those users or user groups.

For example, to enable other users to create and manage reports, grant them the following permissions:

l In Report Permissions, the permission to view reports.

l In Application Permissions, the permission to manage reports.

Grant Permissions to a User or User Group
1. Click the Home tab, then in the Navigation Pane, click Administration.

2. To change application permissions for a user, complete the following steps:
a. Under Security, double-click Application Permissions.

b. In the work area, select the user or user group whose permissions you want to change.

c. Change the permissions.

3. To change report permissions for a user, complete the following steps:
a. Under Security, double-click Report Permissions.

b. In the work area, select the report group or report to change.

c. Select the user or user group whose permissions you want to change.

d. Change the permissions.

4. Click Home > Save.

Note: Permissions assigned to an individual user override any permissions assigned to the
user through the groups that the user is assigned to.

Remove a User's Access to a Report
You can prevent a user from being able to access a report in CDM. For example, you might want to do
so if the user transfers to a different department and different responsibilities.

You can also remove a user's access to CDM temporarily.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Report Permissions.

3. In the work area, select the report.
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4. Select the user.

5. Select the Deny checkbox for the permissions in the following areas:

l Report Generation

l Report Object Management

l View

6. Click Home > Save.

Application Permissions
Permissions are set at the application level or report level or both in CDM. Application permissions
determine what you can and cannot do when managing the application as a whole.

Security and Workflow

Permission Allows the user the ability to

Manage Permissions for
Users and Groups

Grant permissions to specific users or user groups to create and modify
users and user groups, to manage permissions for the users and user
groups that they create, and to change password for other users. If you
need to change the password for another user, you must be granted
this permission. Then, under Security, double-click Users, right-click
the user, and click Reset Password.

Manage Workflow Templates
Create, modify, associate, and delete workflow templates, and get the
list of active users and groups for the workflow

Manage Notifications

Manage subscriptions and configure notifications and templates.
Notifications are used in CDM to create and send users automated
emails that include required information. For example, when users
change the workflow status for a section or report object, they can
automatically receive an email reminding them to notify the person
responsible for the next step in the workflow. See Email Notification for
Workflow Processes.

Manage Resources

Manage custom groups, workflow states, or report object templates. A
report object template is used in CDM to provide managed layout and
style options to a project. You can export, import, and revert report
object templates that are applied to a project in CDM.

Import Report Import or export reports

Site Administration Access the Site Administration tile in the CDM web client

Data Management

Permission Allows the user the ability to

Manage Data Sources Create, edit, and delete data sources

Manage Query Variables Manage query variables at the application level

Manage Data Queries Create, edit, and delete data queries
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Permission Allows the user the ability to

Manage Expiration Policies Work with expiration policies for data sources

Manage Tasks View, add, edit, manage, and delete task lists and tasks

Manage Macros Manage macros that are output at generation

Report Object Management

Permission Allows the user the ability to

Manage Report Object
Checkin/ Checkout

Check in a report object that another user has forgotten to check in

Create Standard and
Cascade Report

Create reports and modify the properties of reports

Delete Report Delete a report

Change References Change references from the reference object or from the report

Dashboard

Permission Allows the user the ability to

Manage Dashboard View, add, edit, manage, and delete custom dashboards

View Dashboard View existing dashboards

View

Permission Allows the user the ability to

Manage Checklists Manage all checklists

Manage Reports Use the Reports section in Administration

View Audit Trail

View an audit trail. An audit trail is a detailed analysis of all changes that
are made to reports or report objects. By default, only the administrator
can view the audit trail in CDM. However, you can grant permission to a
user or user group to perform this task. The audit trail feature records
every submission to the CDM database, along with the user name and
the date of submission. See also Report Permissions > Audit Trail >
View Audit Trail.

View Tasks View and mark tasks in a list as complete or incomplete

Manage Desktop Publishing
Styles

Work with desktop publishing styles. See also Report Permissions >
View > Manage Desktop Publishing Tags.

Filing

Permission Allows the user the ability to

Manage Packages Manage a filing package

Manage Reporting Entities Manage a reporting entity

Perform XBRL Validation Test the filing report to ensure that the XBRL is valid
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XBRL

Permission Allows the user the ability to

Manage Taxonomies Add, edit, and delete taxonomies

Manage Projects
Add, edit, and delete projects. The user can create a project that
associates a report and a taxonomy

Manage Namespaces Add, edit, and delete namespaces

Manage Units and Measures Add, edit, and delete units and measures

Manage Time Periods Add, edit, and delete time periods

Manage Transformation Sets Add, edit, and delete transformation sets

Manage Entity Schemas Add, edit, and delete entity identifier schemes

Manage Entities
Add, edit, and delete entity identifiers. When you grant permission to
manage entities to users, you are not automatically granting them
permission to manage entity schemes

Manage Project Associations
Associate time periods, units, and entity identifiers to a specified
project

Manage Taxonomy Mappings Map elements between two taxonomies

Manage Cache Manager
Items

Load all the prerequisite files that are needed to load taxonomies. This
is useful for users who have restricted access to the internet and might
not be able to go online to get taxonomy files

Manage Formula Linkbases Allow access to add, edit, and delete an ad hoc linkbase

Tag Data

Tag data that is associated with a project. This is useful for users who
can review tagged data but cannot modify the tags. The user is granted
permission to add, edit, and delete the contents of tags and footnotes.
If the Tag Data permission is not given, the user cannot refresh data

Generate Instance Document Generate an XBRL instance

Manage Extension
Taxonomies

Manage the XET capabilities

Edit Extension Taxonomies Access the XET capabilities

Report Permissions
Permissions are set at the application level or report level or both in CDM. Report permissions
determine what you can and cannot do with specified reports.

Report Generation

Permission Allows the user the ability to

Generate Entire Report Generate the entire report

Generate Selected Report
Objects

Generate selected objects or sections of a report that belong to a
custom group

Generate Validation Report Generate the validation reports

Generate EDGAR HTML Generate EDGAR HTML

Export Report Export reports

Generate Report Containing Generate Excel or PowerPoint output that includes Macros
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Permission Allows the user the ability to

Macros

Security and Workflow

Permission Allows the user the ability to

Manage Report Object
Workflow

View and modify the workflow for an object or section

Manage Report Workflow View and modify the workflow for a report

Manage Report Object
Checklists

Add, modify, or delete checklists associated with an object

Add Object-Level Comments Add comments in an object

Add Report-Level Comments Add comments at the report level

View Comments View comments

Delete User Comments Delete comments at the report or object level

Delete All Comments Delete all comments

Manage Variable Security
Set variable security for users, which controls what is displayed in the
Insert Variable window. See Permissions for Managing Variable
Security.

Report Object Management

Permission Allows the user the ability to

Add Object Add, copy, cut, paste, or move sections or report objects in the report

Add Web Object Add, copy, cut, paste, or move a web object in the report

Delete Object Delete sections, report objects, or web objects in the report

View Report View the report

Push Down Objects

Push sections and report objects down to other reports. In the
destination report, grant permission to view the report and to add
sections and report objects. In the source report, grant permission to
push down section or report object updates and to create sections or
report objects.

Break Reference Break references to a shared object in a report

Unshare Object

Unshare an object that has a reference to a shared object in a report.
When the current report object is shared, it makes the report object
visible in the window that opens when you add reference objects.
When a report object is set as Shared, an icon in the report tree beside
the report object name indicates that the report object is a shared
object.

Reference Shared Objects

Work with shared objects. A shared object can be added as a copy of
the shared object or as a reference object that is updated when
changes are made to the source object. Shared objects can be
unshared and references to the shared objects can be broken without
deleting the report object.

Modify Report Properties Modify the properties of a report
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Permission Allows the user the ability to

Modify Report Object
Properties

Modify the properties of a section or report object

Modify Print Settings of a
Report Object

Modify the print settings for a section or report object, such as
changing an object from Printable to Not Printable

Modify Break Type of a Report
Object

Modify the break type of a report object in order to insert blank pages
or blank rows between report objects

Manage Report Object
Attachments

Manage attachments for report objects

Tag Report Objects with
Custom Group

Associate report objects with custom groups

Protect Report Object Data Protect data of the report object

PerformWrite-Back Perform the Write-Back operation

Import Report Objects Import report objects into the report

Export Objects Export report objects in the report

Data Source

Permission Allows the user the ability to

Load Data from Query Load data from data queries that are available for the report

Audit Trail

Permission Allows the user the ability to

View Audit Trail
View the audit trail for the report. See also Application Permissions >
View > View Audit Trail

Snapshot

Permission Allows the user the ability to

Create Snapshot Create snapshots of the report

Delete Snapshot Delete snapshots of the report that are no longer needed

View Snapshot View or compare snapshots of the report

Variables

Permission Allows the user the ability to

Manage Report Query
Variables

Override values for existing query variables at the report level

Manage Report Object Query
Variables

Override values for existing query variables at the object level
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View

Permission Allows the user the ability to

View Progress Report Navigate to and export, group, or filter the results in the progress report

View Orphan Variable Report
View the orphan variable report to analyze and detect orphan variable
references in the report

View Reference Variables
View the reference variable report and track different variations of
variables available in the report

View User by Workflow Report
View the user by workflow report to check the assignment of users to
different stages of a workflow

Manage Desktop Publishing
Tags

Work with desktop publishing tags. See also Application Permissions >
View > Manage Desktop Publishing Styles.

Workflow Visibility

Permission Allows the user the ability to

View All Objects View all objects in the report (no filtering)

View Objects by Workflow
View only the objects if the user is part of at least one workflow state for
the object

View Objects by Workflow
State

View only the report objects when the current workflow state advances
to a state that the user is a part of

Note: When two different groups are assigned different
workflow visibility settings, the permission that takes
precedence is the least permissions. For example: Group 1
has View All Objects, Group 2 has View Objects by Workflow.
If a user is assigned to both group 1 and group 2, then the user
permission will be set to View Objects by Workflow. This
controls the level of access based on different user roles.

Certent 365 Project

Permission Allows the user the ability to

Owner

Member

See Report Permissions for the Web Client for more information.

Filing Wizard

Permission Allows the user the ability to

Create Filing

Delete Filing
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Permission Allows the user the ability to

View Filing

Submit Live Filing

Amend Filing

Report Permissions for the Web Client
Permissions are set at the report level for CDM web client users.

Users can be granted roles with the project Owner or Member permissions.

If an existing CDM permission exists for a user, the web client will acknowledge it and allow that user to
use that permission. If it is a net new web client feature, access is only given using the role permissions.

For example, for permissions in the web client to rename a report:

l Works with existing permissions (View Report and Modify Report Properties).

l Works with Owner and Modify Report Properties.

l Works with Owner.

l Doesn't work in any other situation.

In the CDM desktop client, the Owner and Member roles are able to load a report. All other operations
are linked to existing permissions.

Task Project Owner
Project
Member

Existing Desktop Client Permission?

Move Folder Yes No
Yes - Application Permissions > Manage
Reports

Move Project Yes No
Yes - Application Permissions > Manage
Reports

Rename Project Yes No
Yes - Application Permissions > Manage
Reports

Rename Folder Yes No
Yes - Application Permissions > Manage
Reports

Change Project Picture Yes No No

Change Project Description Yes No
Yes - Report Permissions > Modify
Report Properties

View Project Details Page
and all tiles

Yes Yes No

View Project Detail Tiles'
Details Pages

Yes Yes No

Create/Edit/Manage a Project
Plan

Yes No No

Create/Edit/Manage Project
Plan Tasks

Yes No No
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Task Project Owner
Project
Member

Existing Desktop Client Permission?

Change Project Plan Task
Status (Not
Started/WIP/Complete)

Yes Yes No

Open HD HTML Yes No No

Permissions for Managing Variable Security
You can manage variable security by restricting the use of a one or more report variables.

There are two types of variables:

l Public variables have no restrictions (allow or deny)

l Restricted variables have at least one restriction (allow or deny) set for a user or user group.

By default, all variables are public. So variables contained in imported reports or report objects are
public until restrictions are set on them. Before you can restrict the use of a variable, you must have the
following report permissions:

l View Report

l View Reference Variables

l Manage Variable Security

When you set variables restrictions for a specific user, the Insert Variable window filters out the
variables they are not allowed to add in a report. Also, if a user is denied the use of a specific variable
and tries to manually insert that variable into a report object or imports an object containing that
variable, they will not be able to save the report object until the variable is removed. If the user has
access to a report object that already uses the restricted variable, they are still able to generate and
resolve the variable for that object only. However, they are still prohibited from inserting the variable into
other objects.

Deleting a variable also removes any restrictions set on that variable (it becomes a public variable if
added again). Variable security settings are maintained in reports that are rolled forward or cascaded.

Note: A user with the Manage Variable Security permission for a report containing reference
objects is also allowed to set restrictions for any variables that are in the source report. Also,
global variables can have restrictions set on them from any open report.

The following procedure describes how to grant the appropriate permissions to a user and how a user
can manage variable security.

1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Report Permissions.

3. In the work area, select the report or report group.

4. Select the user or user group.
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5. Select the permissions for the user or user group:

l Under Report Object Management, select View Report.

l Under View, select View Reference Variables.

l Under Security and Workflow, select Manage Variable Security.

6. Click Home > Save.

Account Locking
You can configure CDM to set the number of failed log in attempts a user can make and the duration
they have to wait before making another attempt. A user account can also be locked immediately after a
failed log in attempt.

Configure Account Locking
You can configure the CDM.config file so that the number of failed log in attempts by CDM users is
controlled.

1. Open the CDM.config file on the computer where CDM server is installed. The default location is
C:\inetpub\wwwroot\CertentCDM-Server\Config.

2. Locate the CdmAccountLockoutPolicy key:

<CdmAccountLockoutPolicy accountLockoutThreshold="0"
accountLockoutDuration="0" />

3. Modify the key by making these changes:

l Enter a number for the accountLockoutThreshold parameter. A number greater than 0
must be used. The number entered represents the number of initial failed attempts a user
can make before the duration parameter takes affect.

l Enter a number for the accountLockoutDuration parameter. The value must be any
number greater than 0 or a negative integer. A number greater than 0 represents the
number of minutes a user's account is locked after the threshold has been met. When the
duration has passed, the user can attempt another log in. If it fails, the duration takes effect
again and for each subsequent single log in failure thereafter. Entering a negative integer
locks a user's account immediately when the threshold is reached and requires an
administrator to unlock it.

Log in attempts are controlled.

Unlock a User Account
You can unlock a user account in CDM that has been locked due to an incorrect login by the user.

If CDM is configured to lock a user's account immediately after a failed log in attempt by the user, the
administrator must unlock the account before the user can attempt to log in again. A locked user
account is indicated by a lock icon appearing in the Locked column in the Administration > Users tab.

To unlock a user account:
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1. Click the Home tab, then in the Navigation Pane, click Administration.

2. Under Security, double-click Users.

3. In the work area, select the user whose account you want to unlock.

4. Click Home > Unlock User.

5. Click OK.

Security Audit Logging
Specific actions in CDM are audited so you can see which users are granted permissions for the
application, reports, and so on, as well as who modifies application settings (for example, data source
connections, workflow templates, and so on)

The application actions are logged by default in core.AuditLog, a CDM SQL DB table. However, you
can configure CDM to log the actions in a log file as well.

Security audit logging is disabled by default when CDM is installed. To enable this feature, see Enable
Security Audit Logging.

For logging to a database table, there is a buffer size of 100 set as the default
(<bufferSizevalue="100" />), meaning, information is not written in the database until the
threshold of 100 lines is reached. This setting can be modified.

Log messages contain:

l The time, logging level, User ID and User Login ID of the user performing the operation,
operation ID, operation type, action, message (details).

l The Message column contents might be different depending on the operation type.

l One row per action (for example, granting an entire suite of permissions to a user generates as
many rows as the number of permissions granted).

These application actions are logged (regardless of what triggers them. In effect, Import Report triggers
Report Permissions Assignment, Add Data Source, Add Data Query, Add Query Variable, Associate
Data Query to Report):

l Administration > Reports
o Export Report

l Administration > Security > Users
o Add/Import new user
o Activate/Inactivate User
o Change Password

l Administration > Security > Groups
o Add/Import new group
o Activate/Inactivate group
o Autoregister On/Off
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l Administration > Security > Associate Users with Groups
o Save

l Administration > Security > Application Permissions
o Add/Update/Remove User application permission
o Add/Update/Remove Group application permission

l Administration > Security > Report Permissions
o Add/Update/Remove User report permission
o Add/Update/Remove Group report permission

l Administration > External Data
o Add/Edit/Remove Data Source
o Add/Edit/Remove Data Query
o Preview Data Query
o Add/Edit/Remove Query Variable
o Add/Edit/Remove Query Association to Reports

l Administration > Workflow > Workflow Templates
o Add/Remove User Assignment to Workflow State
o Add/Remove Group Assignment to Workflow State

Enable Security Audit Logging
You can enable security audit logging in CDM.

Security audit logging is disabled in default when CDM is installed. Perform these steps to enable the
security audit logging feature.

1. Open the Logging.config file on the computer where CDM server is installed. The default
location is C:\inetpub\wwwroot\CertentCDM-Server\Config.

2. Locate the audit logging key and change the level value from OFF to INFO.

<logger
name="Ibm.CognosDM.BusinessLogic.Audit.AuditLog"additivity="false">
<level value="OFF" />
<appender-ref ref="AuditLogDatabaseAppender" />
</logger>

Configure Security Audit Logging to a File
You can configure security audit logging in CDM to put logging information in a file.

Security audit logging information is logged by default in core.AuditLog, a CDM SQL DB table. You can
also configure CDM to place the information into a log file.

1. Open the Logging.config file on the computer where CDM server is installed. The default
location is C:\inetpub\wwwroot\CertentCDM-Server\Config.
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2. Add the appender to log to file key to the file and give it these values:

<appender name="AuditLogAppender"
typee="log4net.Appender.RollingFileAppender">
<!--logfile: .\LogFiles\AuditLog.yyMMdd.log-->
<file value="LogFiles\AuditLog"/>
<datePattern value=".yyMMdd.'log'" />
<rollingStylevalue="Date" />
<encoding value="utf-8" />
<staticLogFileName value="false" />
<appendToFile value="true"/>
<lockingModel typee="log4net.Appender.FileAppender+MinimalLock" />
<maxSizeRollBackups value="2" />
<maximumFileSize value="500KB"/>
<layout type="log4net.Layout.PatternLayout">
<conversionPattern value="%date{MM/dd/yyyy HH:mm:ss} Level:%-
5levelLoginId:%X{currentUserId} CurrentUser:%X{loginId} OperationId:%X
{operationId}Operation:%X{operationType} Action:%X
{operationCrudTypes}Message:%message%newline%newline" />
</layout>
</appender>

3. Add the appender to log to file to the logger:

<logger name="Ibm.CognosDM.BusinessLogic.Audit.AuditLog"
additivity="false">
<level value="INFO" />
<appender-ref reff="AuditLogDatabaseAppender" />
<appender-ref reff="AuditLogAppender" />
</logger>

The security audit logging information is now sent to a log file and the core.AuditLog database
table.

4. If you want to send the security audit logging information to only the log file, comment or delete
the AuditLogDatabaseAppender appender and remove the reference of the database appender
from the logger.
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Configuration Settings
A set of configuration files is available for CDM to configure some advanced features.

Server Configuration
Database administrators can adjust the configuration settings on the server to set up advanced features
in CDM.

The default location for the configuration files is C:\inetpub\wwwroot\CertentCDM-
Server\Config. Using Windows Explorer, navigate to that folder (or where the CDM server has been
installed) and open the appropriate .config file to perform the configuration.

l AppSettings.config - Advanced application settings.

l CDM.config - Application specific settings.

l Credentials.config - Credentials used for impersonation when contacting an external system
which may need Windows™ credentials.

l Connection Strings.config - Connection strings for the application and cache databases.

l Logging.config - Server logging settings.

l Notifications.config - Settings for notification templates.

Important:
l Do not edit any server configuration files other than those in this list.

l Make a backup of the configuration files before making a change.

l The names of the .config files must remain the same.

Application Settings
The following tables list the configuration settings available in CDM.config, along with a description and
possible values that you may assign. Never edit settings that are not included in the tables.

Table 1: Batch Processing Configuration Settings

Setting Description Value

objectLockingParallel
ThreadsNo="8"

Specifies the maximum number of threads to be
used at lock report time, when locking multiple
report objects at once by using parallel execution.

n

generationBatchRefresh
Enabled="true"

Enables or disables batch refresh when
generating a report.

true/false

generationBatchRefresh
ParallelThreadsNo="8"

Specifies the maximum number of threads to be
used at report generation time, when refreshing
multiple report objects at once by using parallel
execution.

n

https://insightsoftware.com/


160

Setting Description Value
generationBatchRefresh
Size="10"

Specifies the number of objects to be refreshed at
once (in a batch) at Report Generation time.

nn

generationBatchRefresh
WaitTimeout="00:02:00"

Specifies the maximum timeout to wait for a
refresh response already initiated in the batch
refresh of objects.

HH:MM:SS

Table 2: Import and Data Cleanup Configuration Settings

Setting Description Value

<AllowRememberCredentials
enabled="true" />

Enables or disables the
Remember me checkbox on
the client.

true/false

<CacheZoneReference
cacheZone="ImportCache" />

Specifies the reference to the
cache zone. This cache is
used when importing users
and groups from the active
directory.

The name of the
cache zone to be
used

<SessionDataCleanupTime
timeToKeepData="30.00:00:00"/>

The data retention time set to
keep the user sessions in the
database. The default value is
30 days.

DD:HH:MM:SS

<LrpDataCleanupTime
timeToKeepData="3.00:00:00" />

The data retention time to
keep the results of the
processes. The default value
is 3 days.

D:HH:MM:SS

Table 3. Data Source Configuration Settings

Setting Description Value

<DataSources
queryMetadataLoadTimeout>

Handles the relational query metadata load
during query creation or editing.

n

<DataSources
skipLoadMetadata>

Bypasses the metadata load action leaving the
query builder empty, allowing advanced users
(that do not use the query builder UI) to improve
query creation/editing performance.

<DataSources
queryPreviewMaxCells="20000
0">

The number of cells can be controlled in the
query window.

n

<Whitelist>
<add name="unique_name"
serverName="server_name or
IP_address"/>
</Whitelist>
</DataSources>

For each data source, you must add an add line
to the DataSources\Whitelist element.

The name property identifies the configuration
and must be unique in the whitelist element.

The serverName property contains the fully
qualified server host name or IP address. You
can use the following wildcards:

Name

Server name
or IP address
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Setting Description Value

l * which represents any sequence of zero
or more characters.

l ? which represents any single character.

Examples:

<add name="Fixed IP"
serverName="192.168.1.100" />

<add name="Whole subnet"
serverName="192.168.1.*" />

<add name="First 10 IPs"
serverName="192.168.1.10?" />

<add name="Fixed hostname in
domain"
serverName="dataSourcesServer.mydom
ain.com" />

<TM1Configuration
RestApiVersion="v1" />

The version of the TM1 REST API you want to
use.

v1, v2, v3,
and so on
(refer to the
TM1 REST
API
documentati
on)

<BIConfiguration
RestApiVersion="v1" />

The version of the Cognos BI REST API you
want to use.

v1, v2, v3,
and so on
(refer to the
Cognos BI
REST API
documentati
on)

<DataSourceConnector
UseSecureConnection="false"
ServerCertificateName="CertN
ame"/>

Specifies parameters for the Data Source
Connector.

The UseSecureConnection attribute denotes
whether the connection between the CDM
server and the Data Source Connector should
be secured. Set it to true for a secure connection
(in this case you also have to provide a valid
certificate name).

The ServerCertificateName attribute
specifies the name of the certificate used to
secure the connection between the CDM server
and the Data Source Connector. The certificate
should be imported in IIS (the certificate that is

true/false

String value
certificate
name

https://insightsoftware.com/


162

Setting Description Value

already configured for the CDM Server
WebService is normally used).

Table 4: Session Configuration Settings

Setting Description Value

SessionExpiration="true" The expiration of a session. If set to
false, the session never expires.

true/false

timeoutAfterLogOn="24:00:00"

The timeAfterLogOn attribute
specifies the amount of time after the
creation of a session that the session will
expire.

HH:MM:SS

acceptedIdleTime="02:00:00" This option dictates when CDM will time
out the session, based on inactivity.

HH:MM:SS

<CdmAccountLockoutPolice
accountLockoutThreshold="0"
accountLockoutDuration="0"
/>

The accountLockoutThreshold
property identifies the allowed number of
initial failed attempts to log in by the user
before the duration property takes effect.
The value must be any number greater
than 0.

The accountLockoutDuration
property identifies the time in minutes the
user's account is locked after the
threshold has been met. When the
duration has passed, the user can
attempt another log in. If it fails, the
duration takes effect again and for each
subsequent single log in failure
thereafter. The value must be any
number greater than 0. A negative
integer locks the user's account
immediately when the threshold is
reached and requires an administrator to
unlock it.

n

<UserDisplayFormat
name="DisplayName" />

This option is used to set how user
information is displayed. The default is
DisplayName which is the display name
entered when the user was created. You
can add either UserName to display the
user's login name, or
ImportSourceName to display the
source that the user was imported from if
their user information was imported, or
both. If no parameters exist in the
UserDisplayFormat key,
DisplayName is used as the default.

DisplayName/
UserName/
ImportSourceName

https://insightsoftware.com/


163

Table 5: Cache Storage and Refresh Configuration Settings

Setting Description Value

<CacheZoneReference
cacheZone="RefreshCache"/>

Specifies the cache zone to be used by
the refresh cache.

Name of
the cache
zone
listed in
the
CDM.con
fig file

<DataSourceMonitor
recoverWaitInterval="00:05:00"/>

The recoverWaitInterval attribute
specifies the time interval to wait for a
data source (identified as currently
unavailable) to recover from its failure.

HH:MM:S
S

<PendingRefresh enabled="true"
pendingRefreshVerifyInterval="00:00:
01"
maxWaitTime="00:01:00"/>

The enabled attribute specifies if
Pending Refresh is used. This option is
used when a refresh is performed on an
object that is currently being refreshed;
the Pending Refresh feature waits until
the first refresh is completed, then will
get the refreshed value from the cache
without doing a new refresh. This
feature only works in the same process
space.

The
pendingRefreshVerifyInterval
attribute specifies the time to wait for a
pending refresh item to be checked
regarding its refresh completion. This is
used when multiple refresh requests on
the same resources, objects, and
queries are executed at the same time.
In this case only one refresh is made
and the other requests are waiting for
the refresh to be completed.

The maxWaitTime attribute specifies
the maximum time to wait for the first
refresh to finish.

true/false

HH:MM:S
S

HH:MM:S
S

<ExcelRefresh
queryResultMaxRows="1000"
truncateOnQueryResultMaxRowsExceeded
="True"/>

The queryResultMaxRows attribute
specifies the maximum number of rows
to return after executing a query when
the
truncateOnQueryResultMaxRowsE
xceeded attribute is set to True.

Note: This setting applies to
all these data query types

n

true/false
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Setting Description Value

when inserted into an Excel
object: OLAP and relational
databases, and external
Microsoft™ Excel files.

<ExpirationPolicies
minimumAcceptedSlidingTime="00:10:0
0" />

Specifies the minimum accepted sliding
time for time expiration policies.

HH:MM:S
S

Table 6: Backing Stores Configuration Settings

Setting Description Value

add name="RefreshMemoryStore"

The name attribute specifies the
name of the backing store, and is a
reference in the Cache Zone
settings.

String

storageProvider="Ibm.CognosDM.
Cache.Storage.Providers.
InMemoryNoZonesCacheStorage,
Ibm.CognosDM.Cache"

The storageProvider attribute
defines the actual implementation of
the ICacheStorage.

String

monitorPerfomanceCounters="false"
memoryLimitMegabytes="500"
persistentCacheSyncInterval="00:10:0
0"

The
monitorPerformanceCounters
attribute specifies the storage that
should update the Generic Cache
Layer counters. As a dual
implementation is used, only one
storage should make these updates
and usually the persistent storage is
used.

true/false

n

HH:MM:SS

priorityScavengingInterval="00:10:00"
priorityScavengingMegabytes="50"

The
priorityScavengingInterval
and
priorityScavengingMegabytes
attributes specify the interval to test if
the memory limit exceeded and the
size that the in-memory storage will
be reduced.

HH:MM:SS

n

add name="ImportMemoryStore"

The name attribute specifies the
name of the backing store, and is a
reference in the Cache Zone
settings.

String

storageProvider="Ibm.CognosDM.
Cache.Storage.Providers.
InMemoryNoZonesCacheStorage,
Ibm.CognosDM.Cache"

The storageProvider attribute
defines the actual implementation of
the ICacheStorage.

String

monitorPerfomanceCounters="false" The true/false
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Setting Description Value

memoryLimitMegabytes="200"
persistentCacheSyncInterval="00:10:0
0"

monitorPerformanceCounters
attribute specifies the storage that
should update the Generic Cache
Layer counters. As a dual
implementation is used, only one
storage should make these updates
and usually the persistent storage is
used.

n

HH:MM:SS

priorityScavengingInterval="00:30:00"
priorityScavengingMegabytes="20"

The
priorityScavengingInterval
and
priorityScavengingMegabytes
attributes specify the interval to test if
the memory limit exceeded and the
size that the in-memory storage will
be reduced.

HH:MM:SS

n

<persistent>
<add name="PersistentStore"
storageProvider="Ibm.CognosDM.
Cache.Storage.Providers.
PersistentCacheStorage,
Ibm.CognosDM.Cache"
connectionStringName="CDMCache"
pageSize="100" />
</persistent>

The persistent storage uses a
connectionStringName attribute
and pageSize attribute to define the
location and the page size used for
the proactive-loading at application
startup.

String

true/false

n

Table 7: Report Generation and Report Export and Import Configuration Settings

Setting Description Value

<ReportGeneration imageDpi="200"
reduceStyles="false"
htmlOutputFixedWidthInches="8.5">
</ReportGeneration>

The imageDpi attribute is used to
specify the DPI ratio used to render the
##IRS-##IRE ranges as images in a
Word object.

The reduceStyles attribute describes
how a table or list style is applied when
defined and used in multiple Word
objects included in a report generation.
When set to true, the first occurrence of
the style is the one used for all styles of
the same name. When set to false, all
styles are copied each time in the
generated output. False is the default
setting.

The htmlOutputFixedWidthInches
attribute is used to set a fixed width for
HTML output content in a browser for
EDGAR and Inline XBRL outputs. If this

n

true/false

n
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Setting Description Value

attribute is not present the default width is
8.5 inches.

<Export path="Filepath"/>

The path attribute sets the path where
the temporary export files are stored. The
value of this attribute is mandatory but
there is no default value. The
administrator needs to provide a path to
an existing folder where the Application
Pool Identity has write access.

Path and file
name

<Import path="Filepath"/>

The path attribute sets the path where
the temporary import files are stored. The
value of this attribute is optional. The
administrator can provide a path to an
existing folder where the Application Pool
Identity has write access.

If the Import element is not supplied the
temporary folder of Application Pool
Identity is used to store the temporary
import files.

Path and file
name

Table 8: High Definition HTML Generation Configuration Settings

Setting Description Value

<Fonts> ... </Fonts>

Specifies the font names to include in HD
generation. You can add a font using the <add
name=""/> tag, for example <add
name="Arial"/>. All the fonts inside this list
are considered supported by CDM. This means
that if any of these fonts is used inside CDM
objects, in the resulting HD generation the fonts
are referenced by name (when the HTML is
viewed in a browser, the browser will use that
reference in combination with the font present
on the machine to render the output). If a CDM
object contains a font that is not mentioned in
the list, the generation will:

l Embed the font inside the HTML when
the Embed font checkbox is selected for
the following generation types: High
Definition HTML, High Definition ESMA
ESEF xHTML, and Inline XBRL High
Definition (ESMA and ISA jurisdictions).
An embedded font is included (as a
base64 string) inside the HTML file,
allowing browsers to correctly render it
on machines that do not have that font
installed.

String
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Setting Description Value

l Not embed the font when the Embed font
checkbox is not selected for High
Definition HTML generations, and return
a warning
(UnsupportedFontDetectedWarning).

l Fail and return an error message
(UnsupportedFontDetectedError),
informing the user regarding the
unsupported font, for the following
generation types:

o EDGAR HTML and Inline XBRL
High Definition (SEC jurisdiction)

o High Definition ESMA ESEF xHTML
and Inline XBRL High Definition
(ESMA and ISA jurisdictions), when
the Embed font checkbox is not
selected.

<CreateHtmlTables
value="false"/>

Enables or disables rendering HD tables using
HTML table tags. This setting applies only to
Inline XBRL High Definition generations, for
ESMA and ISA jurisdictions.

true/false

<FixStyleForSecInlineViewer
value="false"/>

Enables or disables fix styles for rendering in
Edgar Renderer. Should be true for Arelle
versions earlier than 2023.

true/false

<InlineCSS value="false"/>

Enables or disables generating CSS styles
inline so auditors can review text blocks in
external tools for ESEF. When set to true, it
increases the inline instance file size.

true/false

<PixelsThreshold
value="1"/>

Controls the tolerance when deciding to create
inline blocks to fill up space between words.

n

<Precision value="2"/>

The number of decimals to place on
coordinates and widths. This setting has a
direct impact on file size and number of unique
styles.

n

Table 9: Desktop Publishing Generation Utility Configuration Settings

Setting Description Value
<EnableDesktopPublishing
AutomaticWordGeneration
value="true">

The EnableDesktopPublishing attribute is
used to grant access to the Desktop Publishing
Utility.

true/false

Table 10: Enforcement of Microsoft Office Version Configuration Settings
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Setting Description Value

<ForceToOfficeVersion
enabled="true"
Value="" />

Enter a specific Office version then all objects
saved by client systems are saved in this level of
Microsoft Office.

If the field remains empty, there is no enforcement
of an Office version. The report is generated based
on the version of Office in which each object was
last saved.

For more information, see Multiple Versions of
Microsoft Office.

A supported
version of Microsoft
Office, for example,
2013 or 2016

Table 11: Enable or Disable Simultaneous Query Requests

Setting Description Value

<ParallelRefresh
enabled="true">
</ParallelRefresh>

Used to enable and disable the running of
simultaneous query requests to a data source
when there are multiple data queries in an object.
If an object only has one data query within it then
this feature is not used.

true/false

Table 12: Enable or Disable Using Advanced Refresh

Setting Description Value
<BackgroundTaskServi
enabled="true">
</BackgroundTaskService>

Used to enable the use of Advanced Refresh in
the report properties.

true/false

Table 13: Feature Flags

Setting Description Value

<add
name="InlineHiddenBookmarks"
enabled="true" />

Used to include or exclude hidden
bookmarks when generating inline XBRL.
When set to false, the hidden bookmarks
will be ignored at reordering.

true/false

<add
name="ESMAParagraphTagging"
value="false" />

Used to display the Paragraph Tagging
command in the Home tab ribbon of CDM
XBRL Project. When set to true, you can
toggle on paragraph tagging to apply a
text block concept to one or more
paragraphs when you select a portion of
the paragraphs.

true/false

Advanced Application Settings
The following table lists the configuration settings available in AppSettings.config, along with a
description and possible values that you may assign. Never edit settings that are not included in this
table.
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Setting Description Value
<add key="PerformanceMonitor"
value="True"/>

Enables the performance monitoring
and logging of the server.

true/false

<add key="EncryptionKeyFile"
value="Filepath"/>

Specifies the file that contains the
master encryption key.

Path and file
name

Credential Settings
The following table lists the configuration settings available in Credentials.config, along with a
description and possible values that you may assign. Never edit settings that are not included in this
table.

Setting Description Value

<DataSourcesCredentials
enabled="true"
userName="accountUserName"
password="theUsePassword" />

When connecting to a data
source using Windows
authentication, a special Data
Sources User is
impersonated. The user name
and password for this user are
configurable.

true/false

The user name of
the Windows
account

The password for
the account

<ActiveDirectoryImportCredentials
enabled="true"
userName="accountUserName"
password="theUsePassword" />

The credentials to be used for
accessing Active Directory
import sources.

true/false

The user name of
the Windows
account

The password for
the account

<EmailCredentials enabled="true"
userName="accountUserName" password=
"theUsePassword" />

The credentials to be used for
accessing a SMTP server,
when email settings are
configured with Use Default
Credentials set to true.

true/false

The user name of
the Windows
account

The password for
the account

Client Configuration
Configuration settings on the CDM client machine can be adjusted by a database administrator to set up
advanced features in CDM. Never edit other configuration files or other settings in these files.

l IBM.CognosDM.exe.config - Main configuration settings.

l AppSettings.config - Advanced application settings (for server settings, see Advanced
Application Settings).

l Logging.config - Server logging settings.
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Important:
l Do not edit any server configuration files other than those in this list.

l Make a backup of the configuration file before making a change.

l The names of the .config files must remain the same.

Main Configuration Settings
The following table lists the configuration settings available in Ibm.CognosDM.exe.config, along with a
description and possible values that you may assign. Never edit settings that are not included in this
table.

Setting Description Value

<OfficeAddins
enabled="true">

Specifies the Microsoft™ Office add-ins that are
loaded in the client by default. The entire setting
can be enabled or disabled.

true/false

<OfficeCommandbars
enabled="true">

Used to ensure that a certain CommandBar
provided by an add-in is successfully loaded in
the Microsoft Office editor provided by the client.
The entire setting can be enabled or disabled.

true/false

Advanced Application Settings
The following table lists the configuration settings available in AppSettings.config, along with a
description and possible values that you may assign. Never edit settings that are not included in this
table.

Setting Description Value
<add key="PerformanceMonitor"
value="True"/>

Enables the performance monitoring
and logging of the client.

true/false

<add key="CDMClientRebranding"
value="False"/>

Enables the color schema and design
that align with the insightsoftware
branding for the File menu of the client.

true/false

Logging Configuration
The Logging.config file contains settings related to logging and tracing, on both the CDM client and
server.

To open the location for the client application:

1. Start CDM.

2. Open Windows Task Manager.

3. In the Processes tab, right-click the Ibm.CognosDM.exe *32 process and click Open File
Location.
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Make sure you read the following important notes:

l Make a backup of the configuration file before making a change.

l The XML-based settings must not contain xml validation errors, otherwise the logging will stop.

l Changes to the logging levels in the Logging.config file can have an effect on performance.

l The name Logging.config must not change.

l For the server, the log files generated by CDM are Application.log, Performance.log, and
Refresh.log.

l For the client, the log files are AllErrors.log, Application.log, and Trace.log.

File Structure
The Logging.config file that controls the output to the generated log files has the following structure (the
logging module is based on the log4net logging framework):

<root>
<level value="INFO" />
<appender-ref ref="AllErrorsLog" />
</root>
<logger name="Ibm.CognosDM">
<level value="ALL" />
<appender-ref ref="ApplicationLog" />
</logger>
<!--appender-->
<appender name="AllErrorsLog" type="log4net.Appender.RollingFileAppender">
<appender name="ApplicationLog" type="log4net.Appender.RollingFileAppender">

An appender is an output destination for a log file. In the example structure two appenders are shown:
one that logs only the errors in the application, another that logs everything. Appenders should only be
defined, created or changed when necessary.

The root node defines a reference to one appender. The logger node contains a reference to the second
appender. You can group multiple appenders together, and specify a logging level for the group. The
logging level filters the logging output. The logging module is based on the log4net logging framework.

Available Settings
The following table lists the configuration settings available in Logging.config, along with a description
and possible values that you may assign. Never edit settings that are not included in this table.

Key Description
Value for the

Client
Value for the

Server

<level value="INFO" /> The logging level for
the appenders group.

ALL, OFF, INFO,
WARNING,
ERROR, DEBUG

INFO,
WARNING,
ERROR,
DEBUG

<file The location of the log Path and file Path and file
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Key Description
Value for the

Client
Value for the

Server
value="LogFiles\AllErrors"/> file. name name

<datePattern
value=".yyMMdd.'log'"/> The date format.

yyMMdd,
ddMMyy,
MMddyy

yyMMdd,
ddMMyy,
MMddyy

<appendToFile value="true" />
Enables and disables
the output of the
appender.

true/false true/false

<levelMin value="INFO" /> The minimum logging
level for the appender.

ALL, OFF, INFO,
WARNING,
ERROR, DEBUG

INFO,
WARNING,
ERROR,
DEBUG

<levelMax value="OFF" /> The maximum logging
level for the appender.

ALL, OFF, INFO,
WARNING,
ERROR, DEBUG

INFO,
WARNING,
ERROR,
>DEBUG

Note: If both levelMin and levelMax are set to OFF, the appender is disabled and no
output will be present in the log file.

XBRL Whitelist Configuration
The web.config file contains settings to configure the XBRL whitelist. For how to access the file, see
Server Configuration.

The <CDMXBRL> section of the web.config file contains elements that specify which Internet domains
can be accessed when you add taxonomies from a URL. The <CDMXBRL> section is prepopulated with
standard Internet domains that are required. You can add Internet domains to this list.

By default this whitelist contains these Internet domains:

l fasb.org and its subdomains

l xbrl.us

l xbrl.org

l sec.gov

l ifrs.org

l eurofiling.info

l eiopa.europa.eu

To add a domain, in the <WhiteList> section, add an element of the form <Entry Name="domain_
name" Domain="domain_url"/>, where domain_name is a unique descriptor for the domain and
domain_url is the web address of the domain.
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If you want to include subdomains, add a prefix of *. to the domain URL. For example, a domain URL of
xbrl.org allows URLs such as xbrl.org/children.xml, while a domain URL of *.xbrl.org
allows URLs such as children.xbrl.org. Note that you must have entries with both xbrl.org and
*.xbrl.org to allow both a domain and its subdomains.
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Accessibility Features
CDM has accessibility features that help users who have a physical disability to use the product.

Keyboard Shortcuts
CDM includes keyboard shortcuts to help you navigate the product and perform tasks.

The following keyboard shortcuts are based on US standard keyboards.

Applies To Action Shortcut Keys

General Perform the command for an active command button. ENTER

General
Move forward to the next item in the tab index order.
Cycle to the first tab index when at the end.

TAB

General
Move backward to the previous item in the tab index
order. Cycle to the last tab index when at the
beginning.

SHIFT+TAB

Checkboxes Select or clear the checkbox. SPACEBAR

Menus Navigate down a menu and select a menu item. Down arrow and then Enter

Menus Navigate up a menu and select a menu item. Up arrow and then Enter

Scrolling Scroll down. Down arrow

Scrolling Scroll up. Up arrow

Zooming Zooming in.
CTRL and +; CTRL+MOUSE
wheel up

Zooming Zooming out.
CTRL and -; CTRL+MOUSE
wheel down

Zooming Return to default zoom level. CTRL+0

Navigation Reload the current page. F5

Navigation Move backward to the previously opened page. ALT+Left Arrow; BACKSPACE

Navigation Move forward to the previously opened page.
ALT+Right Arrow;
SHIFT+BACKSPACE

Navigation Stop a page from loading. ESCAPE

Search
Open a search box to perform a search on the current
page.

CTRL+F; F3

Search
Find the next match of the searched text on the
current page.

CTRL+G; F3

Search
Find the previous match of the searched text on the
page.

CTRL+SHIFT+G; SHIFT+F3
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Multiple Versions of Microsoft Office
Your reports in CDM can contain Excel, Word, and PowerPoint objects. Some aspects of your reports
and report objects depend on the version of Microsoft™ Office that was used to create the report object,
and the version of Microsoft Office that you use to open the report.

Important: Macros applied to report objects are not preserved when you save the report
object.

If all report objects in your report are created with the same version of Microsoft Office, and all users of
your report use the same version of Microsoft Office, you do not need to read the rest of the topics in this
section.

However, if any report objects in your report are created with different versions of Microsoft Office, or
some users use a different version of Microsoft Office, read the following sections for useful tips on how
to work with your report and report objects.

Effects of Using Multiple Versions of Microsoft
Office
When you use multiple versions of Microsoft™ Office, some aspects of your reports in CDM depend on
the version that was used to create various report objects. The version of Microsoft Office that you use
can affect actions such as opening reports and report objects, pasting and exporting report objects, and
generating reports.

Open Reports and Report Objects
Consult the following table to learn about how different Microsoft Office versions affect opening reports
and report objects.

Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

You can open and save reports and report objects. When you save
report objects, you automatically save them in the format of the version
of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can open and save reports and report objects normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office.

You view the later report object in the format of the version of Microsoft
Office that you use, and you might not see features or formatting
specific to the later version. However, no changes are made in the
database.

If a report object is saved in Microsoft Office 2007 and then you open it
in a later version of Microsoft Office and then save, the report object is
saved in Microsoft Office 2007 format, even though you are working in a
later version.

To view a report object in its original format, you must upgrade to the
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Situation Effect

version of Microsoft Office that was used to create the report object.

Copy and Paste Report Objects
Consult the following table to learn about how different Microsoft Office versions affect copying and
pasting report objects.

Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

You can copy and paste a report object by right-clicking the report
object and then using the Copy and Paste options. When you save a
pasted report object, you automatically save it in the format of the
version of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can copy and paste a report object normally by right-clicking the
report object and then using the Copy and Paste options.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can copy and paste a report object by right-clicking the report
object and then using the Copy and Paste options. All later report
objects are saved in the format of the version of Microsoft Office that
you use, and you might lose features or formatting specific to the later
version. The original report object remains in its original format.

To view and save a pasted report object in its original format, you must
upgrade to the version of Microsoft Office that was used to create the
report object.

Work with Shared Objects
Consult the following table to learn about how different Microsoft Office versions affect shared objects.

Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

You can work with shared objects. All copied report objects are saved in
the format of the version of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can work with shared objects normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office

Report objects are opened in the format of the version of Microsoft
Office that you use. When you save the report object, you receive a
message in which you must specify whether you want to save in the
format of the version of Microsoft Office that you use.

l Reference - The content cannot be modified. A linked object
actually has no content, so when an object is opened, the
content is retrieved from the original source object. This content
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Situation Effect

opens in the version of Microsoft Office that is on your computer,
and you might lose features or formatting specific to the later
version.

l Copy - The content can be modified because a copy is treated
like any other report object that has content. All later shared
report objects are saved in the version of Microsoft Office that
you use, and you might lose features or formatting specific to the
later version.

To view a shared object in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.

Export Report Objects
Consult the following table to learn about how different Microsoft Office versions affect report object
exports.

Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

You can export report objects. All earlier report objects are saved in the
format of the version of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can export report objects normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can export report objects. All later report objects are saved in the
format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version.

To export a report object in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.

View and Compare Audit Trails or Snapshots
Consult the following table to learn about how different Microsoft Office versions affect audit trails and
snapshots.

Note: If you work in Microsoft Office 2007, you can work with only one instance of a
PowerPoint object at a time. When you view audit trails for PowerPoint objects, the audit trail
content does not load because of this limitation. You will receive a message in which you can
save the logs separately. If you work in a later version of Microsoft Office, this restriction does
not apply.
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Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office, or if the snapshots
were created in an earlier
version of Microsoft Office

You can view and compare audit trails or snapshots. When you select
an audit trail entry or snapshot, you view it in the format of the version of
Microsoft Office that you use. The changes are not saved to the
database.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use, or if the
snapshots were created only
in the version of Microsoft
Office that you use

You can view and compare audit trails or snapshots normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office, or if at least one of the
snapshots was created in a
later version of Microsoft
Office

You can view and compare audit trails or snapshots. When you select
an audit trail entry or a snapshot, you view it in the format of the version
of Microsoft Office that you use, and you might not see features or
formatting specific to the later version. The changes are not saved to
the database.

To view an audit trail entry or snapshot in its original format, you must
upgrade to the version of Microsoft Office that was used to create the
report objects in the audit trail or the snapshot.

Generate Reports
Consult the following table to learn about how different Microsoft Office versions affect report
generation.

Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

You can generate the report. All earlier report objects are saved in the
format of the version of Microsoft Office that you use. The report is
generated as a .docx file.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can generate the report normally. The report is generated as a
.docx file.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can generate the report. All later report objects are saved in the
format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version. The report is
generated as a .docx file.

To generate the report in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.

Perform Report Rollovers
Consult the following table to learn about how different Microsoft Office versions affect report rollovers.
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Situation Effect

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

You can perform a report rollover. All later report objects are saved in
the format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can perform a report rollover normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can perform a report rollover. All later report objects are saved in
the format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version.

To roll over the report in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.

Enforcement of a Microsoft Office Version
The administrator can set a configuration file to force Word, Excel, and PowerPoint objects to be saved
at a particular version level of Microsoft™ Office. This enforcement of the Microsoft Office version is a
setting for all client systems of CDM.

More than one version of Microsoft Office can be in use by client systems. An object can be saved as a
specific Microsoft Office version and subsequently saved in compatibility mode under a different
Microsoft Office version by a different user. The save under compatibility mode removes all specific
features and formats of Office 2010. This cycle of upgrade and downgrade between different version
levels can cause usability problems.

To stop this cycle of downgrade and upgrade, the administrator can configure the
<ForceToOfficeVersion enabled="true" Value="" /> application setting in the CDM.config
file on the server to enforce a particular version Microsoft Office. Setting the version to a specific version
of Microsoft Office ensures that when a new object is saved, it is saved in the version level that is
configured.
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