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Introduction to CDM User Guide

The CDM User Guide describes how to use CDM to work with reports and report objects.

CDM is a unified financial governance solution that focuses on improving financial processes and
controls, particularly in the final stages before disclosure. It helps the finance department improve the
timeliness and quality of financial management processes and reporting. CDM also facilitates audits,
extends enterprise resource planning (ERP) transactional controls, and improves financial risk
management.

To find additional information, contact Certent CDM Support.

Audience

The CDM User Guide is intended for individuals working in the Office of Finance, who need to work with
reports, report objects, variables, and desktop publishing tags in CDM. Users who have been granted
various permissions can perform the tasks in this guide.
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Overview of CDM

CDM is a corporate reporting solution that combines numeric data with other presentation elements.
Text and graphics can be used to supplement data in a report.

Many organizations manually produce their external financial reporting documents, for example, 10K,
10Q, and Board Books. With CDM, statutory financial reports are dynamically generated from a central
database to produce highly formatted reports complete with appropriate commentary and
supplementary notes.

CDM provides a collaborative environment that incorporates workflow and audit trails to ensure a high
degree of data accuracy and to provide better internal controls for corporate governance.

Functionality of CDM

The CDM interface is used to produce and output financial reports.
CDM contains the following functionality and capabilities:

« Performance
The document rendering mechanism is fast because rendered output is put into a cache that then
is shared by all users working on the same part of the report.

« Collaboration
Users can check out multiple report objects simultaneously.

« Workflow
Users can easily see the status of each part of a financial document and determine which parts
are overdue and who is responsible. Workflow includes automatic email notification to quickly
contact the persons responsible for items that are overdue.

« Internal Control
CDM provides a comprehensive set of internal controls to ensure that the proper steps are
followed in the creation, submission, and approval of each document.

o Audit Trail
Users can easily compare any two versions of the document to see what was changed, who
changed it, and when it was changed. Audit trails are divided into the following sections:

o Login Audit - Records every authentication request to the CDM database via the web
service.

o Report Properties - Records any changes that have occurred in a report.
o Report Object Properties - Records any changes that have occurred in an object.

« Data Sourcing
This feature provides an easy-to-use method to pull data from various data sources including the
leading ERP systems, the leading consolidation systems, relational databases, OLAP
databases, and Microsoft™ Excel.

« Ease of Use
If users already know how to use Microsoft Excel, Microsoft Word, and Microsoft PowerPoint,
using CDM is intuitive and easy. It provides a user interface that leverages all the calculation
abilities of Excel, the formatting capabilities of Word, and the presentation abilities of PowerPoint.
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« Data Collection for Operational Data
CDM provides functionality so that the user can write back to Cognos® TM1® for data collection.
External financial documents often include data that might not exist in your ERP or consolidation
system.

« User Security
CDM provides controlled access to sensitive information and helps to maintain privacy.

« Business Rules and Validation
In some organizations, data might come from various sources. CDM business rules ensure that
summary data in one area of the document always ties to detailed data that exists elsewhere in
the document.

« PowerPoint Integration
Users can create PowerPoint objects to output presentations using existing data in the report.

« Report and Object Level Commentary
Gives users insight on the creation process for reports and report objects.

« Dashboards
Users can present financial information in the form of charts, graphs, and grids by creating
widgets in the dashboard.

« Integration with IBM® and IBM Cognhos® Products

« Ability to support Single Sign-On

Typical Report Examples

You can use CDM to create various financial reports for internal or external publication for any
organization.

Corporate and regulatory reports often contain repetitive sections that are time-consuming to reproduce
and manage with consistency. CDM enables such reports to be used as templates, which can simplify
and accelerate the process of submitting reports.

Statutory Reporting

In many countries or regions, federal securities laws require publicly traded companies to disclose
information on an ongoing basis. You can use CDM to prepare statutory reports.

US Regulatory Reporting: 10-K, 10-Q, and 20-F

Regulatory bodies such as the Securities and Exchange Commission (SEC) require businesses to
submit annual reports on Form 10-K, and quarterly reports on Form 10-Q for specified events.
Businesses must comply with various other disclosure requirements. Foreign issuers must use Form
20-F to meet disclosure requirements.

The annual report on Form 10-K provides a comprehensive overview of the company's business and
financial condition and includes audited financial statements. The annual report on Form 10-K is distinct
from the annual report to shareholders.
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Form 10-Q includes unaudited financial statements and provides a continuing view of the company's
financial position during the year. The report must be filed for each of the first three quarters of the
company's fiscal year.

Form 20-F is a comprehensive core disclosure document that foreign private issuers must file annually
with the SEC to register securities when they are offered in the US.

Exhibits specifically refer to attachments that the SEC officially defines in its rules and regulations. The
SEC might require one or more exhibits to be included with a 10-K or 10-Q filing.

Canadian Regulatory Reporting: Annual Reports and MD&A

In Canada, public and privately owned corporations are required to produce annual reports and to
disclose important events that affect the business in Management Discussion and Analysis (MD&A)
reports. You can also use CDM for various other required reports.

UK Regulatory Reporting: Annual Reports and Form 363

The EU Transparency Directive is designed to bring all European stock exchanges up to the same level,
with a uniform set of rules for Listing and Disclosure that apply across the European Union. There are
more stringent requirements for interim and annual reports.

In the UK, the Companies House and Financial Services Authority (FSA) requires businesses to submit
various reports and forms on a timely basis. For example, the Companies House requires an Annual
Return (Form 363) to update company contact information, including contact information for corporate
executives, and to provide a statement of principal business activities.

Corporate and Industry Reporting

You can use CDM to create standard corporate reports, such as quarterly and annual reports. You can
also create industry-specific reports, such as airline industry reports.

Quarterly Reports, Annual Reports, and Board Books

In general, corporations in different countries and regions are required to produce quarterly and annual
reports, displaying financial results for the period. CDM enables consistent report formatting and
presentation of data.

You can also use CDM to create and manage content related to board meeting agenda packets, known
as board books.

Airline Industry: Form 41

The Form 41 provides valuable information for those who need to analyze and understand the US
airline industry and its member carriers. Form 41 reports on carrier costs, operations, profit and loss
statements, and balance sheets.

Internal Reporting

You can also use CDM to create reports used for internal control. You can also maintain existing
customized reports.

Any report that was built in Microsoft™ Excel, Microsoft Word, or any presentation built in Microsoft
PowerPoint can be created and maintained in CDM. Additional functionality, such as Workflow and
Audit Trail, can then be applied.
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Basic Concepts

Before you begin to use CDM, you should understand some basic concepts.

Important: Using CDM requires a working knowledge of Microsoft™ Excel, Microsoft Word,
and Microsoft PowerPoint. The advanced functionality for Microsoft products is beyond the
scope of this guide. However, some topics are included for your convenience. For more
information, see the Microsoft documentation.

The CDM Interface

The CDM interface is designed to make it easy for you to perform tasks related to your reports.

Depending on the task that you are completing, various ribbon and windows provide the information that
you need.

Views in the Interface

You can adapt the appearance of some areas of the CDM interface to meet your needs as you are
working.

Depending on the tasks that you are performing, you can click the following icons to change your view of
the interface to meet your needs. The icons are located in the status bar at the bottom right.

Icon ‘ Name | Description
Used as the default view in CDM.

Default View « The Navigation Pane and the CDM ribbon are visible.
Mode

* The Microsoft™ Office ribbon is not visible.

Used to hide the main ribbon on any screen. When a report object is open on
the screen, it also reveals the Microsoft ribbon for that report object (for

example, the Excel ribbon in an Excel object).
Section View

Mode » The CDM Navigation Pane and the Microsoft Office ribbon are visible.

« The CDM ribbon is not visible.

Used to maximize the CDM working space. It is particularly useful when you
are working in a complex report object.

& Full View Mode| « The Microsoft Office ribbon is visible.

« The Navigation Pane is collapsed and the CDM ribbon is not visible.

The Ribbon

The ribbon is a command bar in CDM that organizes commands into logical groupings to make working
with the application easier.
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The ribbon contains the following features that you can use when you are working in CDM.

Tabs

Tabs are the most obvious feature of the ribbon. A tab is a collection of the commands you can use
when working with the application. For example, when working with a report object, the tab contains
only commands that can be used with report objects. Another tab holds commands that are specific to
the data you can use in an Excel object.

Designed for easy browsing, the ribbon includes commands that perform a task, open a menu, or open
a window. The commands are collected together on tabs.

Figure 1. Ribbon for the Report Object Tab
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Groups

Each tab contains one or more groups of related commands. You can use these groups to browse the
ribbon more easily by viewing the relationship among commands on a particular tab.

Tab Scrolling

You can use the mouse scroll wheel to navigate from one tab to another when the mouse pointer is over
the ribbon.

Split Buttons

You can use a split button to either perform a default action or view a menu of commands.

Figure 2. Split Button from Ribbon

Click the icon to perform a default action or click the arrow and text label to display the menu. The
default action is the first item in the menu. Split buttons can be identified by the line beneath the graphic
icon and the text description of the button.

Switch Ribbons

You can view the main ribbon for CDM, or the Microsoft™ ribbon in a particular report object.

When you start to work in CDM, by default you see the CDM ribbon. However, when you open a report
object, such as an Excel object, you might want to work with an Excel ribbon, so that you can use
Microsoft Excel features in your Excel object.

« To switch from the CDM ribbon to a report object ribbon, click the Section View Mode icon.

« To switch from a report object ribbon to the CDM ribbon, click the Default View Mode icon.
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Navigation Pane

The Navigation Pane is an area of the interface in CDM that you can use to select the items that you
want to work with. It is a narrow area at the side of your computer screen.

The title and content of the Navigation Pane depends on the choices that you have made in the
interface. For example, if you are working with reports and report objects, the title of the Navigation
Pane is Report, and the content is a list of report objects in the selected report. If you are working on
administrative items, the title of the Navigation Pane is Administration, and the content is a list of
administrative tasks that you can perform.

Depending on what Navigation Pane is available, you can select and right-click an item to use context-
menu commands. For example, if the title of the Navigation Pane is Report, you can right-click the main
report and select Expand or Collapse to expand or collapse the entire object report tree. If you select
just a report object and select Expand or Collapse, only the child objects of the selected object are
shown or hidden. Also, if you type a term into the search field, only those report objects containing that
search term are displayed in the object report tree.

If you are working in CDM, and you want to view other items on your screen in more detail, you can hide
the Navigation Pane temporarily.

To hide the Navigation Pane, click the Full View Mode icon. The Navigation Pane becomes narrower
on the side of your screen, allowing more space for other items.

To view a hidden Navigation Pane, click the arrow in the Navigation Pane. You can now see the entire
Navigation Pane again.

Tabs

Tabs in CDM are designed to be task-oriented. They organize commands on the ribbon around the core
scenarios and tasks that you perform with the application.

The Data tab is displayed only when an Excel object is selected.

Important: Access to particular tabs, reports, and report objects depends on permissions
granted by the administrator.

File Tab

The File tab in CDM presents a backstage view of your active project elements. You can use the File tab
to manage the entire project environment.

These options are available:

« Recent
Displays a list of reports and report objects you have used recently. Click an item for a preview of
that report object, selected properties, and a button to open the item.

e Open
Displays the project, report, dashboard, and extension taxonomy groups that you have access to
view or edit.

» Administration
Displays groups of administrative commands.
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Gallery

Displays items that have been built as solutions that can be used with CDM. The items are fed
from a public online RSS feed. If an Internet connection exists, new updates are detected (new
items or new versions of existing items) and a message is shown at the bottom of the Gallery
pane indicating that a refresh is needed for latest updates. Click the link on the message to
refresh the Gallery pane. Select an item in the Gallery pane and a preview of the item is
displayed in the Preview pane. You can click Open to display a window with information about
the item and actions you can perform (for example, clicking on a URL to go to an external website
for more information).

Help
Displays links to several methods of user assistance.

Options
Click to open a window where you can configure specific settings for using CDM.

Log Out
Click to log the current user out of CDM and return to the login window.

Exit
Click to close CDM.

Home Tab

You can use the Home tab in CDM to access tools to use with project, report, dashboards, and report
administration tools.

Each command group contains a series of commands that you can use to perform tasks related to that
group, such as the Open command in the Dashboard group.

Home Tab for Reports

When a report is open, the Home tab contains commands for working with reports.

Table 1: Commands for Reports in the Home Tab

Command ’ Description

Paste Used to paste an item from the clipboard to the current report.

Cut, Copy, Delete

Used to remove the selected item from the current report. Cut and copied
items can be pasted in other locations in the current report.

Refresh Report

Used to refresh or reload the data in the report. Reference variables, Excel
data sources and reference objects are updated. Quick Refresh Report
reloads data from the local cache while Full Refresh Report fetches data from
external data sources.

Used to add a new or shared object to the report. When a report is opened by

Add filtering one or more custom groups, new report objects that are added are
automatically assigned to the custom group or groups.
Used to add an existing Word, Excel, PowerPoint, or PDF file to the report as
Import a report object. When a report is opened by filtering one or more custom

groups, report objects that are created from imported files are automatically
assigned to the custom group or groups.
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Validate Used to validate the data in the current object.

Generate Used to output the entire report or selected report objects.

Show Properties

Used to open the Properties and Comments window to view or modify report
object properties.

Manage Workflow

Used to display the report workflow.

Reference Variables

Used to view the object variables that are used in the report.

Progress Report

Used to view a detailed status of report objects in the report.

Used to view a detailed analysis of all changes that were submitted to the

Report Audit Trail CDM databases.

Orphan Variables Used to ylew variables that do not contain an accompanying source
declaration.

User Workflow Used to view workflow assignments for reports, blanks sections, and report

Assignment objects.

View Snapshots Used to view a snapshot of the report content.

Custom Groups Used to associate one or more report objects with a custom group.

Report Query .

Variables Used to manage report query variables.

Lock Report or Report |Used to prevent the content in a report from automatically updating when the

Object data is refreshed.

Manage Variable Used to manage variable security by restricting the use of a one or more report

Security variables.

Home Tab for Administration

The following commands are available in the Home tab when the Administration tools are active.

Table 2: Commands for Administration Objects in the Home Tab

Command | Description

Refresh Used to refresh the information in the Administration tab.

Save Used to save changes to the current item.

Add Used to create an instance of the selected item.

Edit Used to edit the selected item.

Delete Used to delete the selected item.

Import Used to import data such as reports, users, or desktop publishing styles into
CDM.

Export Used to export data such as reports from CDM.

View By U.sed to ar.range the Ffep.ort Permissions tab when assigning permissions by
different views: Permissions, Users and Groups, and Reports.

Rollforward Used to create a complete copy of a report.

Cascade Used to create a completg copy of a report, where shared objects are
converted to reference objects.

Change References Used to change the report where source objects are located.
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Command
Manage Workflow

Used to display and edit the report workflow.

Description

Workflow Template

Used to view, create, and edit templates for the workflow.

Default Template

Used to set the selected workflow template as the default to be applied to new
reports and, subsequently, new sections and report objects.

Change Password

Used to change the password of a selected user.

Force Checkin

Used to force a check-in of report objects that are checked out.

Report Object Tab

When you open a report in CDM and double-click a report object to open it, the Report Object tab
displays on the ribbon.

The Report Object tab contains a specific ribbon for Excel, Word, PowerPoint, PDF, and Web objects.
The commands that are available depend on the report object that is active.

Table 3: Commands in the Report Object Tab

Command ‘ Report Object Description
Type
Used to refresh or reload data in the report object. Reference
Refresh Excel variables, Excel data sources and reference objects are
updated. Quick Refresh reloads data from the local cache
while Full Refresh fetches data from external data sources.
Used to check out a selected report object for editing. When a
Check Out All report object is checked out it is locked and can be edited only
by the user who checked out the report object.
Used to check in a report object that is checked out, making the
Check In All . . .
report object available for other users to edit.
Save All Used to save changes made to the report object.
Generate Excel and Word [Used to generate the entire report or selected report object.
Show Properties  |All Useq to open thg Propert|e§ and Comments window to view or
modify report object properties.
Manage Report All Used to display and edit the report object workflow.

Object Workflow

Insert Variable

Excel, Word, and

Used to insert a reference variable in the report object.

PowerPoint
. Excel, Word, and . L .
Import Object PowerPoint Used to import a report object into the current report object.
Excel, Word,
Export Object PowerPoint, and [Used to export the report object.
PDF
Used to prevent content in the report object from automatically
Lock All updating when the data source, reference variable, or
reference object is updated.
Manage Used to add, modify, and delete attachments for the report
All A
Attachments object.
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Command ‘ REEOLE! Description
Type

Manage Checklist |All Used to attach an existing checklist to the report object.

Used to allow the user to push down one or more newly created

Pushdown All .

report objects from a master report to all cascaded reports.

Object Audit Trail |All Used to display the report object audit trail.

Used to validate selected objects for conversion to EDGAR

Validate All HTML. The selected objects are scanned for validation

warnings.

Preview Al Used to preview how the current object looks when converted

to EDGAR HTML.

Show Tags Al Usgd to V|.ew the list of de;ktop publishing tags that are

available in the report object.

Add Tag Excel Used to add a desktop publishing tag to the Excel object.

Delete All Tags Excel Us.ed to delete all desktop publishing tags from the Excel

object.

Hightlight Tags Excel Us.ed to view the desktop publishing tags that exist in the Excel

object.

Go to Previous Tag|Excel Useq to move from.a desktop publishing tag to the previous

one in the Excel object.

Go to Next Tag Excel Used to mov.e from a desktop publishing tag to the next one in

the Excel object.
Excel objects . Used to enable the use of Excel add-ins, for example, HFM

Add-Ins Mode when performing Smartview
XBRL tagging |

Used to toggle on tagging mode for the report object. Each time
you open a report, tagging mode is disabled for all the report
Excel and Word |objects by default.

Toggle Tagging objects when When tagging mode is not toggled on, you can only modify the
perfgrmmg XBRL |report object but will not be able to add tags; however, you can
tagging edit and delete existent tags in the report object from the Tag

Inspector. If you delete any tagged text in non-tagging mode,
CDM will update the bookmarks with correct information.

Data Tab

When you open an Excel object in a report in CDM, the Data tab becomes available on the ribbon.

Table 4: Commands for Administration Objects in the Home Tab

Command

Insert Data

Description

Used to insert previously defined queries into an Excel object.

Manage Data Queries

Used to view, edit, or delete all data queries inserted in an Excel object.

Report Object-Level
Variables

Used to override report-level query variables at the object level, so that you
can customize the value for a particular Excel object.

Manage HFM Servers

Used to associate HFM (Hyperion Financial Management) connections with
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Command | Description
the selected Excel object.

HFM Connection Used to connect to an HFM data source.

Add-Ins Mode Used to enable the use of Excel add-ins, for example, HFM Smartview.

Used to protect the data in an Excel cell from being modified, if that cell

Protect contains write-back data. This command is active only when a worksheet

contains data queries.

Unprotect

Used to allow the data in an Excel cell to be modified, if that cell contains write-
back data. This command is active when a worksheet contains data queries.

Status Bar

You can use the status bar in CDM to view information about the objects and activities.

The following information is available in the status bar:

User name
This field shows the current logged in user. Click this field to open the User Profile window where
you can review your user profile or change your login password.

Server
This field shows the name of the application server that CDM is connected to.

Report name and path

This field shows the name of the current report. Hover over this field to view the report path of the
current report. The report path indicates whether the current report was rolled forward or
cascaded from a previous report.

Active item
This field shows the name of the currently active item in the work area. This field displays the
report object name, administrative task, or taxonomy name, depending upon the task that you are
performing.

o For all report objects, the date and time the object was most recently modified is displayed.

o For Excel objects, a Refresh link is available for refreshing object data.

= Tip: You can hover over this field to view the date and time of the last refresh.

Project
This field shows the name of the currently open project. This field is not present if no project is
open. This field also contains icons to switch between horizontal layout and vertical layout.

Validation
Click this field to view a list of EDGAR validation errors for the active object. Any errors or
warnings found by running EDGAR validation on the object are listed.

Tasks
Click this field to view the name of the currently open task list.

All processes completed
Click this link to open a window that contains a list of all processes in the application during the
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current session. While processes are running, the title bar shows the number of running
processes. When the processes are finished, the title is All processes completed.

« View mode icons
Click an icon to switch between the available views.

= Tip: You can customize the status bar by right-clicking the status bar to add or remove these
fields.

The Options Window

You can use the Options window to configure specific settings for CDM. You can access the Options
window from the File tab.

The following options are available:
General
Displays options including:

- Language
The ability to choose language used in the application.

« Allow alerts to be displayed when working with Excel report objects
« Show informational hints throughout the application
« Register Certent CDM Protocol
« Report Object Double Click Action
The ability to select if you want a report object that is double-clicked to be opened in Preview or

Edit mode.

« Include Certent CDM support files during generation
To enable the saving of temporary files during generation.

« When Changing Workflow State > Allow custom email notification message

« When Generating Snapshots > Use Custom Folder for Snapshots
To choose a folder for snapshots.

« Globalization options
You can select if you want to use CDM in a language that is read from right to left, such as Arabic
or Hebrew.

Important: The option to register the CDM protocol must be enabled if you want to open
an object from an email notification.

Servers

Displays the CDM application servers that you can connect to. You can add, edit, remove, or change the
default server on this tab. You can also test the connection to the selected application server.
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Quick Access Toolbar

Displays all available commands from different menus and tabs that you can use to customize your
Quick Access toolbar.

Resources

Displays detailed system information as well as the CDM and CDM XBRL client and application server
versions. You have the option of copying this information to your clipboard for your reference or if you
need to contact support.

Office Addins
Displays the Office add-ins enabled in CDM.

The Reference Variables Window

The Reference Variables window is an area of the interface in CDM that you can use to select reference
variables that you want to insert into a report object. It is docked by default when first opened in a
session, however, you can undock it and position or dock it elsewhere.

Subsequent openings place the window where it was last positioned.

With a report object checked out, you can click Insert Variables in the Report Object tab on the ribbon
to open the Reference Variables window. If you click Insert Variables directly, all reference variables in
CDM are displayed. If you use the drop-down menu on the Insert Variables button, different variables
are displayed depending on the option selected.

Option | Icon ‘ Variable Type ’ Description

A source-destination reference
variable is displayed if a destination
variable (for example,
##D<currentyear>)is paired with a
source variable (for example,

= ##S<currentyear>). Displayed with
Source-Destination {#} Source-Destination the icon is the name of the variable
and the report object and report name
where the source variable is defined. If
you hover over the icon, other
information like comments and
location (address) in the report object
are displayed.

A global source-destination reference
variable is displayed if a global
destination variable (for example,
##GD<currentyear>) is paired with
= a global source variable (for example,
Source-Destination {#} Global Source-Destination |##GSD<currentyear>). Displayed
with the icon is the name of the
variable and the report object and
report name where the global source
variable is defined. If you hover over
the icon, other information like
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| Icon ‘ Variable Type Description

comments and location (address) in
the report object are displayed.

A named range reference variable is
displayed if a named range destination
variable (for example,
##D<currentassets>)is paired
with a source named range variable
- (for example,

##S<currentassets>). Displayed
Named Range iﬂj Named Range with the icon is the name of the
variable and the report object and
report name where the source variable
is defined. If you hover over the icon,
other information like comments and
location (address) in the report object
are displayed.

A global named range reference
variable is displayed if a global named
range destination variable (for
example, ##GD<currentassets>)
is paired with a global source named
range variable (for example,
##GSD<currentassets>).
| Global Named Range Displayed with the icon is the name of
the variable and the report object and
report name where the global source
variable is defined. If you hover over
the icon, other information like
comments and location (address) in
the report object are displayed.

@“’ﬂ

Named Range

An image range reference variable is
displayed if a destination image range
variable (##IRS) is paired with a
source image range variable (##IRE).

Displayed with the icon is the name of
r . !

Image Range | l Image Range the variable and the report object and
report name where the source variable
is defined. If you hover over the icon,
other information like comments and
location (address) in the report object
are displayed.

A chart variable is displayed if a chart
is defined in an Excel report object.
Displayed with the icon is the name of
the variable and the report object and
report name where the chart variable
is defined. If you hover over the icon,

Chart |l Chart
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Option | Icon ‘ Variable Type Description

other information like location
(address) in the report object is
displayed.

You can use the dropdown menu to select the following options:

e Float
Allows you to move and position the window wherever you choose.

« Dock
Keeps the window docked in the interface.

« Dock as Document
This option is unavailable.

o Auto Hide
Collapses the window to a sidebar that, when clicked on, expands the window.

« Close
Closes the window.

The following buttons and menus can be used to sort what is displayed:

» Refresh
Refreshes the display in the window to update any changes to the list of reference variables that
are shown.

o Type
o All - Displays all variables.
o Source-Destination - Filters out all variables except for source-destination variables.
o Named Range - Filters out all variables except for named range variables.
o |Image Range - Filters out all variables except forimage range variables.

« Group
o All - Displays all variables of the type selected using the Type filter.

o Variables from this report only - Displays variables from the current report that are of the
type selected using the Type filter.

o Global variables only - Displays only global variables that are the type selected using the
Type filter.

Report Overview

In CDM, the administrator creates reports and assigns users the ability to work on various parts of the
report. Users can access data, adjust, or calculate data values, and present data with formatting, text,
and images.

User Object Summary Tab

When you open a new or existing report in CDM, you first view it in the User Object Summary tab, which
displays information about the report as it is completed. The work area of the User Object Summary tab
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lists the report objects for which you have workflow permission to view or edit. You can review report
objects that you have checked out or that other users have checked out. You can also view report
objects checked out by other users for which you have workflow permission. Double-click a report object
in the report tree to open that report object.

You can view the following information in the columns of the User Object Summary tab area for reports,
and sort the columns in ascending or descending order by clicking the column header.

 Name
The user-specified name of each report object in the report.

o Document Type
The purpose of a Word object. For example, if the Word object contains page setup content, the
document type is PageSetup.

e Printable
The print setting for the report object. A check mark indicates that the object is printable. An x
indicates that the object is not printable. Only the documents and objects marked as Printable will
be included in the final generated report.

« Report Object Due Date
The date when the report object must be complete, as set by the administrator.

» Workflow Status
The current workflow state for the report object. The state can be updated at any time by an
administrator or by a valid user in the workflow approval process.

» Workflow Due Date
The deadline for completing the workflow process for the report object, as assigned by the
administrator. A deadline is displayed only if the administrator set a deadline within the workflow
process for that report object.

« Checkout Status
The checkout state for the report object. An object is checked in or checked out (locked) by the
current user or another user. A message appears on your screen, identifying the person who
checked out the report object.

The following commands are available on the ribbon for the User Object Summary tab:

Name ‘ Description
Refresh Used to refresh the information in the User Object Summary tab.
Used to open a Word or PowerPoint report object selected in the work area as checked
Preview in and displaying any variables as resolved (that is, how hey will appear in a generated

report). This cannot be used for Excel report objects.

Used to open and edit a report object selected in the work area. Word or PowerPoint
report objects are opened as checked out and any variables are displayed as

Edit unresolved (that is, they are not shown as they will appear in a generated report). Excel
report objects are opened as checked out and any variables are displayed as resolved
(that is, how they will appear in a generated report).

Used to open the report object selected in the work area as checked in and any
variables displayed as unresolved (that is, they are not shown as they will appearin a

Open
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Name ‘ Description

generated report).

Printable Used to toggle between printable and non-printable for the report object selected in the
work area.

. Used to output the information in the User Object Summary tab to an Excel

Export List
spreadsheet.

Workflow Used to view and modify the workflow for the report object selected in the work area.

Open a Report

To edit the content of a report, you must sign in to CDM, and then open the report.
You can use several methods to open a report:

« Click File > Open > Reports, and double-click the report that you want to open. After the report is
open, the User Object Summary tab displays. You can optionally export the content into a CSV
file by right-clicking in the work area and clicking Export as .csv.

« If you opened the report previously, and you want to open it again, click File > Recent, and then
double-click the report that you want to open.

« On the quick access toolbar, click the Open icon, and then double-click the report that you want
to open.

« If you receive an email indicating that the report object is ready for review, you can click the report
object name to open the report object directly.

Copy a Report as a URL

To copy a report as a URL, select the report name in the report tree, and then right-click and select
Copy as a Link. This action allows you to send the location of the report as a URL. When a user clicks
the URL, the report opens directly in CDM if the user has the appropriate View Report permission.

Lock a Report

If a reportin CDM is nearing its deadline for filing, you can lock the report. Locking a report prevents any
updates to variables, data queries, and reference objects when new information becomes available in
the source. This is useful when the report does not require a refresh for new information, for example, if
the user is nearing quarter close when data needs to be finalized.

Users granted the Manage Report Workflow permission can perform this task.
To lock a report:

1. Open the report that you want to work with.

2. Select the report.

3. Click Home > Lock Report or Report Object.

el
4. Thereportis locked as indicated by the Lock icon S’”—JL' in the report tree and the Lock Report or
Report Object command on the Home tab remains highlighted.
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5. To unlock the report, click Home > Lock Report or Report Object. The command is no longer
highlighted and the report is unlocked.

Report Object Overview

A report object defines the type of content that is in a report. Report objects represent most of the
content of your report in CDM.

There are five types of report objects in CDM: Excel, Word, PowerPoint, Web Page, and PDF. If you are
the administrator, you can add report objects to any report.

Overview of Excel Objects

Excel objects are primarily used to work with data values in CDM.

When an Excel object is added to a report, the Excel object has no data. You can reference and display
data from the database or an external source in the Excel object. You can also add text or data
manually.

When the data is in the Excel object, it can be referenced by other Excel formulas. You can reference a
large data set and display only some of the values. You can also import external Excel files directly into
Excel objects for reference and storage.

Overview of Word Objects

Word objects are primarily used to present textual information in a report in CDM.

When a new Word object is added to a report, the Word object contains no text. CDM can leverage
existing reports by importing them directly into the Word object for use in the report. You can add text,
images, graphs, or data to enhance the report. Every time you save a Word object, the data is saved in
the CDM database.

You can view an audit trail for the report object information and content in the database and you can
compare different versions.

Overview of PowerPoint Objects

In CDM, PowerPoint objects are primarily used for visual presentations in a report.

When a new PowerPoint object is added to a report, the object contains no text. CDM can take
advantage of existing PowerPoint documents by importing them directly into the PowerPoint object for
use in the report. You can add charts, display ranges, or image ranges containing data or graphics to
enhance the PowerPoint object. Every time you save a PowerPoint object, the data is saved in the CDM
database.

You can view an audit trail for the report object information and content in the database and you can
compare different versions of the PowerPoint object.

o Note: If you work in Microsoft™ Office 2007, you can work with only one instance of a
PowerPoint object at a time. When you view audit trails for PowerPoint objects, the audit trail
content does not load because of this limitation. You will receive a message in which you can
save the logs separately. If you work in a later version of Microsoft Office, this restriction does
not apply.
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Overview of Web Page Objects

You can use Web Page objects to display web pages in a report in CDM for reference.

Web Page objects can be included in the report for reference while you are working on the report, but
they are not generated upon output.

o Note: Because Web Page objects are not included in the generated report, Web Page objects
cannot be included in the Table of Contents.

Overview of PDF Objects

You can use PDF objects to attach documents in Portable Document Format (PDF) to a report in CDM
for reference.

PDF objects can be included in the report for reference while you are working on the report, but they are
not generated upon output.

o Note: Because PDF objects are not included in the generated report, PDF objects cannot be
included in the Table of Contents.

Report Object Tab

The Report Object tab in CDM contains commands that provide functionality specific to the report object
in CDM.

When you work in an Excel, Word, or PowerPoint object in CDM, you can use the same interface that
you use in Microsoft™. The interface contains generic Microsoft commands that you can use to create,
control, edit, delete, and format information in the object. When you open a PDF object in CDM, the
object has the same functionality as found in Adobe™ Reader or Adobe Acrobat.

You can view the Report Object tab inside your object by clicking the Section View Mode icon in the
status bar. To switch back to the main view, click the Default View Mode icon.

Workflow and Auditing Overview

A workflow is a process that is used to track the progress of a report and its report objects toward
completion. The workflow defines what needs to be done at each point in the approval process. You
have permission to view and work with report objects that are associated with your assigned workflow
state.

You can also advance or reject a report object through all the statuses configured for that report object
or section. A user can only advance the current status to the next status in the approval chain, or reject
and revert a report object to its previous status.

Audit Trail

CDM has an Audit Trail feature that records every submission to the database, along with the user
name and date of submission. It can be used to view all status changes to report objects in the report.
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Data Source Overview

A data source is the physical connection to a data repository such as a relational database, an OLAP
cube, or a Microsoft Excel file.

A data source connection specifies the parameters needed to connect to the data source, such as the
location of the database. It can also include credential information and other details specific to the data
source.

In CDM, the administrator can add data source connections to these types of databases:

« OLAP

» Relational

» Microsoft™ Excel

 Hyperion Financial Management (HFM)

The administrator must create a data source connection before users can create queries. After the
administrator adds a data source, users should be informed that the data source is available for them to
perform queries and run reports.

Query Overview

A query is a request for information from a database that is based on specific conditions. You can use a
query to create custom data queries on data from the data sources available to CDM and retrieve the
results into a report. The query can then be inserted into an Excel object.

When querying relational data sources, you retrieve data through SELECT statements. However, you
can also use other query commands against the database, as permitted by the data source provider.

Important: The advanced functionality for Microsoft™ products is beyond the scope of this
guide. However, some topics are included for your convenience. For more information, see
Microsoft documentation or Microsoft online help.

Checklist Overview

In CDM, a checklist is primarily used to provide task-oriented information and reference within a report.
You can create customized checklists as a means of process control, compliance, and verification.

You can add or delete checklists at any time when you are building a new report or when you are
working with an existing report. You can leverage your existing checklists and procedures, or you can
configure CDM to provide standard checklist types to use with your reports.

Users can add or delete checklists in a report and also append files to a checklist for reference and
support in the reporting process.

These default checklists are available:

« Task
Represents a task that the user needs to complete.
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« Information
Represents informational content.

« Reference
Includes a reference to a file attached to the checklist.

« Misc.
Represents a checklist of any other type.

Task and Task List Overview

In CDM, administrators can define tasks in an hierarchical or task list that users are required to
complete.

Task lists can coordinate a long process such as steps required to configure CDM for a 10K/Q report or
as simple as a list of set up tasks. Task lists can be either ordered, or unordered. You can also assign
different icons to different tasks.

Dashboard Overview

A dashboard is an interface that integrates data from a variety of sources and provides a unified display
of relevant and in-context information. Fixed dashboards are available in CDM to view the progress of a
report by graphical means. The administrator also has the ability to create custom dashboards and
make them available to the user.

The function of the dashboard differs, depending on whether your role in CDM is as an administrator or
a user.

« The administrator can add, edit, and configure the dashboard by opening the Administration tab
in the Navigation Pane.

« The user can view a dashboard by opening the Dashboard tab in the Navigation Pane. The
Dashboard tab contains a list of dashboards that are configured for the user.

When a dashboard is configured, you can open and view the dashboard types.

Custom Dashboards

A custom dashboard is a dashboard that is created by the user from widgets and various data sources
to meet specific requirements. It is not supplied with the application. A custom dashboard is configured
by a user who has administrative rights.

You can use these widgets in a custom dashboard:

e Chart
Shows the progress as an area, bar, line or pie chart. Both 2D and 3D charts are available.

« Grid
Shows textual information in a grid format. You can optionally export the contents of the grid into
a CSV file by right-clicking in the grid widget and clicking Export as .csv.

« Gauge
Shows one value from a column of values.
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« Image
Allows the user to add an image to the dashboard.

« Web browser
Allows the user to enter a link to a web page in the dashboard.

Fixed Dashboards

A fixed dashboard is a dashboard that is supplied with the application to provide report and data source
information in a graphical format. CDM includes these fixed dashboards: Report Summary Dashboard
and Excel Analysis Dashboard.

You cannot edit or delete a fixed dashboard, even if you are an administrator.

Report Summary Dashboard

The Report Summary dashboard in CDM is a fixed dashboard that displays generic report information. It
contains the Document Summary, Object Status, and Object Summary widgets.

Document Summary Widget
The Document Summary widget is a grid widget that displays the following information on a report.

+ Report Name
The name of the report selected from the dropdown menu.

« Report Group
If the report belongs to a group, the name of the report group.

« Report Owner
The name of the user who is owner of the report.

» Period End Date
The end date of the reporting period.

* Report Due Date
The date that the report is due for completion to meet the submission date.

« Submission Date
The date that the report is due for completion to meet the submission date.

« Number of Working Days Before Submission Due Date
The number of working days before the report is due for completion to meet the submission date.

Object Status Widget

The Object Status widget is a pie chart widget that displays the workflow status of the report. The pie
chart provides the user with workflow information that indicates the completion status and the percent
breakdown of the current workflow state for each section or report object.

Object Summary Widget

The Object Summary widget is a grid widget that displays information related to the completion of each
section and report object in the report. You can optionally export the contents of the grid into a CSV file
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by right-clicking in the grid widget and clicking Export as .csv.

Name
The title of each section or report object in the report.

Report Object Due Date
The deadline for completing the workflow process for a section or report object. A deadline is
displayed only if one was set within the workflow process for that section or report object.

Workflow Status
The progress of the section or report object (for example, work in progress, under review,
approved, and so on).

Workflow Due Date
The deadline for completing the workflow process for a section or report object. A deadline is
displayed only if one was set within the workflow process for that section or report object.

Active User
The current workflow user.

Printable
A check mark indicates that the section or report object is printable. Otherwise, it contains an x.

Locked
A check mark indicates that the section or report object is locked. Otherwise, it is empty.

Shared
A check mark indicates that the section or report object is shared. Otherwise, it is empty.

Reference
A check mark indicates that the section or report object is a reference. Otherwise, it is empty.

Excel Analysis Dashboard

The Excel Analysis dashboard in CDM is a fixed dashboard that displays the analysis of Excel objects
within a report in terms of data sources. It contains the Document Summary, Data Source Retrievals,
Object Status, and Object Summary widgets.

Document Summary Widget

The Document Summary widget is a grid widget that displays the following information of a report.

Report Name
The name of the report selected from the dropdown menu.

Report Owner
The name of the user who is owner of the report.

Report Due Date
The date the report is due for completion to meet submission date.

Current Workflow State
The current state of the report.
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Data Source Retrievals Widget

The Data Source Retrievals widget is a gauge widget that shows the total number of data source
retrievals for all report objects within a report. For example, if there are five report objects in a report and
Obj1 has five Data source retrievals and Obj2 has three data source retrievals, the gauge pin points to
8

Object Status Widget

The Object Status widget is a pie chart widget that displays the workflow status of the report. The pie
chart provides the user with workflow information that indicates the completion status and the percent
breakdown of the current workflow state for each report object.

Object Summary Widget

The Object Summary widget is a grid widget that displays information related to the completion of each
Excel object in the report. You can optionally export the contents of the grid into a CSV file by right-
clicking in the grid widget and clicking Export as .csv.

 Name
The title of each report object in the report.

« Workflow Status
The progress of the report object (for example, work in progress, under review, approved, and so
on.

» Checkout Status
The checkout status of the report object: Checked In, Checked Out.

o Active User
The current workflow user.

« Printable
A check mark indicates that the report object is printable. Otherwise, it contains an x.

» Shared
A check mark indicates that the report object is shared. Otherwise, it is empty.

« Reference
A check mark indicates that the report object is a reference. Otherwise, it is empty.

« Data Query Name
The name of the data query associated with the report.

« Data Query Type
The type of query, OLAP, Relational query, or External Excel File Query.

Bidirectional Language Overview

If you use CDM in Arabic or Hebrew, the direction of most content appears on your screen from right to
left automatically, as you would expect. Arabic or Hebrew are considered bidirectional languages
because some content should appear in the opposite direction from the basic text.
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The default text direction of a language does not allow the proper display of Arabic or Hebrew text in an
English user interface, and Latin-based text in an Arabic or Hebrew user interface. Also, numbers and
some other special types of content should normally appear from left to right, regardless of the language
of the surrounding text. CDM uses a concept called base text direction to apply your preference for the
direction in which certain types of bidirectional items appear in the user interface.

In addition, if you use CDM in Arabic, you can choose to view digits in the manner normally seen in
English and many other languages, or in the digit shaping common in Arabic. CDM uses a concept
called digit shaping to apply your preference for the appearance of digits in the user interface.

Base Text Direction for Arabic or Hebrew

If you use CDM in Arabic or Hebrew, you can ensure that special types of content appear in the correct
direction in your user interface. To do this, you must specify your preference for base text direction.

CDM uses a concept called base text direction to apply your preference for the direction in which certain
types of bidirectional items appear.

« For left-to-right sentences in English and other Latin-based languages, the proper base text
direction is left-to-right, even if the sentence includes Arabic or Hebrew words.

» Forright-to-left sentences in Arabic or Hebrew, the proper base text direction is right-toleft, even
if the sentence includes English words or numbers.

This list displays some of the types of content that should appear left-to-right even if the main content is
right-to-left:

« Textin English or another left-to-right language
e Numbers

« URLs

o Email addresses

» File paths

o Trademark symbols

Important: Your selection for base text direction is not applied in password fields, and just the
content of the field is mirrored according to the selected language (locale).

To select the base text direction for Arabic or Hebrew:
1. Click File > Options.
2. Inthe Options window, select your preferred language in the Language field.
3. Click the Base text direction field, and select one of these options:

« Default - To inherit the default natural direction of the language that is used in the user
interface. If you want to use the default behavior of the language in your user interface, this
is your best choice.
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« Left-to-right - To properly display text in left-to-right languages such as English and French.
If you are sure that your content contains text from English or any Latin-based language
only, this is your best choice.

» Right-to-left - To properly display text in right-to-left languages such as Arabic and Hebrew.
If you are sure that your content contains text from Arabic or Hebrew only, this is your best
choice.

« Contextual - To properly display text whose direction is not known in advance. CDM
selects the direction based on the context of the most recent strongly directional character.
If your content might contain both Latinbased text and also Arabic or Hebrew text or any
special content elements, this is your best choice. For example, in a right-to-left context, a
trademark sign is considered to be right-to-left, and it would be displayed in an incorrect
order if the brand name is in English or a Latin-based language. In an Arabic or Hebrew
report, to correctly display a trademark sign for an English name brand (left-to-right), you
must select Contextual.

4. Click OK.

5. Toensure that all your selections are applied to your user interface, exit from CDM and log in
again.

Special content appears in your user interface in the order that you specified. If you want, you can apply
similar preferences to your Excel, Word, and PowerPoint objects. For more information, see Microsoft™
documentation or Microsoft™ online help.

Digit Shaping for Arabic

If you use CDM in Arabic, you can specify whether you want to view digits in Arabic style in your user
interface. To do this, you must specify your preference for digit shaping.

In Arabic, digits often have an appearance that is different from the appearance of digits that are used in
other languages. If you do not specify your preference, CDM applies digit shaping in your user interface
based on your selection in the Digit Shaping field in the General tab of the Options window.

o Note:

 Inyour database, all numbers are stored in Latin-based format, even if you choose to
display them in Arabic style.

« CDM does not support numeric shaping when you generate Word reports from Excel
objects.

To select digit shaping for Arabic:
1. Click File > Options.

2. Inthe Options window, select Arabic in the Language field.
3. Click the Digit Shaping field, and select one of these options:

« National - To specify digit shaping based on the language that you are using when you
work in CDM.
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« Contextual - To specify digit shaping based on adjoining characters in the value. Latin-
based digits follow Latin scripts, and Arabic digits follow Arabic text. When there is no
preceding text, the value in the Base text direction field determines digit shaping.

+ None - To display the digits in their Latin-based form and shape. The digit shape appears in
CDM as it appears in your regional settings form if you specify None in the Digit Shaping
field.

4. Click OK.

5. Toensure that all your selections are applied to your user interface, exit from CDM and log in
again.

Digit shaping appears in your user interface as you specified. If you want, you can apply similar
preferences to your Excel, Word, and PowerPoint objects. For more information, see Microsoft™
documentation or Microsoft™ online help.

o Note: If you use CDM in Arabic, and if you select Contextual for Digit Shaping in the Options
window, some dates in report properties might appear with Latin-based number shaping. The
dates that appear with Latin-based humber shaping are those that are selected through a
calendar field in CDM.

EDGAR HTML Overview

You can use the HTML tools for Electronic Data Gathering, Analysis, and Retrieval (EDGAR) in CDM to
preview your HTML file for the SEC.

You can use CDM to generate valid EDGAR content for the SEC in this way:

¢ You can generate HTML output. You can find information on this method in this documentation.

« You can generate output that conforms with SEC EDGAR Filer Manual rules. The EDGAR Filer
Manual validates that the taxonomy and instance document comply with the rules. You can find
information on this method in the CDM XBRL User Guide.

« You can generate high definition HTML output. You can find information on this method in this
documentation.
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Getting Started

To get started in CDM, you need to know how to log in. You also need to know your role because your
role determines the tasks that you can perform.

Roles

CDM provides a collaborative environment for users to contribute to the report, based on the role of the
user. Your contributions depend on whether your role is administrator or user.

Administrator Role

The administrator in CDM creates the initial structure of a report and provides security access to the
report. The administrator assigns parts of the report to users, along with a deadline for submission.

The administrator can edit any part of the report, maintain the overall structure of the report, manage the
project deadlines, configure user access levels, configure dashboards, and monitor work status and
submissions.

The administrator can also publish the report for the users. The administrator can choose to delegate
some administrative tasks to non-administrative users.

User Role

Users can contribute content to various parts of a report in CDM, and multiple users can work on
different aspects of the same report.

Users can view details, but they can update the report only within the documents that were assigned to
them. By default, tasks such as changing deadlines for submission or changing global settings for all
reports are normally performed only by the administrator. Users with the correct permissions can view
the dashboards that are created for them. The administrator can choose to delegate some
administrative tasks to non-administrative users.

Sign In to Certent CDM

The administrator provides you with your login credentials for CDM.

1. Select your server and click OK. At any time you can click Switch Server to enter a specific
server address.

2. Inthe Sign in prompt, enter your user name and click Next.

3. Inthe Enter password prompt, enter your password and click Sign in.

o Note: Depending on security set by the administrator, if you enter an incorrect name or
password, you might have to wait for a period before you can attempt another log in. It
is also possible that your account is locked immediately. If this occurs, contact the
administrator to unlock it.

4. If you have any objects that are checked out from a previous session, you are prompted to load
the report that the objects are in. Select the report and click OK. Optionally, expand the hierarchy
of the report and select the object that was checked out in a previous session. The report and
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objects open in the same session as when you last logged out. Or, click Cancel to start CDM
without opening the report with objects that were checked out.

CDM opens, with the Open tab in view or a report with checked out objects in view. Depending on your
role, you can now select a report or dashboard, or you do other tasks.

Important: For security reasons, sign out when you finish working with CDM.

If you want to change your password, use one of these methods:

« Inthe status bar, click your user name. In the User Profile window, enter your old password and
new password. Confirm the new password and click OK.

« If you have sufficient permission, click Administration, and then under Security, double-click
Users. Right-click your name and click Change Password. Enter and confirm a new password,
and then click OK.
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Workflow

A workflow is a process that is used to track the progress of a report, section, or report object towards
completion. The workflow states define what needs to be done at each point in the approval process.
You have permission to view and work with blank objects or report objects that are associated with your
assigned workflow state.

If the administrator has made reports, sections, or report objects editable, you can modify them.

The administrator can assign a due date to the workflow state. If the due date is equal to the current
date or has passed, Workflow Due Date in the Properties and Comments window is highlighted.

For each workflow state in the workflow process, there might be multiple transitions that link it to any
number of other states. You have the option to move the current state to any number of different states
based on which transition you choose. One transition can be defined as a default that moves the current
state automatically to another state or you can choose one of the other transitions created for that state.

Move the report, section, or report object to the next state when you are done working with it. The report,
section, or report object is automatically assigned to the next user or group. You cannot assign the
report, section, or report object to another user except by advancing them to the next workflow state.
You can also reject and revert a report, section, or report object to its previous state. For example, when
you review report objects, you realize that the previous user needs to make further changes. You move
the report object to the previous state.

= Tip: If you advance the workflow state of a report, section, or report object by mistake, and you
require access to the report, section, or report object again, you must contact the
administrator.

Reuse a Workflow

To save time when you are constructing a workflow diagram for sections or report objects in CDM, you
can reference a workflow template or copy a completed workflow process and reuse it.

This task can only be performed on sections or report objects that have workflow inheritance disabled.
Any descendant sections or report objects that have workflow inheritance enabled will inherit the new
workflow.

Users can modify workflow states but they cannot add new states or delete existing states to a
referenced workflow.

A referenced workflow is connected to the original template. It maintains the same set of states and
links, but it has its own associated data such as users, groups, permissions, due date, and email.

A copied workflow is generated by copying the entire structure of the template workflow, the state
positions, and all the data associated with the copied template. A copied workflow has no relation to the
workflow template and therefore can evolve independently

To reuse a workflow:

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the report object that you want to edit and select Workflow
> Edit Workflow.
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3. Inthe Manage workflow window, right-click in the Workflow pane to access the following
options:

« Add Referenced Workflow - Adds a new workflow to a report object using a workflow
template as the source. This creates a dynamic link to the workflow template.

« Add Copied Workflow - Adds a copy of the existing workflow template that you select. If the
report object already has a workflow assigned, the existing workflow structure must be
deleted before adding the structure of the new one.

« Break Reference - Creates a copy of the workflow by breaking the reference to the
workflow template.

4. Click OK.

Manage Workflow and Workflow Inheritance

Workflow can be managed at any level of a report (report, section, or report object).

Create and Al?:?ly a Report Level Workflow to All
Sections and Report Objects

Administrators (with the Manage Workflow Templates permission) can set a default workflow template
for CDM. The default workflow template is applied to any newly created report. At any time, report
administrators (with the Manage Report Workflow permissions) can define a new workflow or apply
another workflow template to the report. They can also apply the workflow to all sections and report
objects in the report by right-clicking the report and selecting Workflow > Apply Report Workflow. The
workflows of the descendant sections and report objects are discarded and they inherit the report
workflow.

Create and Apply a Section Level Workflow to All
Descendants Within a Section

Section owners (with the Manage Report Object Workflow permission) can create a customized
workflow for a section to override the report workflow or any section workflow inherited from higher-level
sections. That customized section workflow, when created, is inherited by any new objects or sections
that are added as descendants to the section. At any time, you can apply the section workflow to all
sections and report objects within the section by right-clicking on the section and selecting Workflow >
Apply Section Workflow. The workflows of the descendant sections and report objects are discarded
and they inherit the section workflow.

Create and AEpIy a Report Object Level Workflow to
an Individual Report Object

Object owners (with the Manage Report Object Workflow permission) can create a customized workflow
process for report objects. If the report object inherits the workflow you must first disable workflow
inheritance by right-clicking the section or report object and selecting Properties > Manage All Object
Properties and clearing the Inherit Workflow checkbox in the Properties and Comments window. You
then create a new workflow by right-clicking on the section or report object and select Workflow > Edit
Workflow. You can then modify the previous workflow to create a new one for that section or report
object.
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Workflow Inheritance Conditions

These apply to workflow inheritance:

« Report objects must be checked in when applying a report or section workflow to them, otherwise
the operation will fail.

« Sections or report objects that are inheriting a workflow are indicated by the inherited indicator to
the bottom left of the workflow icon.

« The Manage Workflow and Lock commands are not available on the ribbon for sections or report
objects with an inherited workflow. The workflow management (including the lock and editable
properties for the current workflow state) can be managed through the closest ancestor with a
customized workflow.

« The Workflow menu (right-click a section or report object) is not available for sections or report
objects with an inherited workflow.

« The User Object Summary workflow ribbon and contextual menu is not available for sections or
report objects with an inherited workflow.

Customize the Workflow Assigned to a Section or
Report Object

You can customize the workflow for a section or report object in CDM.

The particular changes that you can make depend on your permissions, but you cannot change the
overall workflow.

This task can only be performed on sections or report objects that have workflow inheritance disabled.
Any descendant sections or report objects that have workflow inheritance enabled will inherit the new
customized workflow.

To customize the workflow assigned to a section or report object:

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the section or report object and select Workflow > Edit
Workflow. The Manage workflow window opens.

3. If you want to add workflow states, complete the following steps:

a. Inthe Toolbox box, select icons that represent workflow states that you want in this
workflow process, and drag them to the Workflow box.

b. Arrange the icons in the appropriate order for your workflow process.

c. To create transitions, connect the icons by drawing lines from the gray Out pipe on the first
icon to the white In pipe on the second icon. A line appears between the icons. You can
create transitions from one state to several others and designate one transition as the
default. The default represents the most likely transition to be used automatically when the
state moves to another state. However, a user can choose the other transitions not
designated as the default as an option when the state is moved. Right-click on a transition
and select Default to set it as the default.
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4. Change the attributes of the workflow states as needed. See Change the Attributes for a
Workflow State.

5. If you want to change the users or group who have access to the report object, complete the
following steps:

a. Select the state that you want to change.
b. Click Assign Users/Groups.

c. Add or remove users and groups.

d. Click OK.

6. If you want to add text to the email notification, double-click the line between the workflow states,
enter the text, and click OK.

Ensure that the default email client is running. If the email client is not open, the email is not sent
and the email appears in the outbox of the email client.

7. When you have finished customizing the workflow, click OK.

Assign Sections or Report Objects to a User or
User Group in a Workflow Process

You can use the workflow process to assign sections or report objects to users or user groups in CDM.
You can also use a workflow to control access to sections or report objects, and to control the
progression of a section or report object along the workflow chain as it is completed.

This task can only be performed on sections or report objects that have workflow inheritance disabled.
Any descendant sections or report objects that have workflow inheritance enabled will also inherit the
newly assigned users or user groups.

Sections and report objects can be assigned by the administrator to other users for completion through
the workflow process. If a section or report object is already assigned to a user, the administrator can
reassign it to any other user.

Users cannot assign a section or report object to another user, except by advancing the section or
report object to the next stage of the workflow chain. This action automatically changes the assigned
user to the next person responsible for working on the section or report object.

Important: If the initial user assigns the section or report object to another user via workflow by
mistake, only the administrator can reassign the section or report object again.

To assign a section or report object to a user or user group in a workflow process:

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the section or report object and select Workflow >
Workflow Users.

3. Select a user or user group and click OK.

4. Inthe confirmation window, click OK.
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Change the Workflow State for a Report

When you are working on a report in CDM, you can change its workflow state. You can move the report
to a specific state or to the next state determined by the workflow.

Any descendant sections or report objects that have workflow inheritance enabled will move to the
selected new workflow state.

For a report, there might be multiple transitions that link it to any number of other states. You have the
option to move the current state to any number of different states based on which transition you choose.
One transition can be defined as a default that moves the current state automatically to another state or
you can choose one of the other transitions created for that state.

To ensure that you receive email notifications, you must make sure that email notification is configured.
For more information, see the CDM Administration Guide.

If you advance a workflow process to the next step in the workflow, an email can be sent automatically
to the user who must perform that step. In that email, the user can click the report object name to open
the report and report object in CDM directly from the email.

To change the workflow state for a report:

1. Open the report that you want to work with.

2. To move the report to the next state as determined by the workflow, complete the following steps:

a. Inthe report tree, right-click the report and select Workflow > Move to Next State >
Automatic to move it to the next state as defined by the default transition in the workflow, or
select Workflow > Move to Next State > Custom to move it to one of the other transitions
set for the state. The Select State for Selected Report Object window is displayed. Select
the next state from the drop-down list and click OK. A confirmation message is displayed.

b. If custom email notification is configured, an additional window opens where you can add
custom messages to the default email template that was sent. Click Yes to proceed, or click
No to change the status without an email notification.

3. Tochange the workflow state for the report to a different state, not necessarily the next state,
complete the following steps:

a. Right-click the report, and click Properties > Manage All Report Properties.
b. Select a new status for Current Workflow State.

c. Click OK to confirm the change.
d

If custom email notification is configured, an additional window opens where you can add
custom messages to the default email template that was sent. Click Yes to proceed, or click
No to change the status without an email notification.

Change the Workflow State for a Section or
Report Object

When you are working on a section or report object in CDM, you can change the workflow state for a
section or report object. You can move the section or report object to a specific state or to the next state
determined by the workflow.
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This task can only be performed on sections or report objects that have workflow inheritance disabled.
Any descendant sections or report objects that have workflow inheritance enabled will move to the
selected new workflow state.

For each section or workflow state in the workflow process, there might be multiple transitions that link it
to any number of other states. You have the option to move the current state to any number of different
states based on which transition you choose. One transition can be defined as a default that moves the
current state automatically to another state or you can choose one of the other transitions created for
that state.

To ensure that you receive email notifications, you must make sure that email notification is configured.
For more information, see the CDM Administration Guide.

If you advance a workflow process to the next step in the workflow, an email can be sent automatically
to the user who must perform that step. In that email, the user can click the report object name to open
the report and report object in CDM directly from the email.

To change the workflow state for a section or report object:

1. Open the report that you want to work with.

2. To move the section or report object to the next state as determined by the workflow, complete
the following steps:

a. Inthe report tree, right-click the section or report object and select Workflow > Move to
Next State > Automatic to move it to the next state as defined by the default transition in the
workflow, or select Workflow > Move to Next State > Custom to move it to one of the other
transitions set for the state. The Select State for Selected Report Object window is
displayed. Select the next state from the drop-down list and click OK. A confirmation
message is displayed.

b. If custom email notification is configured, an additional window opens where you can add
custom messages to the default email template that was sent. Click Yes to proceed, or click
No to change the status without an email notification.

3. To change the workflow state for the section or report object to a different state, not necessarily
the next state, complete the following steps:

a. Right-click the section or report object and select Properties > Manage All Section
Properties/Manage All Object Properties.

b. Select a new status for Current Workflow State.
c. Click OK to confirm the change.

d. If custom email notification is configured, an additional window opens where you can add
custom messages to the default email template that was sent. Click Yes to proceed, or click
No to change the status without an email notification.

Change the Attributes for a Workflow State

You can change the attributes for a workflow state in CDM. Workflow state attributes determine how
users work with a section or report object.

This task can only be performed on sections or report objects that have workflow inheritance disabled.
Any descendant sections or report objects that have workflow inheritance enabled will inherit the new
workflow state attributes.

For each workflow state, you can set the following attributes:
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o Set Due Date
Determines when the workflow state is due. The due date is set in relation to the due date of the
assigned report object.

For example, the current date is June 1; the report object's due date is June 30. You have three
states in this example workflow that will be completed simultaneously. You need 5 days to
complete the tasks in the first state, 10 days for the second state, and 15 days for the third state.
To complete all workflow states by June 30, the first state is due June 25 (June 30 minus the
offset of 5 days), the second state is due June 20 (June 30 minus the offset of 10 days), and the
third state is due June 15 (June 30 minus the offset of 15 days).

o Default
Determines the default state for report objects. The first state added to the diagram is
automatically the default state. You can specify a different state as the default.

- Editable
Determines whether users can edit the report object when it is in this workflow state.

» Locked
Determines whether the report object can be refreshed.

To change the attributes for a workflow state:
1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click a section or report object and select Workflow > Edit
Workflow. The Manage workflow window opens.

3. Tochange the due date, select the state and click Set Due Date. Select an appropriate due date
offset and click OK.

To change which state is the default state, select the new state and click Default.
To allow users to edit sections or report objects in this state, select the state and click Editable.

To lock sections or report objects in this state, select the state and click Locked.

N o g &

To show or hide the legend, click Show Legend.

Edit a Workflow State Transition

You can change the details of a workflow state transition in CDM.

This task can only be performed on sections or report objects that have workflow inheritance disabled.
Any descendant sections or report objects that have workflow inheritance enabled will inherit the edited
workflow state transitions.

To edit a workflow state transition:

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the section or report object and select Workflow > Edit
Workflow. The Manage workflow window opens.
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3.

To reposition a transition, click and hold the transition at either the gray Out pipe or white In pipe
of the workflow state and drag it to the corresponding pipe on another transition. The transition
line is repositioned.

To edit the message that is to be sent by email when the workflow state is moved, right-click the
transition and select Email Body. Edit the text of the message and click OK.

To edit a transition as the default when the workflow state is moved, right-click the transition and
select or clear Default.

To edit transition rules, right-click a transition and select Transition Rules and apply or remove a
condition.

To delete a transition, click to select the transition and click Delete.

Click OK.

Define Workflow Rules for Object-Level
Workflows

You can define workflow rules to control the workflow process based on user-defined conditions. Rules
apply to either referenced or copied object-level workflows in CDM.

You can use workflow rules in the following instances:

State Check condition
You can use the workflow state variable ##Ws to retrieve the current state of a specified object.
The workflow rule then leverages the result of this variable to apply the condition.

This condition prevents an object from advancing to the next state when a particular condition is
set. For example, a rule states that Object 1 must be in the Approved state before Object 2 can
proceed to the next state. If Object 1 is not in the Approved state, then the workflow cannot be
advanced.

Value Check condition

You can use the workflow rule variable # #WR to identify the condition that will determine if the
workflow state is allowed to be advanced. The workflow rule must enforce uniqueness within the
report.

This condition can be created to determine if a particular value in an Excel object is as expected.
If the particular value is not entered, the workflow cannot be advanced to the next state.

To define workflow rules for object-level workflows:

1.
2.

Open the report that you want to work with.

In the report tree on the left, open and check out the Excel object that you want to apply the
condition to.

If you want the rule to check the workflow state of the object, complete the following steps:
a. Type ##WS in a cell outside the printable range, that is, outside of the ##RS-##RE range.

b. After the cell where you typed ##Ws, type the object name.

For example, you create a rule that will check the workflow state of the Assets object.
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4.

Table 1: Example of the cells for a rule that checks the workflow state

Cell F2 \ Cell G2

#H#WS Assets

Cell H2

Work in Progress

c. Save and refresh the object.

If you want to define a workflow rule, complete the following steps:
a. Type ##WR in a cell outside the printable range.

b. After the cell where you typed # #WR, specify a name for the rule.

c. Enterthe condition to be checked. This can be any value or a Microsoft™ Excel formula.

Table 2: Examples of conditions

Condition

=IF ((Example!E10>10000),0,1)

Description

This formula validates cell E10 in the
Example worksheet to see if the value is
above 10,000. The workflow can be
advanced to the next state only when the
value is above 10,000.

=IF((Example!D15-5="Test"),0,1)

This formula validates cell D15 in the
Example worksheet to see if the word Test
is specified. If the text is not Test, the
formula returns a 1, which means that the
workflow cannot be advanced to the next
state.

For example, the condition =IF (H2="Approved", 0, 1) prevents users from advancing
objects to the next state if the Assets object is not in the Approved state.

Table 3: Example of a workflow rule that uses the workflow state rule

Cell F2 \ Cell G2 \

##WS Assets

Cell H2

Work in Progress

##WR Rule 1

=IF (H2="Approved",0,1)

5. You can enter a comment for the rule after the cell where you entered the condition.

6. To enforce this rule, complete the following steps:

a. Select the object where you want the condition to be applied and edit the workflow.

o Note: This task can only be performed on objects that have workflow inheritance
disabled. Any descendant sections or report objects that have workflow
inheritance enabled will inherit the new rule.

b. Right-click the transition to the next workflow state and select and apply the condition.

c. Save the changes.

Note the following:



https://insightsoftware.com/

Y insightsoftware 41

« When a formula evaluates to zero (0), it means the condition is met. When the formula evaluates
to anything else, the condition has not been met. This includes an empty cell or text. If the
condition is not met, the workflow cannot be advanced no matter what the assigned permissions
are for the users. However, if a user enters 0.01 and changes the value to appear as 0, it is
considered to pass the rule.

« After you add a workflow rule, a shadow under the transition arrow indicates that a rule exists.

« If a workflow state contains a transition that is validated by a rule that no longer exists in the
report, the rule is ignored.

« The workflow state names are validated when the object is opened or saved. This is useful if an
object was renamed and the variable still uses the old name. An orphan variable entry is added to
the Orphan Variable window. If there are multiple objects with same name used in the workflow
state, the first object name in the report object tree is used.

« Workflow rules are not evaluated if someone is editing the workflow. The changes made to the
workflow are saved even if a rule associated to the current transition does not pass. Workflow
rules are evaluated when the workflow is moved to the next state, or when the workflow state is
set, or when the current state is changed in the report object properties form. Note that this
applies when changing the workflow from the object tree as well as from the user summary
screen.

« After you edit and save the workflow, you optionally see a list of workflow rules that are no longer
defined in any object in the report. You can leave the workflow like this, with the orphaned rules
still set on the transitions, or you can remove the orphaned rules.

« If you move multiple objects to the next state in the workflow, the rules are evaluated for each
object. Objects that pass the rule move to the next state while objects that fail the rule do not
move to the next state.

« If a workflow rule relies on a ##D value that is no longer linked to its source because ##S was
removed, the rule uses the value specified on the object. If no value exists, the rule does not
retrieve a value and the object fails the rule.

Set Up CDM to Enable Hyperlinks in Emails

You can set up CDM to allow hyperlinks in emails. You can then create hyperlinks that will be sent
through the workflow process to the appropriate users, so that they can open the report and section or
report object automatically, even if CDM is not currently open.

Normally, this setting is enabled automatically during installation. However, if the setting has been
disabled, you can follow this procedure to enable it.

Important: If you use web mail, links might not appear or function correctly.

To set up CDM to enable hyperlinks in emails:
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1. Inthe File tab, click Options.

2. Inthe General > User Interface Options section, complete the following steps:

a. Totrigger the operating system to launch CDM and open the report and section or report
object that are referenced by the link, click Register Certent CDM Protocol.

Important: Select this option only if you are sure you want to proceed. If you
change your mind, you cannot reverse your action by clearing the checkbox
because it requires system administration privileges to use the Windows™
Registry. If you must clear this selection, ask your administrator to remove the
feature through the client installer.

b. If you do not want to launch a new instance of CDM when you open a section or report
object through an email link, select Use single application instance. When a section or
report object is opened through a hyperlink in an email, it opens in the instance of CDM that
is currently open. If CDM is not open, it launches automatically.

c. If you want to launch a new instance of CDM when you open a section or report object
through an email link, do not select Use single application instance. When a section or
report object is opened through a hyperlink in an email, it opens in a new instance of CDM.

d. To make these changes take effect, restart CDM before you proceed with the rest of the
steps in this procedure.

3. Inthe When Changing Workflow State section, select the Allow custom email notification
message checkbox if you want.

4. Click OK.

When you receive an email notification that a workflow state has changed, the name of the section or
report object contains a hyperlink that you can click to open the section or report object in CDM.

Optionally, you can copy the hyperlink of a report, section, or report object and paste it outside the
context of a workflow email. For example, you might want to paste the hyperlink into a separate email to
an approver or reviewer. To do so, click Copy > Object as a Link.

Create a Workflow Assignment Report

The workflow assignment report in CDM provides a detailed view of your assigned areas of the
workflow. For example, you can see the due date for your assignments.

To create a workflow assignment report:

1. Open the report that you want to work with.
2. Click the Home tab and then click User Workflow Assignment.
3. Inthe progress report, perform one or more of the following tasks:

« To change the appearance of the report, right-click any column header and select one of
the available options. For example, you can sort, group, and filter.

« To refresh the data in the report, click Refresh.

4. Click Close.
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Reports

In CDM, the administrator creates reports and assigns users the ability to work on various parts of the
report. Each part of a report is called a report object.

As a user, you can access data, adjust or calculate data values, and present data with formatting, text,
and images.

Report Properties

You can view and edit report properties in CDM.

Properties for a report can be set by an administrator when the report is created. To view or edit these
properties, open the report, select the Home tab, and click Show Properties. The Properties and
Comments window is displayed.

You can view or edit the following information:

Property | Description
Name The user-specified name of the report.

Shows the initial creator of the report. This name can be changed in
the Properties and Comments window.

Report Owner

Description Displays the report description

Period Start Date Displays the starting period date of the report.

Period End Date Displays the ending period date of the report.

Report Due Date Displays the configured due date for the report.
Current State Due Date Displays the due date for the current state in the report.
Submission Date Displays the submission date for the report.

Specifies a character to represent the zeros in the report when the

Zero Amount Shown As .
report is generated.

Current Workflow State Displays the current workflow state for the report.

Template Workflow Assigned Displays the workflow template assigned to the report.

Allows you to specify the orientation of slides in PowerPoint objects.

PowerPoint Print Options The default choice is Landscape.

Allows you to set the preferred language and region that will be used
Language and Region Options |to generate Excel print areas and variables to Microsoft Word,
Microsoft PowerPoint, Adobe PDF and Edgar HTML.

Allows you to generate charts as images. If selected, this option will
be set as an active default for the report. Users, however, can clear it
when working with reports or when generating a report. If you
generate charts as images, you can view the information in your
generated report, but you cannot change it afterward. If this option is
not selected, charts are generated as Microsoft™ Office chart
objects. It is recommended that charts be generated as Microsoft
Office chart objects.

Generate charts as images

Allows you to replace embedded fonts in the report as base64 in HD

Replace Embedded Fonts in HD .
generation.
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Property | Description

When enabled, if the content in an Excel cell is word-wrapped and is
not completely displayed because the height of the corresponding
Report Row Height (At least) row is specified to a smaller value, CDM will apply the least row
height that can accommodate the whole content in Word generation
to make the entire content visible.

This option must be enabled in the CDM.config file to appear in the
report properties. When enabled, queries are updated immediately
after the data source expires according to its expiration settings.
Also, Excel report objects are updated immediately after a data
query or a destination variable is enabled.

CDM performs the Advanced Refresh operations using the Refresh
Service Account. In CDM, refreshing data is an audited process, so
CDM needs to have an identity for background tasks. CDM hence
creates the Refresh Service Account by default and applies it to start
background data refresh processes automatically. As stated in its
name, the Refresh Service Account is a service account in the

Use Advanced Refresh database (in the IsService column of the core.User table) and
therefore cannot be used for logging in to CDM.

o Note:

« ltis not possible to change the name of the Refresh
Service Account in the database; otherwise, CDM
won't recognize it anymore.

* The Refresh Service Account is not visible when
administering CDM native users.

Allows you to switch between cell display value and cell actual value
when evaluating either a report validation rule (##R) or a workflow
validation rule (##WF).

Use cell value for report and
workflow validation

Sections

You can add sections in any report in CDM to group and organize report objects in the report.

Full reports can contain many report objects. Administrators can add sections periodically throughout
the report and organize the report objects in the sections. The sections make it easier for users to
navigate the report hierarchy.

You can apply a workflow to a section and have all new or existing descendant report objects and
sections below it in the report hierarchy inherit that workflow, eliminating having to individually create
workflows for each of the report objects.

You can also designate top-level sections as exhibit sections. All descendant report objects in an exhibit
section become exhibit documents and are combined into one exhibit document that is included with the
report when using Word generation.
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Add a Section to a Report

You can add sections to provide spacing and grouping of report objects.

After adding a section, you can click and drag it to reposition it anywhere in the report hierarchy. When
you add a section, the template workflow assigned to the report is automatically applied to the section
workflow and any report objects and sections below it in the report hierarchy that have Inherit Workflow
enabled.

To add a section to a report:
1. Open the report that you want to work with.

2. Determine the location where you want the section.

3. Do any of the following:

« If adding a section to the report, right-click and select Add Child > Section. The section is
placed immediately below the report in the report tree structure.

« If adding a section to another section, right-click the section and select Add Sibling >
Section. The new section is placed on the same level in the report tree structure as the
section you selected. Or right-click the section and select Add Child > Section. The new
section is placed one level below in the report tree structure as the section you selected.

« If adding a section between report objects, right-click the report object thatimmediately
precedes that location and select Add Sibling > Section. The section is placed below but
on the same level as the report object you selected.

Edit the Properties of a Section

You can view and modify the properties of a section to tailor the section in a specific way.

1. Open the report that you want to work with.
2. Inthe report tree, right-click the section and select Properties > Manage All Section Properties.

3. Inthe Properties tab of the Properties and Comments window, edit the properties as you want.
You can change any property that is not gray.

4. Click OK.

You can view or edit the following information:

Property | Description

Name User. specified name for the section. Each section in a report must have
a unique name.

Section Due Date The due date of the section.
If selected, the section inherits the due date from its parent section due

Inherit Due Date date or the report due date, depending on its position in the report
hierarchy.

Workflow Due Date The due date of the section's workflow.

Inherit Workflow If se!ected, the section inherits the workflow due date from its parer.1t
section workflow due date or the report workflow due date, depending
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Property | Description
on its position in the report hierarchy.

The print options for the section.

¢ Printable - When selected and the report or section is
generated, descendant report objects whose properties have
Printable selected are included in the output. When not selected,
all descendant report objects are excluded in generation output
and their names in the report outline become lighter and more
transparent.

« Exhibit - When selected, designates the section as an Exhibit
Section. If selected, report objects grouped together in the
section are combined into one document separate from the
report. Enter values for these fields:

Print Options

o Exhibit Type - The type of exhibit that is being included with
the report.

o Exhibit Description - Used to enter a description about the
exhibit document.

o Exhibit File Name - Designates the file name for the exhibit
document created at generation. If this field is left blank,
then the name given to the section is used.

Check In and Check Out Report Objects in a Section

You can check in or check out multiple report objects that are in a section in one action.

1. With the report open, right-click on the section in the report tree.

2. Select Check In (if you want to ensure in all report objects in the section have a checked-in
status) or Check Out (if you want to check out all the report objects in the section for editing).

3. The Checkout Status for the report objects is updated in the User Object Summary tab.

Delete a Section from a Report

If you no longer need a section in a report, you can delete it.

When deleting a section in a report, any report objects or sections that are descendants (children) of
that section will also be deleted.

To delete a section in a report:

1. Open the report that you want to work with.
2. Inthe report tree, right-click the section that you want to delete and select Delete.

3. Inthe confirmation window, click Yes.
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Report and Section Due Dates

A due date is applied to a report or a section to indicate a deadline for when work should be completed.

How Due Dates Are Used

Users granted the Modify Report Properties permission can assign a due date to a report. Users
granted the Manage Report Object Properties permission can assign a due date to a section orto a
report object.

The due dates are used to indicate the date on which all work should be completed. If the due date is
equal to the current date or has passed, Current State Due Date in the Properties and Comments
window is highlighted.

Manage Due Dates and Due Date Inheritance

Due dates can be managed at any level of a report (report, section, or report object).

« Create and apply report-level due dates to all sections and report

o To set or change a due date for a CDM report, in the Report tab in the Navigation Pane,
right-click the report and select Properties > Manage All Report Properties, then enter a
date in the Report Due Date field.

o To apply the due date to all sections and report objects in a report, right-click the report and
select Properties > Apply Report Due Date. The descendant report objects and sections
will now inherit the due date from the report due date setting.

« Create and apply section-level due dates to all descendants within a section
You can set an explicit due date for a section by clearing the Inherit Due Date checkbox in the
Properties and Comments window (right-click the section and select Properties > Manage All
Section Properties) and setting a new due date. When set, the due date is inherited by any new
objects or sections that are added as descendants to the section. At any time, you can apply the
section due date to all sections and report objects within the section by right-clicking on the
section and selecting Properties > Apply Section Due Date. Due dates for the descendant
sections and report objects are discarded and they inherit the section due date.

« Create and apply report object-level due dates to an individual report object
You can set an explicit due date for a report object by clearing the Inherit Due Date checkbox in
the Properties and Comments window (right-click the report object and select Properties >
Manage All Object Properties). You then enter a new due date for the report object in the Report
Object Due Date field.

Workflow State Due Dates

Due dates can also be applied to workflow states to enforce when certain stages in the workflow must
be completed.

When the due date for a workflow state has passed the workflow due date of the report object, the
section or report will be highlighted in the Properties.

The workflow state due date for a report object, section, or report is calculated relative to its due date.

To learn more about how to set workflow state due dates and how they are calculated, see the CDM
Administration Guide.
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Comments in a Report

A comment is a message that you can add to a report in CDM to share information with other users.

Comments can be used in reports to communicate about specific information about that item. You can
view, add, edit, and delete the comments in reports.

You can view the comments as a list or in a tree view, with replies under the original comments. To
toggle between the two views in the Comments tab, click View as List or View as Tree.

o View as List
Presents all comments listed by date, starting with the oldest comment.

« View as Tree
Presents all comments in a tree view, in which replies to comments are shown under the original
post and slightly indented.

You can also use comments in individual report objects.

Add a Comment to a Report

In CDM, you can create comments in reports to communicate with other users about specific content in
the report.

You can add text comments to reports, which can be seen by users that work in that report. Comments
are not included in the generated report.

You need permission to view comments in reports. The name of the user who added the comment
displays along with the comment. Hover over the comment to see the exact day and date the comment
was added.

= Tip: To reply to an existing comment, click Reply on the comment posted.

To add a comment to a report:

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the name of the report and select Properties > Manage All
Report Properties.

3. Click the Comments tab.

4. Add your comment and then click Add. When a comment is added, CDM creates an audit trail
entry for the report. The entry includes details about the user who added the comment.

Edit a Comment in a Report

You can edit comments in reports and maintain an audit trail of modifications that are made to the
comments.

Comments are used to communicate with other users about reports in CDM. Users can modify the
content of a comment at any time. For example, you can include more information, clarify an existing
comment, or fix an error in a comment. Users must have appropriate permission to view comments in
the report.
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The name of the user who edited the comment appears along with the comment. Hover over the
comment to see the exact day and date the comment was edited.

= Tip: When a comment is edited, CDM creates an audit trail entry for the report. The entry
includes details about the user who edited the comment.

To edita comment in a report:

1. Open the report that you want to work with.

2. Inthe report tree, right-click the name of the report and select Properties > Manage All Report
Properties.

Click the Comments tab.
Select the comment that you want to edit.

Click the Edit icon.
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Edit the comment, as needed, and click Save.

Delete a Comment from a Report

You can delete a comment from a report for any reason and maintain an audit trail of deleted comments.

If you no longer need a comment that is associated with a report, you can delete the comment. If the
comment has a reply, you can delete both the comment and all replies, or delete the comment only.

When you delete a comment and leave a reply, the reply remains indented. The name of the user who
deleted the comment is displayed along with the date and time the comment was deleted. CDM also
creates an audit trail entry for the report with details about the user who deleted the comment.

To delete a comment from a report:

1. Open the report that you want to work with.

2. Inthe report tree, right-click the name of the report and select Properties > Manage All Report
Properties.

3. Click the Comments tab.
4. Selectthe comment that you want to delete.

5. Click the Delete icon. If there are replies associated with the comment, you can choose to delete
the comment only, or to delete the comment and its replies.

6. Inthe confirmation message, click Yes.

Attachments

An attachment in CDM is a file that you add to a report object.

You can attach a Microsoft™ Word, Microsoft Excel, Microsoft PowerPoint, or PDF file to any report
object. You can also view or delete attachments in CDM.
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Attach a File to a Report Object

In CDM, you can attach a Microsoft™ Word, Microsoft Excel, Microsoft PowerPoint, or PDF file to any
report object, regardless of whether it is checked out, to provide additional information. For example, a
financial manager might add a PDF file to a report object that outlines the expectations for how to create
or complete the report object.

1.

Open the report that you want to work with.

2. Inthe report tree on the left, double-click the report object to open it.

3. Inthe Report Object tab on the ribbon, click Manage Attachments. The Manage Attachments
window opens.

4. Click Add. The Add object attachment window opens.

5. Click Browse to select a file to attach to the report object.

6. You can change the name you want to assign to the attachment in the Name field. This will not
change the name of the file you are attaching.

7. Specify information in the Description, Provider, Originator, Reference, and Validation Type
fields as you want.

8. You can change the date in the Date received field.

9. If you want to include this attachment when this report object is rolled forward or cascaded to a
new report, select the For Rollforward checkbox.

10. Click OK. The Add object attachment window closes and the attachment is added to the
Available Attachments list in the Manage Attachments window.
9 Tip: You can click the name of the attachment in the Available Attachments list and
click Open to open and view its content. You cannot modify existing attachments.
View an Attachment

In a report in CDM, you can open and view the contents of an attachment.

1.
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Open the report that you want to work with.

Open the report object.

In the Report Object tab on the ribbon, click Manage Attachments.

From the Available Attachments list of the Manage Attachments window, select an attachment.

Click Open. The attachment opens and its contents are displayed.

Edit Attachment Details

In a report in CDM, you can edit the details of an attachment associated with a report object.

1.
2.

Open the report that you want to work with.

Open the report object.
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In the Report Object tab on the ribbon, click Manage Attachments.

From the Available Attachments list of the Manage Attachments window, double-click the
attachment whose details you want to edit. The Properties and Comments window opens and
displays information about the attachment.

In the Properties tab, modify or add details in any of the fields.

Click OK to close the Properties and Comments window and save your changes.

Add or Modify Attachment Comments

In a reportin CDM, you can add a comment to an attachment or modify existing comments.

1.
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6.

Open the report that you want to work with.
Open the report object.
In the Report Object tab on the ribbon, click Manage Attachments.

From the Available Attachments list of the Manage Attachments window, click the attachment to
which you want to add or modify a comment. The Properties and Comments window opens and
displays information about the attachment.

Click the Comments tab, and perform one of the following tasks:

¢ Enter a comment and click Add to add the comment.

« Select an existing comment and click Reply to enter a reply to the comment, Edit to edit the
comment, or Delete to remove the comment.

Click OK to close the Properties and Comments window and save your changes.

Delete an Attachment

If you no longer need an attachment on a report object, you can delete it.

Important: If you delete an attachment, you cannot undo your action. Proceed with caution.

To delete an attachment:

1.
2.
3.

Open the report that you want to work with.
Open the report object.
In the Report Object tab on the ribbon, click Manage Attachments.

From the Available Attachments list of the Manage Attachments window, select the attachment
that you want to delete.

Click Delete to delete the attachment or Delete All to delete all attachments in the list.

Click OK.
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Checklists

You can attach checklists to report objects in CDM. Checklists contain task, reference, or informational
content for users to follow while going through a workflow.

Attach a Checklist to a Report Object

Before you can attach a checklist to a report object, the checklist must have been created and linked to
the report that contains the report object. For information about creating checklists, see the CDM
Administration Guide.

To attaching a checklist to a report object:

1.
2.
3.

6.
7.

Open the report that you want to work with.
In the report tree on the left, double-click the report object to open it.

In the Report Object tab on the ribbon, click Manage Checklists. The Attach Checklist window
opens.

Checklists that can be attached to this report object are displayed in the Available Checklists
and Tasks at Report Level pane. Any checklists that have already been added to this report
object are displayed in the Attached Checklists and Tasks for this Report Object pane.

To attach a checklist to a report object, click its name in the Available Checklists and Tasks at
Report Level pane and either drag it into the Attached Checklists and Tasks for this Report
Object pane or click the down arrow button.

To keep the checklist attached to the report object if the object is rolled forward or cascaded to a
new report, select the Rollforward checkbox.

Click View to see the Description text in a multiline window.

Click OK to save your changes.

Detach a Checklist from a Report Object

You can detach a checklist from report objects if it is no longer needed.

Important: If you delete a checklist, you cannot undo your action. Proceed with caution.

To detach a checklist from a report object:

1.
2.
3.

Open the report that you want to work with.
Open the report object.

In the Report Object tab on the ribbon, click Manage Checklists. The Attach Checklist window
opens.

Any checklists that have already been added to this report object are displayed in the Attached
Checklists and Tasks for this Report Object pane. To detach a checklist from a report object,
click its name in the pane and either drag it into the Available Checklists and Tasks at Report
Level pane or click the up arrow button.

Click OK to save your changes.
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Tasks

In CDM, administrators define tasks in hierarchical lists that users are required to complete.

Tasks are added to task lists in a hierarchical structure. Task lists can coordinate a long process such
as steps required to configure CDM for a 10K/Q report or as simple as a list of set up tasks. A task list
can be ordered or unordered. Ordered task lists contain tasks which must be completed in the same
order as they appear in the task hierarchy. Unordered task lists contain tasks which can be completed in
any order.

Administrators assign permissions to users so they can view task lists and tasks and mark them as
complete. Tasks can be viewed from the Navigation Pane or from the status bar.

Find a Task

If your report contains many tasks, you can easily search for the task that you need.

All tasks in the report that you are viewing are listed in the Tasks tab in the Navigation Pane. To find a
particular report object, you can scroll down the list and then click the report object that you want to work
with. However, if your report contains many tasks, you might prefer to use the search functionality in
CDM.

To find a task using the search functionality:

1. Click the Home tab, then in the Navigation Pane, click Tasks.
2. Click the Search icon in the Tasks tab heading in the Navigation Pane.

3. Inthe search field, type the full name or part of the name of the task that you want to find. You
cannot type special characters in the search field. A search result list of all matching tasks opens
under the field.

4. To focus on the appropriate task, click the name in the search result list. The selected task is
highlighted in the Tasks tab.

View Task Lists and Tasks from the Navigation Pane

You can view a task list and its tasks and subtasks using the Navigation Pane.

1. Click the Home tab, then in the Navigation Pane, click Tasks.
2. The Tasks tab in the Navigation Pane displays all existing task lists.

3. Double-click a task list. The Task List tab opens in the work area, displaying all tasks and
subtasks in the task list.

You can now mark one or more tasks complete or incomplete.

View Task Lists and Tasks from the Status Bar

You can view a task list and its tasks and subtasks using the status bar.

1. Click the Home tab, then in the Navigation Pane, click Tasks.
2. Click Tasks in the status bar.

3. Inthe Select a Task List window, click the drop-down button and select a task list from the menu.
You can see the tasks and subtasks contained in the task list.
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You can now mark one or more tasks complete or incomplete.

Mark a Task as Complete

You can mark a task as complete. Ordered task lists contain tasks that must be completed in the same
order as they appear in the task hierarchy. Unordered task lists contain tasks that can be completed in
any order.

1. Click the Home tab, then in the Navigation Pane, click Tasks. The Tasks tab in the Navigation
Pane displays all existing task lists.

2. Double-click a task list that contains tasks you want to mark as complete. The Task List tab
opens in the work area, displaying all tasks and subtasks in the task list.

3. Perform one of the following actions:

« Select an incomplete task and click Home > Mark Complete.

« Click Home > Mark All as Complete. In the confirmation message, click Yes.

A check mark is displayed in the checkbox for the task name and a line is drawn through the task name
to indicate it is complete.

Mark a Task as Incomplete

You can mark a task as incomplete.

1. Click the Home tab, then in the Navigation Pane, click Tasks. The Tasks tab in the Navigation
Pane displays all existing task lists.

2. Double-click a task list that contains completed tasks you want to mark as incomplete. The Task
List tab opens in the work area, displaying all tasks and subtasks in the task list.

3. Perform one of the following actions:

« Select a completed task and click Home > Mark Incomplete.

« Click Home > Mark All as Incomplete. In the confirmation message, click Yes.

The check mark displayed in the checkbox for the task name and the line through the task name is
removed.

Shared Objects

In CDM, the administrator can select an existing report object and make it available as a shared object.
The report object can then be used in other locations in the same report or in other reports.

A shared object is a report object that is made available for its content to be referenced within the same
report or across reports. Any report object in CDM can be shared within the same report or any other
report.

Copy Objects and Reference Objects

A shared object can be added as a copy of the shared object or as a reference object that is updated
with the shared object.
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A copy object is a copy of a shared object that is added to a new report or new location in the same
report using the Copy option. A copy object exhibits the following behavior:

« If the original report object is modified, the changes do not appear in the copy.
« If the copy report object is modified, the changes do not appear in the original.
« A copy object retains the Share Object setting of the original report object.

« If you open a report by filtering one or more custom groups, a copy object is not automatically
assigned to the custom group or groups.

A reference object is a shared object that is referenced within the same report, or in a different report. A
reference object does not contain its own content. A reference object exhibits the following behavior:

« Reference objects are read-only. You cannot modify the contents of a reference object.
« If the original report object is modified, the changes appear in the referenced object.

« If you open a report by filtering one or more custom groups, referenced objects that are added to
the report are automatically assigned to the custom group or groups.

If a report object name exists when you are adding a copy or reference, the name of the new report
object is appended with a number, such as [2] or [3].

Shared and Reference Object Indicator

Shared and reference objects display a small indicator beside the report object name in the Navigation
Pane. The indicator on a shared object is a little hand ; the indicator on a reference object is a little

arrow . An unshared report object does not display an indicator. You can also hover over a report
object for a tool tip that indicates if that report object is shared or a reference object.

In addition, when a report object references another report object, you can see the following message:

This object is referencing another object.

Shared Objects in Cascaded Reports

When you copy an existing report in CDM, you can use a cascaded report type to refer to shared objects
in the original report.

Cascaded reports contain all the report objects in the original source report. Cascaded reports allow for
single sourcing. For example, you can cascade a report from one fiscal year and use the same report for
a different year.

If the report contains reference objects, you can modify data in the source object in the source report.
The modifications are copied to the reference objects in the cascaded reports.

If needed, you can change the references from the original report to the current, cascaded report or any
other report.

You can also create cascaded reports that are based on other cascaded reports. Each subsequent
cascaded report references the original shared object.
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o Note: All referenced objects in copied reports are read-only.

Exhibits and Supporting Documents

All report object properties (in effect, Printable, Custom Groups, Workflow and Assignment, Due Date,
and so on) are applicable to this section.

All CDM variable types can be used in exhibits and supporting documents.

A snapshot includes all exhibits and supporting documents that are generated along with the report or
any selected report objects.

Click Documents on the Section tab of a Generation Workspace to select and open any exhibits and
supporting documents that were generated with a report or a report selection to Microsoft Word. After
making your selection, the exhibits or supporting documents are opened in separate tabs in the CDM
Workspace.

Exhibits

Exhibits are documents that are typically published or submitted along with the main report. They can
be used to present a detailed disclosure that was briefly covered in the main report, a contract, a plan of
acquisition, merger, reorganization, and so on.

Exhibit Sections

CDM top-level sections (children of the report node in the CDM report outline) can be designated as
exhibit sections by selecting Exhibit in the Section Properties > Print Options section.

Exhibit sections in the CDM report outline are shown as having the exhibit icon
All descendant report objects of an exhibit section are used to create a single exhibit.

When generating a report or report selection to Microsoft Word, Adobe PDF, Edgar HTML, all exhibit
sections are automatically included (the Include Exhibits option does not play any role).

Generated exhibits are given names according to these rules:

« The value that is entered in the Exhibit File Name field of the exhibit section's properties is used.

« If the Exhibit File Name field is blank, the name given to the exhibit section in the CDM report
outline is used.

When opening an exhibit that has been generated to Word, the CDM Workspace tab has the name as

.

previously described along with the exhibit icon

o Note: All CDM report generation features are available to be used for exhibit sections.

Create an Exhibit Section

In a report you can have one or more sections containing multiple report objects defined as exhibit
sections.
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. Open the report that you want to work with.

Determine the location in the report hierarchy where you want to add a section that will be the
exhibit section under which you want to group your exhibits.

Right-click and select Add Child or Add Sibling and then Section.
Enter a name for the section.

Right-click the section and select Properties > Manage All Object Properties and select the
Exhibit checkbox.

Enter an exhibit type, description and file name in the respective Exhibit Type, Exhibit
Description, and Exhibit File Name fields. The information you enter will be displayed in the
manifest that is created upon report generation. Also the Exhibit File Name is used as the file
name for the exhibit document created upon report generation.

Click OK.

Add or import Word or Excel report objects under the exhibit section. They automatically become
designated as exhibit documents.

If you want, you can click and drag any Word or Excel report object in the report and place them
under the exhibit section. They automatically become designated as exhibit documents.

o Note: When you designate a section as an exhibit section, any descendant report objects or

sections currently grouped under that section automatically become exhibit objects. You can
only change their exhibit object designation by clicking and dragging them out from under the
Exhibit Section to another location in the report hierarchy.

Hyperlink to Exhibits

Managing hyperlinks to content being authored can be a hassle. CDM manages the hyperlink to exhibit
files being created regardless of the generation format: Microsoft Word, Microsoft Excel, Microsoft
PowerPoint, Edgar HTML, Adobe PDF, or inline XBRL.

Insert a Hyperlink to an Exhibit Section

In a report, you can have one or more sections containing multiple report objects defined as Exhibit
sections. You can place a hyperlink to an exhibit section in a report object.

1.
2.
3.

6.

Open the report that you want to work with.
Open and check out the report object in which you want to place a hyperlink to an exhibit section.

In the Report Object tab on the ribbon, click Insert Variable > Exhibit. The Reference Variables
pane is displayed, listing all exhibit variables in the report.

In the report object, click on where you want to insert the hyperlink.

In the Reference Variables pane, select an exhibit section variable and click Insert (or double-
click the exhibit section variable). The hyperlink is inserted.

Save and check in the report object.

If the exhibit file name property is set, the exhibit links the report main document to it.


https://insightsoftware.com/

Y insightsoftware 58

If the exhibit file name property is not set, the exhibit links the report main document to the name of the
exhibit section. The exhibit is generated with the file name set to the name of the exhibit section.

Insert a Hyperlink to a Web Object (External URL)

In a report, you can define Web objects as exhibits. You can then place a hyperlink to a Web object
exhibit in a report object.

You can define a Web object as an exhibit by right-clicking on it and selecting Properties > Manage All
Object Properties, and then selecting the Is Exhibit checkbox and clicking OK.

To insert a hyperlink to a Web object:

1. Open the report that you want to work with.

2. Open and check out the report object in which you want to place a hyperlink to a Web object
exhibit.

3. Inthe Report Object tab on the ribbon, click Insert Variable > Exhibit. The Reference Variables
pane is displayed, listing all exhibit variables in the report.

4. Inthe report object, click on where you want to insert the hyperlink.

5. Inthe Reference Variables pane, select a Web object exhibit variable and click Insert (or double-
click the Web object exhibit variable). The hyperlink is inserted.

6. Save and check in the report object.

If you generate the report to EDGAR HTML and open the HTML, hyperlinks point to the selected section
exhibits file when you click the links. Or if you generate in Word and save the generated Word
document, the hyperlinks point to the correct linked files or URL for the Web object.

About Legacy Exhibit Objects

Legacy CDM report objects that have the Exhibit print option selected in the properties are still
supported but not recommended for use. It is recommended that these legacy exhibit report objects be
moved to exhibit sections. If you clear the Exhibit print option for a legacy CDM report object, it becomes
disabled.

Supporting Documents

Supporting documents are mainly used to support or detail facts being presented or to prove statements
being made in a report.

These CDM report objects can be supporting documents:

« Microsoft Excel Workbook objects
« Microsoft Word Document objects

» Microsoft PowerPoint Presentation objects
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Create a Supporting Document
1. Open the report that you want to work with.

2. Determine the location in the report tree where you want to insert a supporting document, and
create the Excel, Word, or PowerPoint object.

3. Right-click the report object and select Properties > Manage All Object Properties. The
Properties and Comments window is displayed.

4. Inthe Report Object Configuration > Print Options section, select the Supporting Document
checkbox.

5. Insert the appropriate content for the supporting document.

How Are Supporting Documents Used

When generating a report or report selection to Microsoft Word, Adobe PDF, EDGAR HTML, or
Microsoft PowerPoint, you can select the Include Supporting Documents option:

« A separate file is generated for each report object that has Supporting Document selected in its
Report Object Configuration > Print Options properties section.

« Optionally, you can choose to merge the supporting documents into the report or report objects
selected for generation. When Include Supporting Documents > Include supporting
documents in the main report is selected, the supporting documents are generated into the
main report file according to their position in the CDM report outline.

If Include Supporting Documents is selected when generating a report or report selection to Microsoft
Word, Adobe PDF, or EDGAR HTML, these report objects are generated as supporting documents:

« Microsoft Word Document report objects with Supporting Document selected as a print option.

 Printranges (enclosed within the ##RS and ##RE combination mark-up) from Microsoft Excel
Workbook report objects with Supporting Document selected as a print option.

If Include Supporting Documents is selected when generating a report or report selection to Microsoft
PowerPoint, these report objects are generated as the supporting documents:

« Microsoft PowerPoint presentation report objects with Supporting Document selected as a print
option.

When opening a supporting document that was generated along with a report or selected report objects
to Word, its CDM Workspace tab has the name of the CDM report object and the supporting document

icon

When a supporting document is saved in a snapshot or locally, the name of the source report object is
used as its file name.

Report Snapshots

A snapshot is the content of a report or report object captured at a specific moment in time.

You can use a snapshot to determine the changes made to a report or a report object over time. If the
snapshot output option is selected when a report is generated, CDM saves a snapshot of the report.
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PDF and Web objects are not included in a report snapshot and cannot be generated as report object
snapshots.

When you generate a filing report, CDM automatically generates a snapshot at the same time. The
snapshot contains the XBRL file and an Excel document with the validation result as a separate
worksheet.

Add a Snapshot

You can use a shapshot to represent the content of a report, report objects grouped in a section, or
report object captured at a specific moment in time.

Important: When you generate a filing report, CDM generates the snapshot automatically, and
you do not need to perform the following procedure.

To add a snapshot in a report:

1. Open the report that you want to work with.

2. Inthe report tree on the left, select the report, a section containing report objects, or one or more
report objects.

Right-click the selection and select Generate Selection.
In the generation window, select a format, for example Microsoft Word.
Under Additional Preferences, select the Save as Snapshot option and enter a description.

Select other options as required.
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Click OK.

Add a Snapshot from the Section Tab

1. Open the report that you want to work with.

2. Inthe report tree, double-click the report or a section containing report objects. The report or
section opens in the work area and the Section Tools area containing the Section tab displays
on the ribbon.

3. Inthe Section tab, click Save as Snapshot.
4. Inthe Save as Snapshot Description dialog, enter a description for the snapshot you are saving.

5. Click OK. The snapshot is saved.

View a Snapshot

You can view a snapshot of a report, a single report object, or multiple report objects, if the Save as
Snapshot option was selected when a report was generated.

Ensure that the report contains the snapshot that you want to view. The report or report objects must be
generated with the Save as Snapshot option.

To view a snapshot of a report:
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4.

5.

. Open the report that you want to work with.

Click Home > View Snapshots.

Select a snapshot, and then click View. The snapshot opens in a specific viewer based on the
format that was selected for the snapshot when it was generated. For example, if you selected
Microsoft Word as the format, the snapshot will open in Microsoft Word for viewing. The View

Snapshots window contains the following information about each snapshot:

+ Report Name - The name of the report used to generate the snapshot.

« Generation Type - The format of the snapshot.

« Description - Any text entered in the Description field when the snapshot was generated.
« Date Created - The date that the snapshot was created.

« User - The user who created the snapshot.

You can sort any column in the View Snapshots window by clicking a column header. Or, for any
column, click the column filter icons to edit your view of the table.

When you are finished with the View Snapshots window, click Close.

Use Snapshots to Compare Versions of a Report or
Report Object

You can use shapshots to compare two versions of a report or report object. When you compare
snapshots, you can see any changes made over time. For example, you can see what was deleted from
an earlier version or what was added to a later version.

To compare versions of a report or report object using snapshots:

1.

Ensure that the report contains the snapshots that you want to view. The report or report object
must be generated with the Save as Snapshot option.

Open the report that you want to work with.
Click Home > View Snapshots.

Select any two snapshots by pressing CTRL and clicking each snapshot. You can sort any
column in the View Snapshots window by clicking a column header. Or, for any column, click the
column filter icons to edit your view of the table.

Click Compare.

The snapshots open in Microsoft™ Word or your PDF viewer, based on the format of the
snapshot when generated.

« If you compare two Microsoft Word snapshots, the first selected snapshot is compared to
the second selected snapshot. The second selected snapshot displays with any differences
identified.

« If you compare two PDF snapshots, each snapshot displays in the PDF viewer. You can
visually inspect the two snapshots for differences.


https://insightsoftware.com/

Y insightsoftware 62

« If you compare a Microsoft Word snapshot and a PDF snapshot, the snapshots open in
Microsoft Word or your PDF viewer. You can visually inspect the snapshots for differences.

Delete a Snapshot

If you do not need a snapshot of a report or report object, you can delete the snapshot.

Important: If you delete a snapshot, you cannot undo your action. The deleted snapshot is no
longer present in the View Snapshots window, and it is removed from CDM. Proceed with
caution.

To delete a snapshot:

1. Ensure that the report contains the snapshot that you want to view.
Open the report that you want to work with.
Click Home > View Snapshots.

Select the snapshot you want to delete, and click Delete.

a > oD

In the confirmation message, click Yes.

Imports and Exports

You can import documents from Microsoft™ Excel, Microsoft Word, Microsoft PowerPoint, and Adobe™
PDF into CDM. You can also export content from Excel objects, Word objects, PowerPoint objects, and
PDF objects into external files.

Import External Content

You can import documents from Microsoft™ Excel, Microsoft Word, Microsoft PowerPoint, and Adobe™
PDF into CDM. There is no direct link to an external file; the imported file is associated with the report,
compressed, and stored in the database.

You must first check out the report object that you want to import content into.

When a report is opened by filtering one or more custom groups, report objects that are created from
imported files are automatically assigned to the custom group or groups.

You can perform the following import tasks:
» Import a document into an existing report object.

Important: When you import content into an existing report object, the imported content
overwrites the content in the report object.

« Import multiple documents as siblings of a report object

When you import Excel content, every worksheet that exists in the file being imported is saved as a new
worksheet in the Excel object. Any changes made to imported data in CDM are reflected only in the
report and are not updated in the original source.
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By design, the source file is not updated dynamically. If changes are made to the source file after it is
loaded into CDM, you need to import it again.

Documents imported as siblings appear as new report objects in the report and are ordered
alphabetically.

You cannot import a document into an existing reference report object. You cannot import a document
as a child of a report object.

To import a document:

1. Open the report that you want to work with.
In the report tree on the left, open and check out the report object that you want to edit.
Click the Section View Mode icon in the status bar.

Unless the report object is the report itself, check out the report object.

a &> w b

To import documents as siblings of the report object, complete the following steps:
a. Inthe report tree, right-click the report object and click Import, then As Sibling.

b. Navigate to the location of the files that you want to import. Select the files and click Open.

6. Toimport a document into the report object, complete the following steps:
a. Inthe Report Object tab on the ribbon, click Import Object. A warning appears that this
action will overwrite the content of the report object.
b. Click Yes to continue.

c. Navigate to the location of the file that you want to import. Select the file and click Open.
The contents of the file are imported into the report object. For example, when you are
importing an Excel file into an Excel object, all worksheets that exist in the file are imported
into the Excel object.

7. Click the Default View Mode icon in the status bar.

8. Check in the report object and save your changes to the report.

Export Report Objects

You can export content from Excel objects, Word objects, PowerPoint objects, and PDF objects from
CDM into external files.

With this export process, there is no direct link to the database. The information contained in CDM is
uncompressed and extracted from the database.

If the name of a report object contains invalid characters, is too long, is duplicated, or if the report object
does not have a name, a warning window opens. If the name of the report object contains invalid
characters, is too long, or is duplicated, CDM adapts the original name to create an acceptable name. If
the original report object does not have a name, CDM creates a new hame.

Any changes that are made to the data in CDM are reflected in the report only; they are not updated in
the exported file.

By design, information extracted from CDM is not updated dynamically. If there are changes to the data
in CDM, after export, you must export the data again.
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You do not have to open a report object to export it. In addition, you can export report objects that are
currently checked out by other users. When you export a report object that is checked out, the exported
report object reflects the last saved changes to the report object at the time of the export.

To export report objects:
1. Open the report that you want to work with.
2. Open and check out the report object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Inthe report tree, select the report object that you want to export. To export multiple report
objects, press either SHIFT or CTRL and click the report objects.

5. Inthe Report Object tab on the ribbon, click Export Object. You can also right-click the report
object and click Export.

6. Navigate to the location where you want the export file to be saved.
7. Click the Default View Mode icon in the status bar.

8. Click OK.

The report object is exported to an external file. The file has the same name as the report object.

Report Output

You can generate your report in CDM in several formats such as Excel, Word, PDF, and HTML. Before
you generate output from an Excel object, you can also preview the output to ensure all content is
correct.

Report Output Formats
You can generate your report in the following formats:

« Microsoft Excel
You can generate the report as a Microsoft™ Excel document.

« Microsoft Word
Microsoft Word is the default output format. When you generate the report as a Microsoft Word
document, all report presentation details are applied. PowerPoint objects, Web Page objects,
and PDF objects are not included in Microsoft Word output.

» Microsoft PowerPoint
Unlike Microsoft Word or PDF output, when you select Microsoft PowerPoint as the output
format, only PowerPoint objects are included in the output. This behavior applies to both the
Generate Entire Report and Generate Selected Objects options. Word objects and Excel objects
are not included in the Microsoft PowerPoint output. If a PowerPoint object includes references to
external data, such as a graph in an Excel object, the referenced object is included in the
Microsoft PowerPoint output.

« Adobe PDF
Like output to a Microsoft Word document, output to a PDF document includes all report
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presentation details. The PDF format provides a high-resolution output for printing. PowerPoint
objects, Web Page objects, and PDF objects are not included in PDF output.

Email with PDF Attached
You can generate a PDF document and send it to one or more recipients. The PDF document is
the same as a document created by using the Adobe PDF output option.

High Definition HTML
You can generate a high definition .htm version of your Word reports.

EDGAR HTML
If you use the EDGAR feature in CDM, you can generate a document in HTML format suitable for
use with the EDGAR feature.

Desktop Publishing
If you use the desktop publishing feature in CDM, you can generate a document in XML format
suitable for use with a desktop publishing application such as Adobe™ InDesign.

XBRL Instance

You can generate an XBRL instance document for your filing reports. An XBRL instance
document is a business report prepared using the XBRL standard. It refers to a specific
taxonomy entry point and it is the combination of the XBRL instance document and the taxonomy
that enables the contents of an XBRL instance document to be fully understood.

XBRL CSV

You can generate an xBRL-CSV report for your filing reports. An xBRL-CSV report is a type of
XBRL report that uses the simple and efficient CSV file format. Due to its compact size, xBRL-
CSV is particularly well suited to tabular reports with a large number of facts.

Preview an Excel Object

Before you generate output from an Excel object, you can preview the output. You might find this useful
to ensure that all content appears correctly, especially if the Excel object contains ## variables.

To preview an Excel object:

1.

2
3
4.
5
6

Open the report that you want to work with.

. Open the Excel object.

In the Report Object tab on the ribbon, click Generate & Preview > Preview.
In the Preview window, confirm that the content appears correctly.

If necessary, check out the Excel object and make changes.

. When the content appears correctly in the preview, you can generate the Excel object.

Specify Regional Settings for Report Output

Users granted the Modify Report permission can set the preferred Language and Region Options in
the report properties that will be used to generate Excel print areas and variables to Microsoft Word,
Microsoft PowerPoint, Adobe PDF and Edgar HTML.
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When generate a report, users are still able to select a different language and region option than the
preferred option.

ELI_ Generate Entire Report )

Select Format -
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When no Language and Region Options is set in the report properties, or selected on generation, the
default language and region that is set on the CDM application server is used, making the default
behavior identical with the one from previous versions.

Validate Report Output

As you are working with a report in CDM, you can validate the report periodically to find errors that can
cause report generation to fail.

While you are compiling the report, a full validation can cost time and is rarely needed. Therefore two
types of validation are available: Quick Report Validation and Full Report Validation. The quick
validation is made against the cache without doing a cache refresh. The latest changes in the report are
validated. A full validation refreshes the cache before validation. In either case, before generation of a
report, the report is automatically validated.

To validate a report:

1. Open the report that you want to work with.

2. Click the parent report and click Home > Validate and select one of the following actions: Quick
Report Validation and Full Report Validation.

3. Click OK to start the validation.

= Tip: You can view the progress in the All processes completed window in the status
bar. While processes are running, the title bar shows the number of running processes.
When the processes are finished, the title is All processes completed.

4. To open the validation file, open the All processes completed window in the status bar, and click
the Open icon. A check mark indicates that a process generated properly. An exclamation point
indicates an error that stopped the process.
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Generate Report Output

You can generate output from CDM to test the report building progress or to create a document for
internal or external reporting. You can also generate output containing macros and for the EDGAR
feature or desktop publishing applications such as Adobe™ InDesign, if you use those features.

o Note: When you generate an inline document or submission package, you can choose to save
temporary files on the server (associated to the long running process). These files are saved
in a Support Files folder (the XPS file will not be included). To do this, enable Include Certent
CDM support files during generation in the Options window (to access the Options window,
click Options on the File tab).

Before you generate report output, you should verify that the print setting is correct for Word, Excel, and
PowerPoint objects. Only report objects that are set to Printable are included in the report output. As
additions to the main report, you can generate separate documents for report objects that are set to
Supporting Document or Exhibit. The administrator must configure and enable email notifications to
support the Email with PDF Attached report output option.

When you generate a report, all report presentation details are applied, such as page setup properties,
note variables, and table of contents settings. You can customize report generation to provide the
following results:

« Generate the report by selecting one or more custom groups.

« Include supporting documents and exhibits. Supporting documents can be generated as
separate documents or included in the main report. Exhibits are grouped in an Exhibit section
and are combined into a single document at generation. You cannot include supporting
documents and exhibits with Microsoft™ PowerPoint output.

« Create a report snapshot. Report snapshots are useful for tracking changes to reports.

Refresh data to include the most recent information from data sources, variables, and reference
report objects in the generated report. The use of cached data is useful to reduce generation time
because the server does not have to contact data sources and update all their values.

Generate the report for all Excel objects or selected Excel objects.

If you select all Excel objects, you generate all content from the printable range (##RS-##RE) in
all Excel objects in the report to an external Excel file at the highest version of the Microsoft Office
version available in the report. If you make a selection of Excel objects, you generate the
selected content from the printable range in the Excel objects in the report to an external Excel
file at the highest version of the Microsoft Office version available in the report.

You can also specify to have multiple workbooks for the output. If you select Use Separate
Workbooks, then you must specify the number of worksheets in each book. For example, if you
make a selection of 100 printable ranges and 25 worksheets per workbook, you generate four
workbooks, each with 25 worksheets. The naming convention of each worksheet for the
workbook follows the convention objectName_rangeNumber and is limited to 31 characters.

« If you generate a report or report object in Microsoft Word or PowerPoint format in Microsoft
Office Version 2007 or later, and if you choose Microsoft Word or PowerPoint as your output
format, you can choose to generate charts as either images or objects.
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You can specify the culture to be considered for date formats, number formats, and currency
formats. The culture is in the form of language and regional settings that are applied to Excel
report objects in the generated report. The setting is available for the report output types:
Microsoft Word, Microsoft PowerPoint, Adobe PDF, and EDGAR HTML.

When you generate a section of a report, the header from a previous section is sometimes
generated even if the header is not associated with the generated section.

The list of macros that can be selected for a particular generation are filtered based on the
macros' target (Excel or PowerPoint) when the macro was created. The generated report
contains the selected macros in separate modules for each macro. The modules have the
macros' names from CDM. When generating a report, the all processes window differentiates a
macro generation from a regular generation. If at generation time, an empty macro (in effect, the
user added a name and target and optionally a description but no VBA code) is selected for
insertion, a warning is displayed when opening the generation in CDM.

To generate report output:

1.
2.
3.

Open the report that you want to work with.

Click the Home tab, then in the Navigation Pane, click Administration.
Double-click Reports. The Reports tab opens in the work area.

To generate the entire report, complete one of the following actions:

« Right-click the report name and click Report Generation > Entire Report.
« Click Home > Generate > Generate Entire Report.

To generate one or more Word objects or PowerPoint objects without generating the entire
report, complete one of the following actions:

« Right-click the Word or PowerPoint object or objects and click Report Generation >
Selected Report Objects.

« Open the Word or PowerPoint object. Then, in the Report Object tab on the ribbon, click
Generate.

To generate one or more Excel objects without generating the entire report, complete one of the
following actions:

« Right-click the Excel object or objects and click Report Generation > Selected Report
Objects.

« Open the Excel object. Then, in the Report Object tab on the ribbon, click Generate &
Preview > Generate.

= Tip: If you use this method, you can choose to preview the Excel object first, to
see if it appears correctly before you generate. To do so, click Generate &
Preview > Preview.
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7.

Select the format, custom group, additional preferences, and macros that are to be included.
Alternatively, you can double-click a format icon to generate the report in the selected format with
the current options.

= Tip: The generation of a report always starts with a validation. You can check Perform
Full Refresh to refresh the cache before validation.

Specify how you want to generate charts:

« If you generate charts as images, you can view the information in your generated report, but
you cannot change it afterward. This option might result in better rendering of advanced
chart types such as 3D charts and rounded edges. To generate charts as images, make
sure that the Generate charts as images checkbox is selected. This is the default selection
for Microsoft Office version 2007 or later.

« If you generate charts as objects, the appearance of the chart is clearer, and you can click
the content afterwards and edit it, if necessary. However, it might take longer to process
your report if you generate charts as objects. To generate charts as objects, make sure that
the Generate charts as images checkbox is cleared.

= Tip: In Windows™ Server 2003, generated charts appear wider than the original ones. If
you use Windows Server 2003, you might prefer to generate charts as images.

To save a snapshot of the report, select Save as Snapshot.

Use the Select Language and Region Option drop-down list to select the culture option for your
generated report.

11. If you want to see the appearance of variables before you proceed, click Preview.

o Note: No matter which versions of Office are used in your system, when you preview a
report or report object by clicking the Preview button, you can see charts only as
images. However, when you actually generate the report or report object, if you use
Office 2007 or later, you can generate charts as either images or objects.

12. Click OK.

Excel objects in the report might contain more than one data worksheet. (The first data worksheet is
originally named Sheet1, but it might have been renamed.) If there are multiple ##RS and # #RE range
variables applied in the same worksheet, or across different worksheets, the content is read from left to
right and then top to bottom when it is generated in the final document. At that point, all the printable
ranges inside the Excel object are separated by one blank row.

o Note: A ##RS-##RFE range cannot overlap with other ##RS-##RE directives when you are

defining a worksheet with multiple ranges.

CDM creates the output file on your computer. For example, on Microsoft Windows 7, the report is
added to the C: \Users\username\AppData\Local\Temp directory. The output file is not added to
the CDM database.
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If you selected macros to be included in the generated report, the resulting workbook or presentation is
macro-enabled (for example, XLSM, PPTM) and contains those macros.

When you open a report, you can choose to save it. If you do so, and then you open it again, the report
opens from the location that you specified; otherwise, it opens from a temporary location.

Audit Trails

An audit trail is a detailed analysis of all changes that are made to reports or report objects. CDM
supports blacklining. The Audit Trail feature records every submission to the CDM database, along with
the user name and the date of submission.

You can use an audit trail to view a list of all changes submitted by users for a report object. You can
also view a version of a report object in the application it was created in, or compare two versions of
Word or Excel objects.

View an Audit Trail

You can create an audit trail for a report object in CDM, and use the audit trail to view a list of all
changes for the report object.

1. Open the report that you want to work with.

2. Inthe report tree on the left, double-click to open the report object that you want to create an
audit trail for.

3. Inthe Report Object tab on the ribbon, click Object Audit Trail. The Report Object Audit
window opens.

4. You can perform several types of tasks with the data:

« To view report object versions in the application they were created in, select a version of the
report object and click View.

« To compare two versions of Excel or Word objects, select two versions of the report object
and click Compare.

« To copy the data into Microsoft Excel for further analysis, click Export to Microsoft Excel.

View Versions of a Report Object

You can view versions of a report object in CDM in the application that the report object was created in.

1. Open the report that you want to work with.
2. Open the report object that you want to view versions of.
3. Inthe Report Object tab on the ribbon, click Object Audit Trail.

4. Inthe Report Object Audit window, select a version of the report object and click View. The report
object opens in the application that it was created in.

Compare Two Versions of a Report Object

You can use the audit trail from an Excel, Word, or PowerPoint object to compare two versions of the
object in CDM.
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Open the report that you want to work with.
Open the Excel, Word, or PowerPoint object that you want compare versions for.
In the Report Object tab on the ribbon, click Object Audit Trail.

In the Report Object Audit window, click the two versions that you want to compare while
pressing the CTRL key.

Click Compare. The comparison works differently depending on what type of report object you
are comparing.

« If you are comparing two Word objects, the two versions open in a comparison view within a
single instance of Microsoft™ Word.

« If you are comparing Excel object versions or PowerPoint object versions, click Open
Containing Folder to find the two versions of the Excel files and open the files for
comparison. Alternatively, click Open Documents and the two versions will open in
separate instances of Microsoft Excel.

Restore Version from Audit for Word, Excel, and
PowerPoint Objects

You can use an audit trail to restore an earlier version of all changes for a Word, Excel, or PowerPoint
report object in a report in CDM. When you restore an earlier version it becomes your working copy. All
versions still exist in the CDM database and can also be restored as required.

To restore a report object version from an audit trail:

1.
2.
3.

Open the report that you want to work with.
Open the Excel, Word, or PowerPoint object of which you want to restore an earlier version.
Click Object Audit Trail in the Report Object tab on the ribbon.

In the Report Object Audit window, select an audit version and click View to identify it as the
version you want to restore.

With the identified audit version selected, click Restore.
A prompt is displayed to confirm the restore is completed. Click OK to close the prompt.

The Report Object Audit window displays the restored version with an updated time stamp and
Restore Object from Audit displayed in the Operation Type column.

Close the Report Object Audit window. The report object displays content from the version you
restored.

o Note: Desktop publishing and XBRL tags that have been created on the report object after the

creation date of the restored audit entry are orphaned and need to be recreated.
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Report Objects

A report object is a type of content in a report. Report objects represent most of the content of your
reportin CDM.

There are five types of report objects: Excel object, Word object, PowerPoint object, PDF object, and
Web Page object. Depending on the kind of content that you want to add to your report, you must select
the appropriate type of report object. For example, if you want to insert columns of data, an Excel object
would be appropriate; if you want to add paragraphs of text, a Word object would be more suitable.

For Excel objects, Word objects, and PowerPoint objects, you work in the report object in exactly the
same way that you would work in Microsoft™ Excel, Word, or PowerPoint. Certain functionality might not
be available unless your administrator provides you with access.

You can work with CDM in Arabic and Hebrew, if you prefer. These languages are considered
bidirectional because the main text direction is right-to-left, but some content should appear left-to-right.
You can display certain types of content in the direction that you prefer in your user interface in Arabic or
Hebrew. You can also apply digit shaping to numbers in your user interface in Arabic. If you want, you
can apply similar preferences to your Excel, Word, and PowerPoint objects. For more information, see
the Microsoft documentation.

Tasks for All Types of Report Objects

A report object is a type of content in a report in CDM. Some tasks that you perform on report objects
are similar for all types of report objects; other tasks are specific to the type of report object.

For example, you can add comments to all types of report objects, regardless of the report type. On the
other hand, you can perform certain types of calculations on data in Excel objects only.

Copy and Past Report Objects

You can copy and paste report objects and their properties in various ways.

You can right-click the report object in the report tree and click Copy, and then click one of the following
items to perform various copy actions:

« Report Object
Copies the report object. You can paste the report object before or after another report object by
right-clicking the report object, clicking Paste, and then clicking Before or After.

Important: You cannot paste report objects from one report to another report. You can
only paste a report object to an other place in the same report.

« Properties
Copies the report object properties. You can paste the report object properties into another report
object by right-clicking the report object, and then clicking Paste, followed by clicking Properties.
When pasting into a different report object type, only the common properties are pasted.

« Objectas a Link
Copies the report object as a link. This action allows you to send the location of the report object
as a URL. When a user clicks the URL, the report object opens directly in CDM if the user has the
appropriate View Report permission.
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Open a Report Object as Checked In

You can open a report object as checked in. A report object that is checked in can only be viewed and
cannot be edited until it has been checked out.

o Note: Double-clicking on an Excel report object opens it in Open mode (checked in and
variables resolved). By default, double-clicking on a Word or PowerPoint report object opens
them in Preview mode (checked in and variables resolved). You can change this default by
changing the value in the Report Object Double Click Action field in the Files > Options >
General section so that a Word or PowerPoint object opens in Open, Edit, or Preview mode.

To open a report object as checked in:

1. Open the report that you want to work with.

2. Inthe User Object Summary tab, select the report object you want to open checked in and
double-click or click Open. The report object is opened and checked in.

Open a Report Object as Checked Out

You can open a report object as checked out. A report object that is checked out can be edited.

o Note: Double-clicking on an Excel report object opens it in Open mode (checked in and
variables resolved). Double-clicking on a Word or PowerPoint report object opens them in
Preview mode (checked in and variables resolved).

To open a report object as checked out:

1. Open the report that you want to work with.

2. Inthe User Object Summary tab, select the report object you want to open checked out and click
Edit. The report object is opened and checked out.

For Excel report objects that are opened as checked out, variables in the object are shown as resolved
(that is, how they will look when the report is generated). For Word or PowerPoint objects, variables are
not resolved until you check the object in.

Find a Report Object

If your report contains many report objects, you can easily search for the report object that you need.

All report objects in the report that you are viewing are listed in the report tree. To find a particular report
object, you can scroll down the list and then click the report object that you want to work with. However,
if your report contains many report objects, you might prefer to use the search functionality in CDM.

To find a report object using the search functionality:
1. Open the report you want to work with.
2. Click the Search icon in the Report tab heading in the Navigation Pane.

3. Inthe search field, type the full name or part of the name of the report object that you want to find.
You cannot type special characters in the search field. A search result list of all matching report
objects opens under the field.
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4. To focus on the appropriate report object in the report tree, click the name in the search result list.

5. The selected report object in the report tree is highlighted. If the report object is checked out to
you or to another user, this information is visible when you hover over the name of the report
object. If the report object is checked out to you, the name of the report object is green and bold.

Rename Report Objects

You can right-click a report object in the report tree, click Rename, and then specify a new name for the
currently selected report object.

Include or Exclude Report Objects in a Generated
Report

Print options can be used to control print and print-type properties for report objects and sections.

Printable Property
You include or exclude report objects from a generated report by using the Printable property.

You can set the Printable property for an individual report object to include or exclude it from a
generated report. You can also set the Printable property for a section to include or exclude all its report
objects and subsections from the generation.

When a section is set to Not Printable, the descendant report objects and sections appear as Not
Printable. The section descendants' Printable property is grayed out and you cannot change their
Printable property.

The explicit Printable property of report objects and sections is maintained in CDM, therefore, you can
change the Printable property of a parent section without modifying the Not Printable property of a
report object that is not to be printed.

Variables defined in Microsoft Excel objects that are Not Printable are still resolved when referenced in
other CDM report objects.

Print Type Property

You can use the Print Type property to determine if Microsoft Word, PowerPoint, and Excel objects or
sections are to be generated in the main report, in an exhibit, or are supporting documents.

When adding or importing a child report object or section to an exhibit section, the Print Type property is
automatically set to Exhibit. The report object or section is included in the generation of the exhibit
section. This property can not be changed. Such report objects can be additionally marked as Exhibit
Supporting Document using the report object properties.

In all other scenarios, the default Print Type for newly created or imported report objects and sections is
to be included in the main report. Such report objects can be additionally marked as Supporting
Document using the report object properties. You can then use the Include Supporting Documents
and Include supporting documents in the main report generation options to control how supporting
documents are generated and accessed.
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Set the Printable Property for a Report Object or Section
1. Open the report that you want to work with.

2. To exclude a single report object from generation, right-click it and select Properties > Printable
> Not Printable.

3. To exclude all of descendant report objects in a section, right-click the section and select
Properties > Printable > Not Printable.

4. To make a report object or section eligible for generation again, right-click and select Properties
> Printable > Printable.

= Tip: When sections or report objects in a report are set as Not Printable, their names in the
report tree become lighter and more transparent. You can also set a report object or section as
Not Printable in their Properties and Comments window (right-click and select Properties >
Manage All Object Properties and clear the Printable checkbox).

Push Report Objects Down to Cascaded Reports
You can push down one or more report objects from a master report to cascaded reports.

« In the destination report, you need permission to view the report and to add report objects.

« In the source report, you need permission to push down report object updates and to create
report objects.

As you add new report objects to a master report, you can add copies of these report objects to any
cascaded reports by pushing the report objects down.

In a cascaded report, pushed-down report objects appear in the report tree under the Pushed Down
Objects heading. Report objects under this heading are not included when you generate the report. If
you want to include any pushed-down report objects in a generated report, drag the report objects to a
different part of the hierarchy.

To push report objects down to cascaded reports:

1. Open the report that you want to work with.

2. Inthe report tree, right-click the report object that you want to push down to the cascaded reports
and select Pushdown.

= Tip: If you want to push down more than one report object at once, press CTRL and
select multiple report objects. Then right-click in the report tree and select Pushdown.

3. Select the checkboxes for the cascaded reports that you want to push the report object down to,
and click OK.

4. A copy of the report object is pushed down to the cascaded reports. If you push down a report
object that already exists in the cascaded report, a number is added to the name of the report
object.

o Note: By default, pushed-down report objects are not printable.
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Report Object Properties

In CDM, you can view and modify report object properties to tailor the report object in a specific way.

Properties of a report object are the general properties of the object, the related dates of the object, and
the report object configuration.

Edit the Properties of a Report Object

1. Open the report that you want to work with.

2. Inthe report tree, right-click the report object and click Properties > Manage All Object
Properties.

3. Inthe Properties tab of the Properties and Comments window, edit the properties as you want.
You can change any property that is not gray.

4. Click OK.

You can view or edit the following information:

Property Report Object Type Description

User specified name for the report object.

Name All Each report object or section must have a
unique name.
Report Object Due Date All The due date of the report object.

If selected, the report object inherits the due
date from its parent section due date or the
report due date, depending on its position in
the report hierarchy.

Inherit Due Date All

Workflow Due Date All The due date of the current workflow.

If selected, the report object inherits the
workflow due date from its parent section
Inherit Workflow All workflow due date or the report workflow due
date, depending on its position in the report
hierarchy.

The document type for the current Word
object.

» Page Setup - Defines the Word object
as a page setup object that can
enforce certain styles and formatting

Document Type Word throughout the entire report.

« Normal - Defines the Word object as a
normal page.

» Header - Defines the Word object as a
header.
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Property Report Object Type | Description

o Note: When you generate a
section of a report, the
header from a previous
section is sometimes
generated even if the header
is not associated with the
generated section.

» Footer - Defines the Word object as a
footer.

Header Footer Placement - Enabled
when you select header or footer. You
can display the header or footer on
odd or even pages.

» Footer Reset Style - Enabled when
you select Footer. This setting defines
the style used for page numbers.

» Page Reset Number - Enabled when
you select Footer. This setting controls
how many pages are reset when you
define the page number. For example,
you browse to the Word object and by
using the context menu, you click
Properties. You can define the
number of pages that you need to
reset the overall page number by using
this option. This is useful when you
require the page numbers to reset to
Page 1 after you create a specific
number of report objects.

The print options for the current report object.

 Printable - When the report is
generated, the report object is printed.

. . Excel, W . .
Print Options xcel, Word, and * Not Printable - When the report is

PowerPoint o
generated, the report object is not
printed. An icon in the report tree
beside the report object name
indicates that the report object is not
printable. Web Page and PDF objects
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Property

Report Object Type

Description

are automatically not printable.

e Exhibit - This is a read-only checkbox.
Itis shown as selected if the report
object is grouped with other exhibit
report objects under an Exhibit section.
When the report is generated, the
report object is combined with the
other exhibit documents in the Exhibit
section into one document seperate
from the report. An exhibitis a
mandatory document that is required
by the regulatory body, along with the
report itself.

« Supporting Document - If selected,
when the report is generated, the
report object is printed as a separate
document. Optionally, a supporting
document can be included as part of
the report content at generation. A
supporting document is an additional
optional document that a company
chooses to submit along with the
mandatory content.

Break Type

Excel, Word, and
PowerPoint

When you specify a break type, you can
specify the number of pages, rows, or slides
to use for spacing.

You cannot assign break types to Web Page
and PDF objects because these report
objects are not included in the generated
report.

Continue with Next

Word

Specifies a string of text that is displayed on
the second and later pages of a report if the
current report object that contains a note
variable heading exceeds one page.

ToC Variable

Excel, Word, and
PowerPoint

Defines a table of contents variable for the
report object.

You cannot assign ToC variables to Web
Page and PDF objects because these report
objects are not included in the generated
report.

Note Type

Excel and Word

Specifies the note types that the report uses.
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Property

Report Object Type

Description

+ Automatic - Enables the Note Variable
field.

+ Manual - Enables the Note Number
and Note Variable fields.

° You can use the Note Number
field to enter the value of the note
number required.

° You can use the Note Variable
field to specify the name of the
variable that is associated with
this note.

You cannot assign note variables to Web
Page and PDF objects because these report
objects are not included in the generated
report.

Active User

All

Displays the user who checked out the
current report object.

Current Workflow State

All

Shows the current workflow state of the
report object.

Share Report Object

All

Marks the current report object as shared and
makes the report object visible in the window
that opens when you add reference objects.
When a report object is set as shared, an icon
in the report tree beside the report object
name indicates that the report objectis a
shared object.

Include in XBRL Inline
Generation

PDF

Specifies whether to include the PDF content
in XBRL inline generation. This feature is only
available for ESMA jurisdiction. It allows you
to add supplementary documents to an
annual filing to meet a jurisdictional
compliance requirement.

» Do notinclude - Specifies not to
include the PDF.

* Include before - Specifies to stitch the
PDF content at the beginning of the
generated document.

« Include after - Specifies to stitch the
PDF content at the end of the
generated document.
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Property ‘ Report Object Type | Description

When multiple PDF objects are included
before/after the generated document, they
will be stitched at the beginning/end of the
document, in the same order they are found
in the report tree. The PDF content will
always start on a new page.

o Note:

« You can modify properties for a report object only if you have checked it out and have
permission to modify report object properties. You cannot modify report object
properties if the report object is checked out by another user. Also, if a report object is
checked out and the session state is invalid, for example as a result of a crash, you
cannot modify report object properties, until the object is forcefully checked back in.

« If you use CDM in Arabic and you select Contextual for Digit Shaping in the Options
window, some dates in report properties might appear with European number shaping.
The dates that might appear with European number shaping are those that are selected
through a calendar field in CDM.

Lock the Properties of a Report Object

In CDM, you can prevent a report object from being edited or updated. Locking a report object prevents
any updates to variables, data queries, and reference objects when new information becomes available
in the source. This is useful when the report object does not require a refresh for new information, for
example, if the user is nearing quarter close when data needs to be finalized.

1. Open the report that you want to work with.
In the report tree, right-click the report object that you want to lock.

Click Properties > Locked > Lock.

WD

Click OK.

To unlock the report object, repeat the steps and click Unlock.

= Tip: You can also lock a report object by using the Edit workflow window, or by selecting the
object from the report tree and then clicking Home > Lock.

Copy the Properties of a Report Object to Other Report
Objects

In CDM, you can copy the properties of one report object, and then paste those properties into one or
more other report objects. For example, if you want to apply the enforcement settings of one report
object to other report objects, you can apply the properties in the original report object to one or more
other report objects.

1. Open the report that you want to work with.

2. Inthe report tree, right-click the report object that contains the properties you want to copy.
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3. Click Copy > Properties.

4. Inthe report tree, select one or more report objects that you want to have the same properties,
and click Paste > Properties.

5. Inthe confirmation message, click OK.

The properties that you copied from the original report object are pasted into the destination report
object, except for the name property. If the original report object is a different type from the destination
report object (for example, if you copy from an Excel object and paste to a Word object), only properties
that are common to both the Excel object and the Word object are pasted into the destination report
object.

Comments in a Report Object

A comment is a message that you can add to a report object in CDM to share information with other
users.

Comments can be used in report objects to communicate about specific information about that item.
You can view, add, edit, and delete the comments in report objects.

You can view the comments as a list or in a tree view, with replies under the original comments. To
toggle between the two views in the Comments tab, click View as List or View as Tree.

» View as List
Presents all comments listed by date, starting with the oldest comment.

+ View as Tree
Presents all comments in a tree view, in which replies to comments are shown under the original
post and slightly indented.

You can also use comments associated with the entire report.

Add a Comment to a Report Object

You can create comments in report objects to communicate with other users about specific content in
the report object.

You can add text comments to report objects, which can be seen by users that work in that report object.
Comments are not included in the generated report.

You need permission to view comments in report objects. The name of the user who added the
comment displays along with the comment. Hover over the comment to see the exact day and date the
comment was added.

= Tip: To reply to an existing comment, click Reply on the comment posted.

To add a comment to a report object:

1. Open the report that you want to work with.
2. Inthe report tree on the left, select the report object where you want to add a comment.

3. Right-click the name of the report object and select Properties > Manage All Object Properties.
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4. Click the Comments tab.

5. Add your comment and then click Add. When a comment is added, CDM creates an audit trail
entry for the report object. The entry includes details about the user who added the comment.

= Tip: You can also add a reference comment to a report object. To add a reference comment,
select content within the current report object, and then click the arrow in the Add icon and
select Add with Reference. After you add and confirm the message, the comment specifies
the content that was referenced. Referenced comments are static references. If the item is
changed, the reference is not updated.

Edit a Comment in a Report

You can edit comments in report objects and maintain an audit trail of modifications that are made to the
comments.

Comments are used to communicate with other users about report objects in CDM. Users can modify
the content of a comment at any time. For example, you can include more information, clarify an existing
comment, or fix an error in a comment. Users must have appropriate permission to view comments in
the report object.

The name of the user who edited the comment appears along with the comment. Hover over the
comment to see the exact day and date the comment was edited.

= Tip: When a comment is edited, CDM creates an audit trail entry for the report object. The
entry includes details about the user who edited the comment.

To edita comment in a report:

1. Open the report that you want to work with.

In the report tree, select the report object that contains the comment that you want to edit.
Right-click the name of the report and select Properties > Manage All Object Properties.
Click the Comments tab.

Select the comment that you want to edit.

Click the Edit icon.

N o o > w b

Edit the comment, as needed, and click Save.

Delete a Comment from a Report Object

You can delete a comment from a report object for any reason and maintain an audit trail of deleted
comments.

If you no longer need a comment that is associated with a report object, you can delete the comment. If
the comment has a reply, you can delete both the comment and all replies, or delete the comment only.

When you delete a comment and leave a reply, the reply remains indented. The name of the user who
deleted the comment is displayed along with the date and time the comment was deleted. CDM also
creates an audit trail entry for the report object with details about the user who deleted the comment.
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To delete a comment from a report object:

1. Open the report that you want to work with.
In the report tree, select the report object that contains the comment that you want to delete.
Right-click the name of the report and select Properties > Manage All Object Properties.
Click the Comments tab.

Select the comment to delete.

o a &~ w N

Click the Delete icon. If there are replies associated with the comment, you can choose to delete
the comment only, or to delete the comment and its replies.

7. Inthe confirmation message, click Yes.

Work with Excel Objects

Excel objects are primarily used to work with data values in CDM.

When an Excel object is added to a report, the Excel object has no data. You can reference and display
data from the database or an external source in the Excel object and add data manually.

o Note: Any Alt Text added to Excel object charts, tables, name ranges, or print areas is
maintained when referenced in generated Word objects.

Important: Excel objects in CDM have the same functionality as Microsoft™ Excel. The
advanced functionality for Microsoft products is beyond the scope of this guide. However,
some topics are included for your convenience. For more information, see the Microsoft
documentation. Depending on the version of Microsoft Excel that is installed on your
computer, some of the steps that you must follow might vary slightly.

Excel Object Worksheets and Data

In CDM, every Excel object that is added to a report has a Database worksheet and one or more data
worksheets.

A Database worksheet is used to contain values retrieved from an OLAP or relational database source
or from an external Excel file source. Database worksheets are read-only and cannot be formatted or
modified by users.

A data worksheet can be used to present data values in the report. The data worksheet is originally
named Sheet1, but you can rename it if necessary.

You can use formulas to reference data contained in the Database worksheet. You can also include text
or data in the data worksheet. You can add extensive formatting and formulas to enhance presentation
of the information and perform further calculations. You can also add additional worksheets as required.

To switch between worksheets, click the worksheet tab in the Excel object.

You can use the functionality of Microsoft™ Excel formulas in an Excel object. There are hundreds of
formulas available.
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Add a Worksheet to an Excel Object

You can add another worksheet to an Excel object in CDM.

1.

@ &~ b

o

7.
8.

Open the report that you want to work with.

Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

Right-click any worksheet tab in the Excel object and insert a new worksheet.

Select the newly added worksheet from the list, double-click the worksheet tab, and enter a new
name.

Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Change the Order of Worksheets in an Excel Object

You can arrange the order of worksheets in an Excel object in CDM.

1.
2.

© N o u

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

To select the worksheet tab that you want to move, click and hold the left mouse button and drag
the worksheet tab to the desired location.

Release the left mouse button.
Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Delete a Worksheet from an Excel Object

If you no longer need a worksheet in an Excel object in CDM, you can delete it.

1.
2.
3.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Right-click the worksheet tab in the Excel object and delete. Ensure that the worksheet that you
are deleting is not a data worksheet such as Sheet1. Data worksheets must be edited or deleted
from the Manage Data Queries window.

Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.
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Protect a Worksheet in an Excel Object

There might be certain parts of a report that you do not want other users to modify, for example,
compliance checklists. You can use cell locking in an Excel object in CDM and then apply password
protection to prevent modification.

If you want to protect a worksheet in an Excel object, always use a password; otherwise, users can
unprotect the worksheet and cells are not locked.

To protect a worksheet in an Excel object:

1. Open the report that you want to work with.
2. Open and check out the Excel object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Find the protection area and enter a password to further protect the worksheet. To customize
other actions that a user can perform while the worksheet is locked, select the appropriate
checkboxes.

At the prompt that appears, enter the password again. Apply the settings to the worksheet.
Save your changes to the Excel object.

Click the Default View Mode icon in the status bar.

®© N o g

Save your changes to the report and check in the Excel object.

Lock and Unlock Cells in an Excel Object

You can choose which cells can be edited when a worksheet is protected in an Excel object in CDM.

1. Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Select the cells that you want to lock or unlock.

a &~ b

Find the protection area and specify locking for the selected cells.

Important: Cell protection is not yet enabled. For these settings to take effect, the
worksheet must be protected.

6. Save your changes to the Excel object.

7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Excel object.

View the Source of a Cell Value in an Excel Object

You can view the value in a cell in the data worksheet of an Excel object in CDM from an Excel
calculation, a formula that references data found in the Database worksheet, or a number manually
entered by a user. The data worksheet is originally named Sheet1, but you can rename it if necessary.
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To view the source of a cell value in an Excel object:

1.
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Open the report that you want to work with.

Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Click the cell containing the value that you want to investigate.
Look at the Formula bar to view the source of the cell value.
Save your changes to the Excel object.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Reference a Cell Value in a Range in an Excel Object

You can use a VLOOKUP formula in an Excel object in CDM to reference and display a single value in
the data worksheet from a range of cell values found in the Database worksheet.

1.
2.
3.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Switch to the Database worksheet and determine the data value that you want to reference.
Make a note of the cell coordinates for the data that you want.

Switch to the data worksheet. The data worksheet is originally named Sheet1, but you can
rename it if necessary.

Determine what cell you want to display the data query value in.

Type an Excel VLOOKUP formula that calls on the cell values in the Database worksheet.

=VLOOKUP ("Cash 5", Database ! Al:Cll, 2, FALSE)
Where:

« The equal sign (=) indicates the start of the formula.
e VLOOKUP is the name of the formula being used.
e Cash 5 isthe account name being looked up. It must be contained in quotes.

e Database ! isthe name of the worksheet being referenced. The exclamation point (!)
identifies Database as another worksheet.

e Al:C11 isthe range of cells to be referenced in the Database worksheet.

« 2 refers to the second column in the range of cells. The formula returns a value for the Cash
5 account from the second column.

e FALSE returns an exact value match. TRUE returns either an approximate or exact match.
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8.
9.
10.
11.

Press Enter.
Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Reference a Cell Value in Another Worksheet in an Excel
Object

You can create a reference in a data worksheet in an Excel objectin CDM to a cell value found in the

Database worksheet.

1.
2.
3.

10.
11.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

Switch to the Database worksheet and determine the data value that you want to reference.

Make a note of the cell coordinates for the data that you want.

Switch to the data worksheet. The data worksheet is originally named Sheet1, but you can
rename it if necessary.

Determine what cell you want to display the OLAP or relational data value in.

Type a cell reference formula that calls on the cell values in the Database worksheet.

=Database ! C7
Where:

» The equal sign (=) indicates the start of the formula.
» Database is the name of the worksheet being referenced.

e Database ! isthe name of the worksheet being referenced. The exclamation point (!)
identifies Database as another worksheet.

« C7isthe cell to be referenced in the Database worksheet.

Press Enter.
Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

87

Change the Weighting of Referenced Data in an Excel Object

When source data is imported into an Excel object in CDM, the value might be weighted as positive or
negative as it is stored in the external source, for example, relational. You can use an Excel formula to
adjust the weighting.
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10.
11.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Switch to the Database worksheet and determine the data value that you want to reference.
Make a note of the cell coordinates for the data that you want.

Switch to the data worksheet. The data worksheet is originally named Sheet1, but you can
rename it if necessary.

Determine what cell you want to display the OLAP or relational data value in.

Type a cell reference formula that calls on the cell values in the Database worksheet and also
changes the weighting to a positive value.

= ( Database ! C7 ) * -1
Where:

» The equal sign (=) indicates the start of the formula.

e Database ! isthe name of the worksheet being referenced. The exclamation point (!)
identifies Database as another worksheet.

« C7is the cell to be referenced in the Database worksheet.
« *-1 multiplies the referenced value by a negative and reverses the value weighting.

Press Enter.
Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Add a Chart to an Excel Object

You can add a chart to an Excel object in CDM.

1.
2.
3.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Determine the data source for the chart:
a. Ifrequired, import data into an Excel object.

b. Review the data to determine what you want to display in chart format.

In the Excel object, click the worksheet that will contain the chart.

From the Excel menu, click Insert, then in the Charts section, select the type of chart you want to
insert.
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7. Configure the chart according to how you want it displayed, for example, design, layout, and
format.
8. Select data for the chart.

9. From the Database worksheet or a data worksheet, select the source data range that you want to
use. The data worksheet is originally named Sheet1, but you can rename it if necessary.

10. Ifrequired, add or edit legend entries and axis labels.
11. Save your changes to the Excel object.
12. Click the Default View Mode icon in the status bar.

13. Save your changes to the report and check in the Excel object.

Excel Object Formatting

All standard Microsoft™ Excel formatting functionality is available in Excel objects in CDM. You can
apply Excel formatting in any worksheet except the Database worksheet and any other worksheets that
contain data queries.

You can use the Format Cells window to apply the following cell formatting to cells and worksheets:

» Leaders between words and values

¢ Number format

« Alignment of the cell or table in the Excel object (left, center, or right)
« Font format

» Borders around rows, columns, and cells

« Patternsin the cell

« Protection to prevent cells from being edited

Show and Suppress Rows and Columns in an Excel Object
When the Report Is Generated

When you generate a report, CDM automatically suppresses any rows or columns that contain only zero
values and shows all other rows and columns. If necessary, you can specify that you want to show or
suppress particular rows or columns.

If an original value that was entered in the Excel object is a very small number that would be
automatically rounded down to zero (for example, 0.00001), this number is treated as zero in the
following procedures.

In the Zero Amount Shown As field in report properties, the administrator can specify a character such
as a dash (-) to represent zeros in the report when the report is generated. If a character was specified in
the Zero Amount Shown As field and you want zero values to appear in your report, then that character,
rather than a zero, appears when the report is generated.

To show and suppress rows and columns in an Excel object when the report is generated:
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1. Open the report that you want to work with.

W DN

Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

Select the data worksheet. The data worksheet is originally named Sheet1, but you can rename it

if necessary.

If you want to show content that would normally be suppressed in the generated report, or if you
want to suppress content that would normally be shown, consult the following table:

Content of
row or
column

Row contains

Default behavior in the
generated report

Row is automatically
suppressed. If the table
contains only one row, and
the row would normally be

If you want to
perform the
following task

Show the
contents of the

Complete these steps

Navigate to the end of the display
range that contains the row you want
to show, then in that row, type a plus

contains only
zeros

and the column would
normally be suppressed,
the column header would
be suppressed as well.

only zeros suppressed, the row row sign (+) in the column that contains
header would be the ##RE variable.
suppressed as well.
Column is automatically
suppressed. If the table Navigate to the end of the display
Column contains only one column, |Show the range that contains the column you

contents of the
column

want to show, then in that column,
type a plus sign (+) in the row that
contains the ##RS variable.

Row contains

Navigate to the end of the display
range that contains the row you want
to suppress, then in that row, type a
minus sign (-) in the column that
contains the ##RE variable.

atleastone |Row is automatically Suppress the
_ contents of the o
non-zero shown. row Note: If a range extends to
value more than one page, the
suppression is applied
after the table is divided
into multiple tables.
Navigate to the end of the display
range that contains the column you
CO'“”_‘” want to suppress, then in that
containsat |, oo automatically Suppressthe | .,jymn, type a minus sign (-) in the
least one shown. contents of the | oy that contains the ##Rs variable.
non-zero column
value

o Note: If a range extends to
more than one page, the
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Content of Default behavior in the If you want to

row or perform the Complete these steps

generated report

column following task

o suppression is applied
after the table is divided
into multiple tables.

Restrictions:

« The following cell formats are ignored by automatic suppression: empty cells, cells with
text, cells containing numbers, and non-numeric formatting.

» Columns that contain the following variables are ignored by automatic suppression, even if
the content of the cells are non-zero: ##NL, ##NR, ##SL, and ##SR.

« If a column is being suppressed as a result of automatic row or column suppression, any
##NL, ##NR, ##SR, and ##SL variables that follow the suppressed column are also
suppressed.

+ When the Excel object contains merged cells, automatic row or column suppression occurs
in the following manner:

o Ifarow is merged across other columns, automatic row suppression applies if all
values in the row are zeroes.

o Ifa column is merged across other rows, automatic column suppression applies if all
values in that column are zeroes.

o Ifthere is a mixture of merged rows and columns, automatic suppression is based on
the entire table.
6. Save your changes to the Excel object.
7. Click the Default View Mode icon in the status bar.
8. Save your changes to the report and check in the Excel object.
When the report is generated, CDM deals with suppression items in the following order:
1. Plus and minus signs are applied.
2. Automatic suppression of zeros is applied.
3. Zero amounts shown as values are appended to the table.

4. Superscript or note columns are attached to the columns.

Apply Leaders Between Columns in an Excel Object

You can apply leaders between columns in an Excel object in CDM to make the text easier to read.

1. Open the report that you want to work with.

2. Open and check out the Excel object that you want to edit.
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3. Click the Section View Mode icon in the status bar.
4. Type one of the following symbols in the column where you want leaders to appear:

o @*.- To apply leader dots between two columns.
e @*- - To apply leader dashes between two columns.

e« @*_-To apply leader lines between two columns.

5. Save your changes to the Excel object.
6. Click the Default View Mode icon in the status bar.

7. Save your changes to the report and check in the Excel object.

Apply Font, Border, and Pattern Formats to an Excel Object

You can apply font, border and pattern formatting to cells in an Excel object in CDM.

1. Open the report that you want to work with.

Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

Select the cells that you want to format and right-click.

Click the tab containing the format controls that you want to use.
Apply the formatting.

Save your changes to the Excel object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Excel object.

Enable Cell Merging in an Excel Object

By default, the merge cells setting is not enabled for any cells in a newly created Excel object in CDM. If
you prefer, you can enable cell merging.

1. Open the report that you want to work with.

Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Select the cells that you want to format and right-click.

Find the alignment area and select the field for cell merging.
Save your changes to the Excel object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Excel object.
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Enable Text Wrapping in an Excel Object

By default, the text wrapping setting is not enabled for any cells in a newly created Excel object in CDM.
If you prefer, you can enable text wrapping.

1. Open the report that you want to work with.

Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Select the cell or range of cells.

Select the cells that you want to format and right-click.

Find the alignment area and select the field for text wrapping.
Save your changes to the Excel object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Excel object.

Change Cell Alignment in an Excel Object

By default, an Excel object in CDM aligns text in a table to the lower left corner of a cell. If you prefer,
you can change the alignment of text in a cell. You can change the vertical alignment (top, center, or
bottom) and also the horizontal alignment (left, center, or right).

1. Open the report that you want to work with.

Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Select the cells that you want to format and right-click.

Find the alignment area and select your preferred alignment.
Save your changes to the Excel object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Excel object.

Change the Height/Width of a Row/Column in an Excel Object

You can change the height of a row as well as the width of a column in an Excel object in CDM.

1. Open the report that you want to work with.
2. Open and check out the Excel object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Rest the pointer on the row/column boundary that you want to move until it becomes a two-
headed arrow.

5. Click and drag the boundary until the row/column is the height/width that you want.
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6.
7.
8.

Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Change the Size of All Rows and Columns in an Excel Object

You can change the size of all rows or all columns in a worksheet in an Excel object in CDM at the same

time.

1.
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8.
9.

Open the report that you want to work with.

Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

Move to the worksheet that you want to resize and select all rows and columns.

To resize all rows, move the pointer between rows until the row resize handle appears and
double-click.

To resize all columns, move the pointer between columns until the column resize handle appears
and double-click.

Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Set Conditional Formatting in an Excel Object

You can use the conditional formatting feature in an Excel object in CDM to set rules for cell formatting
based on the value in another cell. If the rules (conditions are met, then the formatting is applied.

1.
2.
3.

10.
11.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Click the data worksheet. The data worksheet is originally named Sheet1, but you can rename it
if necessary.

Select the cell that you want to conditionally format.
Find the conditional formatting area.

Select the type of formatting you want (font, highlight cell, and so on) and enter the conditions
that enable formatting for the cell.

To delete conditional formatting, select the cell or cells to which conditional formatting has been
applied and clear the settings.

Save your changes to the Excel object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.
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Data Retrieval and Adjustment

CDM uses Excel objects to retrieve source data. The data is retrieved into worksheet cells in an Excel
object.

You can add more than one data query to the same Excel object in different worksheets, as well as add
multiple data queries from different data sources to the same worksheet in an Excel object. However,
each cell or table can have only one data source associated with it.

You cannot modify the data source worksheet (the worksheet that retrieves an underlying data from a
query), unless the data query is an OLAP data query that is configured to allow data writeback.

For more information about creating and editing OLAP data queries for write back, see the CDM
Administration Guide.

You can add text or data manually to the data worksheet (the worksheet that is organized for
generation). The data worksheet is originally named Sheet1, but you can rename it if necessary.
However, such data cannot be refreshed from a data source unless there is a direct link to the Database
tab where the query is inserted.

Load Data into Excel Objects

You can import data in an Excel object in CDM from an external source. The source can be OLAP,
relational, an external Excel file, HFM servers, IBM® Cognos® TM1®, IBM Cognos Controller, IBM
Cognos Analysis for Microsoft™ Excel, IBM Cognos Business Intelligence, and IBM Cognos for
Microsoft Office. Cognos Analysis for Microsoft Excel, and Cognos for Microsoft Office work through the
Excel add-in, and Cognos® Controller also uses the add-in.

A data query must be defined before you can load data. When the query is defined, it must be
associated with the report.

You need permission to create and associate queries and to load data into an Excel object.

Cognos Analysis for Microsoft Excel, and Cognos for Microsoft Office work through the Excel add-in,
and Cognos Controller also uses the add-in. Data from Cognos Analysis for Microsoft Excel, Cognos for
Microsoft Office, Cognos Controller, and Cognos TM1 Perspectives cannot update automatically if the
source data has changed. You must manually click the Refresh button on the add-in to update the data.
This concept is known as dynamic refresh, and is not supported in CDM when you use data from these
add-ins.

CDM can directly access an OLAP or relational data source and retrieve data from the source into the
report.

Data can also be imported from an Excel file into CDM. Multiple ranges can be imported from the same
file, for example, A1:B20, C10:F30. As well, CDM dynamically refreshes the data directly from the
source file. You can also add specific named ranges.

When data is retrieved from the underlying data source, it is imported into the default Database
worksheet in the Excel object. In CDM, one worksheet can have multiple data sources contained in it,
for example, an OLAP source and a relational source.

When querying chart reports using a Business Intelligence query, only the data is brought into CDM.

After the data is retrieved, it can then be referenced by any other Word or Excel object in the report by
using variables.

To load data into an Excel object:
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1. Open the report that you want to work with.
Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

W DN

In the Data tab for Excel object on the ribbon, click Insert Data. The Insert data for report object
window opens.

o

Select the data query that you want to insert in the Excel object. Click Next.
6. Select the location of the worksheet that will contain the query.

7. Accept or modify the default named range that is to be associated with the query.

o Note: The named range is used when managing data queries to navigate quickly to
where the query is located in the report object for review. If a data query in an Excel
object has no named range associated with it, the default named range is assigned to it
the first time the report object is checked out.

8. If you want to override report object query variables in the query, specify the variables, values,
and a comment if necessary.

9. Click Finish.
10. Save your changes to the Excel object.
11. Click the Default View Mode icon in the status bar.

12. Save your changes to the report and check in the Excel object.

Edit OLAP Write-Back in Excel Objects

A write-back process is a process that gives users the ability to edit the data in a query and save the
updated data back to an OLAP source. You can edit the data in some OLAP data queries in an Excel
object in CDM and save the changed data back to the data source.

A data query must be defined and loaded in an Excel object before you can edit data.
You need permission to write back data in an OLAP data query.

You can use a data query in CDM to directly access an OLAP data source and retrieve data into the
report. OLAP data queries can be configured to write data back to the data source.

Important: To write data back to OLAP, all dimension members in the data query must be leaf-
level members. A leaf-level member is a member of a hierarchy that has no children. For
information about data queries, see the CDM Administration Guide.

By default, OLAP data queries are protected to prevent editing. You can use the Unprotect command in
the Data tab to allow selected cells to be edited. The Protect command prevents editing of an
unprotected cell.

= Tip: After you unprotect a cell, that cell will remain unprotected until you protect the cell again.


https://insightsoftware.com/

Y insightsoftware 97
To edit OLAP write-back in an Excel object:
1. Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Select one or more calls in the data query that you want to edit.
In the Data tab for Excel object on the ribbon, click Unprotect.
Edit the data in the unprotected cells, as necessary.

Save your changes to the Excel object.
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If you want to save changes data query, select Include OLAP Changes. The updated data is
written back to the data source.

8. If you are done editing an unprotected cell, select that cell and click Protect in the Data tab.

o Note: If you do not have appropriate permissions, the write-back fails.

9. Save your changes to the report and check in the Excel object.

Manage Data Queries in an Excel Object

A query is a request for information from a database that is based on specific conditions. You can view
the queries that are inserted in an Excel object in CDM and then you can make changes.

You can change the name of the worksheet that contains the query and you can delete a query.
However, if you change the worksheet name or delete the worksheet outside the Manage data queries
window, the renamed worksheet will no longer be connected to the query and a new worksheet will be
created with the same name as the original worksheet. A warning message will appear informing you
that the Excel object is manually protected.

You can also modify the query variables associated with the query and navigate to the query where it is
located in the current report object or to Administration for editing.

To manage data queries in an Excel object:
1. Open the report that you want to work with.
2. Open and check out the Excel object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Inthe Data tab for Excel object on the ribbon, click Manage Data Queries. The Manage Data
Queries window opens.

5. To delete a data query, select it and delete.
6. To edit a data query, complete the following steps:
a. Select it and then edit.

b. To change the name of the worksheet that contains the data query, specify the name that
you prefer.

c. If you want to associate query variables in the Excel object with the query, select the


https://insightsoftware.com/

Y insightsoftware 98

variables.

= Tip: To see a variable, it must be overridden at report object level.

7. To navigate to and edit the data query properties in Administration, select the query and then
select Data Query from the Navigate to drop-down menu.

8. To navigate to where the query is located in the current report object, select the query and then
select Named Range from the Navigate to drop-down menu.

9. Save your changes to the Excel object.
10. Click the Default View Mode icon in the status bar.

11. Save your changes to the report and check in the Excel object.

Associate HFM Connections with Excel Objects

You can associate Hyperion Financial Management (HFM) connections with Excel objects in CDM
using HFM formulas to refresh the data.

An administrator must first define HFM data sources in CDM before you can associate an HFM
connection with an Excel object. The HFM Smartview add-in must be installed before you can edit HFM
formulas.

You can use these methods to define HFM formulas:

» Formula with connection nhame
You specify the HFM data source connection name in the formula. The connection name must
match the name of the data source defined in CDM.

« Formula without connection name
You can choose to not include a connection name in the formula.

For both methods, formulas are refreshed when you associate an HFM connection with the Excel
object. If there is no connection associated with the Excel object, for formulas defined using the second
method, the default connection is used. The default connection must be selected in the Manage HFM
Servers window.

You can associate multiple HFM connections with an Excel object. However, if the multiple connections
are to different data sources, the formulas must be defined using the first method. You then specify the
connection to associate with the formula.

As stated earlier, the HFM Smartview add-in must be installed before you can edit HFM formulas.
However, the refresh process to retrieve the latest values from the HFM data source is performed on the
application server, so the refresh process does not require the add-in. During report generation, the
data refresh is also performed on the application server. To refresh a formula at the report object level,
use manual refresh in add-in mode.

To associating HFM connections with an Excel object:

1. Open the report that you want to work with.
2. Open and check out the Excel object that you want to edit.

3. Click the Section View Mode icon in the status bar.
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4. Inthe HFM servers area, select the connections that you want to associate with the Excel object.

5. To specify the default connection to use for formulas defined using the second method, select the
server that you want to be the default server.

6. Save your changes to the Excel object.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Excel object.

Enable the HFM SmartView Add-in

You can enable the HFM SmartView Microsoft™ Excel add-in in CDM so that it can be used in Excel
objects. HFM Smartview must be installed before it can be enabled.

1. Open the report that you want to work with.

Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

In the data area, enable add-ins.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Excel object.

Connect to an HFM Data Source

You must provide connection details to a Hyperion Financial Management (HFM) data source to use so
you can create and refresh HFM formulas at the report object level in CDM.

There must be HFM data sources defined in CDM and you must have an Excel object open and
checked out in add-in mode.

When HFM is installed and HFM data sources are defined, the Connect to an HFM Data Source
window will be displayed.

To connect to an HFM data source:

1. If a default HFM connection exists and you want to use that connection, select the Use HFM
default connection checkbox.

2. To select another HFM data source, ensure that the Use HFM default connection checkbox is not
selected and specify the following connection parameters:

o User Name - Enter the username of the account.

« Password - Enter the password for the account.

« Name - Select the data source.

« Machine Name - This name appears after the server connection is made. It is not editable.
« Cluster name - This name appears after the server connection is made. It is not editable.

« Application - The name of the application that holds the HFM data. This field is not editable.
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« Domain - Enter the domain name of the server that contains the HFM data.

« Url - Enter the URL of the HFM server.

3. Click OK.

= Tip: After you initially log in to the HFM server, you are automatically logged in after
each refresh, check in, or check out of an Excel object for the same session.

Client-Side Microsoft Excel Add-ins

You can connect to data sources for other IBM® Cognos® products in CDM by using Microsoft™ Excel
add-ins.

You can connect to data sources for the following IBM Cognos products:

« IBM Cognos® TM1®

« IBM Cognos Controller

« IBM Cognos Analysis for Microsoft Excel
« |IBM Cognos for Microsoft Office

If you set up IBM Cognos Access Manager authentication, you can authenticate to Cognos Access
Manager in the Excel add-in outside CDM, and you are automatically authenticated in CDM. This only
works with Cognos Access Manager imported users and groups. For more information, see the topics
about importing users and groups from Cognos Access Manager in the CDM Administration Guide.

IBM Cognos TM1

You can use the Cognos TM1 Perspectives Excel add-in to connect to a Cognos TM1 cube in CDM.
This connection is an alternative method to creating a Cognos TM1 OLAP data source in CDM
Administration.

The differences between the two methods of accessing Cognos TM1 data sources are shown in the
following table.

Cognos TM1 OLAP
data source

Cognos TM1 Perspectives Excel add-

Feature .
in data source

Manage Cognos TM1 administrative
functions, such as deleting cubes, No Yes
managing dimensions, and security

Dynamic refresh and locking capabilities |Yes No
Performance and scalability Yes No
No, each report object in the report

Sharing a single Cognos TM1 query

. Y must be refreshed manually if
across multiple reports es ust be refreshed manually if a query

result changes.

For information about configuring Excel to use the Cognos TM1 Perspectives Excel add-in, see the IBM
Cognos TM1 Installation and Configuration Guide.
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IBM Cognos Controller

You can use the Cognos Controller Excel add-in to connect to a Cognos Controller repository in CDM.
This add-in is an alternative method to converting a Cognos Controller repository to a Cognos TM1 cube
and then creating a Cognos TM1 OLAP data source in CDM Administration.

If you use the Cognos Controller Excel add-in, you do not have the dynamic refresh and locking
capabilities available with a Cognos TM1 OLAP data source. For information about dynamic refresh,
see Load Data into Excel Objects.

For information about configuring Excel to use the Cognos TM1 Perspectives Excel add-in, see the IBM
Cognos Controller Installation and Configuration Guide.

IBM Cognos Analysis for Microsoft Excel

You can use the Cognos Analysis for Microsoft Excel add-in to connect to IBM Cognos Business
Intelligence and IBM Cognos TM1 data sources in CDM.

If you use the Cognos Analysis for Microsoft Excel add-in, you do not have dynamic refresh and locking
capabilities. Check out the Excel object first so that information can be saved without potential data loss.

For information about configuring Excel to use the Cognos Analysis for Microsoft Excel add-in, see the
IBM Cognos Analysis for Microsoft Excel User Guide.

IBM Cognos for Microsoft Office

You can use the Cognos for Microsoft Office add-in to connect to IBM Cognos Business Intelligence
Reporting products, in CDM.

If you use the Cognos for Microsoft Office add-in, you do not have dynamic refresh and locking
capabilities. Check out the Excel object first so that information can be saved without potential data loss.

For information about configuring Excel to use the Cognos Analysis for Microsoft Excel add-in, see the
IBM Cognos for Microsoft Office User Guide.

Add-ins Not Requiring Add-ins Mode

There are add-ins in CDM that allow Excel objects to load without putting the object in Add-ins mode.
The add-ins are listed and managed by selecting File > Options > Office Addins.

This list contains predefined items that cannot be deleted and represents the supported add-ins in CDM:

Name | Description
CognosOfficeUDF.Connect Cognos for Microsoft Office (Café and Go Office)
IBM Cognos TM1 Perspectives TM1 Perspectives
IBM Cognos Controller Link Older Cognos Controller
Cognos Controller Link for Microsoft Excel Cognos Controller starting with 10.2 RP1
Controller Conversion Utility ,;-\g((jzl_i;[:;nal Controller functionalities (for the older

Important: These items must be identical to the name of the add-in, which is not always the
same as the label displayed in the Excel add-ins list. Add-ins not on this list are not loaded in
Excel objects in CDM.
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Reference Variables in an Excel Object

In an Excel object in CDM, you can reference source-destination variables and named range variables
that you have defined in other Excel objects.

Reference a Source-Destination Variable in an Excel Object

In an Excel object in CDM, you can reference a source-destination variable from a different Excel

object.

In the source Excel object, you must have defined a source report object variable.

1.
2.
3.

8.
9.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Position the pointer in a cell outside of any range variables (that is, ##RS and ##RE or ##IRS and
##IRE).

Click the Report Object tab on the ribbon, then click Insert Variable > Source-Destination. The
Reference Variables window opens, displaying all destination (##D<varname>) and global
destination (# #GD<varname>) variables that have a corresponding source (##S<varname> or
##GSD<varname>) variable defined in CDM.

Select the destination variable you want to use and click Insert. The destination variable is
inserted into the Excel object.

Save your changes to the Excel object. The data defined in the value of the source variable is
copied into it.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Reference a Named Range Variable in an Excel Object

In an Excel object in CDM, you can reference a named range from a different Excel object.

In the source Excel object, you must have defined a source named range variable for a cell range.

1.
2.
3.

Open the report that you want to work with.
Open and check out the Excel object that you want to edit.
Click the Section View Mode icon in the status bar.

Click the Report Object tab on the ribbon, then click Insert Variable > Named Range. The
Reference Variables window opens, displaying all destination named range (##D<varname>)
and global destination named range (##GD<varname>) variables that have a corresponding
source named range (##S<varname> or ##GSD<varname>) variable in CDM.

Select the destination named range variable you want to use and perform one of the following
actions:

» Position the pointer in a cell outside of any range variables (that is, ##RS and ##RE or
##IRS and ##IRE). Click Insert on new worksheet. The destination named range variable
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7.
8.

is inserted into the Excel object. When you save the Excel object, a new worksheet is
created and named after the name range. All data defined in the named range is copied into
this new worksheet, starting at cell A1. Formatting is not copied.

« Position the pointer in a cell outside of any range variables (that is, ##RS and ##RE or
##IRS and #4#IRE). Use the Insert on new worksheet dropdown menu to select Insert on
selected worksheet. The destination named range variable is inserted into the cell you
selected in the Excel object (for example, B3), with the location of the content set to the cell
one row below (for example, C3). In the third column, modify the value to specify the
location and formatting of the content. For example, Sheet1 ! B3*, where Sheet1 is the
worksheet name, B3 is the starting cell to copy the content to, and the asterisk (*) means
that both the data and formatting is copied.

Save your changes to the Excel object. The data defined by the source named range variable is
copied into it.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Excel object.

Preview an Excel Object

Before you generate output from an Excel object in CDM, you can preview the output. You might find
this useful to ensure that all content appears correctly, especially if the Excel object contains # #
variables.

1.
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Open the report that you want to work with.

Open the Excel object.

In the Report Object tab on the ribbon, click Generate & Preview > Preview.
In the Preview window, confirm that the content appears correctly.

If necessary, check out the Excel object and make changes.

When the content appears correctly in the preview, you can generate the Excel object.

Work with Word Objects

Word objects are primarily used to present textual information in a report in CDM.

CDM can leverage existing reports by importing them directly into the Word object for use in the report.
You can add text, images, graphs, or data to enhance the report. Every time you save a Word object,
the data is saved in the CDM database.

o Note: Any Alt Text added to Excel object charts, tables, name ranges, or print areas is

maintained when referenced in generated Word objects. You can view an audit trail for the
report object information and content in the database and you can compare different versions.

Important: Word objects in CDM have the same functionality as Microsoft™ Word. The
advanced functionality for Microsoft products is beyond the scope of this guide. However,
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some topics are included for your convenience. For more information, see the Microsoft
documentation. Depending on the version of Microsoft Word that is installed on your
computer, some of the steps that you must follow might vary slightly.

Word Object Tables

When you need to add textual content to a report in CDM, you use a Word object. For consistency in the
overall document design, use tables to contain information such as text or images.

Each section in a table is referred to as a cell. A table consists of rows and columns of cells that you can
fill with text or graphics. When a table is inserted into a Word object, it is displayed as a grid.

= Tip: Although a Word object can contain information outside of a table, it is easier to use
tables for consistency in formatting.

Draw a Table or Cell in a Word Object

You can create a customized table in a Word object in CDM. For example, you can create a table
containing cells of different heights or varying columns per row.

1. Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Click where you want to create a table and insert the table.
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Position the pencil icon in your preferred location and draw the table or cell. To define the outer
table boundaries, click and drag to create the size of table or cell that you want. Then draw the
column and row lines inside the table or cell. You can erase a line or group of lines, if necessary.

When you are finished, exit table mode.
Save your changes to the Word object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Word object.

Add a Table or Worksheet to a Word Object

You can add a table to a Word object in CDM. Depending on the formatting that you prefer, you can
create the table in several ways.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Click where you want to create a table.
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5. Todraw a table with your own formatting, complete the following steps:
a. Click where you want to create a table and insert the table.

b. To specify the number of columns and the number of rows to include in the table, select the
appropriate numbers.

c. To adjust the table size, select the automatic behavior that you prefer.

6. Toinsert a table with a certain number of rows and columns, complete the following steps:
a. Click where you want to create a table.

b. Select the correct number of rows and columns, and then release the pointer.

7. Toinsert a table with predefined formatting, complete the following steps:

a. Click where you want to create a table and insert a quick table. Click one of the samples,
such as a calendar or a tabular list.

b. Adapt the appearance as necessary by changing colors, formatting, and content. You can
click the samples to change colors and formatting.

8. To use an Excel worksheet as a table in a Word object, complete the following steps:

a. Click where you want to add an Excel worksheet and insert an Excel worksheet into your
Word obiject.

b. Adapt the appearance of the Excel worksheet as necessary.
9. Save your changes to the Word object.
10. Click the Default View Mode icon in the status bar.

11. Save your changes to the report and check in the Word object.

Add a Nested Table to a Cell of a Table in a Word Object

You can insert a table into a cell of a table in a Word object in CDM. A table within a table is called a
nested table.

1. Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Inside the table, click the cell where you want to insert a nested table.

a > w b

Click where you want to create a nested table and insert the table.

a. To specify the number of columns and the number of rows to include in the table, select the
appropriate numbers.

b. To adjust the table size, select the automatic behavior that you prefer.
6. Save your changes to the Word object. The nested table appears inside the table cell.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Word object.
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Split a Table in a Word Object into Two Tables

If the table in a Word object in CDM contains too much information, you can split the table into two
separate tables.

1.
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Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Position the cursor in the row where you want the second table to start.

Click the option to split a table. The table splits into two tables at the location that you selected.
Save your changes to the Word object.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

Convert Text in a Word Object to a Table

You can convert existing text in a Word object in CDM into a table format.

Text separators, such as paragraph markers or tabs, are required to indicate where a new column
should begin. You can define what is considered a text separator.

Each new paragraph is placed in a newly created row. If you selected paragraphs as a text separator,
text is converted into a table with one column.

To convert text in a Word object to a table:

1.
2.
3.

Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

To indicate where you want to divide text into columns, insert the text separator that you want, for
example, tabs, paragraphs, or commas. For example, if you want a new column to appear in the
table wherever a new paragraph starts in the existing text, make sure that your paragraphs are
divided in the appropriate locations.

Select the text that you want to convert.

Click where you want to create a table and insert the table.
a. Select the number of columns and the number of rows to include in the table.

b. To adjust the table size, select the automatic behavior that you prefer.

c. Indicate the type of text separator that you want to use when you convert the text to a table.
Save your changes to the Word object. The text is displayed in a table in the Word object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.
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Convert a Table in a Word Object to Text

You can convert the text contained in a table in a Word object in CDM into normal paragraphs.

1. Open the report that you want to work with.

Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Click anywhere inside the table.

Select the option to convert a table to text.
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Indicate the type of text separator that you want to use when you convert the table to text. The
table is removed and its text appears in paragraphs.

~

Save your changes to the Word object.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

Navigate in a Table in a Word Object

When you are working with a table in a Word object in CDM, it is helpful to understand how to navigate
through the table and how to select items in the table.

1. Open the report that you want to work with.

2. Open and check out the Word object that you want to edit.

3. Click the Section View Mode icon in the status bar.

4. You can complete any of the following steps on cells, rows, or columns:

« To select a cell, click the left edge of the cell.

« To select arow, click to the left of the row, just outside the table.

o To select a column, click just above the upper grid line of the column.

« To select multiple cells, rows, or columns, click and drag across the cell, row, or column.

« To select the entire table, click the upper left corner of the table.

« Tomove to the next cell, press Tab. If you press Tab in the last cell, you create a new row.

« To move to the previous cell, press SHIFT+Tab.

Important: Depending on the version of Microsoft™ Word that is installed on your
computer, some of the steps that you must follow might vary slightly.

5. Click the Default View Mode icon in the status bar.

6. If you made any changes, save your changes to the report and check in the Word object.
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Insert Rows and Columns into a Table in a Word Object

When you are working with a table in a Word object in CDM, you can insert rows and columns to contain
the text for the table.

1.
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8.
9.

Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Click in the location in the table where you want to insert rows or columns.

To add rows, complete one of the following actions:

To add rows above your selection, click the option to insert rows above and select the
number of rows.

To add rows below your selection, click the option to insert rows below and select the
number of rows.

To add one row below your selection, click in the last cell of the table and press Tab.

To add columns, complete one of the following actions:

To add columns to the left of your selection, click the option to insert columns left and select
the number of columns.

To add columns to the right of your selection, click the option to insert columns right and
select the number of columns.

Save your changes to the Word object.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

Delete Cells, Rows, Columns, or Tables from a Word Object

If the table in a Word object in CDM contains content that you do not need, you can delete cells, rows,
columns, or the entire table.

1.
2.
3.

Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Click in the part of the table that you want to delete and select the appropriate cells, rows, or

columns, or the entire table.

Save your changes to the Word object.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.
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Word Object Formatting

When you need to add textual content to a report in CDM and want consistency in the overall document,
you can use tables in a Word object. You can format text in cells in the same way as other text. You can
format the table by adding or deleting the lines around the cells, and by shading the background. You
can also adjust the width of columns and the height of rows.

A plthormattmg Properties to Cells and Tables in a Word
jec

You can apply formatting to cells and tables in a Word object in CDM. For example, you can specify
alignment, row height, and column width.

1. Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Select the cells or table that you want to format.

Click the area for the cell, row, or column that you want to format, or the entire table.
Apply the formatting that you need.

Save your changes to the Word object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Word object.

Enable Text Wrapping in a Table in a Word Object

By default, the text wrapping setting is disabled in a newly created Word object in CDM for optimal
report design. You can enable text wrapping if necessary.

1. Open the report that you want to work with.

Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Click in the table.

Find the text wrapping area.

Select the type of wrapping and positioning that you prefer.
Save your changes to the Word object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Word object.

Set the Preferred Width of a Table in a Word Object

By default, the preferred width setting for a table in a Word object in CDM is disabled (set to zero
inches). You can apply a preset width for tables in a Word object. The maximum width for the table is
seven inches.
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1. Open the report that you want to work with.

Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Click in the table.

Find the width settings.
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Set the number field to the width that you prefer, to a maximum of seven inches. Select inches for
the measurement setting.

~

Save your changes to the Word object.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

Change the Size of a Table in a Word Object

If the size of a table in a Word object in CDM is incorrect, you can resize the table.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Move the pointer near the lower right corner of the table until a double-headed resizing arrow
appears.

5. Drag the table boundary until the table is the size that you want. The maximum width of a table is
seven inches.

6. Save your changes to the Word object.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Word object.

Change the Height of a Table Row in a Word Object

You can change the height of a row in a table in a Word object in CDM.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. To change the approximate height of a table row, complete the following steps:

a. Rest the pointer on the lower boundary of the row that you want to edit until the pointer
becomes a two-headed arrow.

b. Click and drag the boundary until the row is the height that you want.
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5.

6.
7.
8.

To change the exact height of a table row, complete the following steps:
a. Click a cell in the row that you want to edit.

b. Inthe properties area, click the row. Specify the height that you want and specify other
settings regarding the height.

Save your changes to the Word object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

Change the Width of a Table Column in a Word Object

You can change the width of a column in a table in a Word object in CDM.

1.
2.
3.

7.
8.

Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

To change the approximate width of a table column, complete the following steps:

a. Rest the pointer on the right boundary of the column that you want to edit until the pointer
becomes a two-headed arrow.

b. Click and drag the boundary until the column is the width that you want.

To change the exact width of a table column, complete the following steps:
a. Click a cellin the column that you want to edit.

b. Inthe properties area, click the column. Specify the width that you want and specify whether
you want to measure in inches or as a percentage of the width of the table.

Save your changes to the Word object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

Make Multiple Cells in a Table in a Word Object the Same
Height or Width

If a table in a Word object in CDM contains rows or columns with different heights or widths, you can
adjust the heights and widths automatically.

1.
2.
3.

Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

To make rows the same height, complete the following steps:
a. Select the rows that you want to make the same height.

b. Click the option to distribute rows.
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5. To make columns the same width, complete the following steps:
a. Select the columns that you want to make the same width.

b. Click the option to distribute columns.
6. Save your changes to the Word object.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Word object.

Change the Spacing Between Cells in a Table in a Word
Object

You can change the spacing between the cells in a table in a Word object in CDM.

1. Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Click the table.

Find the settings for spacing and specify the spacing that you want.
Save your changes to the Word object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Word object.

Change the Borders and Shading in a Table in a Word Object

By default, when a table is inserted in a Word object in CDM, a border is automatically added around
cells in the table and no shading is applied. You can change the borders and shading if necessary.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Select the cell or range of cells that you want to format. If you want to format the entire table, do
not select any cells.

5. Find the settings for borders and shading.
6. To change borders and shading, complete one or more of the following:

« Change the settings, style, color, width, and area of the table to apply changes to.
« Add a border to the entire page.
« Change the fill color and pattern and select the area of the table to apply the changes to.

7. Save your changes to the Word object.
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8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

Change the Direction of Text in a Table in a Word Object

By default, a Word object in CDM aligns text horizontally in table cells, callouts, text boxes, or
AutoShapes. You can change the text orientation so that the text is displayed vertically.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Select the cells containing the text that you want to edit. If you want to edit only one cell, click in
the cell.

5. Inthe alignment area, select the direction option that you want. You can specify whether you
want the text to be horizontal, vertical upwards, or vertical downwards.

6. Save your changes to the Word object.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Word object.

Change the Cell Alignment of a Table in a Word Object

By default, a Word object in CDM aligns text in a table to the upper left corner of a cell. You can change
the vertical alignment (top, center, or bottom) and the horizontal alignment (left, center or right).

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Select the cells containing the text that you want to edit. If you want to edit only one cell, click in
the cell.

5. Find the alignment area and select the alignment option that you want. You can select left,
center, or right alignment, and top, middle, or bottom alignment.

6. Save your changes to the Word object.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the Word object.

Fix Text and Number Alignment in a Table Cell in a Word
Object

By default, text or numbers in a Word object in CDM align to the left side of a column. You can correct
the alignment if necessary by inserting a non-breaking space.

Tables in Word objects do not manage number alignment automatically. Format selections and
characters such as brackets might affect alignment in a cell. Text or numbers that seem to be correctly
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aligned in the Word object might not be correctly aligned in the generated report. You can insert a non-
breaking space to control alignment issues. It acts as a blank placeholder symbol in the cell.

1.
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7.
8.

Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Position your cursor in the cell where you need to fix the alignment of text or a number.

In the symbols area, insert a non-breaking space. If a non-breaking space does not appear in the
list, select a different font and try again.

Save your changes to the Word object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

Repeat Table Headings in a Word Object on All Pages in a
Long Report

A table in a Word object in CDM might have table headings. In a very long report, you can make the
headings automatically appear on each page of the report where the table appears.

1.
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7.
8.

Open the report that you want to work with.

Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Click any cell in the first row of the table.

Find the field or checkbox where you can specify that you want to repeat a header row at the top
of each page.

Save your changes to the Word object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

When the table in the Word object extends across multiple pages in the generated report, the table
headings appear on each page.

Control Where a Table in a Word Object Is Divided in a Report

If a page break occurs in a large row in a Word object in CDM, the Word object allows a page break to
divide the row between two pages. You can prevent a table from breaking across pages and you can
force the table to break across pages at a particular place.

1.
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Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Click any cell in the table.
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Find the field or checkbox where you can specify that you want rows to break across pages.
Save your changes to the Word object.

Click the Default View Mode icon in the status bar.
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Save your changes to the report and check in the Word object.

If a page break occurs in a large row in the Word object when the report is generated, the page break
occurs in the specified location.

Sort Table Entries in a Word Object

In a Word object in CDM, you can sort table entries alphabetically, numerically, or by date.

1. Open the report that you want to work with.

Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

Select the table that contains entries that you want to sort.

Find the field or checkbox where you can specify that you want to sort data.
Select the sort options that you want.

Save your changes to the Word object.

Click the Default View Mode icon in the status bar.

© o N o o ~ w N

Save your changes to the report and check in the Word object.

Total a Row or Column of Numbers in a Table in a Word
Object

You can insert a total value for a row or column of numbers in a table in a Word object in CDM. If your
column or row contains blank cells, Word does not total the entire column or row. Blank rows require
zeroes for totaling to work correctly.

= Tip: If you need complex formulas, use an Excel object and copy or link to the results.

1. Open the report that you want to work with.
Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.

WD

Click in an empty cell where you want to insert a total. If you want to total a column, select a cell
at the end of the column. If you want to total a row, select a cell at the end of the row.

o

Specify a formula for the cell that will contain the total.

6. Depending on the cell location that you selected, the default formula calculates the values of the
cells in the column or row. The total appears in the selected cell.

7. Save your changes to the Word object.
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8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

Reference Variables in a Word Object

In a Word object in CDM, you can reference variables such as source-destination variables, named
range variables, and image range variables that you have defined in an Excel object. You can also
reference a chart or picture from an Excel object in a Word object.

Reference a Chart in a Word Object
In a Word object in CDM, you can reference a chart from an Excel object.

In the source Excel object, you must have defined a chart. See Add a Chart to an Excel Object.

1. Open the report that you want to work with.
Open and check out the Word object that you want to edit.

Click the Section View Mode icon in the status bar.
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Position the pointer where you want the chart to appear in the Word object.

= Tip: You can also create a table or text box and make it the size you want the chart to
be displayed and position the pointer inside of it.

5. Click the Report Object tab on the ribbon, then click Insert Variable > Chart. The Reference
Variables window opens, displaying all chart variables in the report.

6. Select the chart variable you want to use and from the Insert as Chart button drop-down menu
select one of the following options:

« Insert as Chart - Use this option to import a chart in its original size.

« Insert as Chart and resize - Use this option to import a chart into the table or text box you
have created. Make the table or text box bigger or smaller depending on the size of chart
you want displayed.

A hyperlink to the chart is inserted.
7. Save your changes to the Word object.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

After you generate the document, the chart defined in the Excel object will resolve in the Word object
with the original formatting.

Reference a Picture in a Word Object

In a Word object in CDM, you can reference a picture from an Excel object.

In the source Excel object, you must have inserted a picture. If you format the picture by entering an ALT
Text description for it, this description is then used to identify the picture by name in the Reference
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Variables window. If no ALT Text description exists, the file name of the picture is used to identify the
picture.

To reference a picture from an Excel object in a Word object:

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Position the pointer where you want the picture to appear in the Word object.

= Tip: You can also create a table or text box and make it the size you want the picture to
be displayed and position the pointer inside of it.

5. Click the Report Object tab on the ribbon, then click Insert Variable > Picture. The Reference
Variables window opens, displaying all picture variables in the report.

6. Select the picture variable you want to use and from the Insert as Image button drop-down menu
select one of the following options:

« Insert as Image - Use this option to import a picture in its original size.

« Insert as Image and resize - Use this option to import a picture into the table or text box
you have created. Make the table or text box bigger or smaller depending on the size of
picture you want displayed.

A hyperlink to the picture is inserted.
7. Save your changes to the Word object.
8. Click the Default View Mode icon in the status bar.
9. Save your changes to the report and check in the Word object.
After you generate the document, the picture inserted in the Excel object will resolve in the Word object.
Reference a Source-Destination Variable in a Word Object

In an Word object in CDM, you can reference a source-destination variable in an Excel object.

In the source Excel object, you must have defined a source variable.

1. Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Position the pointer in the Word object where you want to insert the destination variable.
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Click the Report Object tab on the ribbon, then click Insert Variable > Source-Destination. The
Reference Variables window opens, displaying all destination (##D<varname>) and global
destination (##GD<varname>) variables that have a corresponding source (##S<varname> or
##GSD<varname>) variable defined in CDM.
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6. Select the destination variable you want to use and click Insert. The destination variable is
inserted into the Word object.

7. Save your changes to the Word object. The data defined in the value of the source variable is
copied into it.

8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

Reference a Print Area Named Range Variable in a Word
Object

In a Word object in CDM, you can reference a print area named range variable in an Excel object.

In the source Excel object, you must have defined a print area named range variable for a cell range.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Position the pointer where you want the print area named range variable to appear in the Word
object.

5. Click the Report Object tab on the ribbon, then click Insert Variable > Named Range. The
Reference Variables window opens, displaying all print area variables.

6. Select the print area named range variable you want to use and click Insert as Hyperlink. The
print area named range variable is inserted into the Word object.

7. Save your changes to the Word object. The data defined by the print area named range variable
is copied into it.

8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Word object.

Reference a Named Range Variable in a Word Object

In a Word object in CDM, you can reference a named range variable that was created within a print area
in an Excel object.

In the source Excel object, you must have defined a name range variable for a cell range within a print
area.

1. Open the report that you want to work with.
2. Open and check out the Word object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Position the pointer where you want the destination named range variable to appear in the Word
object.

5. Inthe Report Object tab on the ribbon, click Insert Variable > Named Range. The Reference
Variables window opens, displaying all print area variables.
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Select the print area variable that contains the named range variable you want to use, click the
Insert as Hyperlink drop-down arrow, and select Insert Print Area Named Ranges.

A window is displayed, listing the named range variables that have been defined within the print
area you selected in the Reference Variables window.

Click on a named range variable and it is inserted into the Word object.

Save your changes to the Word object. The data defined by the source named range variable is
copied into it.

Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the Word object.

Reference an Image Range Variable in a Word Object

In a Word object in CDM, you can reference an image range variable in an Excel object. The image
range can contain either a graphic or data that is rendered as an image in Word.

In the source Excel object, you must define an image range by using the image range start (##IRS) and
image range end (##IRE) variables. The image range can contain data or a graphic. If you have
specified a choice in the Zero Amount Shown As report property, or if you have specified rows or
columns in the Excel object that you want to show or suppress, your choices might affect the
appearance of the image that you create.

To reference an image range variable from an Excel object in a Word object:

1.
2.
3.

Open the report that you want to work with.
Open and check out the Word object that you want to edit.
Click the Section View Mode icon in the status bar.

Position the pointer where you want the image range to appear in the Word object.

= Tip: You can also create a table or text box and make it the size you want the image to
be displayed and position the pointer inside of it.

Click the Report Object tab on the ribbon, then click Insert Variable > Image Range. The
Reference Variables window opens, displaying all image range variables in the report.

Select the image range variable you want to use and from the Insert as Image drop-down menu
select one of the following options:

» Insert as Image - Use this option to import a referenced image range that contains only
data (no pictures or charts). The data is converted into an image that contains only the cell
data (in effect, numbers or text). This option causes changes to suppression and zeroes.
The image is generated according to the default size of 150 DPI.

« Insert as Image and resize - Use this option to import a referenced image range that
contains only data (no pictures or charts) into a table or text box you created and sized. The
data is converted into an image that contains only the cell data (in effect, numbers or text).
This option causes changes to suppression and zeroes. The size of the generated image
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fits the size of the table or text box you have created. Make the table or text box bigger or
smaller depending on the size of image you want displayed.

« Insert as Snapshot - Use this option to import a referenced image range that is an exact
snapshot of the image range you specified, which can include data, pictures and charts, or
just pictures and charts. The range is converted to an image according to the default size of
150 DPI.

« Insert as Snhapshot and resize - Use this option to import a referenced image range that is
an exact snapshot of the image range you specified, which can include data, pictures and
charts, or just pictures and charts, into a table or text box you created and sized. The size of
the generated image fits the size of the table or text box you have created. Make the table
or text box bigger or smaller depending on the size of image you want displayed.

A hyperlink to the referenced image is inserted.
7. Save your changes to the Word object.
8. Click the Default View Mode icon in the status bar.
9. Save your changes to the report and check in the Word object.

After you generate the document, the image range defined in the source Excel object will resolve in the
Word object.

Preview Variables in a Word Object
You can preview variables that are displayed as unresolved in a Word object in CDM.

When a Word report object is opened, variables in the object are displayed by default as resolved (that
is, they are shown as they will look when the report is generated). However, if you have selected Open
or Edit as the setting in the Report Object Double Click Action checkbox in File > Options > General,
then double-clicking a Word object will open the object with variables displayed as unresolved. You can
then preview the variables to show how they will look when the report is generated.

1. Open the report that you want to work with.

2. Inthe User Object Summary tab in the work area, select the Word report object you want to
preview variables in and click Preview. The report object is opened and checked in with the
variables displayed as resolved (that is, how they will look when the report is generated).

The variables are displayed as resolved until the Word object is checked out.

Work with PowerPoint Objects

In CDM, PowerPoint objects are primarily used for visual presentations in a report.

CDM can take advantage of existing PowerPoint documents by importing them directly into the
PowerPoint object for use in the report. You can add charts, display ranges, or image ranges containing
data or graphics to enhance the PowerPoint object. Every time you save a PowerPoint object, the data
is saved in the CDM database.

You can view an audit trail for the report object information and content in the database and you can
compare different versions of the PowerPoint object.
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Important: PowerPoint objects in CDM have the same functionality as Microsoft PowerPoint.
The advanced functionality for Microsoft products is beyond the scope of this guide. However,
some topics are included for your convenience. For more information, see the Microsoft
documentation. Depending on the version of Microsoft PowerPoint that is installed on your
computer, some of the steps that you must follow might vary slightly.

Reference a Chart in a PowerPoint Object

In a PowerPoint object in CDM, you can reference a chart from an Excel object.

In the source Excel object, you must have defined a chart. See Add a Chart to an Excel Object.

1. Open the report that you want to work with.
2. Open and check out the PowerPoint object that you want to edit.
3. Click the Section View Mode icon in the status bar.

4. Insert a text box and position it where you want the chart to appear in the PowerPoint object.

= Tip: You can also make the text box the size you want the chart to be displayed.
5. Click the Report Object tab on the ribbon, then click Insert Variable > Chart. The Reference
Variables window opens, displaying all chart variables in the report.

6. Select the chart variable you want to use and from the Insert as Chart button drop-down menu
select one of the following options:

« Insert as Chart - Use this option to import a chart in its original size.

« Insert as Chart and resize - Use this option to import a chart according to the size of the
text box you have created. Make the text box bigger or smaller depending on the size of
chart you want displayed.

A hyperlink to the chart is inserted.
7. Save your changes to the PowerPoint object.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the PowerPoint object.

After you generate the document, the chart defined in the Excel object will resolve in the PowerPoint
object with the original formatting.

Reference a Picture in a PowerPoint Object

In a PowerPoint object in CDM, you can reference a picture from an Excel object.

In the source Excel object, you must have inserted a picture. If you format the picture by entering an ALT
Text description for it, this description is then used to identify the picture by name in the Reference
Variables window. If no ALT Text description exists, the file name of the picture is used to identify the
picture.

To reference a picture from an Excel object in a PowerPoint object:
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1. Open the report that you want to work with.
Open and check out the PowerPoint object that you want to edit.

Click the Section View Mode icon in the status bar.

W DN

Insert a text box and position it where you want the picture to appear in the PowerPoint object.

= Tip: You can also make the text box the size you want the picture to be displayed.
5. Click the Report Object tab on the ribbon, then click Insert Variable > Picture. The Reference
Variables window opens, displaying all picture variables in the report.

6. Select the picture variable you want to use and from the Insert as Image button drop-down menu
select one of the following options:

« Insert as Image - Use this option to import a picture in its original size.

« Insert as Image and resize - Use this option to import a picture according to the size of the
text box you have created. Make the text box bigger or smaller depending on the size of
picture you want displayed.

A hyperlink to the picture is inserted.
7. Save your changes to the PowerPoint object.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the PowerPoint object.

After you generate the document, the picture inserted in the Excel object will resolve in the PowerPoint
object.

Reference a Source-Destination Variable in a
PowerPoint Object

In an PowerPoint object in CDM, you can reference a source report object variable in an Excel object.
In the source Excel object, you must have defined a source variable.

1. Open the report that you want to work with.
Open and check out the PowerPoint object that you want to edit.

Click the Section View Mode icon in the status bar.

A w0 N

Position the pointer in the PowerPoint object where you want to insert the destination variable. If
you are inserting the variable in a blank slide, you do not have to position your cursor.

5. Click the Report Object tab on the ribbon, then click Insert Variable > Source-Destination. The
Reference Variables window opens, displaying all destination (##D<varname>) and global
destination (##GD<varname>) variables that have a corresponding source (##S<varname> or
##GSD<varname>) variable defined in CDM.

6. Select the destination variable you want to use and click Insert. The destination variable is
inserted into the PowerPoint object.
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7. Save your changes to the PowerPoint object. The data defined in the value of the source variable
is copied into it.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the PowerPoint object.

Reference a Named Range Variable in a PowerPoint
Object
In a PowerPoint object in CDM, you can reference a named range variable in an Excel object.
In the source Excel object, you must have defined a name range variable for a cell range.
1. Open the report that you want to work with.
2. Open and check out the PowerPoint object that you want to edit.

3. Click the Section View Mode icon in the status bar.

4. Position the pointer where you want the named range variable to appear in the PowerPoint
object. If you are inserting the variable in a blank slide, you do not have to position your cursor.

5. Click the Report Object tab on the ribbon, then click Insert Variable > Named Range. The
Reference Variables window opens, displaying all named ranges including print area variables.

6. Select the named range variable you want to use and click Insert. The named range variable is
inserted into the PowerPoint object.

7. Save your changes to the PowerPoint object. The data defined by the source named range
variable is copied into it.

8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the PowerPoint object.

Reference an Image Range Variable in a PowerPoint
Object

In a PowerPoint object in CDM, you can reference an image range variable in an Excel object. The
image range can contain either a graphic or data that is rendered as an image in PowerPoint.

In the source Excel object, you must have defined an image range by using the image range start
(##1RS) and image range end (## IRE) variables. The image range can contain data or a graphic. If you
have specified a choice in the Zero Amount Shown As report property, or if you have specified rows or
columns in the Excel object that you want to show or suppress, your choices might affect the
appearance of the image that you create.

To reference an image range variable from an Excel object in a PowerPoint Object:

1. Open the report that you want to work with.
2. Open and check out the PowerPoint object that you want to edit.

3. Click the Section View Mode icon in the status bar.
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4. Position the pointer where you want the image range to appear in the PowerPoint object.

8.
9.

= Tip: You can also create a text box and make it the size you want the image to be
displayed and position the pointer inside of it.

Click the Report Object tab on the ribbon, then click Insert Variable > Image Range. The
Reference Variables window opens, displaying all image range variables in the report.

Select the image range variable you want to use and from the Insert as Image drop-down menu
select one of the following options:

 Insert as Image - Use this option to import a referenced image range that contains only

data (no pictures or charts). The data is converted into an image that contains only the cell
data (in effect, numbers or text). This option causes changes to suppression and zeroes.
The image is generated according to the default size of 150 DPI.

Insert as Image and resize - Use this option to import a referenced image range that
contains only data (no pictures or charts) into a table or text box you created and sized. The
data is converted into an image that contains only the cell data (in effect, numbers or text).
This option causes changes to suppression and zeroes. The size of the generated image
fits the size of the table or text box you have created. Make the table or text box bigger or
smaller depending on the size of image you want displayed.

Insert as Snapshot - Use this option to import a referenced image range that is an exact
snapshot of the image range you specified, which can include data, pictures and charts, or
just pictures and charts. The range is converted to an image according to the default size of
150 DPI.

Insert as Snapshot and resize - Use this option to import a referenced image range that is
an exact snapshot of the image range you specified, which can include data, pictures and
charts, or just pictures and charts, into a table or text box you created and sized. The size of
the generated image fits the size of the table or text box you have created. Make the table
or text box bigger or smaller depending on the size of image you want displayed.

A hyperlink to the referenced image is inserted.
Save your changes to the PowerPoint object.
Click the Default View Mode icon in the status bar.

Save your changes to the report and check in the PowerPoint object.

After you generate the document, the image range defined in the source Excel object will resolve in the
PowerPoint object.

Preview Variables in a PowerPoint Object

You can preview variables that are displayed as unresolved in a PowerPoint object in CDM.

When a PowerPoint report object is opened, variables in that object are displayed by default as resolved
(that is, they are shown as they will look when the report is generated). However, if you have selected
Open or Edit as the setting in the Report Object Double Click Action checkbox in File > Options >
General, then double-clicking a PowerPoint report object will open the object with variables displayed
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as unresolved. You can then preview the variables to show how they will look when the report is
generated.

To preview variables in a PowerPoint object:

1. Open the report that you want to work with.

2. Inthe User Object Summary tab in the work area, select the PowerPoint report object you want
to preview variables in and click Preview. The report object is opened and checked in with the
variables displayed as resolved (that is, how they will look when the report is generated).

Work with Web Page Objects

You can use Web Page objects to display web pages in a report in CDM for reference.
Web Page objects can be included in the report for reference while you are working on the report, but
they are not generated upon output.

o Note: Because Web Page objects are not included in the generated report, Web Page objects
cannot be included in the Table of Contents.

Add a Website to a Web Page Object

You can add a link to a website to a Web Page object in CDM.

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the name of the report and select Add Child > Web
Object.

3. Check out the Web Page object that you just added.
4. Inthe work area, click the Address field and type the name of the website.

5. Press Enter. A link to the website is inserted into the Web Page object and the web page displays
in the work area.

6. Save your changes to the report and check in the Web Page object.

Work with PDF Objects

You can use PDF objects to attach documents in Portable Document Format (PDF) to a report in CDM
for reference.

PDF objects can be included in the report for reference while you are working on the report, but they are
not generated upon output.

o Note: Because PDF objects are not included in the generated report, PDF objects cannot be
included in the Table of Contents.

Important: When the file is open, PDF objects in CDM have the same functionality as Adobe™
Reader or Adobe Acrobat. The advanced functionality for Adobe products is beyond the scope
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of this guide. However, some topics are included for your convenience. For more information,
see the Adobe documentation.

Password Protection for PDF Objects

In CDM, you can protect your PDF files with password security to prevent unauthorized users from
copying or extracting information.

CDM does not remove the password protection on PDF files. If the PDF file can be opened and viewed,
it can be attached to a report and viewed correctly. If you want to prevent unauthorized users from
copying or extracting from a PDF, use the security settings in the application used to generate the PDF.

However, if password protection is in place to prevent the PDF file from being opened, CDM cannot
display the PDF file.

Add a PDF File to a PDF Object

You can attach a PDF file to a PDF object in CDM.
PDF files can be added to a report for reference purposes but they are not generated upon output.

1. Open the report that you want to work with.

2. Inthe report tree on the left, right-click the name of the report and select Add Child > PDF
Object.

3. Inthe Open window, navigate to the PDF file that you want to attach to the PDF object and click
Open. The PDF object is added to the report tree and the PDF file is opened in the work area.

4. Click Manage object workflow to configure report object permissions as necessary.

5. Save your changes to the report and check in the PDF object.
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Variables

When data is in a report in CDM, use variables to reference the data wherever it appears in other parts
of the report.

Variables are used to simplify the process of periodically updating the recurrent information that is often
found in a report, or multiple reports. Instead of entering this information throughout multiple reports,
and then having to update it repeatedly, you can use a variable to represent the information.

Wherever a value is displayed in a report, you can define and substitute a variable in place of it. When
the report is generated, the value is substituted in place of the variable. When the value changes, you
can update the variable with the new value in one place and the change is then propagated throughout
all of the reports.

For example, you have a time period "For the year ended 2009" referenced in multiple places in your
report. By using ##D<fsyear> as a variable ("For the year ended ##D<fsyear>") you can change
those multiple time period references to "For the year ended 2010" by applying the value 2010 once to
the variable ##D<fsyear>.

Variable Types

You can use different types of variables in your report in CDM to reference different types of data, build
a table of contents, or specify the order of attached notes.

You can use variables with the following items:

« Report objects
To reference information in report objects, for example, between Excel objects and Word objects.

« Global objects
To reference information in report objects across different reports.

« Queries
To reference information from the data source, for example, time periods. These variables are
configured by the administrator. For more information about creating query variables, see the
CDM Administration Guide.
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Report Object Variables

Uniquely named report object variables are used in CDM to reference information between report
objects in the same report, or in the same report object. They can be created on an ad hoc basis by
users or the administrator. You can also create global report object variables that will reference
information between report objects in different reports.

You can use the following types of report object variables:

» Predefined
A variable that is applied for a specific purpose. No unique name is required for this variable.

« Uniquely named
A variable with a unique name that is created and does not occur elsewhere in the report.

In either case, the ## symbol set is used to denote the beginning of a variable, except when creating a
print area named range variable.

= Tip: You can refresh your objects in advance each time a variable or query update occurs
using the Use Advanced Refresh option (this will not work for interactive queries). This option
must be enabled in the CDM.config file. It can then be selected for use in a report's properties.

Naming Conventions for Report Object Variables

When you use report object variables in CDM, you should follow a naming convention, so that it will be
easy to understand the purpose of each variable.

When you are planning the naming convention for your report object variables, be careful to select a
pattern that CDM can interpret correctly when it compiles your report. Best practice is to create the
name of a report object variable in the following order:

» Two pound signs to indicate that this is a variable.
« A number to indicate the numbering of the variable.

« Aword to indicate the type of item represented by the variable.

In the following incorrect example, the number follows the word and can cause an error when CDM
compiles your report:

Variable Result
##SCashl . . . . .
F4SCash? When the report is compiled, a search is performed for all instances of the variable
§#SCash3 ##SCashl. Two are found because ##SCash11 is incorrectly included in the
search results. Best practice: keep the numbers at the beginning of the string to
#4SCashil avoid this error.

In the following correct example, the variables are changed so that the number precedes the word:
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Variable
##1SCash
##23Cash . . . : .
##BSCZ; When the report is compiled, a search is performed for all instances of the variable
##1SCash. Only one instance is found.
##11SCash

Predefined Report Object Variables

Predefined report object variables are automatically applied to a report when it is generated in CDM.
These variables typically define a range of data to display, or identify a specific format to be applied.

Predefined report object variables, as described in the following table, do not require a unique name:

Variable | Variable Type ‘ Description

Identifies the start of the cell range that is referenced in a report
object. Works in conjunction with the # #RE variable.

Identifies the end of the cell range that is referenced in a report
object. Works in conjunction with the # #RS variable.

In a report object, a note is applied. The note is left-justified in the
cell, forexample, |Revenue (Note 1)....... |

In a report object, a note is applied. The note is right-justified in the
cell, for example, |Revenue ....... (Note 1) |

In a report object, a variable is applied that is raised slightly above
##SL Superscript Left the text line. The variable is left-justified in the cell, for example,
[Revenue (1) ... veeenennennn. |

Identifies a range to be converted into an image. Works in
conjunction with the ##IRE variable.

Identifies a range to be converted into an image. Works in
conjunction with the ##IRS variable.

Uniquely Named Report Object Variables

A report object variable in CDM can represent one data cell in a worksheet, but it must have a unique
name.

##RS Range Start

##RE Range End

##NL Note Left

##NR Note Right

##IRS |Image Range Start

##IRE |Image Range End

You can define the unique name, but the syntax of the variable is always the same.

The following table describes the report object variables that can be uniquely named.

Variable

Variable Type Example Description

This variable tags an item to be displayed in another Excel
or Word report object. The contents of the two cells

S S<f >
i Source i syear immediately to the right of this variable code determine the
unique name for the variable and the value.
54D Destination |#4D<£syear> This variable calls an item that has been tagged by the ##5S

variable in another Excel or Word object.
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Variable

Variable Type Example Description

A report can contain data from different sources. This
variable is useful in applying rules to validate data in a

##R Rule ##R | Cash | 0 |report. The contents of the two cells immediately to the
right of this variable code determine the unique name for
the variable and the value.

For example, you can have a variable with the following values:

o Code: ##s
« Unique Name: fsyear
« Value: 2009

When the variable is applied elsewhere in the report, it has a specific syntax of # #D<fsyear>. In this
example, ##D<fsyear> is replaced with the value 2009 when the report is generated.

Important: Creating source variables that reference destination variables causes refresh
issues, which results in unexpected values. For more information, see the CDM
Administration Guide.

Use Report Object Variables to Set a Display Range

You can use report object variables in an Excel object in CDM to set a display range so that only specific
information (rows or columns) is displayed while other information is excluded when the report is
generated.

The following figure illustrates a display range that points from the ##RS variable to the ##RE variable.

HHERS

HERE

To define the display range:

1. Open the report that you want to work with.

Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

Navigate to the range in the Excel object that you want displayed in your generated report.

In a cellimmediately to the upper left of the range, type ##RS.

o g &~ w b

In a cellimmediately to the lower right of the range, type ##RE.
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7. Save your changes.
8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Excel object.

Use a Report Object Variable to Create a Data
Reference

You can use report object variables to reference data in an Excel object and in a referenced object in
CDM.

Use a Report Object Variable to Reference Data in an Excel
Object

1. Open the report that you want to work with.
Open and check out the Excel object that you want to edit.

Click the Section View Mode icon in the status bar.

w0 DN

In the Excel object, enter the parameters to set up a source object variable (##S). Set up the
source variable in three columns:

a. Inthe first column, enter the ##S variable as an identifier.

b. Inthe second column, enter the unique variable name for reference, for example,
CashCrtYer.

c. Inthe third column, enter the value for the variable, for example, 1,066,510.

Important: Ensure that the variable name is outside of the display range, that is, not
contained inside the ##RS and ##RE variables.

5. Save your changes in the Excel object.
6. Click the Default View Mode icon in the status bar.
7. Save your changes to the report and check in the Excel object.

You can now use the source object variable to import the value you applied to the variable into a
worksheet in another Excel object, or into a Word or PowerPoint object.

Use a Report Object Variable to Reference Data in a
Referenced Object

If a report contains a destination variable (##D) with no corresponding source variable (##5), CDM
searches for the source variable in all shared objects in the same report and other reports. If a reference
object containing the source variable is found, the destination variable from the corresponding reference
object can be refreshed. If the source variable cannot be found, then the destination variable is
considered to be an orphan variable.

Important: If multiple reference objects exist that contain the same source variable, the first
matching source variable, based on the date it was added, will be used for refreshing the
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destination variable. A source variable's value becomes locked if the reference object in which
it is contained is locked. Subsequently, its corresponding destination variable is indirectly
locked.

Important: To use a report object variable to reference data in a referenced object:

1. Open the report that you want to work with.
Open and check out the report object that you want to edit.

Click the Section View Mode icon in the status bar.

w0 DN

In the Excel object, enter the parameters to set up a source object variable (##S). Set up the
source variable in three columns:

a. Inthe first column, enter the ##S variable as an identifier.

b. Inthe second column, enter the unique variable name for reference, for example,
CashCrtYer.

c. Inthe third column, enter the value for the variable, for example, 1,066,510.

Important: Ensure that the variable name is outside of the display range, that is, not
contained inside the ##RS and ##RE variables.

5. Save your changes in the source Excel object.
6. Click the Default View Mode icon in the status bar.
7. Save your changes to the report and check in the Excel object.

You can now use the source object variable to import the value you applied to the variable into a
worksheet in another Excel object, or into a Word or PowerPoint object.

Use a Report Object Variable to Create a Named
Range in an Excel Object

You can use a named range in an Excel object in CDM. When you use source and destination report
object variables, you can create a named range in the worksheet of an Excel object and then use it to
import the information in that range into a worksheet in another Excel object, or into a Word or
PowerPoint object. You can also choose to include or exclude formatting.

The ability to use named ranges is useful when you have a range of information that would normally
require a separate variable for each cell value in the Excel object.

To use a report object variable to create a named range in an Excel object:

1. Open the report that you want to work with.
2. Open and check out the Excel object in which you want to use a named range.
3. Click the Section View Mode icon in the status bar.

4. Inthe data worksheet, select the cell range that you want to define as a named range. The data
worksheet is originally named Sheet1, but you can rename it if necessary.
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5. Click Formulas, then Define Name. The New Name window opens.
6. Type the name of the range in the Name field, for example, AssetsRange, and click OK.

7. Inthe same data worksheet where you added the named range, create a source object variable
(##5) that tags the range. Set up the source variable in two columns:

a. Inthe first column, enter the ##S variable as an identifier.

b. Inthe second column, enter the name you used for the range you created, for example,
AssetsRange.

Important: Ensure that the variable name is outside of the display range, that is, not
contained inside the ##RS and # #RE variables.

8. Save your changes in the source Excel object.
9. Click the Default View Mode icon in the status bar.
10. Save your changes to the report and check in the source Excel object.

You can now use the source named range variable to import the information in that range into a
worksheet in another Excel object, or into a Word or PowerPoint object.

Create a Print Area Named Range Variable in an Excel
Object

You can create a print area nhamed range variable in an Excel object in CDM. When you select a range
of cells in an Excel report object worksheet and name it as a print area, you can create a named range
and then use it to import the information in that range into a Word object.

The ability to use named ranges is useful when you have a range of information that would normally
require a separate variable for each cell value in the Excel object.

You can define only one print area on each worksheet in an Excel report object. Any print areas added
to a print area already defined on a worksheet are not generated, only the first print area is generated. A
print area must have the name Print_Area. You can also add the same markers as you would for the
##RS and ##RE variables (in effect, # #NR, ##NL, ##SR, ##SL, +, - and cell padding). Formatting of
content within the print area is maintained when the print area named range variable is inserted into a
Word object.

To create a print area named range variable in an Excel object:

1. Open the report that you want to work with.

2. Open and check out the Excel object in which you want to create a print area named range
variable.

3. Click the Section View Mode icon in the status bar.

4. Inthe data worksheet, select one or more cell ranges that you want to define as a print area
named range variable. The data worksheet is originally named Sheet1, but you can rename it if
necessary.

5. To define the print area, select Page Layout > Print Area> Set Print Area.
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6. To add an additional cell range to the print area, select another cell range and select Page
Layout > Print Area > Add to Print Area.
7. Enter a unique name for the print area named range variable.
8. Save your changes in the source Excel object.
9. Click the Default View Mode icon in the status bar.

10. Save your changes to the report and check in the source Excel object.

You can now use the print area named range variable in a Word object to import the information in that
range into a worksheet.

Create Multiple Named Ranges in an Excel Object
Print Area

You can create multiple named ranges in the print area of an Excel object in CDM. When you select a
range of cells in an Excel report object worksheet and name it as a print area, you can create one or
more named ranges and then use them to import the information in those ranges into a Word object.

The ability to use named ranges is useful when you have a range of information that would normally
require a separate variable for each cell value in the Excel object.

You can define multiple named ranges in a print area on each worksheet in an Excel report object by
giving each a unique name. You can also add the same markers as you would for the ##RS and # #RE
variables (in effect, # #NR, ##NL, ##SR, ##SL, +, - and cell padding). Formatting of content within the
print area is maintained when the named range variables are inserted into a Word object.

To create multiple named ranges in an Excel object print area:

1. Open the report that you want to work with.
2. Open and check out the Excel object in which you want to create a print area named range.
3. Click the Section View Mode icon in the status bar.

4. Inthe data worksheet, select one or more cell ranges that you want to define as a print area
named range. The data worksheet is originally named Sheet1, but you can rename it if
necessary.

5. To define the print area, select Page Layout > Print Area> Set Print Area.

6. Toadd an additional cell range to the print area, select another cell range and select Page
Layout > Print Area > Add to Print Area.

7. To create a named range, select a cell range within the print area and give it a unique name,
such as NamedRangeO1.

8. Continue selecting cell ranges within the print area and naming them to create additional named
ranges.

9. Save your changes in the source Excel object.
10. Click the Default View Mode icon in the status bar.

11. Save your changes to the report and check in the source Excel object.
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You can now use the multiple named ranges within the print area in a Word object to import the
information in their ranges into a worksheet.

Use a Report Object Variable to Convert a Range in an
Excel Object into an Image

You can use a report object variable in an Excel object in CDM to specify a range, convert it to an image,
and have it display in another report object when the report is generated.

1. Open the report that you want to work with.
Open and check out the Excel object that has a data range that you want to convert to an image.

Click the Section View Mode icon in the status bar.

A w0 N

Navigate to the range in the Excel object that you want to convert to an image in your generated
report.

i

In a cellimmediately to the upper left of the range, type ##IRS.

6. In a cellimmediately to the lower right of the range, type ##IRE.
Important: Ensure that the image variable range is not overlapping or placed inside a
display range (that is, the ##RS and ##RE variables) or another image range.

7. Save your changes in the source Excel object.

8. Click the Default View Mode icon in the status bar.

9. Save your changes to the report and check in the Excel object.

You can now use the source object variable to convert the range to an image, and have it display in
another report object when the report is generated.

Use a Report Object Variable for Note Numbering

You can configure variables to automatically update note numbering and maintain a uniform
appearance with note numbering.

Use a Report Object Variable to Apply Note Numbering

You can use report object variables to add humbered notes to a report to provide details about an item
in CDM.

1. Open the report that you want to work with.
In the report tree, determine the location of where you want to add note numbering.

Open and check out the Excel or Word object where you want to apply note numbering.

w0 DN

Click the Section View Mode icon in the status bar.
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5. Inthe report object properties, ensure the following settings are made:

« Note Numbering - Select Automatic.
+ Note Type - Is automatically set.
« Note Variable - Enter a unique variable to be used, for example, ##CshNote.

6. Save your changes.

7. Inthe work area for the Excel or Word object, type the variable name using the correct syntax.
You must type the variable where you want the note number to appear in the report.

## CshNote. Cash
Where:

« ##CshNote is a uniquely named note numbering variable.
« The period (.) is a period that occurs after the number.

o Cash is the title of the note number to be displayed.

8. Save your changes in the Excel or Word object.
9. Click the Default View Mode icon in the status bar.

10. Save your changes to the report and check in the Excel or Word object.

Use a Report Object Variable to Apply Note Numbering Style

You can use report object variables to maintain a uniform appearance with note numbering in CDM.

1. Open the report that you want to work with.
2. Open and check out the Excel or Word object containing a note.
3. Click the Section View Mode icon in the status bar.

4. Adjust the style of a note by adding one of the following additional variables in a cell above the
column containing note numbering:

o ##NL - Note appears left-aligned.
o ##NR - Note appears right-aligned.
o ##5sI - Note appears as left-aligned superscript.

5. Save your changes.
6. Click the Default View Mode icon in the status bar.

7. Save your changes to the report and check in the Excel or Word object.
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Use a Report Object Variable to Apply Validation Rules
in an Excel Object

A report in CDM can contain various data from various sources (OLAP, relational, or an external data
source). You can use Excel formulas and object variables to compare different data sources, to
determine if the values are what you expect.

In the following example, the same data has been imported into the Excel object from two different
sources. One source provided summary level data (Current Assets) and the other provided line item
breakdown of the data (Note). The validation compares both sources to determine if the total for Cash is
the same. This example creates a validation that uses the rule variable (##R).

To apply validation rules in an Excel object using report object variables:
1. Open the report that you want to work with.
2. Open and check out the Excel object to which you want to apply validation rules.
3. Click the Section View Mode icon in the status bar.

4. Find the data worksheet. The data worksheet is originally named Sheet1, but you can rename it if
necessary. Create source object variables (##S) that tag the values you want to validate, as
shown in the following table.

Table 1: Source Object Variables

Code ‘ Reference ‘ Value
##S CashCrtYer 1,066,510
##S CashCrtYer_1 2,163,539
##S CashCrtYer_2 853,208

5. Save your changes in the source Excel object.
6. Open the Excel object that contains the comparative data you want to use in the validation.

7. Inthe data worksheet, create destination object variables (##D) to call the source data into the
worksheet.

8. Inthe same data worksheet, ensure that the data is in balance, as shown in the following table.

Table 2: Destination Object Variables for Validation

Cash Rule

Code Name Assets Note Total
##D CashCrtYer 1,066,510 1,066,510 0
##D CashCrtYer_1 2,163,539 2,136,539 0
##D CashCrtYer_2 853,208 853,208 0

« Use Excel formulas to subtract Assets from Note.

+ A non-zero balance is displayed in the Total column.
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9. Inthe same data worksheet, create a rule object variable (##R) that tags the result of the
validation for Cash.

Table 3: Rule Object Variables

Code Name Assets Note Total
##D CashCrtYer 1,066,510 1,066,510 0
##D CashCrtYer_1 2,163,539 2,136,539 0
##D CashCrtYer_2 853,208 853,208 0
##R Cash 0

Set up the source variable in three columns:
a. The first column with the ##R variable as an identifier.

b. The second column with a unique variable name for reference (Cash).

c. The third column with the value for the variable, which was calculated by the formulas used
to validate the data.

10. Save your changes in the destination Excel object.
11. Click the Default View Mode icon in the status bar.

12. Save your changes to the report and check in the Excel object.

Report validation can occur in these ways:

« If you want to check validation and generate the report at the same time, the validation process is
automatic. Every time you generate a report that contains at least one ##R variable, the report
validation process runs automatically. If at least one ##R variable exists in the report, the
following events occur:

o All data refreshes.
o All Excel validation formulas are resolved.
o Avalidation report is generated.

o An external Microsoft™ Excel file is generated, containing the validation report. This Excel
file contains the status (pass or fail) of all report objects that contain a ##R variable. The
Excel file also contains other report, date, and time information.

o [f the report contains objects marked as exhibits or supporting documents, the exhibits and
supporting documents generate separately along with the validation report and the external
Microsoft Excel file.

« If you want to check validation without generating the report, you can use the Quick Report
Validation or Full Report Validation command on the ribbon. The quick validation is made
against the cache without doing a cache refresh. The latest changes in the report are validated. A
full validation refreshes the cache before validation. If at least one ##R variable exists in the
report, the following events occur:

o All data refreshes.
o All Excel validation formulas are resolved.
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o An external Microsoft Excel file is generated, containing the validation report. This Excel file
contains the status (pass or fail) of all report objects that contain a ##R variable. The Excel
file also contains other report, date, and time information.

Important: If there are no ##R variables in the report, the validation process does not run in
either case.

Validation is successful if the cell display value:

+ Has avalue of 0.

« Has a value of 0 but the actual value is different (for example, 0.023) and the cell is formatted as

Number, Currency, or Accounting, with zero decimal places.

Validation will fail if the cell display value:

Has a value other than 0O (for example, 1).

Has a value other than 0 (for example, 0.023) but due to the cell width it is displayed as 0.
Is formatted as text.

Is not displayed as 0 (for example, 0.023) and is formatted as accounting.

Has a value with decimals (for example, 0.00) and an actual value of 0 and the cell is formatted
as Number or Currency, with two decimal places.

Use a Report Object Variable to Create a Table of
Contents

You can assign a variable to a report object in CDM so that it is listed in the table of contents (TOC) for a
report.

Building a table of contents involves assigning TOC variables to report objects and then listing these
variables, in either a table or by using paragraphs, in a Word object you add to the report.

To create a TOC using report object variables:

1.
2.
3.

Open the report that you want to work with.
In report tree, determine the location where you want a table of contents to be placed.

Create a Word object that will be used to contain the table of contents. For more information, see
the CDM Administration Guide.

Determine what report objects you want to include in the table of contents.

For each report object that you want to include in the table of contents, check out the report
object and enter a unique TOC variable in the ToC Variable field in the Property and Comments
window. Use the correct syntax, for example, ##3page.

a. Type ## to identify the start of your variable.

b. Enter a unique number for this report object that represents the order that the report object
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is to be placed in the table of contents.

c. Type page to identify the variable as part of the table of contents.

6. Inthe table of contents Word object, complete one of the following tasks:

« Create and format a three-column table. Add as many rows as there are report objects to
which you have designated a TOC variable. In each row, enter the topic heading for the
report object in the first column, leaders (....... ) in the second column, and then the
corresponding TOC variable that you assigned to that report object.

« Enter the topic heading for the first report object, followed by leaders, and then the
corresponding TOC variable you assigned to that report object. Start a new paragraph and
enter the same information for the second report object you want in the table of contents.
Continue to add a paragraph and information for each report object to which you have
designated a TOC variable.

7. Save your changes in the table of contents Word object.

8. Save your changes to the report and check in the Word object.

When the report is generated, the correct page numbers are dynamically updated and appear in the
table of contents for the report.

Create a Section Header Variable in a Word Object

You can create a variable in a Word object in CDM to define section headers. The section headers are
propagated to later pages of the current report object when the current report object is longer than one
page. The appropriate report object property must also be set.

This task creates the headers that are to be repeated at the top of each page in a Word object. These
headers are defined as header variables and work together with report object properties. During report
generation, the section variable is converted to a header. You can create a section header variable for
each Word object as necessary.

To create a section header variable in a Word object:

1. Open the report that you want to work with.
2. Open and check out the Word object for which you want to have a section header.
3. Click the Section View Mode icon in the status bar.

4. Type the header variable in the empty first line of the Word object. Use the correct syntax:
##SH<HeadingName>.

Click the Default View Mode icon in the status bar.
Save your changes in the Word object.
Check in the Word object.

To open the Properties window, click the Show Properties icon.

© o N o o

Type Continued in the Continue with Next field and click OK to save.
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After the report is generated, the header will appear on the first page and append the Continue with
Next on second and later pages.

Global Report Object Variables

You can use global report object variables to reference data across different reports in CDM.

The variable can be applied so that data is updated dynamically in value. Similar to uniquely named
report object variables, a global report object variable is uniquely named and the prefix determines if it is
a source or destination value.

Important: Creating source variables that reference destination variables causes refresh
issues, which results in unexpected values. For more information, see the CDM
Administration Guide.

The following table lists the global report object variables that you can use.

Variable

Code Example ‘ Description

‘ Variable Type

The global source dynamic variable tags an
item to be displayed in an Excel, Word, or
PowerPoint object of another report. The
contents of the two cells immediately to the
right of this variable code determine the unique
name and value for the variable. This type of
variable remains dynamic. The value is
updated whenever you refresh data.

##GSD Source ##GSD | fsyear

The global destination variable calls an item
that has been tagged by the ##GsD variable
and retrieves the result into the Excel or Word
object of another report.

##GD Destination ##GD<fsyear>

Use a Global Object Variable to Create Named Ranges
in Multiple Reports

You can use named ranges in Excel objects in multiple reports in CDM. When you use source and
destination global object variables, named ranges can be created in the worksheet of an Excel object
and copied to a worksheet in another Excel object, or a Word or PowerPoint object in a different report.
You can also choose to include or exclude formatting. The ability to use named ranges in this way is
useful when you have a range of information that would normally require a separate variable for each
cell value in the Excel object.

To use a global object variable to create named ranges in multiple reports:

1. Open the report that you want to work with.
2. Open and check out the Excel object in which you want to use a named range.
3. Click the Section View Mode icon in the status bar.

4. Inthe data worksheet, select the cell range that you want to define as a named range. The data
worksheet is originally named Sheet1, but you can rename it if necessary.
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5. Click Formulas, then Define Name. The New Name window opens.
6. Type the name of the range in the Name field, for example, AssetsRange, and click OK.

7. Inthe same data worksheet where you added the nhamed range, create a global source dynamic
object variable (##GSD) that tags the range. Set up the global source dynamic object variable in
two columns:

a. Inthe first column, enter the ##GSD variable as the identifier.

b. Inthe second column, enter the name you used for the range you created, for example,
AssetsRange.

Important: Ensure that the variable name is outside of the display range, that is, not
contained inside the ##RS and # #RE variables.

8. Save your changes in the source Excel object.

9. Click the Default View Mode icon in the status bar.

10. Save your changes to the report and check in the source Excel report object.

You can now use the global source named range variable to import the information in that range into a
report object in a different report.

Use a Global Object Variable to Create a Data
Reference in an Excel Object

You can use a global object variable to reference data values in an Excel object in CDM.

1. Open the report that you want to work with.
2. Open and check out the Excel object in which you want to use a named range.
3. Click the Section View Mode icon in the status bar.

4. Inthe Excel object, enter the parameters to set up a global source object variable (##GsD). Set
up the source variable in three columns:

a. Inthe first column, enter the ##GSD variable as the identifier.

b. Inthe second column, enter the unique variable name for reference, for example,
CashCrtYer.

c. Inthe third column, enter the value for the variable, for example, 1,066,510.

Important: Ensure that the variable name is outside of the display range, that is, not
contained inside the ##RS and # #RE variables.

5. Save your changes in the source Excel object.

6. Click the Default View Mode icon in the status bar.

7. Save your changes to the report and check in the source Excel report object.

You can now use the source object variable to import the value you applied to the variable into a report
object in a different report.
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Page Reference Variables

You can use page reference variables to identify and reference a report object in a generated report in
CDM. Page start and page end variables are used to signify the starting page and last page of the same
report object.

A page reference number is defined in the Page Reference Variable field of report object properties.
After defining a variable for the page reference and saving the changes, you can reference the report
object anywhere within the report. When you reference a report object, you have the following options:

« Reference the start of a page
You can reference the start of a page by using the # #PRS variable followed by the variable name
specified in the report object properties (# # PRS<varname>). During report generation, this
variable is resolved to the starting page number of the specified report object.

« Reference the end of a page
You can reference the end of a page by using the ##PRE variable followed by the variable name
specified in the report object properties (## PRE<varname>). During report generation, this
variable is resolved to the ending page number of the specified report object.

For referencing the start of a page. You have a report object, called Obj1, that is five pages long. You
want to reference the starting page of Obj1 in a report object that exists elsewhere in the report. You first
navigate to Obj1 and define a page reference variable (pagerefvar1) in the report object properties. You
then use the ##PRS variable to reference the page start of the report object in Obj5 using the following
syntax: ##PRS<pagerefvarl>. After report generation, Obj1 is compiled to start at page 10. When
you navigate to Obj5 after the report is generated, the variable specified has been converted to the
number 10.

For referencing the end of a page. Taking into consideration the example for referencing the start of a
page, you want to now reference the end page of Obj1 in Obj5, which exists elsewhere in the report.
After ensuring that Obj1 has a page reference variable, you first navigate to Obj5 and uses the following
variable to reference the end page of the report object: ##PRE<pagerefvar2>. After report
generation, Obj1 is compiled to start at page 10. Because Obj1 is five pages long, Obj1 ends at page
15. When you navigate to Obj5 after the report is generated, the variable specified has been converted
to the number 15.

Use a Page Reference Variable to Reference the Start
of a Page

You can use a page reference variable to reference the start of a page in an Excel or Word object in
CDM.

1. Open the report that you want to work with.
Open and check out the report object for which you want to reference a start page.
Click the Section View Mode icon in the status bar.

Enter a variable in the Page Reference Variable field of the report object properties.

a > oD

Using the syntax ##PRS<varname>, place the variable in the work area of the report object
where you want the start page to be set.

6. Save your changes in the report object.
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7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the report object.

Use a Page Reference Variable to Reference the End
of a Page

You can use a page reference variable to reference the end of a page in an Excel or Word object in
CDM. Ensure that you have created a page reference variable that references the starting page.

1. Open the report that you want to work with.
Open and check out the report object for which you want to reference an end page.
Click the Section View Mode icon in the status bar.

Enter a variable in the Page Reference Variable field of the report object properties.

a &> w b

Using the syntax ##PRE<varname>, place the variable in the work area of the report object
where you want the end page to be set.

o

Save your changes in the report object.
7. Click the Default View Mode icon in the status bar.

8. Save your changes to the report and check in the report object.

Report Query Variables

A report query variable is a variable that is used to filter data source queries at the report level. The
value of the variable can be overridden to filter the result set for all report objects referencing that query.
The value of the variable can be overridden to filter the result set for all report objects referencing that
query in CDM.

Create a Report Query Variable
1. Open the report that you want to work with.
2. Click Home > Report Query Variables. The Manage Query Variables window appears.

3. Inthe left pane, select an application query variable and click the arrow or drag the variable into
the right pane. The Edit window appears for you to edit the variable according to your report
requirement.

4. Edit the value and comment of the variable.

5. Select the Allows Override checkbox to allow report object query variables to override this
variable.

6. Select the Visible on Rollforward checkbox to allow this variable to be available for the
Rollforward and Cascade operations.

7. Click OK to create the variable.
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o Note: If you do not have the Manage Query Variables application permission, when you add a
query variable that is locked to a report, CDM adds it directly without displaying the Edit
window.

Edit a Report Query Variable
1. Open the report that you want to work with.
2. Click Home > Report Query Variables

3. Inthe Manage Query Variables window, double-click the report query variable you want to edit in
the right pane.

4. Modify the report query variable contents and click OK to save your changes.

o Note: You cannot edit a locked query variable if you do not have the Manage Query Variables
application permission.

Delete a Report Query Variable
If you no longer need a report query variable, you can delete it.
Important: A report query variable can be deleted only if it is not currently overridden at the

report object level. If you delete a report query variable, you cannot undo your action. Proceed
with caution.

To delete a report query variable:

1. Open the report that you want to work with.
2. Click Home > Report Query Variables.

3. Inthe Manage Query Variables window, select a report query variable in the right pane and click
the arrow or drag the variable into the left pane.

4. Click OK to delete the report query variable.

Report Object Query Variables

A report object query variable is a variable that is used to filter data source queries for a particular report
object. You can inherit object-level query variables from the report-level variables and further customize
their properties. After the value of a variable has been overridden at the report level, it can be further
overridden to filter the result set for the report object.

Create a Report Object Query Variable

You can create a report object query variable for Excel objects in CDM.

1. Open the report that you want to work with.

2. Open the Excel object for which you want to create a report object query variable.


https://insightsoftware.com/

Y insightsoftware 146

3. Click the Data tab on the ribbon, then click Report Object-Level Variables. The Manage Report
Object Query Variable window appears.

4. Select areport query variable in the left pane and click the arrow or drag the variable into the right
pane. The Edit window appears for you to edit the variable according to your report object
requirement.

5. Edit the value and comment of the variable.

6. Click OK to create the variable.

o Note: If you do not have the Manage Query Variables application permission, when you add a
query variable that is locked to a report object, CDM adds it directly without displaying the Edit
window.

Edit a Report Object Query Variable

1. Open the report that you want to work with.
Open the Excel object for which you want to edit a report object query variable.

Click the Data tab on the ribbon, then click Report Object-Level Variables.
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In the Manage Report Object Query Variable window, double-click a report object query variable
in the right pane.

5. Modify the report object query variable contents and then click OK to save your changes.

o Note: You cannot edit a locked query variable if you do not have the Manage Query Variables
application permission.

Delete a Report Object Query Variable

If you no longer need a report object query variable, you can delete it.

Important: If you delete a report object query variable, you cannot undo your action. Proceed
with caution.

To delete a report object query variable:

1. Open the report that you want to work with.
2. Open the Excel object for which you want to delete a report object query variable.
3. Click the Data tab on the ribbon, then click Report Object-Level Variables.

4. Inthe Manage Report Object Query Variable window, select a report object query variable in the
right pane and click the arrow or drag the variable into the left pane.

5. Click OK to delete the report object query variable.
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Variable Searches

You might want to find a particular reference variable or orphan variable in your report in CDM. If the
report is large, it might be difficult to find a particular variable.

You can use the Reference Variables window or Orphan Variables window to find a variable. You can
also use the Reference Variables window to open an object containing a variable.

The following reference and orphan variable icons can be displayed.

Icon ‘ Description

qf’ﬂ

Source variable

Destination variable

£y

Global source variable

Global destination variable

Image range start variable

Image range end variable

Named range start variable

Named range end variable

Chart variable

EE@EEEE‘E

Find a Reference Variable

A reference variable is a variable that is used to hold content for report automation. If necessary, you
can search for all the reference variables in a report in CDM. From the search results you can select a
specific variable and directly open the report object in which it is contained.

To search for reference variables:

1. Open the report that you want to work with.

2. Click Home > Reference Variables. The Reference Variables window opens with a list of
reference variables and their respective information in the following columns:

« Report - The name of the report in which the reference variable is located.

« Report Object - Name of the report object in which the reference variable is located.
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« Name - The name assigned to the reference variable. For the ##Rs/##RE and
##IRS/##IRE range variables, the range is shown (for example, A1 : G23). When you hover
over the variable, an icon indicates the type of variable, such as Range or Source.

« Address - For an Excel object, the name of the worksheet within the report object, along
with the row and column of the cell, where the variable is located.

« Comments - Displays any comments associated with the variable.

3. Thetable is a pivot table, so you can change your view.

o Tofilter any column, right-click the column header and select a filter method.

» To group the table by a particular column, drag and drop the column into the Drag a column
header here to group by that column area.

4. You can also perform additional tasks by clicking the following buttons in the Reference
Variables window:

« Refresh - Refreshes the window.
o Export To Excel - Creates a new Excel file and copies the pivot table information into it.

« Open - Select a variable and then click this button to close the window and open the report
object containing the variable.

¢ Close - Closes the window.

Find an Orphan Variable

An orphan variable is a reference variable that does not contain an accompanying source declaration. If
necessary, you can search for all the orphan variables in a report in CDM. From the search results you
can select a specific orphan variable and directly open the report object in which it is contained.

To search for orphan variables:

1. Open the report that you want to work with.

2. Click Home > Orphan Variables. The Orphan Variables window opens, displaying a list of
orphan variables and their respective information in these columns:

» Report - The name of the report in which the orphan variable is located.
« Report Object - The name of the report object in which the orphan variable is located.

« Variable Name - The name assigned to the orphan reference variable. When you hover
over the variable, an icon indicates the type of variable, such as Range or Source.

« Address - For an Excel object, the name of the worksheet within the report object, along
with the row and column of the cell, where the orphan reference variable is located.

« Comments - Displays any comments associated with the variable.
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3. Thetable is a pivot table, so you can change your view.

« To filter any column, right-click the column header and select a filter method.

« To group the table by a particular column, drag and drop the column into the Drag a column
header here to group by that column area.

4. You can also perform additional tasks by clicking the following buttons in the Orphan Variables
window:

« Refresh - Refreshes the window.
« Export To Excel - Creates a new Excel file and copies the pivot table information into it.

« Open - Select an orphan variable and then click this button to close the window and open
the report object containing the orphan variable.

« Close - Closes the window.

Variable Security

You can manage variable security by restricting or enlarging the use of a one or more report variables.

Variables contained in imported reports or report objects are public until restrictions are set. When you
set variables restrictions for a specific user, the Insert Variable window filters out the variables they are
not allowed to add in a report. If a user who is denied the use of a specific variable tries to manually
insert that variable into a report object or imports an object containing that variable, they will not be able
to save the report object until the variable is removed.

If the user has access to a report object that already uses the restricted variable, they are still able to
generate and resolve the variable for that object only. However, they are still prohibited from inserting
the variable into other objects.

Deleting a variable also removes any restrictions set on that variable. It becomes a public variable if
added again. Variable security settings are maintained in reports that are rolled forward or cascaded.

Manage Variable Security

A user with the Manage Variable Security permission can set variable security by restricting or
enlarging the use of one or more report variables.

1. Open the report you want to work with.

2. Click Home > Manage Variables Security. The Manage Variables Security window opens,
displaying all global variables and all local variables from the current report, regardless of any
restrictions that exist for the current user. All users and user groups are also displayed.

3. Click View By to choose your method of managing variables: select a user and assign variables
or select a variable and assign users.

4. Select Allow or Deny to set restrictions.

5. Click Save.
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Desktop Publishing

If you use desktop publishing applications such as Adobe™ InDesign to add special formatting to your
reports, you can use CDM to identify the content that you want to format in a certain way in the output for
your desktop publishing application.

Important: The functionality for desktop publishing applications such as Adobe™ InDesign is
beyond the scope of this guide. For more information, see the appropriate documentation or
online help.

Overview

You can adapt the output from Certent CDM for use in a desktop publishing application such as Adobe™
InDesign.

For Excel objects, you must tag specific content for your desktop publishing application. For Word
objects, automatic Word generation can be used. You can go to Administration > Resources >
Desktop Publishing Styles to import styles from desktop publishing applications such as Adobe
InDesign or manually create new styles. This is applicable for all styles: paragraph, character, list, table,
and so on.

You must have the Manage Desktop Publishing Styles permission to create or import desktop
publishing styles in CDM.

Report content can be generated so that it can be used in desktop publishing tools. The content is
encapsulated in XML tags that are named according to the content style. The generated XML file can
then be imported into a desktop publishing application and the styles can be automatically mapped
using their names.


https://insightsoftware.com/

Y insightsoftware 151

Word Content for Desktop Publishing

Microsoft Word report object content is generated automatically to desktop publishing XML and requires
no tagging.

Styles

Content that uses Word styles that are present in the CDM Desktop Publishing Styles list
(Administration > Resources > Desktop Publishing Styles) are automatically generated (in effect, tags
are not necessary). Contact your administrator to ensure the styles are present. The style names there
must be identical to those in the Word objects you want to generate (the names are case sensitive).

For example, consider this Word object:

Automatic Word Text =

- Dhiect Summans
User Object Summary *

) Check out the report ohject to begin editing,
H osiwqlpd.dock - Compatibility Mode

Insert Design Layout References Mailings Review View Help Q Tell me what you w.

Algerian 12 | A A °C AaB

A& A RE
SAANRDDULL Ad

Paste r T U al . Algeria Bahns
- ¥ Farmat Painter : gerian  Bahndg

Clipboard P Fant Paragraph

1 THIS TEXT USES ALGERIAN STYLE.

2 This text uses Bahnschrift.

[3 This text is not required in the designed document)]

4 THIS TEXT USES ALGERIAN & Bahnschrift

Only the content with Word styles that are matching the names from the Desktop Publishing Styles list
are generated:

Administration Q < | Ay Desktop Publishing Styles X ’
q -

4 i Resources MName

=) Custom Groups

. Algerian
[ Checklists
ﬂ; Desktop Publishing Styles Bahnschrift
_a Report Object Templates Bahnschrift Char

Thus Algerian and Bahnschrift styled content is generated in the output, while the third sentence, using
a style called Text Not Required, is excluded.
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Output Word Styles

Word content is enclosed in the appropriate style paragraph so as to be easily mapped in your desktop
publishing application. Here is the sample generated content from the example in the preceding Styles
section:

<?xml version="1.0"?>
<Root>
- <AIDTest>
- <AutomaticWordText>
<Algerian=1 This text uses Algerian Style </Algerian=>
<Bahnschrift>2 This Text uses Bahnschrift </Bahnschrift>
- =zNormal=
<AlgerianChar=>4 This text uses Algerian</AlgerianChar=>
<BahnschriftChar > & Bahnschrift</BahnschriftChar>
< fNormal>
< fAutomaticWordText >
</AIDTest>
</Root>

As previously explained, Line 3 does not appear as it uses a style not included in the Desktop
Publishing Styles list, and the BahnschriftChar tag shown on line 4 is enclosing the content where the
Word character style was applied in an Algerian styled paragraph.

Included or Discarded Content

When CDM report content is not intended to be published and its formatted with a style that is used on
other parts of the report that must be published, this approach is recommended: You must create two
styles using the same font, character size, and so on, with different names. One of these styles is to be
added to the Desktop Publishing Styles list and is then applied to content that is to be included in the
desktop publishing output. The second style is applied to content that is to be excluded from the output,
and this style is not to be added to the Desktop Publishing Styles list.

Specific Styling Scenarios

« If a character style is applied to part of a paragraph in a Word object, and this style does not exist
in the Desktop Publishing Styles list, but the paragraph style is present, then the paragraph's
entire content is generated under the same XML node (in effect, tag).

« If a paragraph contains a character style that exists in the Desktop Publishing Styles list, but the
paragraph style doesn't exist, then the paragraph's content is not generated in the XML file.

» To generate Word tables, the paragraph and character styles that exist in a table's cells must also
exist in the Desktop Publishing Styles list. If they do not, the generated table is empty. The table
style must also exist, or the table will not generate.

» Print areas and print area subranges are generated with the Table Normal table style and
Normal paragraph styles in cells. These styles must exist in the Desktop Publishing Styles list to
generate the range variables to desktop publishing.

« Objects other than charts and images are not generated (for example, text boxes, shapes, and so
on). To generate charts and images, the style of the paragraph they are anchored to must exist in
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the Desktop Publishing Styles list. Charts and images that are not inline with text are not
generated.

« If you use a linked style in Word, that is, one that may be applied to both paragraphs and
characters and it is used on characters, it must be added to the Desktop Publishing Styles list
twice. The second entry should be its name suffixed by a space and the word "Char", and this
style name must exist in the Desktop Publishing Styles list to generate that nested tag. For
example, you have defined a style named "My Style" that can be used both for paragraphs and
characters. To generate this style for characters, you need to have a "My Style Char" style added
in the Desktop Publishing Styles list.

« When generating content to desktop publishing, the style names might be modified to comply
with the XML naming rules. For example, for the Word style "1_My Style" to be generated, the
same style name, that is "1_My Style", must exist in the Desktop Publishing Styles list and the
XML node will have the name "_MyStyle".

» Charts and images - all XML nodes for charts and images are generated with the name found in
the Alt Text description for Word objects and the tag name for Excel objects.

« Special characters - the < and > characters are not escaped. If needed, a placeholder can be
used instead that can be replaced with the appropriate content in the generated XML (in effect,
&lt; for < and &gt; for >).

Pictures

Pictures are automatically generated if they are inline to a paragraph with a style that has a name
matching a style in the Desktop Publishing Styles list.
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= | &l AID Testing =

H ®- =
Insert Design Layout
.Y
L Calibei (Bod 1
Pasi . J
" FFormstPenter | B T M v am X, x
Clipboard ] Fant

References

Review View Help

& Tell me what you want to do

Mailings

8 .|=3 .
-2 ’ AaBbCche | Aagbcety AaBbC  AaBbCc Aatj AaBt
=% - A~ = 5 &Ox- - Thormal | TNoSpac.. Heading 1 Hesding 2 Tithe 5
Pasagraph 5 Stylei

Collaborative, enterprising filing solution with extensive permissions
controlsfworkflow capabilities, dats connectors and support for various filing formats = leverage
Microsalt Word and Excel,

Streamlines narrative performance reporting (e.g., Board Books, Management Reports) leveraging same
core external reporting capabilities and robust PowerPoint / presentation formatting capabilities.
Supports ESMA, EBA, EIOPA, COREP / FINRER, Solvency I, and other key international reporing
requirements

< uml version="1,0"7>

<Foot>
- cAIDTest>
- «AlDTesting>
<Hormal>
various filing formats - leverage Microsoft Word and Excel.
<Image href="file:f fimages/ Image.png”/=>
«/Normal>
<Nomal> </Nermal>
«Normal> «</Normal>
<MHormals </Normals
</AIDTesting»
</AIDTest>
«fRook>

<HNormal>Streamlines narrative performance reporting (e.q., Board Books, Management Reports) leveraging same core external reporting
capabilities and robust PowerPoint / presentation formatting capabilities. </Hormal>
<Normal>Supports ESMA, EBA, EIOPA, COREP / FINREP, Solvency 11, and ather Key intérnational reporting requirements </Normal>

Collaborative, enterprising filing solution with extensive permissions/ controls/workflow capabilities, data connectors and support for

Excel Content for Desktop Publishing

Add a Desktop Publishing Tag to an Excel Object

154

In CDM, you can add tags to specific content in an Excel object for desktop publishing applications such

as Adobe™ InDesign.

When you tag an Excel object, you can use styles that were created in CDM or styles that were imported
into CDM from InDesign. To do so:

1. Open the report that you want to work with.

2. Check out the Excel object where you want to add a desktop publishing tag.

insightsoftware.com
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3. Select the content that you want to apply a tag to. You can select one cell or multiple contiguous
cells, and you can also tag pictures, graphs, and ranges. You cannot mix different kinds of
content in a single tag or tag content that was already tagged.

4. Click Add Tag > New Tag in the Report Object tab on the ribbon. In the window that opens, a
name is automatically assigned to the tag that you are creating and the next consecutive number
after the previously created tag is used. If you prefer, you can change the name. Select a style
from the list. The list includes styles that were created in CDM and styles that were imported into
this report from an InDesign import file.

Click OK.
Click Save.

Check in the Excel object.

®© N o O

If a message indicates that some items from the Tag Explorer might be out of date, click Refresh
Now.

The order of tags in the XML file that you will eventually generate will be the same as the order of the
objects within the report. The order of tags in a report object are based on their placement in the report
object.

Use of Styles in an Excel Table

Tagging a full table in Excel, instead of individual cells and using proper Excel cell styles, gives the
desired result faster and tag maintenance is kept to a minimum. When tagging an Excel range you must
assign a name to the tag being created and choose a style from the list defined in the Desktop
Publishing Styles list (Administration > Resources > Desktop Publishing Styles). The cell tags
automatically use the Excel cell style name.

Consider this sample Excel table (note that the name of the style is placed in the cell as content). When
the range below is tagged, a tag name of "TableTagCreatedManually" and the "Normal" is assigned:

Bad Input

Bad Input

Bad Input

Bad Input

Bad Input
Tag Explorer - 1
¥ Refresh Show all tags in the following location: S =
MName Style Name Is Orphan
= @ TableTagCreatedManually Normal -

] Referenced Content [Excel] Normal

The generated desktop publishing content is:
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ple="table" aid:trows="5" aid:tcols="4"
48" >Bad</Bad>

idth="53.25">Check Cell</CheckCell>
48" >Input</Input>

1="48" >Accentb</AccentE>

48" >Bad</Bad>

idth="53.25">Check Cell</CheckCell>
48" >Input</Input>
th="48">Accentb</Accenté>

48" >Bad</Bad>

1="53,25">Check Cell</CheckCell>
48" >Input</Input>

1="48" >Accentb</AccentE>
48">Bad</Bad>

<CheckCell 3. 1="53,25">Check Cell</CheckCell>
<Input aid:takle="cell" aid 48">Input</Input>

table="cell" ai 1 ala="1" ai alw 1="48" >Accentb</AccentE>

48" >Bad</Bad>

ith="53.25">Check Cell</CheckCell>
48" >Input</Input>

1="48" >Accantb</Accanté>

<CheckCell aid:tabl
<Input aid:table="cell" aid:

table="cell" ai

. e
<hccenté

<Bad aid:tabl
<CheckCell ai

<Input aid:table="cell" aid:

="gell" aid:crows="1" aid:

able="gell" aid

<hAcceantf aid:table="cell"
<Bad aid:tabl
<CheckCell sle=rgell
<Input aid:tabkle="cell" aid:
table="cell" ai
call® aid:

<hccenté aid

<Bad aid:ta

le="gall" ai

<hccenté ai

<Bad aid:
<CheckCell ax

<Input aid:tak

<hccantf aid:table="cell” rows="1" aid

</Normal>
</TableTagCreatedManually>

Note that the cell style is used as the name of the tag for each cell.

Report Generation for Desktop Publishing

You can generate a report or report object for desktop publishing in CDM. The resulting XML file can be
used in your desktop publishing application, such as Adobe™ InDesign.

1. Open the report that you want to work with.
2. Complete one of the following actions:

« To generate the entire report, select the report and click Home > Generate > Generate
Entire Report.

« To generate a selection of objects or a single report object , select the report objects and
click Home > Generate > Generate Selection.

3. Inthe window that opens, select Desktop Publishing in the Select Format section.

4. Optionally, to save a snapshot of the report or report object at the moment of generation, select
Save as Snapshot.

5. Select Automatic Word Generation.

6. Click OK to start the generation.

= Tip: You can view the progress in the All processes completed window in the status
bar. While processes are running, the title bar shows the number of running processes.
When the processes are finished, the title is All processes completed. A check mark
indicates that a process generated properly. An exclamation point indicates an error
that stopped the process.

7. Ifthe generation is not successful, an error message opens. Double-click the message to view
the Tag Explorer and the particular tag that has problems.

insightsoftware.com
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8. If the generation is successful, the output contains the XML file. To save the generated XML file,
click the Save icon in the All processes completed window, select a location for the file, and
click Save. The generated XML file can now be imported into your desktop publishing
application.

Report Structure

When generating a report or report selection to desktop publishing, the report structure is reflected in
the output XML document for easy tagging in the desktop publishing application.

This report:

Report
£ w Destkop Publishing Report Sample
4 {1 Section
4 /|7y Child Section
) ] Excel
e Wod

is generated as:

<Root>
<DestkopPublishingReportSample>
<8ection>
<ChildSection>
<Excel>
<Test2>
</ChildSection>
</8ection>
</DestkopPublishingReportSample>
</Root>

Desktop Publishing Styles

If you use desktop publishing applications such as Adobe™ InDesign to add special formatting to your
reports, you need desktop publishing styles in CDM to represent that formatting. You can create styles
in CDM, or you can import styles from your desktop publishing application.

You can work with desktop publishing styles if you have the Manage Desktop Publishing Styles
permission.

Grant Permissions for Desktop Publishing Styles

You can adapt the formatting of the content in your reports in CDM for use in a desktop publishing
application such as Adobe™ InDesign. Before users can work with desktop publishing styles, the
administrator must apply permissions to the appropriate reports, users, and user groups.
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1. Click the Home tab, then in the Navigation Pane, click Administration.

2. To specify permissions for a particular user or user group to work with desktop publishing styles,
complete the following steps. You must assign this permission only once per user or user group.

a. Under Security, double-click Application Permissions.

b. Select the user or user group.

c. Inthe work area, expand View.

d. Select the Allow checkbox next to Manage Desktop Publishing Styles.

3. To specify permissions for a particular user or user group to work with desktop publishing tags,
complete the following steps. You must assign this permission for each report.

a. Under Security, double-click Report Permissions.

b. Select the report or report group.

c. Selectthe user or user group.

d. Inthe work area, expand View.

e. Select the Allow checkbox next to Manage Desktop Publishing Tags.

4. Click Save.

Import Desktop Publishing Styles

If your InDesign application already contains many styles, importing styles is a more efficient approach
than creating new styles individually.

Export the styles from InDesign and save the XML file in a location that is accessible at the appropriate
file path. The file must follow XML format, and it must have an .xml extension. You can obtain this file in
InDesign by exporting the document in an .idml file format. You can then extract this archive to find the

style file named mapping.xml.

To import desktop publishing styles in CDM:
1. Do either of the following to open the Desktop Publishing Styles tab in the work area:

« Click the File tab, then navigate to Administration > Resources > Desktop Publishing
Styles.

« Click the Home tab, then in the Navigation Pane, click Administration and double-click
Desktop Publishing Styles under Resources.

2. Click Home > Import.

3. Inthe window that opens, click Browse, select the exported file, and click Open. The styles that
are available in the XML file are listed in the import window.

4. Select the styles that you want to import, or click All to select all styles in the list.

5. Click OK. The desktop publishing styles that you imported appear in the style table in the work
area, with a check mark in the Imported column. If a style with the same name exists in the
application, an error message opens. Styles from Microsoft™ Office are also added automatically
when a tag is created in a Word object.
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Add a Desktop Publishing Style

If you do not want to import styles from InDesign, or if you need one or more additional styles, you can
use CDM to create them.

1. Inthe Desktop Publishing Styles tab in the work area, click Home > Add > Desktop Publishing
Style.

2. Type a name for the desktop publishing style. The name must be unique, and blank spaces at the
beginning or end of the name are not allowed.

3. You can specify a description for the desktop publishing style. Blank spaces at the beginning or
end of the description are not allowed.

4. Click OK. The desktop publishing style that you created appears in the style table in the work
area.

Edit a Desktop Publishing Style

To edit the name or description of a desktop publishing style:

1. Inthe Desktop Publishing Styles tab in the work area, double-click the style that you want to edit.

2. Change the name or description of the desktop publishing style. The name must be unique, and
blank spaces at the beginning or end of the name or description are not allowed.

3. Click OK.

Delete a Desktop Publishing Style

If necessary, you can delete a desktop publishing style in CDM that was originally created for use in a
desktop publishing application such as Adobe™ InDesign. A style cannot be deleted if it is used in a tag.

Important: If you delete a desktop publishing style, you cannot undo your action. Proceed with
caution.

To delete a style:

1. Inthe Desktop Publishing Styles tab in the work area, select the style that you want to delete.
2. Click Home > Delete.

3. Inthe confirmation message that opens, click Yes.

Desktop Publishing Tags

After you create or import your desktop publishing styles, you can use them in CDM to add tags to
specific content in Excel objects for desktop publishing applications such as Adobe™ InDesign. In the
Excel objects, you can create and edit tags, or references to your tags.

View and Navigate Desktop Publishing Tags

To view desktop publishing tags in the Excel object and move from tag to tag:
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. Open the report that you want to work with.

To view the list of tags that are available, open an object and click Show Tags in the Report
Object tab on the ribbon. The Tag Explorer opens, containing a list of all desktop publishing
tags, along with information on the content that is referenced by each tag.

« Toview all tags in the selected report object, click Show all tags in > Selected report
object.

« Toview all tags in the entire report, click Show all tags in > Report.

160

To view tags that exist in an Excel object, open the object and check it out, then click Highlight

Tags.

To move from one existing tag to another in an Excel object, check out the object, and then click

Go to Next Tag or Go to Previous Tag.

Edit a Desktop Publishing Tag

You can change the name of a tag and the desktop publishing style that is associated with the tag.

1.
2.
3.

Open the report that you want to work with.
To view a list of tags that are available, click Report Object > Show Tags.

In the Tag Explorer, click the tag that you want to work with and click Edit.

In the window that opens, you can change the name of the tag. The new name must be unique,

and blank spaces at the beginning or end of the name are not allowed.

You can also change the desktop publishing style that is applied to this tag. Select the style from

the list or type the name of the style until it appears in the list.

Click OK. The desktop publishing tag appears in the Tag Explorer with the changes that you
made.

Edit a Reference to a Desktop Publishing Tag

To edit the reference of a tag and select different content:

1.
2.
3.

Open the report that you want to work with.
Check out the Excel object where you want to edit a reference to a desktop publishing tag.
To view a list of tags that are available, click Report Object > Show Tags.

In the Tag Explorer, click the tag that you want to work with, and expand its hierarchy.

= Tip: To access commands for expanding or collapsing a hierarchy, right-click any tag.

Ensure that the report object is the active document on your screen. To find the appropriate
report object, right-click the referenced content and click Navigate to Report Object.

In the report object, select the new content. You cannot select content that is already tagged.
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7. Inthe expanded hierarchy, click the referenced content that you want to replace with the newly
selected content and click Edit.

8. Inthe window that opens, compare the content in the Preview of Current Content section with
the content in the Preview of Selected Content section. If you are satisfied with the replacement,
click OK.

9. Check in the report object.

10. If a message indicates that some items from the Tag Explorer might be out of date, click Refresh
Now. The desktop publishing tag appears in the Tag Explorer with the changes that you made.

Delete a Reference to a Desktop Publishing Tag

If necessary, you can delete the reference to a desktop publishing tag in CDM that was originally added
to a report for use in a desktop publishing application such as Adobe™ InDesign.

In particular, you should delete orphan tags. Orphan tags are desktop publishing tags that exist in the
database but were deleted from the associated report object. An orphan tag is sometimes created when
the content is deleted before the tag is removed. When you create a tag and then check in a report
object without saving, the next time the report object is checked out, the reference from that tag is no
longer available.

If a tag contains an orphan reference, you can see a check mark in the Is Orphan column of the Tag
Explorer. If one tag contains both orphan reference content and valid reference content, you can see an
exclamation mark in the Is Orphan column of the Tag Explorer.

If a tag contains only one item of referenced content and you delete the referenced content, you
automatically delete the tag also.

Important: If you delete the reference to a desktop publishing tag, you cannot undo your
action. Proceed with caution.

To delete the reference to the tag:

1. Open the report that you want to work with.
2. Check out the Excel object where you want to delete a reference to a desktop publishing tag.
3. Toview a list of tags that are available, click Report Object > Show Tags.

4. Inthe Tag Explorer, click the tag that contains the reference that you want to delete, and expand
its hierarchy.

= Tip: To access commands for expanding or collapsing a hierarchy, right-click any tag.

5. Ensure that the report object is the active document on your screen. To find the appropriate
report object, right-click the referenced content and click Navigate to Report Object.

6. Inthe expanded hierarchy, click the referenced content, and click Delete.

7. Click OK.
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EDGAR HTML

You can use the EDGAR HTML tools in CDM to preview and adjust the HTML file that you plan to
submit to the Electronic Data Gathering, Analysis, and Retrieval (EDGAR) system.

All foreign and domestic companies filing with the U.S. Securities and Exchange Commission (SEC) are
required to file electronically through the EDGAR system.

Due to limitations in HTML, the formatting in your converted HTML file might not exactly match the
formatting in your Excel or Word objects. You can use the EDGAR HTML feature to preview the
appearance of your report after conversion to HTML. The EDGAR HTML feature highlights format
problems with the generated HTML so that you can make adjustments.

You can use the EDGAR tools in CDM to perform the following tasks:
e Preview EDGAR HTML Word and Excel objects.

» Make the corrections to the Word or Excel object.

« Validate selected objects for conversion to EDGAR HTML.

« Validate the complete report for conversion to EDGAR HTML.
« Allow users to generate alternating row coloring in tables.

o Generate EDGAR HTML for Word and Excel objects.

o Generate EDGAR HTML output for the entire report.

Validate EDGAR HTML Content

In CDM, you can scan for validation warnings for a single Excel or Word object, or for the entire report.

Validate EDGAR HTML for an Excel or Word Object

You can select a single Excel or Word object to be scanned for validation warnings.
1. Open the report that you want to work with.
2. From the report tree on the left, open the Excel or Word object.
3. Inthe Report Object tab on the ribbon, click Validate.

4. Click OK to start the validation.

Any errors that are found are displayed in the Validation tab in the status bar. When you click on an
error in the Validation tab, the relevant area of the document is highlighted.

Validate EDGAR HTML for the Entire Report

You can select a complete report to be scanned for validation warnings.

Make sure that the Custom Group settings are correct for Word and Excel objects before you validate
report output. Only objects included in the Custom Group set are included in report validation. As an
addition to the main report, you can include objects set to Exhibit and supporting documents.
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To validate EDGAR HTML for the entire report:

1. Open the report that you want to work with.

2. Click the parent report and click Home > Validate > EDGAR HTML. The EDGAR Validation
Options dialog is displayed.

3. Select the custom group that you require and add exhibits and supporting documents if required.

4. Click OK to start the validation.

= Tip: You can view the progress in the All processes completed window in the status
bar. While processes are running, the title bar shows the number of running processes.
When the processes are finished, the title is All processes completed. A check mark
indicates that a process generated properly. An exclamation point indicates an error
that stopped the process.

5. The validation results are displayed in a tab. If an error has occurred, an explanation is given.
The current and previous validations can also be viewed by clicking on a validation in the Other
section of the report tree.

= Tip: If the generated report is acceptable, you do not need to change the formatting of
the report.

Correct EDGAR HTML Validation Errors

If an EDGAR validation reveals formatting errors, the errors can be corrected before you generate
EDGAR HTML in CDM.

You can use CDM to correct EDGAR HTML errors. You must have completed EDGAR HTML validation
for the Excel or Word object and the object must be open.

To correct EDGAR HTML validation errors:

1. Open the report that you want to work with.
Check out and open the Word or Excel object that contains the error.
In the Report Object tab on the ribbon, click Validate.

Click the Section View Mode icon in the status bar.

a > w b

With the Validation tab open, double-click each error to highlight the error in the Word or Excel
object. Correct each error in the object.

o

Click the Default View Mode icon in the status bar.

7. Save and check in the object.

Preview EDGAR HTML

In CDM, you can view the EDGAR HTML output before you generate EDGAR HTML. You can preview
all Excel and Word objects.
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You can use CDM to preview each Word and Excel object to make sure that the report has an
acceptable format before you generate EDGAR HTML for the SEC.

To preview EDGAR HTML.:

1. Open the report that you want to work with.

From the report tree on the left, open the Excel or Word object.

In the Report Object tab on the ribbon, click Preview EDGAR.

To make changes, click Check out, and make the required changes.

Click Save

o g &~ w b

Click Check In.

Generate an EDGAR HTML Instance Document

In CDM, you can generate an instance document for a single Excel or Word object, or for the entire
report.

Generate EDGAR HTML for One or More Excel or
Word Objects

When you are setting up the generation of HTML output, you can change the width of borders, and
define tables to have alternative row coloring.

1. Open the report that you want to work with.
2. From the report tree on the left, select the report objects, using CTR+click on each report object.

3. Click Home > Generate > Generate Selection. The Generate Selected Report Objects window
is displayed.

4. Inthe Select Format section, select EDGAR HTML.

5. If custom groups are present, select those you want included in the Select Customized Group
section.

6. Ifrequired, in the Additional Preferences section, select either or both Include Supporting
Documents and Include Exhibits. For more information, see Exhibits and Supporting
Documents.

7. If required, select Perform Full Refresh to refresh the cache before validation.

8. Ifrequired, select Include Courtesy PDF. The SEC does not allow the markup of HTML
documents for printing. Generating a courtesy PDF provides you with a PDF version of the
document if markup is required.

9. Ifrequired, select Enable High Definition. For more information, see Generate High Definition
EDGAR HTML.

10. To apply alternating row coloring, select the Alternating Row Coloring checkbox.

11. Use the Select Language and Region Option drop-down list to select the culture option for your
generated report.
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If Enable High Definition is not selected, to control the HTML margin width, use the Left Margin,
Top Margin, Bottom Margin, and Right Margin fields to enter a margin border width in inches.

= Tip: The Left Margin and Right Margin settings change the need for a scroll bar.

Select the Fixed Page Width checkbox to set output content to be 8.5 inches wide and center-
aligned in a browser. This default can be changed by modifying the ReportGeneration
attribute in the CDM.config file. If this option is not selected, content is displayed the entire width
of the browser.

Select Realign List ltems and Border Content if required.
Click OK to start the generation.

You can view the progress in the All processes completed window in the status bar. While
processes are running, the title bar shows the number of running processes. When the
processes are finished, the title is All processes completed. A check mark indicates that a
process generated properly. An exclamation point indicates an error that stopped the process.

To open the file, open the All processes completed window in the status bar, and click the Open
icon. The generated file is displayed in a browser tab.

To save the file, click Save. Select the folder where you want to save the file and click OK.

Generate EDGAR HTML for the Entire Report

You can use CDM to generate the HTML file that you can submit to the Electronic Data Gathering,
Analysis, and Retrieval (EDGAR) system.

Make sure that the Custom Group settings are correct for Word and Excel objects before you generate
report output. Only objects included in the Custom Group set are included in report output. As an
addition to the main report, you can include objects set to Exhibit and supporting documents.

You can generate HTML from the CDM XBRL interface. While you set up the generation of HTML
output, you can change the width of borders, and you can define tables to have alternative row coloring.

To generate EDGAR HTML for the entire report:

1.
2.
3.

Open the report that you want to work with.
In the report tree, select the report.

Click Home > Generate > Generate Entire Report. The Generate Entire Report window is
displayed.

In the Select Format section, select EDGAR HTML.

If custom groups are present, select those you want included in the Select Customized Group
section.

If required, in the Additional Preferences section, select either or both Include Supporting
Documents and Include Exhibits. For more information, see Exhibits and Supporting
Documents.

If required, select Perform Full Refresh to refresh the cache before validation.
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8. Ifrequired, select Include Courtesy PDF. The SEC does not allow the markup of HTML
documents for printing. Generating a courtesy PDF provides you with a PDF version of the
document if markup is required.

9. Ifrequired, select Enable High Definition. For more information, see Generate High Definition
EDGAR HTML.

10. To apply alternating row coloring, select the Alternating Row Coloring checkbox.

11. Use the Select Language and Region Option drop-down list to select the culture option for your
generated report.

12. If Enable High Definition is not selected, to control the HTML margin width, use the Left Margin,
Top Margin, Bottom Margin, and Right Margin fields to enter a margin border width in inches.

= Tip: The Left Margin and Right Margin settings change the need for a scroll bar.

13. Select the Fixed Page Width checkbox to set output content to be 8.5 inches wide and center-
aligned in a browser. This default can be changed by modifying the ReportGeneration
attribute in the CDM.config file. If this option is not selected, content is displayed the entire width
of the browser.

14. Select Realign List Items and Border Content if required.
15. Click OK to start the generation.

16. You can view the progress in the All processes completed window in the status bar. While
processes are running, the title bar shows the number of running processes. When the
processes are finished, the title is All processes completed. A check mark indicates that a
process generated properly. An exclamation point indicates an error that stopped the process.

17. To open the file, open the All processes completed window in the status bar, and click the Open
icon. The generated file is displayed in a browser tab.

18. To save the file, click Save. Select the folder where you want to save the file and click OK.

Generate High Definition EDGAR HTML

In CDM, you can generate EDGAR HTML output that allows you to submit to the SEC a perfect (high
definition) EDGAR HTML document that looks exactly like what would have been printed from Microsoft
Word.

Due to limitations in HTML, the formatting in your converted HTML file might not have exactly matched
the formatting in your Microsoft Word report. You use the EDGAR HTML feature to preview the
appearance of your report after conversion to HTML. The EDGAR HTML feature highlights format
problems with the generated HTML so that you can make adjustments. If you use the high definition
option for EDGAR HTML when generating a report, adjustments for fixed page width and realignment of
listitems and bordered content are no longer necessary.

To generate high definition EDGAR HTML:

1. Open the report that you want to work with.

2. To generate the entire report, select the report in the report tree, then click Home > Generate >
Generate Entire Report. To generate one or more report objects, select the objects in the report
tree and click Home > Generate > Generate Selection.
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The Generate Entire Report window opens, or, if generating one or more report objects, the
Generate Selected Report Objects window opens.

In the Select Format section, select EDGAR HTML.
In the Additional Preferences section, select Enable High Definition.
Click OK to start the generation.

You can view the progress in the All processes completed window in the status bar. While
processes are running, the title bar shows the number of running processes. When the
processes are finished, the title is All processes completed. A check mark indicates that a
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process generated properly. An exclamation point indicates an error that stopped the process.

To open the file, open the All processes completed window, and click the Open icon.

The generated output is displayed.
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Accessibility Features

CDM has accessibility features that help users who have a physical disability to use the product.

Keyboard Shortcuts

CDM includes keyboard shortcuts to help you navigate the product and perform tasks.
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The following keyboard shortcuts are based on US standard keyboards.

Applies To Shortcut Keys
General Perform the command for an active command button. |ENTER
General Move forward to the next item in the tab index order. TAB
Cycle to the first tab index when at the end.
Move backward to the previous item in the tab index
General order. Cycle to the last tab index when at the SHIFT+TAB
beginning.
Checkboxes |Select or clear the checkbox. SPACEBAR
Menus Navigate down a menu and select a menu item. Down arrow and then Enter
Menus Navigate up a menu and select a menu item. Up arrow and then Enter
Scrolling Scroll down. Down arrow
Scrolling Scroll up. Up arrow
. L CTRL and +; CTRL+MOUSE
Zooming Zooming in.
wheel up
. . CTRL and -; CTRL+MOUSE
Zooming Zooming out.
wheel down
Zooming Return to default zoom level. CTRL+0
Navigation Reload the current page. F5
Navigation Move backward to the previously opened page. ALT+Left Arrow; BACKSPACE
L . ALT+Right Arrow;
Navigation Move forward to the previously opened page. SHIFT+BACKSPACE
Navigation Stop a page from loading. ESCAPE
Search Open a search box to perform a search on the current CTRL+F: F3
page.
Search Find the next match of the searched text on the CTRL+G: F3
current page.
Search E;ngdethe previous match of the searched text on the CTRL+SHIFT+G: SHIFT+F3
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Multiple Versions of Microsoft Office

Your reports in CDM can contain Excel, Word, and PowerPoint objects. Some aspects of your reports
and report objects depend on the version of Microsoft™ Office that was used to create the report object,
and the version of Microsoft Office that you use to open the report.
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Important: Macros applied to report objects are not preserved when you save the report
object.

If all report objects in your report are created with the same version of Microsoft Office, and all users of
your report use the same version of Microsoft Office, you do not need to read the rest of the topics in this
section.

However, if any report objects in your report are created with different versions of Microsoft Office, or
some users use a different version of Microsoft Office, read the following sections for useful tips on how
to work with your report and report objects.

Effects of Using Multiple Versions of Microsoft
Office

When you use multiple versions of Microsoft™ Office, some aspects of your reports in CDM depend on
the version that was used to create various report objects. The version of Microsoft Office that you use
can affect actions such as opening reports and report objects, pasting and exporting report objects, and
generating reports.

Open Reports and Report Objects

Consult the following table to learn about how different Microsoft Office versions affect opening reports
and report objects.

Situation

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

Effect

You can open and save reports and report objects. When you save
report objects, you automatically save them in the format of the version
of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can open and save reports and report objects normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office.

You view the later report object in the format of the version of Microsoft
Office that you use, and you might not see features or formatting
specific to the later version. However, no changes are made in the
database.

If a report object is saved in Microsoft Office 2007 and then you open it
in a later version of Microsoft Office and then save, the report object is
saved in Microsoft Office 2007 format, even though you are working in a
later version.

To view a report object in its original format, you must upgrade to the
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Effect
version of Microsoft Office that was used to create the report object.

Copy and Paste Report Objects

Consult the following table to learn about how different Microsoft Office versions affect copying and

pasting report objects.

Situation

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

Effect

You can copy and paste a report object by right-clicking the report
object and then using the Copy and Paste options. When you save a
pasted report object, you automatically save it in the format of the
version of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can copy and paste a report object normally by right-clicking the
report object and then using the Copy and Paste options.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can copy and paste a report object by right-clicking the report
object and then using the Copy and Paste options. All later report
objects are saved in the format of the version of Microsoft Office that
you use, and you might lose features or formatting specific to the later
version. The original report object remains in its original format.

To view and save a pasted report object in its original format, you must
upgrade to the version of Microsoft Office that was used to create the
report object.

Work with Shared Objects

Consult the following table to learn about how different Microsoft Office versions affect shared objects.

Situation

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

Effect

You can work with shared objects. All copied report objects are saved in
the format of the version of Microsoft Office that you use.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can work with shared objects normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office

Report objects are opened in the format of the version of Microsoft
Office that you use. When you save the report object, you receive a
message in which you must specify whether you want to save in the
format of the version of Microsoft Office that you use.

» Reference - The content cannot be modified. A linked object
actually has no content, so when an object is opened, the
content is retrieved from the original source object. This content
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Situation ’ Effect

opens in the version of Microsoft Office that is on your computer,
and you might lose features or formatting specific to the later
version.

» Copy - The content can be modified because a copy is treated
like any other report object that has content. All later shared
report objects are saved in the version of Microsoft Office that
you use, and you might lose features or formatting specific to the
later version.

To view a shared object in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.

Export Report Objects

Consult the following table to learn about how different Microsoft Office versions affect report object
exports.

Situation ’ Effect

If the report contains report
objects that were created in | You can export report objects. All earlier report objects are saved in the
an earlier version of Microsoft |format of the version of Microsoft Office that you use.

Office

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can export report objects normally.

_ You can export report objects. All later report objects are saved in the
If the report contains report  |format of the version of Microsoft Office that you use, and you might

objects that were created in a ||ose features or formatting specific to the later version.
later version of Microsoft
Office To export a report object in its original format, you must upgrade to the

version of Microsoft Office that was used to create the report object.

View and Compare Audit Trails or Snapshots

Consult the following table to learn about how different Microsoft Office versions affect audit trails and
shapshots.

o Note: If you work in Microsoft Office 2007, you can work with only one instance of a
PowerPoint object at a time. When you view audit trails for PowerPoint objects, the audit trail
content does not load because of this limitation. You will receive a message in which you can
save the logs separately. If you work in a later version of Microsoft Office, this restriction does

not apply.
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Situation ’

If the report contains report
objects that were created in
an earlier version of Microsoft
Office, or if the snapshots
were created in an earlier
version of Microsoft Office
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Effect

You can view and compare audit trails or snapshots. When you select
an audit trail entry or snapshot, you view it in the format of the version of
Microsoft Office that you use. The changes are not saved to the
database.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use, or if the
snapshots were created only
in the version of Microsoft
Office that you use

You can view and compare audit trails or snapshots normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office, or if at least one of the
shapshots was created in a
later version of Microsoft
Office

You can view and compare audit trails or snapshots. When you select
an audit trail entry or a snapshot, you view it in the format of the version
of Microsoft Office that you use, and you might not see features or
formatting specific to the later version. The changes are not saved to
the database.

To view an audit trail entry or snapshot in its original format, you must
upgrade to the version of Microsoft Office that was used to create the

report objects in the audit trail or the snapshot.

Generate Reports

Consult the following table to learn about how different Microsoft Office versions affect report

generation.

Situation

If the report contains report
objects that were created in
an earlier version of Microsoft
Office

’ Effect

You can generate the report. All earlier report objects are saved in the
format of the version of Microsoft Office that you use. The report is
generated as a .docx file.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can generate the report normally. The report is generated as a
.docx file.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can generate the report. All later report objects are saved in the
format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version. The report is
generated as a .docx file.

To generate the report in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.

Perform Report Rollovers

Consult the following table to learn about how different Microsoft Office versions affect report rollovers.
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Situation

If the report contains report
objects that were created in
an earlier version of Microsoft
Office
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’ Effect

You can perform a report rollover. All later report objects are saved in
the format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version.

If the report contains report
objects that were created only
in the version of Microsoft
Office that you use

You can perform a report rollover normally.

If the report contains report
objects that were created in a
later version of Microsoft
Office

You can perform a report rollover. All later report objects are saved in
the format of the version of Microsoft Office that you use, and you might
lose features or formatting specific to the later version.

To roll over the report in its original format, you must upgrade to the
version of Microsoft Office that was used to create the report object.
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