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Error: TM1 Data Source Connection Fails Using CAM - Interactive User

CDM 19.11.1

Error

TM1 Data Source Connection not showing Cubes of the selected TM1 Server Instance using CAM - Interactive User authentication in CDM 19.11.1.

Using the Cognos Access Manager Authentication Type results in a successful TM1 Connection. The test connection only fails for CAM Interactive User access.

For more information, see Connection Parameters for IBM Cognos TM1.

Error Log

INFO Ibm.CognosDM.Olap.Tm1.Rest.Tm1RestConnection - (null) Cannot find the certificate '' ? ? ? INFO Ibm.CognosDM.Olap.Tm1.Rest.Tm1RestConnection - (null) Cannot find the certificate '' ? ? ? ERROR Ibm.CognosDM.Services.Exceptions.CdmErrorHandler - (null) Exception Token: 'ec3e9832-b6d1-4a91-8071-725119994618'.Cannot connect to server. ? ? ? Ibm.CognosDM.DataSources.DataSourceUnavailableException: Exception Token: 'ec3e9832-b6d1-4a91-8071-725119994618'.Cannot connect to server. ---> Ibm.CognosDM.Olap.OlapException: Could not connect at Ibm.CognosDM.Olap.Tm1.Rest.Tm1RestConnection.Open() at Ibm.CognosDM.DataSources.Olap.DataSources.OlapDataSourceBase.OpenConnection(OlapConnectionDetails connectionDetails) --- End of inner exception stack trace --- at Ibm.CognosDM.DataSources.Olap.DataSources.OlapDataSourceBase.OpenConnection(OlapConnectionDetails connectionDetails) at Ibm.CognosDM.DataSources.Olap.DataSources.OlapDataSourceBase.GetCubeNames(OlapConnectionDetails connectionDetails) at Ibm.CognosDM.BusinessLogic.DataSources.Olap.OlapDataSourceBusinessLogic.GetApplicationDetails(OlapDataSourceType olapDataSourceType, OlapConnectionDetails connectionDetails, Nullable`1 dataSourceId) at Ibm.CognosDM.Services.DataSources.DataSourceService.GetOlapApplicationDetails(OlapDataSourceType olapDataSourceType, OlapConnectionDetails connectionDetails, Nullable`1 dataSourceId) at SyncInvokeGetOlapApplicationDetails(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

Cause

This can be caused by not having the Share session with other application setting enabled on the CAM side.

Solution

Validate that the CAM import source matches the URIs in the tm1scfg file for the TM1 Server the user is trying to connect to.

Verify that both the TM1 Server and the CAM host (Cognos Analytics server) have the Allow session information to be shared between client applications setting set to True (must be true for CAM interactive user to be used in CDM). This setting can be found in Cognos Configuration > Security > Authentication.

Set "Allow session information to be shared between client applications" to True

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