Skip to main content

Connection Fails to Load Balanced Environment

Issue

In CDM, when connecting to the load balancer URL, the login fails. However, when connecting to each server separately the login is successful. For additional information on setup, see Load Balanced Environments.

Cause

All servers must use the same SSL certificate.

SSL Certificate

Solution

  1. In the IdentityServer directory of the CDM folder, in the AppSettings.json file, verify that the DataProtectionKeysPath and CertificateThumbprint entries exist.
    • DataProtectionKeysPath points to a UNC file path that is accessible by all application servers.

      Value for the DataProtectionKeysPath Entry

    • CertificateThumbprint contains the thumbprint of the SSL certificate used by the application servers. The certificate thumbprint can be found in the certificate details (no spaces).

      Certificate Thumbprint

  2. In the hosts file for each of the application servers, place an entry to point the load balancer URL to 127.0.0.1.
  3. Configure the load balancer to enable Sticky Sessions.

Was this article helpful?

We're sorry to hear that.