Connection Fails to Load Balanced Environment
Issue
In CDM, when connecting to the load balancer URL, the login fails. However, when connecting to each server separately the login is successful. For additional information on setup, see Load Balanced Environments.
Cause
All servers must use the same SSL certificate.
Solution
- In the IdentityServer directory of the CDM folder, in the AppSettings.json file, verify that the DataProtectionKeysPath and CertificateThumbprint entries exist.
- DataProtectionKeysPath points to a UNC file path that is accessible by all application servers.
- CertificateThumbprint contains the thumbprint of the SSL certificate used by the application servers. The certificate thumbprint can be found in the certificate details (no spaces).
- DataProtectionKeysPath points to a UNC file path that is accessible by all application servers.
- In the hosts file for each of the application servers, place an entry to point the load balancer URL to 127.0.0.1.
- Configure the load balancer to enable Sticky Sessions.